Subject: Re: [OAUTH-WG] Examples of structured tokens in the wild?

From: [email-masked]
Date: Thu, 19 Apr 2012 13:31:43 +0200

On 03/25/2012 07:51 PM, Aaron Parecki wrote:
> If you have an example of an API that uses structured access tokens, I
> would love some links to documentation or examples. I'm looking for some
> examples of the types of information people put into structured tokens
> for some OAuth 2 tutorials I'm writing. It would be great if these
> examples were available in public services that I could poke at as well.

Have you found some examples yet?

- Willem

---

From: Lewis Adam-CAL022 <[email-masked]>
Date: Thu, 19 Apr 2012 14:43:06 +0000

I would find this useful as well.  

I've been ramping up on OAuth and have found the lack of standardization of access tokens very frustrating (structured vs. unstructured, if structured then what type of structure, etc).  Not being able to understand what type of access tokens are being returned to the client from the token endpoint, or not being able to understand the introspection of unstructured access tokens between the RS and OAuth STS ... which seems to very entirely by implementation, is a real issue (to my anyway :))

The OAuth spec talks about one AS being able to serve multiple RS, but in reality this might only be possible in a tightly controlled environment, where the AS and each RS is of the same implementation.  It would be nice to standardize on the AS-to-RS interface ... it seems that some work is already going on in that area.

-adam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 19, 2012 6:32 AM
To: Aaron Parecki
Cc: OAuth WG
Subject: Re: [OAUTH-WG] Examples of structured tokens in the wild?

- Willem
_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth