Subject: [OAUTH-WG] OAuth Core -27 Published

From: Mike Jones <[email-masked]>
Date: Fri, 8 Jun 2012 17:51:28 +0000

The chairs approved publication of OAuth Core draft -27 today.  This version is based upon the proposed changes that I'd circulated to the working group.  Changes are:

*        Adds character set restrictions for error, error_description, and error_uri parameters consistent with the OAuth Bearer spec.

*        Adds "resource access error response" as an error usage location in the OAuth Extensions Error Registry.

*        Adds an ABNF for all message elements.

*        Corrects editorial issues identified during review

There are still potential issues with some ABNF definitions that need to be discussed by the working group.  I'll send a separate note about that.  Nonetheless, the chairs felt that publishing this version would be a step in the right direction towards completing the Core and Bearer specifications.

I'll be publishing an updated Bearer draft shortly that references the changes in -27 in ways that should resolve the outstanding DISCUSS issues against Bearer.

Thanks to Dick Hart for publishing the draft.

                                                            -- Mike

---

From: Dick Hardt <[email-masked]>
Date: Fri, 8 Jun 2012 11:08:30 -0700

On Jun 8, 2012, at 10:51 AM, Mike Jones wrote:

> The chairs approved publication of OAuth Core draft -27 today.  This version is based upon the proposed changes that I’d circulated to the working group.  Changes are:
> ·        Adds character set restrictions for error, error_description, and error_uri parameters consistent with the OAuth Bearer spec.
> ·        Adds “resource access error response” as an error usage location in the OAuth Extensions Error Registry.
> ·        Adds an ABNF for all message elements.
> ·        Corrects editorial issues identified during review
>  
> There are still potential issues with some ABNF definitions that need to be discussed by the working group.  I’ll send a separate note about that.  Nonetheless, the chairs felt that publishing this version would be a step in the right direction towards completing the Core and Bearer specifications.
>  
> I’ll be publishing an updated Bearer draft shortly that references the changes in -27 in ways that should resolve the outstanding DISCUSS issues against Bearer.
>  

s/Dick Hart/Dick Hardt/

:)

---

From: Mike Jones <[email-masked]>
Date: Fri, 8 Jun 2012 18:10:58 +0000

Apologies, Dick HARDT! :-)

From: Dick Hardt [mailto:[email-masked]]
Sent: Friday, June 08, 2012 11:09 AM
To: Mike Jones
Cc: [email-masked]
Subject: Re: [OAUTH-WG] OAuth Core -27 Published

s/Dick Hart/Dick Hardt/

:)

---

From: Eran Hammer <[email-masked]>
Date: Fri, 8 Jun 2012 21:28:19 +0000

What the hell just happened? Even if this is allowed under IETF rules, it is clearly against IETF spirit. There is now a published draft with my name as sole editor and text I didn't put in there. No one even suggested this is something the chairs might do.

After all the work I put into this, this is a huge slap in the face by the chairs.

I hope the fact the Mike Jonea just took over with the blessing on the chairs bothers someone else too.

EH

On Jun 8, 2012, at 13:51, "Mike Jones" <[email-masked]<mailto:[email-masked]>> wrote:

                                                            -- Mike

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 08 Jun 2012 15:31:43 -0600

I must say that I found it surprising, too. An explanation beforehand
from the chairs would have helped to prevent confusion.

On 6/8/12 3:28 PM, Eran Hammer wrote:
> What the hell just happened? Even if this is allowed under IETF rules,
> it is clearly against IETF spirit. There is now a published draft with
> my name as sole editor and text I didn't put in there. No one even
> suggested this is something the chairs might do. 
> 
> On Jun 8, 2012, at 13:51, "Mike Jones" <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>> The chairs approved publication of OAuth Core draft -27 today.  This
>> version is based upon the proposed changes that I’d circulated to the
>> working group.  Changes are:
>>
>> ·        Adds character set restrictions for error, error_description,
>> and error_uri parameters consistent with the OAuth Bearer spec.
>>
>> ·        Adds “resource access error response” as an error usage
>> location in the OAuth Extensions Error Registry.
>>
>> There are still potential issues with some ABNF definitions that need
>> to be discussed by the working group.  I’ll send a separate note about
>> that.  Nonetheless, the chairs felt that publishing this version would
>> be a step in the right direction towards completing the Core and
>> Bearer specifications.
>>
>>  
>>
>> I’ll be publishing an updated Bearer draft shortly that references the
>> changes in -27 in ways that should resolve the outstanding DISCUSS
>> issues against Bearer.
>>
>>  
>>
>> [email-masked] <mailto:[email-masked]>

---

From: "Richer, Justin P." <[email-masked]>
Date: Sat, 9 Jun 2012 01:08:17 +0000

I saw the new draft and assumed that Eran had published it, as he has been doing so all along. If this is not the case, I also find this very surprising, even though with three authors on the spec I can see how it can happen from a mechanical level. But even so, shouldn't all three authors at least be aware of the publication?

 -- Justin

On Jun 8, 2012, at 5:31 PM, Peter Saint-Andre wrote:

> [email-masked]

---

From: Igor Faynberg <[email-masked]>
Date: Sun, 10 Jun 2012 17:25:47 -0400

BRAVO!

Igor

On 6/8/2012 2:08 PM, Dick Hardt wrote:
>> ·Adds character set restrictions for error, error_description, and 
>> error_uri parameters consistent with the OAuth Bearer spec.
>> ·Adds “resource access error response” as an error usage location in 
>> the OAuth Extensions Error Registry.
>> ·Adds an ABNF for all message elements.
>> ·Corrects editorial issues identified during review
>> to be discussed by the working group.  I’ll send a separate note 
>> about that.  Nonetheless, the chairs felt that publishing this 
>> version would be a step in the right direction towards completing the 
>> Core and Bearer specifications.
>> I’ll be publishing an updated Bearer draft shortly that references 
>> the changes in -27 in ways that should resolve the outstanding 
>> DISCUSS issues against Bearer.

---

From: Igor Faynberg <[email-masked]>
Date: Sun, 10 Jun 2012 17:28:06 -0400

Oh no... I never even noticed the drama.  I thought that everything has 
been agreed on...

Igor

On 6/8/2012 5:31 PM, Peter Saint-Andre wrote:
>> On Jun 8, 2012, at 13:51, "Mike Jones"<[email-masked]