Subject: [OAUTH-WG] New draft process / editor role

From: Eran Hammer <[email-masked]>
Date: Sat, 9 Jun 2012 01:58:12 +0000

Today, a new draft of the OAuth 2.0 specification was published.

* I had nothing to do with this draft. I did not edit or authored it. I didn't know it was being published.
* The draft was authored by Mike Jones and published by Dick Hardt.
* Neither one is an editor or an active author of the document.

Here are the facts:

* On 5/31 Hannes asked me to publish a new draft with the proposed changes posted by Mike by Sunday 6/3 (within 3 days). The chairs did not offer any reason for requesting such a quick turnaround. It took the chairs weeks to respond to me about the request for ABNF or error text. There wasn't any urgency when it was their task.
* I promptly replied that I plan to wait until the ABNF is completed before publishing a new draft. The ABNF, which is the only pending DISCUSS for the core specification, is still being actively debated on the list and was clearly presented as work in progress.
* Hannes did not reply back with any other instructions.
* Mike replied back trying to speak on behalf of the chairs, suggesting that 'version numbers are cheap'. I replied that my time isn't.
* At no point did any of the chairs indicated any issue with my publication schedule. The full thread is here: http://www.ietf.org/mail-archive/web/oauth/current/msg09111.html.
* Today, using Dick Hardt author credit on the document, Mike published his draft. There is no indication that changes were made by someone other than the editor or that the added sections are still a work in progress and pending consensus as is WG practice (e.g. [[ Pending Consensus ]] or [[ Proposed Text]]).
* No one has offered any explanation as to why the editor was pushed aside and blindsided with a new draft. There was no communication or any attempt to from the chairs, Mike, Dick, or anyone else.
* After posting the new draft, Mike emailed the IESG to resolve a pending DISCUSS item on the core specification, something that is clearly my role and handled by me so far. I was not included in the email list but received a copy through the tracker system as author.

Publishing a new draft must be done by a listed author. The only reason Dick and David are listed is historical in regognition of their initial contribution. Both David and Dick offered to remove their name from the top credits in the past (the reason Dick gave at the time was that the document was clearly my work). Using the author credit as a way to sidestep the editor is within the chairs right but that doesn't make it right.

I have done absolutely nothing to justify taking the document editorial work from me, even temporarily. I have tirelessly published 26 drafts of this documenty. I have been working on this specification for almost 5 years. While the chairs can certainly decide who gets to edit and publish new drafts, there was no reason to do this here, and typically this is done when an editor is unresponsive and has to be removed. In this case, it was the chairs who were unresponsive  and uncommunicative. They didn't think to even give me the courtesy of a head up.

It is not clear to me what my standing is at this point with regard to this document. I will wait for further information from the AD to decide how to proceed.

EH

---

From: Anthony Nadalin <[email-masked]>
Date: Sat, 9 Jun 2012 02:18:03 +0000

Why rant here, talk to the chairs or AD

Sent from my Windows Phone
________________________________
From: Eran Hammer
Sent: 6/8/2012 6:58 PM
To: [email-masked] WG ([email-masked])
Subject: [OAUTH-WG] New draft process / editor role

Here are the facts:

EH

---

From: William Mills <[email-masked]>
Date: Fri, 8 Jun 2012 19:35:50 -0700 (PDT)

+1

> From: Anthony Nadalin <[email-masked]>
>To: Eran Hammer <[email-masked]>; "[email-masked] WG ([email-masked])" <[email-masked]> 
>Sent: Friday, June 8, 2012 7:18 PM
>Subject: Re: [OAUTH-WG] New draft process / editor role
> 
>
> 
>* At no point did any of the chairs indicated any issue with my publication schedule. The full thread is here:
http://www.ietf.org/mail-archive/web/oauth/current/msg09111.html.
>_______________________________________________
>OAuth mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/oauth
>
>
>

---

From: "Franklin Tse" <[email-masked]>
Date: Sat, 9 Jun 2012 12:09:52 +0800

I think the chairs should clarify and explain, via this mailing list,

1. Whether they have authorized Mike Jones and Dick Hardt to author and publish the draft
2a. If they have given the authorization, why they needed to do so and why the editor was not notified;  
2b. Otherwise, whether the current draft should be considered invalid.

The current situation is confusing and I hope that the chairs will give us the answers as soon as possible.

---

From: David Recordon <[email-masked]>
Date: Fri, 8 Jun 2012 23:20:13 -0700

Yes, it would be helpful (and I think reasonable) to have an explanation of
why the process was changed so wildly from the past twenty-six drafts.

--David

---

From: Dick Hardt <[email-masked]>
Date: Sat, 9 Jun 2012 01:56:11 -0700

Mike emailed me the draft and asked if I would publish it.

I reviewed the draft and I thought it captured consensus.

I noted that Hannes had asked Eran to publish the edits a week ago 

There have been numerous indications that Eran has lost interest in continuing as editor. Eg. his decision to discontinue his work on the MAC spec.

I viewed it as my duty as an author to maintain forward momentum of the spec.

Eran is still listed as the editor

Can we move forward with the work at hand now?

-- Dick

---

From: Melinda Shore <[email-masked]>
Date: Sat, 09 Jun 2012 12:20:29 -0800

> I reviewed the draft and I thought it captured consensus.

Chairs call consensus.

> There have been numerous indications that Eran has lost interest in
> continuing as editor. Eg. his decision to discontinue his work on the
> MAC spec.

Okay, but why wasn't Eran at least informed, given that he had *not*
announced that he would no longer be editing this document?  This sounds
like a bobble by the chairs and a possible overreach by you, and this is
something that should be brought to the attention of the working group
(i.e. the legitimacy of this version of the document is, well,
questionable) but resolved offline by the chairs and editors.  A public
apology wouldn't be a terrible thing, either.

Melinda

---

From: Dick Hardt <[email-masked]>
Date: Sat, 9 Jun 2012 13:49:55 -0700

>> I reviewed the draft and I thought it captured consensus.

Agreed. I thought it captured the consensus that Hannes was referring to when he asked the edits to be published.

> apology wouldn't be a terrible thing, either.

I was responding to a request to publish the version from Mike and had the impression this was what the chairs wanted.
I apologize for all the confusion this has caused. 

-- Dick

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 10 Jun 2012 20:11:10 +0300

Hi Eran, Hi all, 

The story is fairly simple: We have three authors on draft-ietf-oauth-v2. Having more than one author is helpful in case others are busy.

We had open issues with the document and we discussed them on the list. Text was proposed and feedback was provided to the list. Thanks everyone for providing constructive input. 

The step that happens afterwards is to create a new snapshot of the document. This helps everyone to know what the latest status is (in case you are not following all the mail discussions). We are also able to let IESG members to clear their DISCUSSes. 

All this work helps us to get closer to completion and I believe we are getting closer. Unfortunately, there is still one other issue that Julian raised after the ABNF text was published, see http://www.ietf.org/mail-archive/web/oauth/current/msg09164.html. I am planning to distribute a separate mail to raise awareness and to solicit feedback. 

We are in the final stages of getting the document published. It would be great if everyone works together to get the work done as quickly as possible. Is this possible?

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 10 Jun 2012 20:24:22 +0300

Hi Franklin, 

> 1. Whether they have authorized Mike Jones and Dick Hardt to author and publish the draft

Derek and I had asked for a new draft version. We are interested to get the work on the document finished. 

Dick is a co-author and can after using the draft submission tool confirm the submission since he receives the confirmation URL. 
This is completely normal. Every co-author can submit a new version. Sometimes co-authors even regularly talk to each other. I have co-authored many documents with other people and I had never run into problems like these before.  

> 2a. If they have given the authorization, why they needed to do so and why the editor was not notified;  

Eran had not published a new version as requested.  

> 2b. Otherwise, whether the current draft should be considered invalid.
The current draft is valid. It contains the discussed changes and there may (or likely will) be another version upcoming to address the issue Julian raised as well. 

> The current situation is confusing and I hope that the chairs will give us the answers as soon as possible.

I would just hope for more collaboration to get the documents published. I understand that everyone is busy with other work related matters and some folks may never become best friends but maybe we could put this aside for a few weeks and get the document out of the door. 

Ciao
Hannes

---

From: Mike Jones <[email-masked]>
Date: Sun, 10 Jun 2012 18:38:19 +0000

About Julian's issue raised at http://www.ietf.org/mail-archive/web/oauth/current/msg09164.html, please see my message to him and the working group "[OAUTH-WG] Discussion needed on username and password ABNF definitions" at http://www.ietf.org/mail-archive/web/oauth/current/msg09171.html.  In it, I request that Julian provide specific proposed text changes to -27 to extend the appropriate parameters to be able to encode non-ASCII characters in a way that doesn't violate constraints of the other specs used.  If this is possible, I suspect that the working group would be open to it.

				Best wishes,
				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Sunday, June 10, 2012 10:11 AM
To: Eran Hammer; [email-masked] WG ([email-masked])
Subject: Re: [OAUTH-WG] New draft process / editor role

Hi Eran, Hi all, 

Ciao
Hannes

---

From: Kristofor Selden <[email-masked]>
Date: Sat, 9 Jun 2012 10:31:34 -0700

> Can we move forward with the work at hand now?

I find your tone to be dismissive – which in general isn't in the spirit of moving things forward.  Your comment on the MAC spec is tangential.

Hannes never replied that Eran's request to wait for the ABNF was a problem nor to confirm Mike's assertion of Hannes' intent (http://www.ietf.org/mail-archive/web/oauth/current/msg09111.html).

I can understand why Eran would feel blindsided.

That being said, it would be nice if further list discussion was forward looking and the looking back discussion was with the chairs.