Subject: Re: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting requested

From: Mike Jones <[email-masked]>
Date: Fri, 13 Jul 2012 23:42:04 +0000

I'm willing to do 5 minutes on the status of the Core and Bearer documents.

I'm willing to give an update on JWT and the JWT Bearer - probably 15 minutes.  It's probably good that we're a day after the JOSE WG meeting, given the JWT dependency upon the JOSE specs.

I'm willing to be part of a discussion on the Assertions draft, but would appreciate doing this with Brian and/or Chuck - I'm guessing 15 minutes for that as well.  (I'm not certain this will be needed, but I'd like to review the recent changes before saying that it's not.)

Looking forward to seeing many of you in Vancouver!

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Saturday, June 02, 2012 12:46 AM
To: [email-masked] WG
Subject: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting requested

Hi all, 

I have requested a 2,5 hour slot for the upcoming meeting. 

While the next meeting is still a bit away it is nevertheless useful to hear 
* whether you plan to attend the next meeting, and 
* whether you want to present something. 

I could imagine that these documents will be discussed:
* draft-ietf-oauth-dyn-reg
* draft-ietf-oauth-json-web-token
* draft-ietf-oauth-jwt-bearer
* draft-ietf-oauth-revocation
* draft-ietf-oauth-use-cases

To the draft authors of these docuemnts: Please think about the open issues and drop a mail to the list so that we make some progress already before the face-to-face meeting. 

I am assume that the following documents do not require any discussion time at the upcoming IETF meeting anymore:
* draft-ietf-oauth-assertions
* draft-ietf-oauth-saml2-bearer
* draft-ietf-oauth-urn-sub-ns
* draft-ietf-oauth-v2
* draft-ietf-oauth-v2-bearer

Ciao
Hannes

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Anthony Nadalin <[email-masked]>
Date: Sun, 15 Jul 2012 03:36:54 +0000

How about a few min on proof-of-possession requirements? I can present our use cases and requirements

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Friday, July 13, 2012 4:42 PM
To: Hannes Tschofenig; [email-masked] WG
Subject: Re: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting requested

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Saturday, June 02, 2012 12:46 AM
To: [email-masked] WG
Subject: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting requested

Hi all, 

Ciao
Hannes

---

From: John Bradley <[email-masked]>
Date: Sun, 15 Jul 2012 08:59:36 -0600

Yes we need to get clearer on the the threats and use cases.

I think Phil Hunt has some though there is likely overlap.

Part of the problem with MAC was people never agreed on the threats it was mitigating.

I can present something or coordinate with Tony or Phil.

John B.

---

From: Phil Hunt <[email-masked]>
Date: Sun, 15 Jul 2012 10:47:22 -0700

Sounds like a great idea. I can put together a few slides. 

Phil

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 15 Jul 2012 20:57:32 +0300

Hi all, 

I have uploaded an agenda for the meeting. 

I am assuming that all these items do not require discussion time anymore: 

Hence, we can focus on the new items. As discussed in the mail below I put a separate slot for discussion of the holder-of-the-key/MAC token security discussion on the agenda. I would suggest that a couple of us meeting during the IETF week to work together on a presentation that provides some concrete suggestions for next steps to the rest of the group. 

I also put the following persons on the spot for the presentations of working group items:

- OAuth Dynamic Client Registration Protocol (Thomas)
- JSON Web Token (JWT) (Mike)
- JSON Web Token (JWT) Bearer Token Profiles for OAuth 2.0 (Mike)
- Token Revocation (Torsten)
- SAML 2.0 Bearer Assertion Profiles for OAuth 2.0 (Brian)
- OAuth Use Cases (Zachary)

Let me know if you want someone else to give the presentation. 

As a preparation for the meeting it would be good if you could 
(a) identify the open issues with your document, and 
(b) find one or two reviewers to have a look at your document during the next two weeks. 

Ciao
Hannes

---

From: John Bradley <[email-masked]>
Date: Sun, 15 Jul 2012 11:59:08 -0600

Good working with you and Tony is the stuff of dreams:)

We can sync up off list and try to reduce duplication.

Are we all at CIS this week?

John B.

---

From: Phil Hunt <[email-masked]>
Date: Sun, 15 Jul 2012 11:07:55 -0700

Unfortunately I won't be at CIS. Should be lots of time to meet in vancouver and we can do a summary in the session if agenda permits. 

Phil

---

From: Anthony Nadalin <[email-masked]>
Date: Sun, 15 Jul 2012 18:40:36 +0000

I will not be at CIS

Sent from my Windows Phone
________________________________
From: John Bradley
Sent: 7/15/2012 10:59 AM
To: Phil Hunt
Cc: Anthony Nadalin; [email-masked] WG
Subject: Re: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting requested

John B.

---

From: Thomas Hardjono <[email-masked]>
Date: Mon, 23 Jul 2012 15:02:21 +0000

Hannes, Derek,

Would it possible to postpone presentation/discussion of the Dyn-Reg
draft (Dynamic Client Registration Protocol) to the Atlanta/November
IETF meeting?

The reason is that none of the proposers will be attending the
Vancouver IETF in-person.

Thanks.

/thomas/

__________________________________________

> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Hannes Tschofenig
> Sent: Sunday, July 15, 2012 1:58 PM
> To: John Bradley
> Cc: [email-masked] WG
> Hence, we can focus on the new items. As discussed in the mail below
I
> put a separate slot for discussion of the holder-of-the-key/MAC
token
> security discussion on the agenda. I would suggest that a couple of
us
> meeting during the IETF week to work together on a presentation that
> provides some concrete suggestions for next steps to the rest of the
> group.
> 
> I also put the following persons on the spot for the presentations
of
> working group items:
> > Part of the problem with MAC was people never agreed on the
threats
> it was mitigating.
> >> Subject: Re: [OAUTH-WG] Meeting slot for the Vancouver IETF
meeting
> requested
> >> I'm willing to give an update on JWT and the JWT Bearer -
probably
> 15 minutes.  It's probably good that we're a day after the JOSE WG
> meeting, given the JWT dependency upon the JOSE specs.
> >>
> >> I'm willing to be part of a discussion on the Assertions draft,
but
> would appreciate doing this with Brian and/or Chuck - I'm guessing
15
> minutes for that as well.  (I'm not certain this will be needed, but
> I'd like to review the recent changes before saying that it's not.)
> >>
> >> While the next meeting is still a bit away it is nevertheless
useful
> to hear
> >> To the draft authors of these docuemnts: Please think about the
open
> issues and drop a mail to the list so that we make some progress
> already before the face-to-face meeting.
> >>
> >> I am assume that the following documents do not require any
> discussion time at the upcoming IETF meeting anymore:

---

From: Torsten Lodderstedt <[email-masked]>
Date: Wed, 25 Jul 2012 18:19:00 +0200

Hi Hannes,

I'm unfortunately had to cancel my trip to IETF-84. Phil will cover the 
status of the threat model document. But none of the authors of the 
Revocation Draft will be attending. So I would ask you to postpone the 
presentation of this I-D to the next IETF meeting as well.

best regards,
Torsten.

Am 23.07.2012 17:02, schrieb Thomas Hardjono:
>> Behalf Of Mike Jones
>> Behalf Of Hannes Tschofenig

---

From: Derek Atkins <[email-masked]>
Date: Mon, 30 Jul 2012 13:55:28 -0400

We will have a WebEx available if you can attend remotely?
That's my plan, as I cannot make Vancouver this week.

-derek

Torsten Lodderstedt <[email-masked]> writes:

> Hi Hannes,
>
> I'm unfortunately had to cancel my trip to IETF-84. Phil will cover the status
> of the threat model document. But none of the authors of the Revocation Draft
> will be attending. So I would ask you to postpone the presentation of this I-D
> to the next IETF meeting as well.
>
> best regards,
> Torsten.
>  
>                 How about a few min on proof-of-possession requirements? I can
>                 
>         present our use cases and requirements
>         
>                 I'm willing to do 5 minutes on the status of the Core and Bearer
>                 
>         documents.
>         
>                 Subject: [OAUTH-WG] Meeting slot for the Vancouver IETF meeting
>                 
>         requested
>         
>                 Hi all,
>                 

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant