Subject: Re: [OAUTH-WG] Mail regarding draft-ietf-oauth-v2

From: Dick Hardt <[email-masked]>
Date: Thu, 12 Jul 2012 17:09:07 -0700

Charles

Thanks for the suggestion. I just did publish a new draft that included a number of items that had been discussed and I would like to get some feedback on your suggestion before incorporating it (or not).

Does anyone have feedback on the change below? (+/-)

-- Dick

On Jul 12, 2012, at 1:45 PM, Honton, Charles wrote:

> E. Hammer, D. Recordon, D. Hardt, et.al,
> 
> I'm looking at draft 28 (http://tools.ietf.org/html/draft-ietf-oauth-v2-28).
> 
> In Section 5.2 the error code should probably include:
> 
> 	server_error
>                The authorization server encountered an unexpected
>                condition which prevented it from fulfilling the request.
>          temporarily_unavailable
>                The authorization server is currently unable to handle
>                the request due to a temporary overloading or maintenance
>                of the server.
> 
> 
> Regards,
> chas
>

---

From: Antonio Sanso <[email-masked]>
Date: Fri, 13 Jul 2012 09:25:38 +0100

Hi Charles, Dick

I think this has been already discussed in [0]

Regards

Antonio

[0] http://www.ietf.org/mail-archive/web/oauth/current/msg08261.html

On Jul 13, 2012, at 2:09 AM, Dick Hardt wrote:

Charles

-- Dick

        server_error

Regards,
chas

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: John Bradley <[email-masked]>
Date: Fri, 13 Jul 2012 07:04:58 -0400

FRom what I can see in a similar discussion Eran pointed out that this is a direct communication, communication between the client and token endpoint.

Server Error and temporarily unavailable are not OAuth specific and are handled by existing HTTP error codes.

I don't see a need for a change.

Unless something else dramatic comes up I would like to see draft 29 go to the RFC editor.

(Though one person mentioned to me that 30 is a nicer number:)

John B.

On 2012-07-12, at 8:09 PM, Dick Hardt wrote:

> [email-masked]

---

From: William Mills <[email-masked]>
Date: Fri, 13 Jul 2012 09:56:55 -0700 (PDT)

I agree that we don't want things like Internal Server Error (500) duplicated in OAuth specific errors.  The only thing I might add to 5.2 is something like "Other HTTP status codes such as 500 (Internal Server Error) may be returned with no OAuth specific parameters."

-bill

________________________________
From: John Bradley <[email-masked]>
To: Dick Hardt <[email-masked]> 
Cc: [email-masked]; "Honton, Charles" <[email-masked]>; "[email-masked] WG" <[email-masked]> 
Sent: Friday, July 13, 2012 4:04 AM
Subject: Re: [OAUTH-WG] Mail regarding draft-ietf-oauth-v2

John B.

Charles
>>server_error The authorization server encountered an unexpected condition which prevented it from fulfilling the request. temporarily_unavailable The authorization server is currently unable to handle the request due to a temporary overloading or maintenance of the server.
>>
>>
>>
>>
>>Regards,
>>chas
>>
>>

---

From: Mike Jones <[email-masked]>
Date: Sat, 14 Jul 2012 19:59:59 +0000

I'd also like to see Core -29 and Bearer -22 go to the RFC Editor.

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of John Bradley
Sent: Friday, July 13, 2012 4:05 AM
To: Dick Hardt
Cc: [email-masked]; Honton, Charles; [email-masked] WG
Subject: Re: [OAUTH-WG] Mail regarding draft-ietf-oauth-v2

John B.

Charles

-- Dick

       server_error

         temporarily_unavailable

               of the server.

Regards,
chas