Subject: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

From: Dick Hardt <[email-masked]>
Date: Fri, 10 Aug 2012 13:04:31 -0700

Once again, would be great to have a few more eyes checking the IANA registrations. 

Note these are for the Bearer Token spec. 

I like that the error registry items are sorted alphabetically already. :)

Begin forwarded message:

> From: "Amanda Baber via RT" <[email-masked]>
> Subject: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt) 
> Date: August 10, 2012 12:20:33 PM PDT
> Cc: [email-masked], [email-masked], [email-masked], [email-masked]
> Reply-To: [email-masked]
> 
> Dear Authors:
> 
> ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED 
> 
> We have completed the IANA Actions for RFC-to-be
> draft-ietf-oauth-v2-bearer-23
> 
> ACTION 1:
> 
> IANA has registered the following OAuth Access Token Type:
> 
> Name: Bearer
> Additional Endpoint Response Parameters: 
> HTTP Authentication Scheme(s): Bearer 
> Change Controller: IETF          
> Reference: [RFC-ietf-oauth-v2-bearer-23]
> 
> Please see
> http://www.iana.org/assignments/oauth-parameters
> 
> 
> ACTION 2:
> 
> IANA has registered the following in the OAuth Extensions Error Registry:
> 
> invalid_request  
> Usage Location: Resource access error response  
> Protocol Extension: Bearer access token type  
> Change Controller: IETF  
> Reference: [RFC-ietf-oauth-v2-bearer-23]
> 
> invalid_token
> Usage Location: Resource access error response  
> Protocol Extension: Bearer access token type  
> Change Controller: IETF  
> Reference: [RFC-ietf-oauth-v2-bearer-23]
> 
> insufficient_scope
> Usage Location: Resource access error response  
> Protocol Extension: Bearer access token type  
> Change Controller: IETF  
> Reference: [RFC-ietf-oauth-v2-bearer-23]
> 
> Please see
> http://www.iana.org/assignments/oauth-parameters
> 
> 
> Please let us know whether the above IANA Actions look OK. As 
> soon as we receive your confirmation, we'll notify the RFC Editor 
> that this document's IANA Actions are complete. (If this document 
> has a team of authors, one reply on behalf of everyone will suffice.)
> 
> Thanks,
> 
> Amanda Baber
> ICANN/IANA
>

---

From: William Mills <[email-masked]>
Date: Mon, 13 Aug 2012 09:34:28 -0700 (PDT)

1) Is it a problem that everything here seems to have "specification required" for the "Registration Procedures"?

2) In HTTP Authentication schemes, is the case insensitivity implicit here? (I think so)

-bill

________________________________
 From: Dick Hardt <[email-masked]>
To: "[email-masked] WG" <[email-masked]> 
Sent: Friday, August 10, 2012 1:04 PM
Subject: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

Begin forwarded message:

>has a team of authors, one reply on behalf of everyone will suffice.)

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Tue, 14 Aug 2012 18:43:12 +0000

"Specification Required" is correct, as that's what's used in OAuth Core.  I believe that the case insensitivity comes from RFC 2617, which for instance, seems to use "Basic" and "basic" interchangeably.

                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of William Mills
Sent: Monday, August 13, 2012 9:34 AM
To: Dick Hardt; [email-masked] WG
Subject: Re: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

-bill

________________________________
From: Dick Hardt <[email-masked]<mailto:[email-masked]>>
To: "[email-masked] WG<mailto:[email-masked]%20WG>" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, August 10, 2012 1:04 PM
Subject: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

Begin forwarded message:

From: "Amanda Baber via RT" <[email-masked]<mailto:[email-masked]>>
Subject: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)
Date: August 10, 2012 12:20:33 PM PDT
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>

Dear Authors:

ACTION 1:

Name: Bearer

Please see

ACTION 2:

invalid_request

invalid_token

insufficient_scope

Please see

Thanks,

Amanda Baber
ICANN/IANA

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: William Mills <[email-masked]>
Date: Tue, 14 Aug 2012 11:51:20 -0700 (PDT)

Thanks.

________________________________
 From: Mike Jones <[email-masked]>
To: William Mills <[email-masked]>; Dick Hardt <[email-masked]>; "[email-masked] WG" <[email-masked]> 
Sent: Tuesday, August 14, 2012 11:43 AM
Subject: RE: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

“Specification Required” is correct, as that’s what’s used in OAuth Core.  I believe that the case insensitivity comes from RFC 2617, which for instance, seems to use “Basic” and “basic” interchangeably.
 
                                                                -- Mike
 
From:[email-masked] [mailto:[email-masked]] On Behalf Of William Mills
Sent: Monday, August 13, 2012 9:34 AM
To: Dick Hardt; [email-masked] WG
Subject: Re: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

 
-bill

 
From:Dick Hardt <[email-masked]>
To: "[email-masked] WG" <[email-masked]> 
Sent: Friday, August 10, 2012 1:04 PM
Subject: [OAUTH-WG] Fwd: [IANA #596670] Protocol Action: 'The OAuth 2.0 Authorization Framework: Bearer Token Usage' to Proposed Standard (draft-ietf-oauth-v2-bearer-23.txt)

 
 
Begin forwarded message:

Dear Authors:

ACTION 1:

Name: Bearer

Please see

ACTION 2:

invalid_request  

invalid_token

insufficient_scope

Please see

Thanks,

Amanda Baber
ICANN/IANA