Subject: [OAUTH-WG] Fwd: [IANA #596671] Protocol Action: 'The OAuth 2.0 Authorization Framework' to Proposed Standard (draft-ietf-oauth-v2-31.txt)

From: Dick Hardt <[email-masked]>
Date: Tue, 7 Aug 2012 17:52:37 -0700

Would appreciate a few others checking to make sure the IANA entries are valid. 

-- Dick

Begin forwarded message:

> From: "Amanda Baber via RT" <[email-masked]>
> Subject: [IANA #596671] Protocol Action: 'The OAuth 2.0 Authorization Framework' to Proposed Standard (draft-ietf-oauth-v2-31.txt) 
> Date: August 7, 2012 5:34:26 PM PDT
> Cc: [email-masked], [email-masked], [email-masked]
> Reply-To: [email-masked]
> 
> Dear Author:
> 
> ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED 
> 
> We have completed the IANA Actions for RFC-to-be
> draft-ietf-oauth-v2-31
> 
> IANA has created the OAuth Access Token Types, OAuth Parameters, OAuth
> Authorization Endpoint Response Types, and OAuth Extensions Errors
> registries at
> 
> http://www.iana.org/assignments/oauth-parameters
> 
> 
> Please let us know whether the above IANA Actions look OK. As 
> soon as we receive your confirmation, we'll notify the RFC Editor 
> that this document's IANA Actions are complete. 
> 
> Thanks,
> 
> Amanda Baber
> ICANN/IANA
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 07 Aug 2012 19:27:52 -0600

Putting the parameters in alphabetical order would make the page more
readable, but other than that it seems fine.

On 8/7/12 6:52 PM, Dick Hardt wrote:
>> *From: *"Amanda Baber via RT" <[email-masked]
>> <mailto:[email-masked]>>
>> *Subject: **[IANA #596671] Protocol Action: 'The OAuth 2.0
>> Authorization Framework' to Proposed Standard
>> (draft-ietf-oauth-v2-31.txt) *
>> *Date: *August 7, 2012 5:34:26 PM PDT
>> *Cc: [email-masked] <mailto:[email-masked]>,
>> [email-masked] <mailto:[email-masked]>,
>> [email-masked] <mailto:[email-masked]>
>> *Reply-To: [email-masked] <mailto:[email-masked]>
>>
>> Dear Author:
>>

---

From: Mike Jones <[email-masked]>
Date: Wed, 8 Aug 2012 01:35:03 +0000

The reference for the OAuth Access Token Types registry should be http://tools.ietf.org/html/draft-ietf-oauth-v2-31 - not http://tools.ietf.org/html/draft-ietf-oauth-urn-sub-ns-06.

Other than that, looks good.

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dick Hardt
Sent: Tuesday, August 07, 2012 5:53 PM
To: oauth WG
Subject: [OAUTH-WG] Fwd: [IANA #596671] Protocol Action: 'The OAuth 2.0 Authorization Framework' to Proposed Standard (draft-ietf-oauth-v2-31.txt)

-- Dick

Begin forwarded message:

From: "Amanda Baber via RT" <[email-masked]<mailto:[email-masked]>>
Subject: [IANA #596671] Protocol Action: 'The OAuth 2.0 Authorization Framework' to Proposed Standard (draft-ietf-oauth-v2-31.txt)
Date: August 7, 2012 5:34:26 PM PDT
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>

Dear Author:

Thanks,

Amanda Baber
ICANN/IANA

---

From: Dick Hardt <[email-masked]>
Date: Tue, 7 Aug 2012 18:53:02 -0700

Hello Amanda (or whoever :)

It would be nice if the OAuth Parameters were listed alphabetical. 

Also, the reference for the OAuth Access Token Types registry should be http://tools.ietf.org/html/draft-ietf-oauth-v2-31 - nothttp://tools.ietf.org/html/draft-ietf-oauth-urn-sub-ns-06.

-- Dick

---

From: John Bradley <[email-masked]>
Date: Tue, 7 Aug 2012 21:54:40 -0400

Yes I was just trying to work out what was going on with the OAuth Access token types.

The OAuth parameters are in the same order as the spec has them so not too surprising.  I can't make out any particular significance of the order,  having them make it alphabetical would not hurt.

Other than that looks fine.

John B.

On 2012-08-07, at 9:35 PM, Mike Jones wrote:

> The reference for the OAuth Access Token Types registry should be http://tools.ietf.org/html/draft-ietf-oauth-v2-31 - nothttp://tools.ietf.org/html/draft-ietf-oauth-urn-sub-ns-06.
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth