Subject: Re: [OAUTH-WG] Error Responses in Device Code Spec

From: Justin Richer <[email-masked]>
Date: Wed, 12 Apr 2017 15:18:57 -0400

Raising this point again. We’ve got a use case where people are wanting to do custom error codes from the device endpoint and would like the spec to have clear guidance. At the moment, it doesn’t even have examples for errors from the device endpoint.

 — Justin

> On Mar 15, 2017, at 12:33 PM, Justin Richer <[email-masked]> wrote:
> 
> Unless I’m missing something, the current device code spec doesn’t specify errors from the device code endpoint, only from the token endpoint. What are people implementing in practice? We’re using token endpoint style errors (invalid_client, inavlid_grant_type, etc).
> 
> — Justin
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Wed, 12 Apr 2017 20:20:02 +0000

It seems reasonable to have the spec say that Token Endpoint errors can also be returned from the Device Endpoint.

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Wednesday, April 12, 2017 12:19 PM
To: <[email-masked]> <[email-masked]>
Subject: Re: [OAUTH-WG] Error Responses in Device Code Spec

 — Justin

---

From: Justin Richer <[email-masked]>
Date: Wed, 12 Apr 2017 16:57:28 -0400

FWIW I’m fine with that solution if that’s where the editor and group go.

 — Justin

> On Apr 12, 2017, at 4:20 PM, Mike Jones <[email-masked]> wrote:
>