Subject: Re: [OAUTH-WG] Call for Adoption: Mutual TLS Profiles for OAuth Clients

From: Justin Richer <[email-masked]>
Date: Mon, 1 May 2017 15:28:58 -0700

I support this draft as a starting point for this work. 

A context on my perspective: several years ago, I worked on a project that looked toward this kind of functionality being standardized in the future. See section 6.1 of this document published in 2015 (written in 2014).

http://secure-restful-interface-profile.github.io/pages/docs/profiles/Secure%20RESTful%20Interface%20Profiles%20for%20OAuth%202%20v1.4.docx <http://secure-restful-interface-profile.github.io/pages/docs/profiles/Secure%20RESTful%20Interface%20Profiles%20for%20OAuth%202%20v1.4.docx>

 — Justin

> On Apr 25, 2017, at 12:45 PM, Samuel Erdtman <[email-masked]> wrote:
> 
> +1 for adoption
> 
> On Mon, Apr 24, 2017 at 9:02 AM, William Denniss <[email-masked] <mailto:[email-masked]>> wrote:
> I support the adoption of this draft by the working group.
> 
> 
> On Sun, Apr 23, 2017 at 9:11 AM, Torsten Lodderstedt <[email-masked] <mailto:[email-masked]>> wrote:
> +1 for adoption
> 
>> Am 21.04.2017 um 21:43 schrieb Nat Sakimura <[email-masked] <mailto:[email-masked]>>:
>> 
>> +1 for adoption
>> 
>> On Apr 21, 2017 9:32 PM, "Dave Tonge" <[email-masked] <mailto:[email-masked]>> wrote:
>> I support adoption of draft-campbell-oauth-mtls
>> 
>> As previously mentioned this spec will be very useful for Europe where there is legislation requiring the use of certificate-based authentication and many financial groups and institutions are considering OAuth2.
>>  
>> The UK Open Banking Implementation Entity has a strong interest in using this spec.
>> 
>> Dave
>> 
>> On 20 April 2017 at 17:32, Hannes Tschofenig <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi all,
>> 
>> based on the strong support for this document at the Chicago IETF
>> meeting we are issuing a call for adoption of the "Mutual TLS Profiles
>> for OAuth Clients" document, see
>> https://tools.ietf.org/html/draft-campbell-oauth-mtls-01 <https://tools.ietf.org/html/draft-campbell-oauth-mtls-01>
>> 
>> Please let us know by May 4th whether you accept / object to the
>> adoption of this document as a starting point for work in the OAuth
>> working group.
>> 
>> Ciao
>> Hannes & Rifaat
>> 
>> 
>> _______________________________________________
>> OAuth mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
>> 
>> 
>> 
>> 
>> -- 
>> Dave Tonge
>> CTO
>>  <http://www.google.com/url?q=http%3A%2F%2Fmoneyhubenterprise.com%2F&sa=D&sntz=1&usg=AFQjCNGUnR5opJv5S1uZOVg8aISwPKAv3A>
>> 10 Temple Back, Bristol, BS1 6FL
>> t: +44 (0)117 280 5120 <tel:+44%20117%20280%205120>
>> 
>> Moneyhub Enterprise is a trading style of Momentum Financial Technology Limited which is authorised and regulated by the Financial Conduct Authority ("FCA"). Momentum Financial Technology is entered on the Financial Services Register (FRN 561538) at fca.org.uk/register <http://fca.org.uk/register>. Momentum Financial Technology is registered in England & Wales, company registration number 06909772 © . Momentum Financial Technology Limited 2016. DISCLAIMER: This email (including any attachments) is subject to copyright, and the information in it is confidential. Use of this email or of any information in it other than by the addressee is unauthorised and unlawful. Whilst reasonable efforts are made to ensure that any attachments are virus-free, it is the recipient's sole responsibility to scan all attachments for viruses. All calls and emails to and from this company may be monitored and recorded for legitimate purposes relating to this company's business. Any opinions expressed in this email (or in any attachments) are those of the author and do not necessarily represent the opinions of Momentum Financial Technology Limited or of any other group company.
>> 
>> _______________________________________________
>> OAuth mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
>> 
>> _______________________________________________
>> OAuth mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 9 May 2017 15:32:30 +0200

resending

-------- Forwarded Message --------
Subject: Call for Adoption: Mutual TLS Profiles for OAuth Clients
Date: Thu, 20 Apr 2017 18:32:55 +0200
From: Hannes Tschofenig <[email-masked]>
To: [email-masked] <[email-masked]>

Hi all,

based on the strong support for this document at the Chicago IETF
meeting we are issuing a call for adoption of the "Mutual TLS Profiles
for OAuth Clients" document, see
https://tools.ietf.org/html/draft-campbell-oauth-mtls-01

Ciao
Hannes & Rifaat

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 9 May 2017 15:37:32 +0200

Sorry; this was the wrong email. I had sent a mail around to confirm the
call for adoption and it turns out that this email got lost somewhere....