Subject: [OAUTH-WG] Authentication Method Reference Values is now RFC 8176

From: Mike Jones <[email-masked]>
Date: Sat, 17 Jun 2017 00:50:42 +0000

The Authentication Method Reference Values specification is now RFC 8176<https://www.rfc-editor.org/rfc/rfc8176.txt>.  The abstract describes the specification as:

The amr (Authentication Methods References) claim is defined and registered in the IANA "JSON Web Token Claims" registry, but no standard Authentication Method Reference values are currently defined. This specification establishes a registry for Authentication Method Reference values and defines an initial set of Authentication Method Reference values.

The specification defines and registers some Authentication Method Reference values such as the following, which are already in use by some Google and Microsoft products and OpenID specifications:

  *   "face" - Facial recognition
  *   "fpt" - Fingerprint
  *   "hwk" - Proof-of-possession of a hardware-secured key
  *   "otp" - One-time password
  *   "pin" - Personal Identification Number
  *   "pwd" - Password
  *   "swk" - Proof-of-possession of a software-secured key
  *   "sms" - Confirmation using SMS
  *   "user" - User presence test
  *   "wia" - Windows Integrated Authentication
See https://www.iana.org/assignments/authentication-method-reference-values/ for the full list of registered values.

Thanks to Caleb Baker, Phil Hunt, Tony Nadalin, and William Denniss, all of whom substantially contributed to the specification.  Thanks also to the OAuth working group members, chairs, area directors, and other IETF members who helped refine the specification.

                                                                -- Mike

P.S.  This announcement was also posted at http://self-issued.info/?p=1701 and as @selfissued<https://twitter.com/selfissued>.

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Fri, 16 Jun 2017 19:25:33 -0700

Thank you Mike!

Phil

> On Jun 16, 2017, at 5:50 PM, Mike Jones <[email-masked]> wrote:
> 
> The Authentication Method Reference Values specification is now RFC 8176.  The abstract describes the specification as:
>  
> “face” – Facial recognition
> “fpt” – Fingerprint
> “hwk” – Proof-of-possession of a hardware-secured key
> “otp” – One-time password
> “pin” – Personal Identification Number
> “pwd” – Password
> “swk” – Proof-of-possession of a software-secured key
> “sms” – Confirmation using SMS
> “user” – User presence test
> “wia” – Windows Integrated Authentication
> P.S.  This announcement was also posted at http://self-issued.info/?p=1701 and as @selfissued.
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_oauth&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=c4h3kFuEtVHltGQ2Mo4qOxZUNOdHh2wTrdydAc7z8zQ&s=SzWRl9usAtrZR4uccnnP_Cq3XEwz6np9UhOmTtxF8rA&e=