Subject: [OAUTH-WG] Genart last call review of draft-ietf-oauth-discovery-07

From: Brian Carpenter <[email-masked]>
Date: Sun, 01 Oct 2017 19:57:50 -0700

Reviewer: Brian Carpenter
Review result: Ready

Gen-ART Last Call review of draft-ietf-oauth-discovery-07

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-oauth-discovery-07.txt
Reviewer: Brian Carpenter
Review Date: 2017-10-02
IETF LC End Date: 2017-10-09
IESG Telechat date: 

Summary: Ready
--------

Comment:
--------

As far as my competence goes, I have no issues with this draft.
Just for fun, I checked that the JSON example works as the
value of a GRASP objective (draft-ietf-anima-grasp) with the
GRASP prototype code. And yes, of course it does, so we could
map OAuth over the ANIMA discover/synchronize model if we wanted.

FWIW there are a couple of errors in the shepherd's writeup:

> This document does not request any actions by IANA.
>
> 18) List any new IANA registries that require Expert Review for future
> allocations. Provide any public guidance that the IESG would find
> useful in selecting the IANA Experts for these new registries.
>
> None.

Wrong, there are extensive IANA considerations and a requirement
for multiple Designated Experts.

> There is no text in formal languages in the document. 

Maybe not, but there is a JSON example (which as noted
above seems to be fine).

--

---

From: Mike Jones <[email-masked]>
Date: Fri, 27 Oct 2017 22:29:34 +0000

Thanks for the review and validating the examples, Brian!

-----Original Message-----
From: Brian Carpenter [mailto:[email-masked]] 
Sent: Sunday, October 1, 2017 7:58 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-oauth-discovery-07

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Summary: Ready
--------

Comment:
--------

As far as my competence goes, I have no issues with this draft.
Just for fun, I checked that the JSON example works as the value of a GRASP objective (draft-ietf-anima-grasp) with the GRASP prototype code. And yes, of course it does, so we could map OAuth over the ANIMA discover/synchronize model if we wanted.

> useful in selecting the IANA Experts for these new registries.

Wrong, there are extensive IANA considerations and a requirement for multiple Designated Experts.

> There is no text in formal languages in the document. 

Maybe not, but there is a JSON example (which as noted above seems to be fine).

--