Subject: [OAUTH-WG] Adding a SAML 2 token type to the OAuth Token Exchange spec

From: Mike Jones <[email-masked]>
Date: Tue, 3 Oct 2017 13:51:08 +0000

A Microsoft use case has come up in which people would like to perform a token exchange for a SAML token. The spec already defines urn:ietf:params:oauth:token-type:jwt for requesting JWT tokens.  Would anybody object to us adding urn:ietf:params:oauth:token-type:saml2 to the next draft to also give us a standard way to ask for SAML 2.0 tokens?

It could always be done in its own spec, but adding it in Token Exchange seems more expedient.

                                                                     -- Mike

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Wed, 4 Oct 2017 09:12:58 +0300

+1

Vladimir

PS: Am I correct that the current token exchange spec can be used with
mTLS and token binding as it is, without any additional changes?