Subject: [Perc] EKT role negotiation

From: Richard Barnes <[email-masked]>
Date: Sat, 18 Nov 2017 10:27:57 +0800

Hey PERC folks,

In response to Jonathan's comments at the PERC meeting, I put together a PR
that decouples EKT roles (who sends the EKTKey) from DTLS roles, using the
same methodology as in RFC 4145.

https://github.com/ietf/perc-wg/pull/148

This complicates EKT a little, but it doesn't seem tragic.  Interested in
what other folks think.

--Richard

---

From: Nils Ohlmeier <[email-masked]>
Date: Sat, 18 Nov 2017 12:51:12 +0800

Hello,

> On Nov 18, 2017, at 10:27, Richard Barnes <[email-masked]> wrote:
> 
> In response to Jonathan's comments at the PERC meeting, I put together a PR that decouples EKT roles (who sends the EKTKey) from DTLS roles, using the same methodology as in RFC 4145.
> 
> https://github.com/ietf/perc-wg/pull/148 <https://github.com/ietf/perc-wg/pull/148>
> 
> This complicates EKT a little, but it doesn't seem tragic.  Interested in what other folks think.

I think it makes sense to decouple the EKT role from the DTLS role, because without it I would be concerned that one day someone comes up with a scenario where he/she needs to operate with unusual roles and then can’t get the KD to actually distribute the keys.

Thanks
  Nils Ohlmeier - as an individual contributor