Subject: Re: [Perc] WGLC: draft-ietf-perc-srtp-ekt-diet-06

From: Emil Ivov <[email-masked]>
Date: Fri, 17 Nov 2017 11:39:26 +0000

I sent this yesterday but apparently it only went to Suhas. Posting again
to the list (as mentioned, I am not really hoping for an answer at this
stage and I am mainly doing it for the record):

Hello all,

I am assuming this will be ignored just as the original complaints but for
the sake of completeness:

No, I do not feel this draft is ready to go and it won’t be until it gets
rid of the requirement for doing triple encryption for repair mechanisms.

I dont believe that there has ever been consensus on this in the WG despite
Suhas’s insistance otherwise.

Speaking as an implementor, we are unlikely to adopt PERC until this is
solved.

Emil

On Tue 31 Oct 2017 at 20:37, Suhas Nandakumar <[email-masked]> wrote:

> All,
>
> This is a working group last call announcement for draft-ietf-perc-srtp-ekt-diet-06 to run through November 15.  Please send your reviews to the list as soon as possible so we can prepare for any discussion of open issues at IETF 100 in Singapore.
>
>
> Thanks
>
> nils & suhas
>
> _______________________________________________
> Perc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perc
>
-- 
—sent from my mobile

---

From: Richard Barnes <[email-masked]>
Date: Fri, 17 Nov 2017 21:08:32 +0800

Re-adding the list...

On Nov 17, 2017 21:07, "Richard Barnes" <[email-masked]> wrote:

Emil - Can you explain what this draft has to do with repair?

EKT allows two DTLS-SRTP endpoints to establish a shared encryption key
that is not directly bound to the DTLS handshake.  It seems no more related
to repair than DTLS-SRTP itself.

On Nov 17, 2017 19:39, "Emil Ivov" <[email-masked]> wrote:

> I dont believe that there has ever been consensus on this in the WG
> despite Suhas’s insistance otherwise.
>

---

From: Emil Ivov <[email-masked]>
Date: Fri, 17 Nov 2017 13:10:36 +0000

Oops sorry, this was an oversight on my behalf!

(Thanks Richard for pointing it out to me!)

I confused the mails about double with the WGLC on ekt-diet.

My mail was intended for double only

Appologies for the confusion!

Emil

-- 
—sent from my mobile