Subject: RE: [Simple] Extending <status> for presence

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 14 Jan 2003 11:09:10 -0500

> Note that while I might want to distinguish my own status as 
> really-offline or online-but-invisible, this isn't a 
> distinction that is 
> shared with those that receive my status, at least until we start 
> distinguishing between what is presented to different people.
Now, please.  Several systems do some form of this now.
Our system will "filter" presence states to watchers.
We classify users into groups, and have a filter rule for
each group.  The rule is a simple substitution of one state
for another.  Basically, you implement a very fine grained
presence state, but may show much coarser grained state
to different users. 

In the context of this discussion, the only implication is
that the "coarser" states are actually represented.  So far,
most of the proposals do that.  That characteristic also
allows simpler presence systems to remain within the 
standards, which is a good thing.

> 
> Conceivably I might be seen as some variant on OPEN to my secretary 
> while I am CLOSED to everybody else. But in that case my 
> secretary might 
> also need to know that I am trying to be invisible to others. I don't 
> see quite how to fit that into presence status.
I don't think you need to.  Some day, we may need some semantics to
allow someone like your secretary to query the presence service
to find out what your presence state as viewed by a particular
watcher, but so far we haven't found that to be necessary.

....snip....

> > Furthermore, I think that for "Busy-no-interrupt" and
> > "Busy-interrupt-with-authority", the specification has to provide
> > some guidance to the software designer.  The presentity's UA should
> > *not* even display IMs for the presentity if it in 
> "Busy-no-interrupt"
> > mode.  Likewise, if the presentity's UA is in 
> "Busy-interrupt-authority"
> > status, only those IMs from an authorized user (i.e. department
> > secretary, hospital administrator, etc.) should be displayed.
We do this by mapping busy-interrupt-with-authority to either
busy or busy-interruptable depending on who you are.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 20 Jan 2003 10:21:14 +0200

Ok, so we are talking about idle detection. I was confused because "Active" could mean that my device is activated and so just wanted to make sure that we are referring to a presentity.

Regards,
Hisham

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: Thursday, January 16, 2003 11:10 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Simple] Extending <status> for presence
> 
> 
> Hisham,
> 
> I'm not sure who you were addressing, but I will assume it was me.
> 
> I didn't originally factor active/inactive into my view, but 
> have been 
> convinced that it is distinct and relevant.
> 
> Most of the popular IM systems have this in one form or 
> another. It is 
> typically used to deal with the case where you are online and present 
> for IM, but then wander away from your system without doing 
> anything to 
> change your presence. In this case, the IM client on your 
> system notices 
> that you seem inactive - often by monitoring your use of the mouse or 
> keyboard - and changes your presence status. It may then also 
> change its 
> own behavior - perhaps sending an automatic reply to incoming 
> messages.
> 
> In general this is tied to a device. If you do IM on your pc but get 
> phone calls on your cell phone, then the fact that you became 
> inactive 
> on your pc doesn't imply anything about your status relative to your 
> cell phone.
> 
> 	Paul
> 
> [email-masked] wrote:
> > If a tuple is representing a device, the OPEN and CLOSED 
> means that the device is available for communication (to the 
> extent that I could tell if the device is turned on or it is 
> off). The list of elements that follow tells you which 
> communication means are available and which are not:
> > 
> > Using draft-lonnfors-simple-prescaps-ext-00.txt. It is:
> > 
> > <tuple id="aak988">
> >    <basic>OPEN</basic>
> >    <callerprefs-stuff>voice not allowed except high
> >     priority</>
> >    <ext:prescaps>
> >       <ext:feature name="message">
> >          <ext:value>false</ext:value>
> >       </ext:feature>
> >       <ext:feature name="audio">
> >          <ext:value>true</ext:value>
> >       </ext:feature>
> >       <ext:feature name="application">
> >          <ext:value>true</ext:value>
> >       </ext:feature>
> >     </ext:prescaps>
> > </tuple>
> > 
> > Active/Inactive could mean that even though my device is 
> open, I, as a presentity, am inactive on that device. Where 
> did those active/inactive come from? What was the original 
> need for them?
> > 
> > Regards,
> > Hisham
> 
>

---

From: [email-masked]
Date: Mon, 20 Jan 2003 10:29:34 +0200

> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, January 16, 2003 9:38 PM
> To: Thanos Diacakis
> Cc: Vijay K. Gurbani; Paul Kyzivat; Henning Schulzrinne; 
> [email-masked]
> inline.
> Thanos Diacakis wrote:
> > Vijay Gurbani wrote:
> >>>While its not clear to me what a basic
> >>>status of OPEN for a presentity means when each of its 
> child tuples (the
> >>>devices) are CLOSED,
> >>
> >>Easy to represent DND.
> > 
> > 
> > No!  My "activity" (DND in this case) is orthogonal to the 
> OPEN/CLOSED
> > status of my devices and we cannot represent the one using 
> the other.  We
> > need a separate variable/tuple/field to do so.
> 
> I am with Thanos here, in that I am not understanding Vijay's 
> definition 
> of DND, or what his interpretation of OPEN/CLOSED for a 
> presentity means.
> 

I will try to interpret what Vijay is trying to say with an example:

I arrive at my office room in the morning and therefore I become available (OPEN). I still haven't switched any of my electronic devices on, so all of them have a status of CLOSED. So in that sense, I am available in my room where anyone can come knocking on the door, but not on any device.

The funny thing is, I need a device to publish the information that I, as a presentity, am available in my office for face to face communication. So Vijay's argument could be tied to devices that publish location information (ankle strap :). That device doesn't convey an communication means, just location.

Regards,
Hisham