Subject: RE: [Simple] FW: I-D ACTION:draft-lonnfors-simple-prescaps-ext-00.txt

From: [email-masked]
Date: Wed, 15 Jan 2003 20:25:29 +0200

Hi,

Back to this old topic. 
Inline:

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 18 November, 2002 08:09
> To: Paul Kyzivat
> Cc: Lonnfors Mikko (NRC/Helsinki); [email-masked]
> Subject: Re: [Simple] FW: I-D
> ACTION:draft-lonnfors-simple-prescaps-ext-00.txt
> 
>  >
>  >> w3c has done a lot of work in describing capabilities 
> (CC/PP, RDF),
>  >> all of which is XML-based. I wonder if there is a better fit here
>  >> to use that kind of syntax?
>  > 
> -Jonathan R.

I have been looking if RDF or CC/PP could be utilized to represent caller preferences information instead of using our own XML format. Basically situation seems to be that RDF may not be the best choice for us in this situation. RDF defines a framework which can be used to represent metadata about resources. It defines simple model for describing relationships among resources in terms of named properties and values. It cannot by itself be used to represent data required by specific applications and so it needs an additional vocabulary for each application.
CC/PP defines one set of vocabulary (based on RDF) which is a description of device capabilities and user preferences that can be used to guide the adaptation of content presented to that device. CC/PP defines things like display size, terminal software, and browser capabilities. These don't provide much help for items needed for caller preferences. So, if we would like to utilize RDF it would have following consequences:
1) We would probably need to define a new vocabulary. It is a bit unclear if this should be done in W3C or in IETF
2) UAs would need to have support for RDF aware parsers. RDF representation is based on XML but parsers need to understand whole RDF schema. Currently such parsers are not widely available.

If the whole presence info would be build utilizing RDF (PIDF would be based on RDF) then it would make sense to use RDF but probably not in this situation. I would propose that for now we stick with our own XML format. 

Best Regards
- Mikko
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 16 Jan 2003 08:43:32 -0500

I am fine with this conclusion. From my own glance through RDF it seems 
like quite a bit of overkill for the very simple things we are doing now.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com