Subject: RE: [Simple] Extending <status> for presence

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 10 Jan 2003 16:28:00 -0500

I think we are talking past one another.

I expect that my incoming SIP (voice) proxy will become
a watcher to my presence.  I will change call forwarding
for incoming calls based on my presence.  There is no
way for callerprefs and CPL to do that (well, my CPL
implementation could have presence as an input, and I
could mechanize the actual call forwarding implementation 
in CPL).  The point is that callER prefs don't have
anything to do with it.  It depends on "calling" presence.

If you, as an acquaintance of mine, have both my sip uri
and my mobile phone number, and you become a watcher to
my presence, and I show as "Out of Office", you have the
option to call me on my mobile number, which I may or
may not answer.  That is not an automaton, and doesn't
need fine grained presence.

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, January 10, 2003 3:57 PM
> To: Rosen, Brian
> Cc: 'Jonathan Rosenberg'; Vijay K. Gurbani; [email-masked]
> Subject: Re: [Simple] Extending <status> for presence
> 
> 
> 
> 
> Rosen, Brian wrote:
> 
> >>I think this is a case where you don't really want "on vacation" or 
> >>"out-of-office" per se, but some kind of more general 
> purpose status 
> >>with semantics that imply preferences for one type of 
> communications 
> >>device over another.
> > 
> > I don't think so.  The presentity sets his state by what he 
> is actually
> > doing.  The systems around him react to that appropriately.
> 
> This is one approach. But not the only one.
> 
> When I publish that I am "on vacation", I leave it up to the presence 
> client to decide if it is ok to call or not. I might prefer 
> not to share 
> that kind of info with the public, but instead simply say 
> whether I am 
> answering the phone or not.
> 
> > I don't want to have a caller know what is happening (although he
> > might care, the note would work to tell him what to expect when he
> > places a call), but I want my system to decide if it should ring
> > my desk, my cell or my home phone depending on who is calling and
> > what my presence state is.
> 
> The behavior you describe here doesn't require presence at 
> all. This is 
> what callerprefs plus CPL are for.
> 
> Presence permits the caller to take over some of this. It is 
> exactly why 
> we are trying to get all the callerprefs info into presence.
> 
> It is interesting to consider a proxy that makes routing 
> decisions based 
> on presence rather than a location service and callerprefs. I firmly 
> believe that this is what would happen if we were starting 
> over with sip 
> - we would use this instead of registration. But given where we are 
> today, I don't think that presence will replace registration 
> any time soon.
> 
> > It's up to me (the presentity) to decide if I will in fact forward
> > a call from you to my cellphone if I am "out of office", and in
> > fact, if it's my wife calling, I will forward the call to my mobile
> > even if I'm "On Vacation".  So, presence state of "On Vacation" is
> > what my local incoming proxy needs.  I make it a watcher, and 
> 
> Surely you can do as you wish. But it is probably unwise to 
> act in ways 
> inconsistent with the presence information you publish. It 
> will simply 
> confuse things. And if you do it enough, your buddies will cease to 
> trust your presence.
> 
> 	Paul
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 10 Jan 2003 18:49:36 -0500

Brian - inline.

	Paul

> I think we are talking past one another.

Yes, I think so. But what follows helps in figuring out where you are 
coming from. But not enough yet.

> a watcher to my presence. 

You say "incoming SIP (voice) proxy" as if that is somehow different 
than your incoming SIP IM proxy, or presence proxy. You may have 
different devices responsible for voice and IM, but why would you want 
them to use a different proxy or registrar, or have a different Address 
of Record?

Then they may all be publishing components of presence status for the 
same presentity (= AoR).

If so, you only have one presence, perhaps with multiple tuples, perhaps 
not, depending on how you want to expose your presence status.

Now you could still build a proxy that routes based on presence. But 
because it also sees all the devices as contacts on the AoR it can also 
route without presence - just using callerprefs logic.

> I will change call forwarding
> way for callerprefs and CPL to do that

I am still confused by how you see this working. Are you saying that the 
address the proxy is processing is distinct from the contacts in the 
tuples of the presence document? That there are no REGISTERed contacts 
for that address (except perhaps for the presence server)?

I suppose that would be one way to skin the cat, but not a way I have 
been considering, or am inclined to favor.

> (well, my CPL

Huh? "calling" presence?

> need fine grained presence.

Why would I want to know both of your numbers? I would much prefer to 
call sip:[email-masked] regardless and have it go to whichever 
of your phones you choose to answer.

We already have a mechanism to do that in sip - you can register both 
phones as contacts of sip:[email-masked]. Your proxy can 
parallel fork to both for everybody, or serially fork to the mobile 
after trying the office. Or it can, with something like CPL, only try 
your mobile phone when its a friend calling. Or, I as a caller could 
specify a callerpref of mobility="mobile", and explicitly select your 
mobile phone.