Subject: RE: dnd (was RE: [Simple] Extending <status> for presence)

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 22 Jan 2003 15:27:50 -0500

I'm agreeing with the flow, and the concept.  We do this now.
The question is, are the states between the entities the same,
or different?  Does the possible states across the
Presentity to PA transaction the same as the possible states from
the PA to the Watcher?

At the moment, I think they are the same.  I think [filter] is
simple state substitution.  I can filter "Out on the phone" to
"Interruptable" for example.

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, January 22, 2003 2:43 PM
> To: Rosen, Brian
> Cc: Peterson, Jon; [email-masked]
> Subject: Re: dnd (was RE: [Simple] Extending <status> for presence)
> 
> 
> > So, are you arguing for one set of states that a presentity 
> > defines to his presence system, and another set of states that the
> > presence system supplies to watchers?  That is possible, but I'm
> > not so sure I think it's the right thing to do.
> 
> This is only one architecture, something like:
> 
> presentity --> [PUBLISH] --> PA (filter) --> [NOTIFY]
> 
> I suspect that such filtering or customized will be fairly common, 
> particularly as more information is added to presence 
> information, such 
> as location information or detailed start/ending times.
> 
> Henning
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 22 Jan 2003 14:42:05 -0600

Rosen, Brian wrote:
> I'm agreeing with the flow, and the concept.  

>We do this now.

Maybe you are already implying this, I am not sure.  But just to be
concrete, I would think that there is some value to having [filter] be
more than simple 1-to-1 state substitutions.  The PA can selectively
advertise me as "Busy" to all watchers except my spouse who sees
"Interruptible", for example.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216