Subject: [Simple] RE: draft-lonnofors-simple-partial-notify-00

From: [email-masked]
Date: Tue, 28 Jan 2003 12:16:57 +0200

Hi Sean,

Definitely that was one of the approaches we were considering but finally it was decided to aim that functionality by considering another content-type rather than defining a new header.
Nevertheless, this should be evaluated in the list since our objective is to have a mechanism that solves this problem in the most optimal and scalable way without altering too much the protocol itself.
Regards,
Jose

> -----Original Message-----
> From: ext Sean Olson [mailto:[email-masked]]
> Sent: 28 January, 2003 09:11
> To: Costa-Requena Jose (NMP/Helsinki); Lonnfors Mikko (NRC/Helsinki);
> Lonnfors Mikko (NRC/Helsinki); Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]
> Subject: draft-lonnofors-simple-partial-notify-00
> 
> 
> Hi,
> 
> I had a quick comment about the draft. I definitely see the need for 
> a partial notification mechanism. I also think the mechanism 
> proposed in
> the draft
> is a fairly straightforward and common approach to solving 
> this problem.
> My main
> comment is whether or not we can potentially generalize this 
> approach by
> moving the
> version and state variables out of the body and into SUB / 
> NOT specific
> headers. Potentially even entity headers? I think this is a cleaner
> approach then
> necessarily creating two different but related schemas for 
> the full vs.
> partial 
> notification. 
> 
> Regards,
> Sean Olson
> Microsoft
> 
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 28 Jan 2003 15:00:21 -0500

I think the version and state information belong in the XML document 
because they are document meta-data that is essential for the processing 
of the document itself. If the document was delivered by some other 
means, that same information would need to be present in order to 
process it (for example, if it was fetched from content indirection).

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com