Subject: RE: dnd (was RE: [Simple] Extending <status> for presence)

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 22 Jan 2003 10:51:22 -0500

> (2) There may be some rule-based mechanism in your presence 
> agent that 
> translates your PUBLISHed 'dnd' to a set of OPEN and CLOSED 
> indications 
> for particular subscribers.
> 
> Other indications, such as 'open' or 'closed', customized for each 
> recipient of the notification, determine the precise meaning for each 
> means of communication.
> 
So, are you arguing for one set of states that a presentity 
defines to his presence system, and another set of states that the
presence system supplies to watchers?  That is possible, but I'm
not so sure I think it's the right thing to do.
 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 22 Jan 2003 14:43:08 -0500

> not so sure I think it's the right thing to do.

This is only one architecture, something like:

presentity --> [PUBLISH] --> PA (filter) --> [NOTIFY]

I suspect that such filtering or customized will be fairly common, 
particularly as more information is added to presence information, such 
as location information or detailed start/ending times.

Henning