Subject: RE: [Simple] MSRP: HOL & SCTP

From: Adam Roach <[email-masked]>
Date: Wed, 23 Apr 2003 22:59:36 -0500

If I thought we'd have SCTP on most major servers within
a year, I'd agree.

/a

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Wednesday, April 23, 2003 22:42
> To: Ben Campbell; Paul Kyzivat
> Cc: Simple WG; Jonathan Rosenberg; Robert Sparks
> Subject: [Simple] MSRP: HOL & SCTP
> 
> 
> 
> Another possible solution for the head of line blocking would 
> be to say that
> it SHOULD support SCTP between relays and MUST support TLS 
> and have in the
> limitations that you just have to live with blocking if you use TCP.
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 23 Apr 2003 21:09:13 -0700

I have been having some out of band discussions with Randall and Ken -
perhaps they can provide more here. It seems unlikely to me we will have it
on most servers in a year but I don't really know much about it's rollout.
Perhaps Randall or Ken can provide more info?

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Thu, 24 Apr 2003 06:59:32 -0500

Well lets see..

BSD - is available now.. (all of the triplets)
Linux - It is available in 2.5.whatever but if I remember
             right even numbers are there "stable" releases. So the
             2.6 release... whenever linus calls it will have SCTP in 
native. Will
              this be within a year.. only linus knows :>

Solaris - I have just been informed Sun is stepping up its effort on getting
               past the "freeware" add that they currently offer and 
putting it
               into base solaris (when I don't know). Will it take a 
year.. probably
               but I hope not much longer...

HP - My contacts there tell me there is a stack currently (I think it is
         an option.. they were not specific).. but they were considering
         doing something else internally too.. of course they are a 
conglomerate
         of DEC/Compac/Tandum and HP.. so they have lots of platforms .. 
which
         ones run there SCTP .. I am not sure.. I could find out if you 
would like..

Windows - ?? I have no idea ?? I know there are add on stacks you can
                   purchase for it.. but who knows what MS is doing... 
of course
                   I don't think one should "engineer" to windows... 
better to
                   do something like is mentioned below and when all of 
MS's
                   competition rolls out there solution... you end up 
with pressure
                   on MS to come on board... otherwise you might has 
well just
                   get MS to design things for you.....

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 25 Apr 2003 17:13:36 -0400

What about:

- firewall support? Don't we need to get this thru firewalls?
   or would we expect it only to be used between relays on the
   public internet?

- JVM support?

Also, even with SCTP between relays, there is still a congestion problem 
to solve as long as there are multiple hops. SCTP would only solve that 
for us if we used it end to end.

Do BEEP and/or Jabber deal with congestion?

	Paul

Randall Stewart (cisco) wrote:
>                   purchase for it.. but who knows what MS is doing... of 
> course
>                   do something like is mentioned below and when all of MS's
>                   on MS to come on board... otherwise you might has well 
> just