Subject: RE: [Simple] Re: Draft-campbell-simple-im-session-01: Integrity and Privacy

From: Adam Roach <[email-masked]>
Date: Mon, 21 Apr 2003 15:57:17 -0500

We're using MIME for the bodies... is there any reason that
S/MIME can't be used to provide the properties you propose?

In particular, I don't think we want to have significantly
different models for signing and sealing when you compare
session-mode messages with page-mode messages. If you do it
two different ways, it's just more code to write.

/a

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Saturday, April 19, 2003 22:35
> To: [email-masked]; Jonathan Rosenberg; Robert Sparks; Paul Kyzivat;
> Ben Campbell
> Subject: [Simple] Re: Draft-campbell-simple-im-session-01: 
> Integrity and
> Privacy
> 
> 
> 
> There should be an option to provide end to end privacy and integrity
> preferably with keying material passed in the SDP that set up 
> the session.
> Probably want to look at CMS key wrap stuff here. MIKEY seems 
> inappropriate
> here given the session was set up with SIP. 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 21 Apr 2003 22:07:19 -0700

I would very much like to see the session mode security be about the same as
the page mode so I like the use of S/MIME. I think we might need some slight
extensions to S/MIME for the keywrap stuff.

---

From: Ben Campbell <[email-masked]>
Date: 22 Apr 2003 15:33:19 -0500

Some questions:

Both of you are assuming a session key is passed in the sdp negotiation,
rather than negotiated using a public key session-key exchange for each
message, right? 

Can someone provide a pointer to "CMS Keywrap stuff"?

Cullen: Can you amplify why you think MIKEY is not useful here?

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 23 Apr 2003 20:40:14 -0700

Yes - we both are assuming a session key was passed in the SDP. The SDP was
end to end protected with S/MIME. There is no need to introduce yet another
complex security scheme such as MIKEY here unless we plan to deprecate
S/MIME from SIP. 

Looks like the keywrap stuff we want has made it into RFC 3394 so ignore
that thread.