Subject: RE: [Simple] Re: Draft-campbell-simple-im-session-01: Loops

From: Adam Roach <[email-masked]>
Date: Mon, 21 Apr 2003 16:02:15 -0500

Inter-relay connections are based exclusively on the
machine-portion of the URI included in the message.
There is no room in the spec for application-based
routing of MSRP messages. As a consequence, loops
are not possible in the current protocol; the longest
chain of connections that could possibly be established
would be four: two clients, two relays.

/a

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Saturday, April 19, 2003 22:37
> To: [email-masked]; Jonathan Rosenberg; Robert Sparks; Paul Kyzivat;
> Ben Campbell
> Subject: [Simple] Re: Draft-campbell-simple-im-session-01: Loops
> 
> 
> 
> If there is more than one relay, it needs to be possible to 
> detect loops in
> relay routing. A counter seems reasonable. Counting up 
> instead of down might
> make the count useful for discovering which path of relays 
> has the least
> number of relays. This would allow an ICE like mechanism for 
> trying various
> combination of relays.
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 22 Apr 2003 15:34:29 -0500

I agree with Adam on this point. I don't think we need to think too much
about this unless we move to an arbitrary number of relays.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 23 Apr 2003 20:39:55 -0700

Agreed.