Subject: RE: MSRP: Connection Sharing (was Re: [Simple] MSRP: Towards clos ure on HoL blocking issue)

From: Adam Roach <[email-masked]>
Date: Wed, 30 Apr 2003 14:35:34 -0500

Ben Campbell writes:

> 2) SCTP does _not_ solve the flow control problem, being defined as
> using up the relay buffers when one of your sessions has a 
> faster input
> than output. Nor does it solve a particular (different from 
> above) class
> of HOLB where relay resource consumption by a given session consuming
> too many resources and thus impacting delivery of messages on another
> session.

...

> 2) will require a solution for any approach--even separate TCP
> connections could cause a problem if a relay is so badly 
> designed to to
> allow any one connection to eat all its resources.

Ummm... there's not a whole lot we can do to protect network
nodes that are "so badly designed that they do X" from
themselves. If you identify some stupid behavior X that
seems likely to be a common mistake, provide guidance.
But it seems an exercise in futility to make excessive
provisions in the protocol to deal with poor design.

> Separate TCP does
> allow us to use the transport layer to quench upstream delivery--but
> that still assumes a lot about how you go about processing 
> inbound data.

And Henning has asked for those assumptions to be explicitly
stated in the document: "The important part in the specification
is to recommend cut-through switching or at least SCTP chunk switching,
i.e., relays should not wait until the whole message is delivered
before starting delivery to the next hop."

I think that would be sufficient guidance to head off the
poor designs you describe above. Do you agree?

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 30 Apr 2003 14:52:33 -0500

> provisions in the protocol to deal with poor design.

My point was that problems of unfair consumption of resources by a
session is not necessarily limited to the shared connection case. It
just makes it incrementally easier to make poor design decisions.

> poor designs you describe above. Do you agree?
While I like this for other reasons, it is not clear to me how it solves
the flow control issue. Further, it complicates matters if a relay now
needs to be able to drop an SCTP chunk in the middle of a message, or it
the relay needs to be able to reply to a chunk, rather than a whole MSRP
message.