Subject: RE: [Simple] Re: Draft-campbell-simple-im-session-01: Assumption s

From: Adam Roach <[email-masked]>
Date: Mon, 21 Apr 2003 16:09:08 -0500

Cullen Jennings writes:

> The point is, there are reasonable 
> cases where more
> than two media relays need to be in the path.  This 
> requirement of more than
> two complicates the protocol. I'm not sure it should be a 
> requirement but we
> need to figure out if it is or not. 

I'm voting for "KISS" here. If you have some special
third-party virus-scrubber relay you want to send
all your messages through, make it a party to the
session. I really don't see the need to complicate
the MSRP protocol with these outlier cases when
other solutions exist.

In other words, we're having to solve this sort of
thing in SIP already (because RTP doesn't include
application-logic routing), so let's re-use those
solutions instead of repeating them in MSRP.

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 22 Apr 2003 14:49:28 -0500

> solutions instead of repeating them in MSRP.

I agree with Adam here. We had many discussions over a requirment for an
arbitrary number of proxies, and generally agreeed to keep the current
scope to two (and one, for most cases). The main reason for this is to
actually get something done. If we cover every possible scenario, that
will never happen.