Subject: [Simple] Message Sessions: SDP and TLS

From: Adam Roach <[email-masked]>
Date: Mon, 7 Apr 2003 18:47:36 -0500

The current message sessions draft has language that
specifies that the syntax "m=message xxxx msrp/tls ..."
is used to specify that a TLS connection will be used.

I think this will cause big problems in the future.
In particular, while it's clear from the syntax that
TLS will be used, we've lost any indication of which
transport will be used. TCP? SCTP? Something else?

TLS is in the presentation layer. I don't think SDP
has been extended for TLS yet, but when it is, I would
think a syntax more like "msrp/tcp-tls" or "msrp/sctp-tls"
would be more appropriate.  (Not technically *correct*
according to my understanding of 2327, but at least it
doesn't confound presentation with transport as badly).
Or, even better, "msrp/tcp" with an "a=presentation:tls"
line.

Thoughts?

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 07 Apr 2003 20:24:27 -0500

> Or, even better, "msrp/tcp" with an "a=presentation:tls"

I like the attribute approach, myself.

Another option just for consideration would be "msrps/tcp". That would
of course require us to define msrps semantics, which I am not convinced
are otherwise necessary.