Subject: RE: [Simple] Re: Draft-campbell-simple-im-session-01: Head of Li ne Blocking

From: Adam Roach <[email-masked]>
Date: Tue, 22 Apr 2003 15:35:40 -0500

Ben Campbell writes:

> That being said, if we went with the message/partial approach (which I
> admit not being an expert on) how much would we have to say 
> about it in this specification?

Unfortunately, MIME imposes a staggering number of restrictions
on the use of message/partial (such as allowing it to only use
7bit encoding) that stem almost exclusively from restrictions
in legacy e-mail systems. This means that we wouldn't be able
to simply say "use message/partial" without specifically relaxing
on the order of a dozen normative statements. So, it might be
a fair bit of text. There's also the complication that, as
specified, message/partial, when reconstituted, is defined
to contain a complete RFC822/2822 message, which isn't what
we mean to say.

That's why I said we might want to define a new "message/msrp-partial",
which (when reconstituted) contains an entire MSRP message.
Doing so would mostly involve copying text from the MIME spec, but
removing most of the restrictions.

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 22 Apr 2003 16:00:34 -0500

> removing most of the restrictions.

Do you think it is necessary to define this in the base specification
for message sessions, or can it be a follow-on work?