Subject: RE: [Simple] Message Sessions: Failure Behavior

From: Adam Roach <[email-masked]>
Date: Mon, 7 Apr 2003 21:21:15 -0500

From Ben Campbell [mailto:[email-masked]]:
> On Mon, 2003-04-07 at 20:55, Adam Roach wrote:
> > Ben Campbell [mailto:[email-masked]] writes:
> > 
> > > Unless of course you cannot re-establish the connection. 
> > > Currently there
> > > is no way for a relay to tell an endpoint this has occurred.
> > 
> > We certainly could add an error code that communicates this
> > case. Am I overlooking something obvious?
> > 
> Only that we were trying to make things so that a relay never 
> replies to
> a SEND request.

Ummm... 

  "If the relay receives a SEND request that does not match the opposite
   URI of the session, the relay MUST return a 404 response. If a SEND
   request arrives on a connection that has no associated sessions, the
   relay MUST return a 481 response."

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 07 Apr 2003 21:23:32 -0500

>    relay MUST return a 481 response."

Uhm, yes, I guess there is that. So a similar return code for "I can't
talk to the other relay" would seem to fit perfectly.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 19 Apr 2003 00:54:14 -0400

Just to be clear; the case you want to avoid is that the relay sends the 
request, and never gets a response, and then generates a timeout error 
response. The lessons we learned in SIP with this should be applied 
here. The relay can ONLY generate its own response if it never actually 
forwarded the request in the first place. That means it cannot generate 
an error response on a timeout.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Ben Campbell <[email-masked]>
Date: 19 Apr 2003 15:42:33 -0500

Agreed.