Subject: [Simple] RE: MSRP: Towards closure on HoL blocking issue

From: Adam Roach <[email-masked]>
Date: Mon, 28 Apr 2003 14:30:17 -0500

I agree.

/a

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Monday, April 28, 2003 14:19
> To: Robert Sparks; Adam Roach; Jonathan Rosenberg; Paul 
> Kyzivat; Cullen
> Jennings
> Cc: Simple WG
> Subject: MSRP: Towards closure on HoL blocking issue
> 
> 
> We have had lots of discussion on this, going off in several 
> directions.
> 
> I re-propose the following. If anyone has serious objections, please
> speak up. (Actually, I would appreciate it if anyone who has 
> previously
> expressed an opinion on this matter to speak up one way or another.)
> 
> 1. 64k-1 end-to-end size limit on MSRP requests, enforced by a fixed
> length message size field.
> 
> 2. Chunking pushed to a future (but real soon) work. Chunking would be
> endpoint controlled, negotiated in SDP, and likely based on 
> the existing
> MIME message/partial spec with some relaxation of the 7 bit 
> rules, etc.,
> that Adam mentioned.
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Adam Roach <[email-masked]>
Date: Mon, 28 Apr 2003 17:40:15 -0500

> I would think that a DOS attacker would simply ignore 
> restrictions that
> say how many outstanding transactions you can have at once. 
> So for this
> to be helpful against attackers, the relay has to _enforce_ the limit.
> How would you enforce it? Forcing a relay to be transaction 
> stateful for
> SEND requests?

Under the model that you're discussing (use of windows),
the relay is already maintaining a queue for each ongoing
session. It will know how deep this queue is. If a sender
tries to send more messages/bytes than allowed, the relay
can trivially enforce the limit by dropping the TCP connection.
You won't ever get a TCP connection drop between two
conforming relays, since the one closest to the client would
enforce the limit before it ever got onto an inter-relay link.

Alternately, you could send an error response. But it
doesn't seem very sporting to play nice with an obvious
DOS attacker.

/a

---

From: Adam Roach <[email-masked]>
Date: Wed, 30 Apr 2003 02:05:23 -0500

I think you need to re-read Henning's arguments about
why SCTP doesn't solve the problems introduced by
connection re-use.

/a

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, April 30, 2003 1:39
> To: Adam Roach
> Cc: 'Simple WG'
> Subject: Re: [Simple] MSRP: Towards closure on HoL blocking issue
> 
> 
> I just want to make sure my position is clear here. I do like 
> reuse, and 
>   would prefer to support it by allowing (but not requiring) SCTP 
> between relays. Each session then goes on a separate stream. We would 
> not attempt to support reuse over TCP.
> 
> -Jonathan R.
> 
> 
> 
> Adam Roach wrote:
> > With enough people weighing in supporting this
> > approach (Jonathan, Ben, Dave, Dean, me, Henning,
> > Aki), and only one objecting (Cullen), it would
> > appear that we're rapidly approaching rough
> > consensus. Chairs?
> > 
> > (Sorry, Cullen. I understand your concern, but
> > the reuse requirement makes everything else too
> > difficult.)
> > 
> > /a
> > 
> > 
> >>From: Jonathan Rosenberg [mailto:[email-masked]]
> >>Sent: Tuesday, April 29, 2003 23:44
> >>To: Dean Willis
> >>Cc: 'David R. Oran'; 'Ben Campbell'; 'Robert Sparks'; 'Adam Roach';
> >>'Paul Kyzivat'; 'Cullen Jennings'; 'Simple WG'
> >>Subject: Re: [Simple] MSRP: Towards closure on HoL blocking issue
> >>
> >>
> >>I concur with Dave and Dean here. Let us have no restriction 
> >>on message 
> >>sizes, and have relays use a different connection for each 
> >>session. We 
> >>should be sure to mention the idea Henning mentioned of 
> holding on to 
> >>connections after the sessions terminate, so they can then be reused
> >>for subsequent sessions.
> >>
> >>Furthermore, I don't even see the real troubles with 
> supporting SCTP 
> >>now. I would not make it mandatory; I would rather say that 
> everyone 
> >>MUST to TCP and MAY do SCTP. From rfc3264 we have a pretty 
> >>good handle 
> >>on how to support discovery for URIs that can run on multiple 
> >>transports.
> >>
> >>-Jonathan R.
> >>
> >>
> >>Dean Willis wrote:
> >>
> >>>>From: [email-masked] [mailto:[email-masked]] On 
> >>>>Behalf Of David R. Oran
> >>>>Sent: Tuesday, April 29, 2003 10:14 AM
> >>>>To: Ben Campbell; Robert Sparks; Adam Roach; Jonathan 
> >>>>Rosenberg; Paul Kyzivat; Cullen Jennings
> >>>>Cc: Simple WG
> >>>>Subject: Re: [Simple] MSRP: Towards closure on HoL blocking issue
> >>>>
> >>>>
> >>>>Sorry if I'm jumping in late. I much prefer to KISS and do 
> >>>>nothing, as 
> >>>>proposed by Henning. If we want to multilex transport 
> >>>>connections in the 
> >>>>future for relays, do it with SCTP and have one stream per 
> >>>>client session.
> >>>>
> >>>>Dave.
> >>>
> >>>
> >>>Ok, let's see if I have this right:
> >>>
> >>>1) We don't mux with TCP. Ever.
> >>>2) We don't size-limit.
> >>>3) If your session gets congested because you sent a huge 
> >>
> >>message, it's your
> >>
> >>>fault, deal with it, and it shouldn't be bothering anybody 
> >>
> >>else because it's
> >>
> >>>on its own stream somewhere.
> >>>4) Everything works fine, but we've reduced the capacity of 
> >>
> >>relays by
> >>
> >>>something less than 50%.
> >>>
> >>>I'm happy with that. It beats trying to explain queuing 
> >>
> >>theory to Adam,
> >>
> >>>especially since he's smarter than I am. 
> >>>
> >>>--
> >>>dean
> >>>
> >>
> >>-- 
> >>Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> >>Chief Scientist                             Parsippany, NJ 
> 07054-2711
> >>dynamicsoft
> >>[email-masked]                     FAX:   (973) 952-5050
> >>http://www.jdrosen.net                      PHONE: (973) 952-5000
> >>http://www.dynamicsoft.com
> >>
> > 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Scientist                             Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 30 Apr 2003 14:06:13 -0400

Yes, chairs are watching. I hope there is an emerging consensus, yes.

From my perspective (and this is something Allison and I have discussed in
the past), using multiple TCP connections is a reasonable way to get around
HOL blocking. It's also worth noting that when SCTP is used over TLS
(forgive me if this has been pointed out already in this thread), it cannot
use its unordered delivery mode - which makes it behave a whole lot more
like multiple independent TCP streams. I'm not crazy about allowing multiple
transports (pluralism can be a headache), but a MUST for TCP and MAY for
SCTP is fine.

Anyway, our need for prompt resolution of this issue outweighs the benefits
of investigating this matter further, I think.

Jon Peterson
NeuStar, Inc.

> From: Adam Roach [mailto:[email-masked]]
> Sent: Tuesday, April 29, 2003 11:23 PM
> To: 'Simple WG'
> Subject: RE: [Simple] MSRP: Towards closure on HoL blocking issue
> 
>