Subject: [Simple] Message Sessions: should visitors leave?

From: Adam Roach <[email-masked]>
Date: Mon, 7 Apr 2003 18:47:33 -0500

The current draft contains language that makes
a visitor explicitly leave an MSRP session when
it is signalled to be over. This leaving almost
always fails, due to the race condition described
in section 4.

I propose that we remove the mechanism by which
a visitor explicitly leaves an MSRP session.
Instead, the SIP BYE transaction should cause
the party hosting the session to free resources
(including a relay, if necessary).

I've worked through most use cases in my head,
and can't come up with any situations in which
this is detrimental.

Does anyone object to removing such a mechanism
from the protocol?

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 07 Apr 2003 20:22:51 -0500

> Does anyone object to removing such a mechanism

I agree with the proposal. In the old draft, where session state was
hard state, I did not want the visitor to depend on the host to get
things right. But, we are planning to make this soft state, so even if
it does not, the state will eventually expire. And of course, the state
is created on behalf of the host, so it really is the host's problem
anyway.