Subject: RE: [Simple] Message Sessions: m= line format

From: [email-masked]
Date: Tue, 8 Apr 2003 16:57:00 +0300

Would it be possible to delegate some of this negotiation down to MSRP? I.e., have the connection registration (VISIT) handshake carry some of the supported media types - at least those carried inside message/CPIM.

Cheers,
Aki

 > -----Original Message-----
 > From: ext Adam Roach [mailto:[email-masked]]
 > Sent: 08 April, 2003 02:48
 > To: [email-masked]'
 > Subject: [Simple] Message Sessions: m= line format
 > 
 > 
 > The current draft currently outlines that the m= line
 > contains a literal, exhaustive list of all supported
 > media types. Because of the nature of IM, this is likely
 > to be rather large.
 > 
 >   m=message 49232 msrp/tcp message/cpim text/plain text/html
 >   text/rtf text/richtext image/gif image/jpeg image/png image/tiff
 >   image/vnd.ms.ink multipart/signed multipart/encrypted 
 > multipart/mixed 
 >   application/sip-iscomposing+xml
 > 
 > This raises two issues. The first is whether to allow
 > wildcarding, like HTTP does.
 > 
 >   m=message 49232 msrp/tcp message/cpim text/plain text/html
 >   text/rtf text/richtext image/* multipart/signed multipart/encrypted
 >   multipart/mixed application/sip-iscomposing+xml
 > 
 > Another thing to add might be the ability to group according to main
 > type. I don't have a good syntax to offer offhand. Perhaps 
 > something like:
 > 
 >   m=message 49232 msrp/tcp cpim
 >   m=text 49232 msrp/tcp plain html rtf richtext
 >   m=image 49232 msrp/tcp *
 >   m=multipart 49232 signed encrypted mixed
 >   m=application 49232 sip-iscomposing+xml
 > 
 > Or, alternately:
 > 
 >   m=message 49232 msrp/tcp message text image multipart application
 >   a=sub:message cpim
 >   a=sub:text plain html rtf richtext
 >   a=sub:image *
 >   a=sub:multipart signed encrypted mixed
 >   a=sub:application sip-iscomposing+xml
 > 
 > The second issue is it might make sense to express a preference for
 > certain types over others. For example, I might have a low-end
 > device that can convert HTML into plain-text for display, but doesn't
 > do a very good job of it. It would be nice to be able to 
 > express that;
 > something like:
 > 
 >   a=sub:text plain;q=1.0 html;q=0.5
 > 
 > /a
 > _______________________________________________
 > Simple mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/simple
 > 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 11 Apr 2003 09:49:26 -0500

I prefer doing the negotiation in SDP. This seems quite analogous to
codec selection for RTP.