Subject: [Simple] Message Sessions: Soft State

From: Adam Roach <[email-masked]>
Date: Mon, 7 Apr 2003 18:47:30 -0500

The current message sessions draft talks about
binding and visiting as operations that create
hard state. In San Francisco, we discussed the
possibility of changing this mechanism so that
they instead create soft-state that requires
refreshing.

I wanted to make certain this topic was brought
up on the mailing list, and that any objections
have a chance to be raised.

Personally, I think the soft-state approach is
a really good idea, and one that we should
definitely add to the MSRP protocol.

Basically, VISIT and BIND would include a header
that indicates a lifetime for the visitation or
binding. If either is not refreshed before the
time expires, resources can be released.

A very simple scheme would involve putting such
values into the 200 response to BIND and VISIT
requests. In other words, the server decides such
values unilaterally. This saves a great deal of
implementation complexity.

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 07 Apr 2003 20:21:04 -0500

> implementation complexity.

I plan to take that approach in the next draft revision (coming real
soon now) unless someone has a good argument otherwise.