Subject: RE: MSRP: Connection Sharing (was Re: [Simple] MSRP: Towards clos ure on HoL blocking issue)

From: Adam Roach <[email-masked]>
Date: Wed, 30 Apr 2003 14:15:48 -0500

Ben Campbell writes:

> Jonathan suggested we should handle flow control by simply dropping
> messages. This is not as heinous as it first sounds, since MSRP does
> have e2e acknowledgement of message delivery.

The prospect of designing yet another protocol that needs to
retransmit requests over a *reliable* transport layer if
no response is received makes me more than a little queasy.

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 30 Apr 2003 17:27:03 -0400

> no response is received makes me more than a little queasy.

You beat me to it - my stomach has been bothering me for awhile too.

I'm trying to remember why we put the end-to-end acks in. I'm quite sure 
it wasn't so we could drop messages with the expectation that the sender 
would retry them. I think maybe it was so the sender can detect when the 
other end fails.

	Paul