Subject: RE: [Simple] Message Sessions: Security as a motivation

From: Adam Roach <[email-masked]>
Date: Tue, 8 Apr 2003 10:17:35 -0500

Aki Niemi writes:

> Also, the draft does not include much discussion on the fact 
> that msrp/tls by no means ensures e2e security when relays 
> are used. Using TLS as the e2e security mechanism would be 
> the best alternative in many scenarios.

I agree. Down with relays! ;-)

> Perhaps it could be 
> possible to add a "tunnel mode" for the MSRP relays?

You mean kind of like the HTTP "CONNECT" request?

I think that might be going a bit overboard. It also probably
defeats most of the policy that one would deploy a relay to
address anyway.

In another thread, I suggested that the draft simply
mandate that MSRP messages received on a secure connection
must be sent on a secure connection. It's not e2e (that's
what S/MIME is for), but it does give you encryption whenever
the messages are on a network.

/a
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 11 Apr 2003 09:52:16 -0500

Certainly, the security consideration section needs work. It was my
intention to support e2e with s/mime, and not to assert any sort of e2e
protection via TLS. Adam's point of requiring all hops to be TLS if any
are TLS is interesting, as it accomplishes much the same effect of an
MRSPS scheme without actually requireing such a scheme.