Subject: RE: [Simple] Re: Draft-campbell-simple-im-session-01: Scale

From: Adam Roach <[email-masked]>
Date: Mon, 21 Apr 2003 15:59:59 -0500

Are you talking about MSRP or SIP?

;-)

I think this issue ties back to the questions surrounding how
DNS is used to look up MSRP relays. I originally proposed
using only A records, but ongoing (okay, stalled) discussion
indicates that SRV records are probably a better choice.

/a

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Saturday, April 19, 2003 22:35
> To: [email-masked]; Jonathan Rosenberg; Robert Sparks; Paul Kyzivat;
> Ben Campbell
> Subject: [Simple] Re: Draft-campbell-simple-im-session-01: Scale
> 
> 
> 
> In theory, a single IP address can support an unlimited number of TCP
> connections to different servers. In practice, on the OS that 
> relays are
> likely to be implemented in, there are a lot of limitations 
> of the number of
> TCP connections. How to build a server that can support 100k 
> connections is
> probably worth some thought and perhaps discussion.
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 22 Apr 2003 15:50:41 -0500

I agree with Adam here. Is there any reason why these issues are any
different than any for other TCP application?

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 23 Apr 2003 20:34:47 -0700

How many concurrent session is a single relay running on a Linux/Solaris/NT
box going to be able to support? What's the requirement for a system like
Yahoo?

I'm willing to believe that MSRP is OK here - I just want to make sure that
we checked before we called the design done.