Subject: RE: [Simple] Message Sessions: Soft State

From: [email-masked]
Date: Tue, 8 Apr 2003 10:35:53 +0300

Actually, I would like to see a good argument for having soft state? Why is it better? All the hear is that its a good idea, but why is it so?

Having said that, I don't have arguments against.

/Hisham

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, April 08, 2003 4:21 AM
> To: Adam Roach
> Cc: [email-masked]'
> Subject: Re: [Simple] Message Sessions: Soft State
> 
> 
> On Mon, 2003-04-07 at 18:47, Adam Roach wrote:
> > The current message sessions draft talks about
> > binding and visiting as operations that create
> > hard state. In San Francisco, we discussed the
> > possibility of changing this mechanism so that
> > they instead create soft-state that requires
> > refreshing.
> > 
> > I wanted to make certain this topic was brought
> > up on the mailing list, and that any objections
> > have a chance to be raised.
> > 
> > Personally, I think the soft-state approach is
> > a really good idea, and one that we should
> > definitely add to the MSRP protocol.
> > 
> > Basically, VISIT and BIND would include a header
> > that indicates a lifetime for the visitation or
> > binding. If either is not refreshed before the
> > time expires, resources can be released.
> > 
> > A very simple scheme would involve putting such
> > values into the 200 response to BIND and VISIT
> > requests. In other words, the server decides such
> > values unilaterally. This saves a great deal of
> > implementation complexity.
> > 
> 
> I plan to take that approach in the next draft revision (coming real
> soon now) unless someone has a good argument otherwise.
> 
> 
> 
> > /a
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 11 Apr 2003 09:44:13 -0500

The main argument for soft-state is network resiliency in failure
conditions. For example, if the client crashes without explicitly
unbinding, the server will eventually clean things up. You might could
do this by noticing the connection had failed, but I am not sure we can
assume that there are no crash scenarios that leave the connection up,
but the client unable to function properly.

If the server crashes, the client will eventually notice this when it
attempts to refresh the state.