Subject: RE: [Simple] Tuple references and device coupling

From: Cnaan Oded <[email-masked]>
Date: Thu, 3 Apr 2003 12:00:02 +0300

Hope this will come out as text ;)
Comments inline.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 03, 2003 11:38 AM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Simple] Tuple references and device coupling
> 
> 
> Oded, can you please switch to text, thanks.
> 
> Comments inline...
> 
> -----Original Message-----
> From: ext Cnaan Oded [mailto:[email-masked]]
> Sent: Thursday, April 03, 2003 11:13 AM
> To: Khartabil Hisham (NMP/Helsinki); [email-masked]; 
> [email-masked]
> Cc: [email-masked]; Niemi Aki (NMP/Helsinki); 
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Simple] Tuple references and device coupling
> 
> 
> 
> 
> > -----Original Message----- 
> > From: [email-masked] 
> [mailto:[email-masked]] 
> > Sent: Thursday, April 03, 2003 10:48 AM 
> > To: [email-masked]; [email-masked] 
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked] 
> > Subject: RE: [Simple] Tuple references and device coupling 
> > 
> > 
> > A tuple represents a service (communcation medium), the 
> > contact address represents the device where that service is 
> > running. How does that sound? If I choose not to include a 
> > contact, then I'm just publishing that I'm available for 
> that service. 
> > 
> > A copositor will have to combine tuples representing the same 
> > service (medium) that don't have contact addresses and 
> > possibly remove them completely if there is a tuple with a contact. 
> > 
> How would you represent an email service? It has no device 
> but does have a contact address? 
> 
> [Hisham] Well, the contact address can certainly be an IM 
> address, email or an Address of Record of some sort. I was 
> suggesting if people want to explicitly point to service on a 
> certain device, they can put the device address in the 
> contact. The tuple still represents a service (communication medium).
> 

You still haven't solved the fundamental problem of how to describe the
relationship between a service (that has one address) to the device on which
it is running (which might have a different address). The most obvious
example is an IM service on top of a mobile phone. The IM uses a SIP URI
while the phone E.164.

Having the same contact address for both the service and the device is not
the general case. Look also at MMS. I might have an 'email-like' address for
MMS and E.164 for the phone.

> I extend my suggestion above to say that a compositor and 
> combine tuples if the contact address in common among them.
> 
> /Hisham
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 03 Apr 2003 22:21:42 -0500

Cnaan Oded wrote:
> relationship between a service (that has one address) to the device on 
> which it is running (which might have a different address). The most 
> obvious example is an IM service on top of a mobile phone. The IM uses a 
> SIP URI while the phone E.164.

You seem to be describing a braindead device. It has chosen to provide 
separate addresses for different aspects of its functionality. So in 
reality you don't have one device, you have two devices that happen to 
always sit next to one another.

I especially wonder why you consider the phone to be a device while the 
IM is a service. Can't you just as well consider the IM to be a device 
and the phone to be a service?

> Having the same contact address for both the service and the device is 
> not the general case. Look also at MMS. I might have an 'email-like' 
> address for MMS and E.164 for the phone.

In this (broken) case, what benefit do I gain from knowing that these 
two services are in the same device? Would it make any difference to me 
if you instead had both a cell phone and a text pager in your pocket?

	Paul

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple