Subject: RE: [Simple] RE: MSRP: Towards closure on HoL blocking issue

From: [email-masked]
Date: Tue, 29 Apr 2003 10:57:27 +0300

Inline.

 > -----Original Message-----
 > From: ext Adam Roach [mailto:[email-masked]]
 > Sent: 29 April, 2003 01:27
 > To: 'Paul Kyzivat'; Ben Campbell
 > Cc: Robert Sparks; Adam Roach; Jonathan Rosenberg; Cullen Jennings;
 > Simple WG
 > Subject: [Simple] RE: MSRP: Towards closure on HoL blocking issue
 > 
 > 
 > Paul Kyzivat writes:
 > 
 > > Also, your proposal would (I think) mean that the
 > > eventual chunking solution would require a response
 > > for every chunk. I think that could end up making file
 > > transfers inordinately expensive.
 > 
 > Ummm... With the size of MSRP responses, you'd end up with
 > something like 0.25% of the volume of the sent messages
 > in the reverse direction to confirm chunks. I don't think
 > "inordinately" means what you think it means.
 > 
 > > This whole HOLB thing is because we are trying to address use 
 > > cases that might better be addressed by a file transfer
 > > protocol. We had better decide how important a use case this
 > > is.
 > 
 > It DOESN'T MATTER how important it is as a use case.
 > Ignore it as a use case. Treat it as a DOS attack.
 > Unless we address it, it IS a DOS attack. Just
 > saying, "that's not what MSRP is meant for" will
 > NOT stop people from doing it -- including people
 > who want to do it maliciously.

I agree. But if sending a large message to a relay always constitutes a DoS attack (malicious or not), I think there is something seriously wrong in the design of such a relay.

Why is the relay swithching messages instead of TCP packets? What is the added value of such processing to the end points of a session? Why do we want to introduce yet another policy point between an end-to-end session?

The question Paul asked earlier was a good one. Is there a requirements document for MSRP?

Cheers,
Aki
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 29 Apr 2003 08:35:10 -0500

> Why is the relay swithching messages instead of TCP packets? What is the added value of such processing to the end points of a session? Why do we want to introduce yet another policy point between…

We actually considered TCP tunneling, much like the way an HTTP proxy
handled HTTPS. But that approach pretty much prevents connection
sharing, which people have considered important in previous efforts.

> The question Paul asked earlier was a good one. Is there a requirements document for MSRP?

Not to my knowledge.