Subject: [Simple] Windows messenger

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 16 Apr 2002 16:14:38 -0400

Xiaotao Wu in my lab just ran windump and confirmed that Windows
Messenger Version 4.6(4.6.0077) uses SIP for NOTIFY, REGISTER,
SUBSCRIBE. For the "proof", see the message dumps at
http://www.cs.columbia.edu/sip/drafts/messenger.txt

To answer my own question: Messenger embraces and extends XPIDF:

<presence>
<presentity uri="sip:[email-masked];method=SUBSCRIBE" />
<atom id="1003">
<address uri="sip:128.59.19.251:13170;user=ip" priority="0.800000">
<status status="open" />
<msnsubstatus substatus="online" />
</address>
</atom>
</presence>

---

From: "Avshalom Houri" <[email-masked]>
Date: Wed, 17 Apr 2002 21:34:05 +0300

I want to clarify the confusion. I have talked with Jonathan Christensen 
from MS and the status is this: 

The public .NET passport account uses a combination of SIP and  the MSN 
proprietary protocol for IM and presence.  A/V is negotiated with SIP and media is transported with standard RTP.

If you are talking with a SIP server the client talks SIP (you need to 
enable it via Tools/Options/Accounts/Communication Service). 

Avshalom Houri
Presence and Instant Messaging Architect
Lotus Sametime, IBM Software Group
[email-masked]

Henning Schulzrinne <[email-masked]>
Sent by: [email-masked]
16/04/2002 23:14
Please respond to Henning Schulzrinne

        To:        [email-masked], [email-masked]
        cc: 
        Subject:        [Simple] Windows messenger

<presence>
<presentity uri="sip:[email-masked];method=SUBSCRIBE" />
<atom id="1003">
<address uri="sip:128.59.19.251:13170;user=ip" priority="0.800000">
<status status="open" />
<msnsubstatus substatus="online" />
</address>
</atom>
</presence>
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Duane Moore <[email-masked]>
Date: Thu, 18 Apr 2002 13:10:23 -0400

This is true, but is there any fully compliant SIP/SIMPLE/CPIM client
available yet?  I would expect future versions of Windows Messenger to
better support the standards as they are finalized.

-----Original Message-----
From: Christian Jansson [mailto:[email-masked]] 
Sent: Thursday, April 18, 2002 9:37 AM
To: Henning Schulzrinne; [email-masked]; [email-masked]
Subject: RE: [Simple] Windows messenger

But the Messenger seems to have a big problem with the presence
format. The presentity uri should identify the presentity for 
whom the presence data is being reported, but Messenger instead
sends the address of the receiver of the information!? 

The Messenger also does not have any Event header its NOTIFY
messages, and it sends a NOTIFY without any content to indicate
that it is offline.

/ Christian Jansson
 
> <msnsubstatus substatus="online" />

  [reminder: [email-masked] for non-technical discussions, please]

---

From: "Christian Jansson" <[email-masked]>
Date: Thu, 18 Apr 2002 17:37:21 +0200

/ Christian Jansson

---

From: "Roberto Myers"<[email-masked]>
Date: Thu, 18 Apr 2002 10:24:06 -0400

Please unsuscribe roberto myers from dist. list

-----Original Message-----
From: Avshalom Houri [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 12:34 PM
To: [email-masked]; [email-masked]
Subject: Re: [Simple] Windows messenger

The public .NET passport account uses a combination of SIP and  the MSN
proprietary protocol for IM and presence.  A/V is negotiated with SIP and
media is transported with standard RTP.

Avshalom Houri

16/04/2002 23:14 

<presence>