Subject: RE: [Simple] New drafts on Instant Messaging - Question

From: Robert Sparks <[email-masked]>
Date: Mon, 6 Aug 2001 03:53:13 -0400

If the body is meant to be interpreted as a reciprocal message,
there is no way to get it across a CPIM interface (since there
is no way to respond to it).

RjS

> -----Original Message-----
> From: Rami Lehtonen [mailto:[email-masked]]
> Sent: Monday, August 06, 2001 2:37 AM
> To: [email-masked]
> Subject: [Simple] New drafts on Instant Messaging - Question
> 
> 
> According to new drafts on Instant Messaging (e.g. SIP Extensions for
> Instant Messaging) it is forbidden to include a body in the 
> 200 OK messages,
> which are sent after MESSAGE. Does this also apply to Instant Message
> Sessions? If yes, what's the reason for that?
> 
> We have designed a negotiation mechanism based on Instant Messaging
> (MESSAGE), and we use currently a body in the 200 OK messages. The
> negotiation mechanism works for both models on Instant 
> Messaging (with or
> without session). So it would be nice to see the body in 
> response to MESSAGE
> at least in session based model if that does not create any unwanted
> behaviour.
> 
> -- Rami Lehtonen
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Ben Campbell <[email-masked]>
Date: Mon, 06 Aug 2001 04:40:55 -0500

Right. I am curious as to what sort of negotiation the original note 
refers to. I can accept the idea of negotiating things using MESSAGE, 
but I would expect that to be an exchange of MESSAGE transactions, not a 
MESSAGE/200 OK negotiation. Any body in a 200 OK will be lost if this 
crosses a CPIM gateway.