Subject: RE: [Simple] -05 MESSAGE and Expires header

From: Adam Roach <[email-masked]>
Date: Tue, 16 Jul 2002 19:41:40 -0500

Personally, I think the "Expires" handling is sufficient
and unambiguious.

The use of "Priority" would be inappropriate. High priority
items don't necessarily have a high urgency -- and what you're
trying to communicate here is urgency, not priority.

However, I'd take a different tact: this is really a disposition
for the message.

In the final equasion, though, I think it's all a moot point,
since "Expires: 0" works just fine.

/a

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, July 16, 2002 18:24
> To: Bobby Sardana
> Cc: Vijay K. Gurbani; Tan Ya-Ching ICM N PG U ID A 1;
> [email-masked]
> Subject: Re: [Simple] -05 MESSAGE and Expires header
> 
> 
> So, for all that have commented on this thread, is the description of 
> Expires in RFC 3261 sufficient? If so, we can fix this by simply 
> dropping the sentence about "Expires:0".
> 
> Or do you think the MESSAGE draft needs to contain additional 
> language 
> concerning "Priority"?
> 
> Bobby Sardana wrote:
> > I'll cast my vote for the Priority header. Expires: 0 
> somehow implies 
> > that the message needs to be dropped.
> > 
> > regards,
> > 
> > Bobby Sardana.
> > [email-masked]
> > 
> > Ben Campbell wrote:
> > 
> >> Vijay K. Gurbani wrote:
> >> > Tan Ya-Ching ICM N PG U ID A 1 wrote:
> >> >
> >> >> Vijay,
> >> >>
> >> >> It is stated in RFC 3261 section 20.19 Expires that :
> >> >> "The precise meaning of this (header) is method dependant".
> >> >
> >> >
> >> > Agreed.
> >> >
> >> >> The use of the Expires header in MESSAGE is as it is 
> defined in -05.
> >> >> It has
> >> >> only one meaning, so there is no overloading.
> >> >
> >> >
> >> > That is debatable; good thing about ASCII protocols is 
> that they are
> >> > self describing.  Thus, having a "Priority: Urgent" is far more
> >> > preferable to overloading "Expires: 0" to mean immediate 
> handling.
> >> > "Priority: Urgent" in this case makes it far more easy to figure
> >> > out what is going on.
> >> >
> >> > - vijay
> >> >
> >> >
> >> >
> >> >
> >>
> >> I do not have strong feelings on this one way or another--either
> >> approach works for me. I will bow to the will of the 
> majority. Anyone
> >> else have comments?
> >>
> >> _______________________________________________
> >> simple mailing list
> >> [email-masked]
> >> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> >>
> > -- 
> > ___________________________ 
> > 
> > Bobby Sardana |  SEVEN 
> > Software Engineer, Engineering  
> > ___________________________ 
> > 
> > 901 Marshall St.
> > Redwood City, CA 94063
> > 650.381.2535 (v)
> > 650.216.6455 (f)
> > [email-masked]
> > www.seven.com
> > 
> >  
> 
> 
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 18 Jul 2002 11:24:51 +0900

Expires is method specific, since its precise interpretation is method 
specific. The general notion is that it indicates a lifetime of 
something; a point after which the thing is no longer valid. I think 
that this more genearl definition is an exact match to our need here, 
and the current Expires text is an appropriate instantiation of it for 
MESSAGE.

I believe that priority is quite different. A message can be for 
immediate delivery, and be either urgent ("my house is on fire") or not 
("leaving now for lunch"). A message can be OK for storage (some 
non-zero expires) and be urgent ("I need that business presentation by 
10pm!") or non-urgent ("Did you see that movie"). The fact that two 
things can be used orthogonally is a sign that they are, in fact, two 
different things.

I strongly support keeping Expires as currently defined.

-Jonathan R.

-- 
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com