Subject: [Simple] Event

From: Sudipta Ghosh <[email-masked]>
Date: Fri, 06 Dec 2002 15:59:12 +0530

Hi,
When IM Client is sending a SUBSCRIPTION request( to a offline user )
for presence notification to proxy,proxy sends response with 200 OK but
adds a event header.

Whats the meaning of it.

In REGISTER request there is also a Event header.
I am sending the packets.(got from MSN Messenger communication service)

SUBSCRIBE sip:[email-masked] SIP/2.0
Via: SIP/2.0/TCP 10.140.13.178:9172
From: "i" <sip:[email-masked]>;tag=5a9e885b-5af7-45b4-ad41-33eb48ae6a99

To: <sip:[email-masked]>
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Contact: <sip:10.140.13.178:9172;transport=tcp>
User-Agent: Windows RTC/1.0
Expires: 1800
Content-Length: 0

SIP/2.0 200 OK
Via: SIP/2.0/TCP 10.140.13.178:9172;received-port=5060
To: sip:[email-masked];tag=UKXBY32U8GYZBRWM
CSeq: 1 SUBSCRIBE
From: "i" <sip:[email-masked]>;tag=5a9e885b-5af7-45b4-ad41-33eb48ae6a99

Call-ID: [email-masked]
Event: presence
Expires: 1800
Content-Length: 0

REGISTER sip:10.140.13.149 SIP/2.0
Via: SIP/2.0/TCP 10.140.13.178:9172
From: <sip:[email-masked]>;tag=de061b7a-5964-43d5-a297-099e5d6e9796
To: <sip:[email-masked]>
Call-ID: [email-masked]
CSeq: 1 REGISTER
Contact: <sip:10.140.13.178:9172;transport=tcp>;methods="INVITE,
MESSAGE, INFO, SUBSCRIBE, OPTIONS, BYE, CANCEL, NOTIFY, ACK"
User-Agent: Windows RTC/1.0
Expires: 1200
Event: registration
Allow-Events: presence
Content-Length: 0
--
***********************************************
System Executive
Mobile and Communication Tech.
Scicom Infotech Pvt. Ltd. (Scicom)
A - 67, Sector - 57
Noida - 201 301
UP
**********************************************

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 06 Dec 2002 11:11:19 -0500

answers inline.

> When IM Client is sending a SUBSCRIPTION request( to a offline user )

The request method is SUBSCRIBE, not SUBSCRIPTION.

> for presence notification to proxy,proxy sends response with 200 OK but

The SUBSCRIBE request contains the Event header. It is not placed in the 
200 OK response. It is, however, placed in the NOTIFY request generated 
by the presence server.

> Whats the meaning of it.

SIP has a general events framework (RFC 3265). A particular resource, 
such as sip:[email-masked], can support multiple types of 
events, including presence, message waiting indicators, dialog events, 
etc. The Event header disambiguates the event types being requested of 
the resource. See RFC 3265 for a complete discussion.

> In REGISTER request there is also a Event header.

No, there is no Event header in REGISTER.

> I am sending the packets.(got from MSN Messenger communication service)

This, to my knowledge, is an error in their implementation. It would be 
ignored by any SIP compliant registrar.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com