Subject: [Simple] New drafts on Instant Messaging - Question

From: "Rami Lehtonen" <[email-masked]>
Date: Mon, 6 Aug 2001 10:36:32 +0300

According to new drafts on Instant Messaging (e.g. SIP Extensions for
Instant Messaging) it is forbidden to include a body in the 200 OK messages,
which are sent after MESSAGE. Does this also apply to Instant Message
Sessions? If yes, what's the reason for that?

We have designed a negotiation mechanism based on Instant Messaging
(MESSAGE), and we use currently a body in the 200 OK messages. The
negotiation mechanism works for both models on Instant Messaging (with or
without session). So it would be nice to see the body in response to MESSAGE
at least in session based model if that does not create any unwanted
behaviour.

-- Rami Lehtonen

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 6 Aug 2001 11:17:54 -0400

Well, also note that a response to the MESSAGE is sent so long as it is
received. You cannot wait for the human to type a response before sending a
SIP response message (i.e., 200 OK), as you will get unending
retransmissions followed by a transaction timeout. 

I too am curious about this "negotiation" mechanism. Details?

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Monday, August 06, 2001 10:41 AM
> To: Robert Sparks
> Cc: 'Rami Lehtonen'; [email-masked]
> Subject: Re: [Simple] New drafts on Instant Messaging - Question
> 
> 
> Right. I am curious as to what sort of negotiation the original note 
> refers to. I can accept the idea of negotiating things using MESSAGE, 
> but I would expect that to be an exchange of MESSAGE 
> transactions, not a 
> MESSAGE/200 OK negotiation. Any body in a 200 OK will be lost if this 
> crosses a CPIM gateway.
> 
> Robert Sparks wrote:
> 
> > If the body is meant to be interpreted as a reciprocal message,
> > there is no way to get it across a CPIM interface (since there
> > is no way to respond to it).
> > 
> > RjS
> > 
> > 
> >>-----Original Message-----
> >>From: Rami Lehtonen [mailto:[email-masked]]
> >>Sent: Monday, August 06, 2001 2:37 AM
> >>To: [email-masked]
> >>Subject: [Simple] New drafts on Instant Messaging - Question
> >>
> >>
> >>_______________________________________________
> >>simple mailing list
> >>[email-masked]
> >>http://mailman.dynamicsoft.com/mailman/listinfo/simple
> >>
> >>
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > 
> 
> 
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>