Subject: RE: [Simple] Message Transport Protocol (SIP vs IMTP)

From: [email-masked]
Date: Tue, 23 Jul 2002 11:43:27 +0300

And how many of those RFC2543 complaint proxies will you see deployed in a year's time?

/Hisham

> -----Original Message-----
> From: ext James Undery [mailto:[email-masked]]
> Sent: Tuesday, July 23, 2002 10:53 AM
> To: SIMPLE (E-mail)
> Subject: [Simple] Message Transport Protocol (SIP vs IMTP)
> 
> 
> Hi,
> 
> At the SIMPLE meeting I believe the consensus was to go with 
> a SIP based message transport, however, it was unclear if 
> this should be SIP or IMTP. The argument for SIP is because 
> of rfc3261 we can now use SIP as is, IMTP was complicated due 
> to all the requirements of messaging that couldn't be 
> addressed easily; I'd definitely agree with that, however, I 
> believe that won't work, rfc2543 proxies may still do all the 
> bad things IMTP was designed to avoid. The suggestion made by 
> Rohan (that I strongly agree with) was to take  rfc3261 and 
> just swap SIP/2.0 for IMTP/1.0 every time the protocol is 
> mentioned in the spec. This has the advantage that you know 
> older proxies aren't going to misbehave and the draft 
> specifying it should be trivial modification to Jonathan's 
> latest draft.
> 
> James
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: "James Undery" <[email-masked]>
Date: Tue, 23 Jul 2002 10:30:58 +0100

There are also other advantages. If it is clear that IMTP is different from SIP this allows more targeted filtering just like SOAP RPC calls over HTTP don't ;-) (Note the much touted firewall avoidance power of SOAP over HTTP is considered a bad thing by the security community, IM is less of a concern but helping administrative policies to be enforced surely is good)

James

P.S. More than one which is all that matters.

> From: [email-masked] [mailto:[email-masked]]
> Sent: 23 July 2002 09:43
> To: James Undery; [email-masked]
> Subject: RE: [Simple] Message Transport Protocol (SIP vs IMTP)
> 
>

---

From: "James Undery" <[email-masked]>
Date: Tue, 23 Jul 2002 14:28:47 +0100

> From: Paul Kyzivat [mailto:[email-masked]]

> James Undery wrote:
> > 
> > Hi,
> > 
> > At the SIMPLE meeting I believe the consensus was to go 
> with a SIP based message transport, however, it was unclear 
> if this should be SIP or IMTP. The argument for SIP is 
> because of rfc3261 we can now use SIP as is, IMTP was 
> complicated due to all the requirements of messaging that 
> couldn't be addressed easily; I'd definitely agree with that, 
> however, I believe that won't work, rfc2543 proxies may still 
> do all the bad things IMTP was designed to avoid. The 
> suggestion made by Rohan (that I strongly agree with) was to 
> take  rfc3261 and just swap SIP/2.0 for IMTP/1.0 every time 
> the protocol is mentioned in the spec. This has the advantage 
> that you know older proxies aren't going to misbehave and the 
> draft specifying it should be trivial modification to 
> Jonathan's latest draft.
> 
> To avoid misbehaving proxies, shouldn't it be sufficient to 
> do something like
> 
> 	Proxy-Require: message_session
> 
> or something to that effect? Changing the version requires 
> much more mucking in the stack.

This is really an implementation's flexibility issue. In soem implementations changing the Protocol can allow for greater efficiency in application servers where modules handle headers like Proxy-Requires. I wouldn't have a problem with Proxy-Require it'd just be nice to think it through.

James

---

From: Adam Roach <[email-masked]>
Date: Tue, 23 Jul 2002 14:49:35 -0500

In the immortal words of Dave Oran: I'm confused.

It seems to me that there have been a couple of proposals
floated here that amount to: "RFC2543 proxies will break
if you send message sessions through them. Therefore, we
must come up with a mechanism to break RFC2543 proxies if
you send message sessions through them."

What?

If they're broken, why take extra steps to break them?

However, all of that seems like a completely moot point
to me. Consider: how would a message session be routed
through a proxy? If we use the mechanism in
draft-rosenberg-simple-message-session-00.txt (which is
the only proposal right now, to my knowledge), the *only*
way a proxy can end up in the route of a message session
is if it (a) knows about message sessions, and
(b) explicitly inserts itself IN THE SDP. Can anyone
point to a deployed RFC2543 proxy that does this? Then
why are we spinning our wheels on this issue?

It seems to me that a number of great minds are wasting
a lot of time solving a non-problem here.

/a

> Sent: Tuesday, July 23, 2002 8:09
> To: James Undery
> Cc: SIMPLE (E-mail)
> Subject: Re: [Simple] Message Transport Protocol (SIP vs IMTP)
> 
> 
> 
> 
> James Undery wrote:
> > 
> > Hi,
> > 
> 	Paul