Subject: RE: [Simple] Multiple 200 Ok

From: "Brian Stucker" <[email-masked]>
Date: Fri, 5 Oct 2001 10:09:59 -0500

Would it be a 403 forbidden? If a 403 were sent back because the
only routable PA wasn't willing to process the subscription, wouldn't
this cause the would-be watcher to not try again later when other
PA's may be available (via forking) that could process the request?

I would think a 404 or a 488 response would be a better fit.

...

When is that new events draft going to appear? Until that comes out
the NOTIFY with expires = 0 is the way you force-expire a subscription.

Regards,

Brian

-----Original Message-----
From: Neil Deason [mailto:[email-masked]]
Sent: Friday, October 05, 2001 9:52 AM
To: Brazier Lachlan; 'Jonathan Rosenberg'; Stucker, Brian
[NGB:B621:EXCH]; ''SIMPLE Mailinglist' '
Subject: RE: [Simple] Multiple 200 Ok

> -----Original Message-----
> From: Brazier Lachlan [mailto:[email-masked]]
>
> Hi,
>
> generally I agree with you about Authorisation and Authentication.
>
> Let me reformulate the question. Which response do I send back, when I
> received a SUBSCRIBE, and I'm not allowed or not willing to be the
> presentity (This can happen if someone defines me as
> presentity without
> letting me know - as the way of authorization is not in the
> scope of the
> presence draft, errors might happen)?

403 would do.

> I have a question concerning the Call flows in the draft.
> When a PA receives a SUBSCRIBE with an Expires header, the
> response contains
> an Expires header as well. What would an Expires header in a
> NOTIFY request
> sent from the PA to the Watcher mean? Would this update the
> subscription
> expiration time?
>
> An example:
> userA subscribes for user userB. As userB is a friend of
> userA, he accepts
> the subscription and the call flows just get on.
> After some time userB doesn't want to be the presentity of
> userA anymore, or
> maybe userB changes the contact information for the SUBSCRIBE
> request at
> it's registrar.
> Now, can userB (better said the PA of userB) send a NOTIFY
> with an Expires
> header with value 0 to tell userA, that it's subscription
> expiration time is
> over?
>
> I think it should be possible to do so, because if not, userB
> would need to
> wait for the next SUBSCRIBE request from userA, before he can
> tell him, that
> the subscription time is over. This could be a time value
> from seconds to
> days, month, years, etc.
>
>
> If there is another mechanism to do so, which one would it be? Maybe a
> NOTIFY with an empty body?

There current proposal is to use a new header,
Subscription-Expires in NOTIFY instead of overloading
Expires to indicate when a subscription will end.
draft-ietf-simple-presence-03.txt refers to this in
describing how PA functionality migrates (5.12). This
header still needs to be detailed in a revised 'SIP
specific event notification' draft.

Cheers,
Neil.
--
Ubiquity Software Corporation, UK        http://www.ubiquity.net

---

From: "James Undery" <[email-masked]>
Date: Mon, 8 Oct 2001 11:24:32 +0100

Hi,

403 is definately better than 488 which is more SDP related. If a PA
exists 403 would be better than 404, 404 is better if no routable PA
exists.

Then again I'd be happy to be contridicted on any of the above if it
results in a clear ruling.

James

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Brian
Stucker
Sent: 05 October 2001 16:10
To: Neil Deason; Brazier Lachlan; 'Jonathan Rosenberg'; ''SIMPLE
Mailinglist' '
Subject: RE: [Simple] Multiple 200 Ok

the NOTIFY with expires = 0 is the way you force-expire a
subscription.
Regards,
Brian
-----Original Message-----
From: Neil Deason [mailto:[email-masked]]
Sent: Friday, October 05, 2001 9:52 AM
To: Brazier Lachlan; 'Jonathan Rosenberg'; Stucker, Brian

403 would do.