Subject: [Simple] Serializing MESSAGE requests in a session

From: "Ajay Chitturi" <[email-masked]>
Date: Mon, 20 Aug 2001 10:44:00 -0700

Hi,

The SIP IM Sessions draft says that MESSAGE requests within message session MUST NOT overlap. I believe this restriction is to prevent the problem where the messages could reach the recipient out of order. Please correct me if I am wrong.

The performance issue with this approach is listed as an open issue. Has there been any subsequent discussion on this issue ? Have other approaches to solve this problem been discussed ?

Also, this problem is present for other requests such as INFO as well. Are there any such restrictions for such methods as well ?

Thanks
Ajay.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 20 Aug 2001 13:52:17 -0400

> -----Original Message-----
> From: Ajay Chitturi [mailto:[email-masked]]
> Sent: Monday, August 20, 2001 1:44 PM
> To: [email-masked]
> Subject: [Simple] Serializing MESSAGE requests in a session
> 
> 
> Hi,
> 
> The SIP IM Sessions draft says that MESSAGE requests within 
> message session MUST NOT overlap. I believe this restriction 
> is to prevent the problem where the messages could reach the 
> recipient out of order. Please correct me if I am wrong.

Right; SIP in general has a restriction on non-overlapping non-INVITEs for
this reason.

> 
> The performance issue with this approach is listed as an open 
> issue. Has there been any subsequent discussion on this issue 
> ? Have other approaches to solve this problem been discussed ?

Well, it would seem that the point is more or less moot, if we are not using
MESSAGE as a transport for the session model.

> 
> Also, this problem is present for other requests such as INFO 
> as well. Are there any such restrictions for such methods as well ?

We discussed this during the SIP meeting. It was debated whether or not to
relax this constraint in general. However, the sequencing becomes harder,
and there was no consensus on whether to do this or not.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Steve Donovan <[email-masked]>
Date: Mon, 20 Aug 2001 13:55:09 -0400

The current direction of the group is to not follow the approach defined in
the IM session draft.  See the thread
http://mailman.dynamicsoft.com/pipermail/simple/2001-August/000574.html.
The MESSAGE request will still be used for the page like IM, but not for
chat sessions.

Steve

> Sent: Monday, August 20, 2001 12:44 PM
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>