Subject: RE: [Simple] URI Conversion

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 2 May 2001 09:13:35 -0400

-----Original Message-----
From: Ngo, Dai (c) [mailto:[email-masked]]
Sent: Tuesday, May 01, 2001 1:40 PM
To: [email-masked]
Subject: [Simple] URI Conversion

>Hi,
>
>Does anyone have any other thoughts of a working "solution" for URI
conversion, i.e. SIP 
>URL from/to Presence/IM URI?
>

I suspect you really only need to convert in one direction - presence/IM URL
to SIP URL. When addressing a SIP->CPIM gateway with a SIP request, you
shouldn't convert the pres URL to a SIP URL to begin with. How to support
that using DNS queries is a good question.

Presence URL to SIP URL conversion is trivial, and would be nothing more
than replacing the scheme with sip.

Alot of this depends on the DNS mechanisms used; if naptr is specified, then
the naptr record would actually specify how the conversion is done. 

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Vasilis Polychronidis <[email-masked]>
Date: Thu, 03 May 2001 16:09:53 -0700

Hi Jonathan,
Please see my comments below:

Jonathan Rosenberg wrote:

> Alot of this depends on the DNS mechanisms used; if naptr is specified,

It was decided in the last IMPP wg meeting to use SRV instead of NAPRT.

> then
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple