Subject: Re: AW: [Simple] RE: Question regarding NOTIFY messages using UDP.

From: "Avshalom Houri" <[email-masked]>
Date: Wed, 5 Dec 2001 15:41:03 +0200

I agree with Henning. It will become very difficult to deploy. Maybe the 
SUBSCRIBE request can contain an hint whether
the subscribing UA would accept notifies with URLs. This way domains that 
took the trouble to deploy the web server etc.
will be able to optimize it only for clients that can support fetching the 
URL.

------------------------
Avshalom Houri
Lotus Sametime
IBM Software Group

Building 18/D, Science Park
Kiryat Weizmann, P.O. Box 2523
Rehovot 76123 Israel

Email: [email-masked]
Office: +972-8-9409761 X123
Fax: +972-8-9409768
Mobile: +972-54-686021

"Henning G. Schulzrinne" <[email-masked]>
Sent by: [email-masked]
04/12/2001 18:55

        To:        Jonathan Rosenberg <[email-masked]>
        cc:        simple <[email-masked]>
        Subject:        Re: AW: [Simple] RE: Question regarding NOTIFY messages using UDP.

Jonathan Rosenberg wrote:
> 
> 
> 
> > -----Original Message-----
> > From: Henning G. Schulzrinne [mailto:[email-masked]]
> > Sent: Tuesday, December 04, 2001 11:40 AM
> > To: Brazier Lachlan
> > Cc: 'Jonathan Rosenberg'; 'Brian Stucker'; 'Michael Hammer';
> > [email-masked]'; simple; Alex Nava; Patrick Sollee;
> > Sanjoy Sen
> > Subject: Re: AW: [Simple] RE: Question regarding NOTIFY messages using
> > UDP.
> >
> >
> > Brazier Lachlan wrote:
> > >
> >
> > > does this mean that in the NOTIFY there is no
> > cpim-xpidf+xml document but a
> > > URI or a list of URI's where the client can get the
> > cpim-xpidf+xml document
> > > with HTTP or whatever is specified?
> > >
> > > I this correct?
> > > If yes, sounds beautiful. Haven't thought about the packages yet.
> >
> > As long as you consider the practical problems. For example, you now
> > need to have the ability to "reach back" to the web server of the
> > notifier. You need to coordinate authentication. If you used
> > hop-by-hop
> > transitive trust, that won't work any more and you'll have to
> > resort to
> > a shared secret, either via TLS from the notified party or
> > standard HTTP
> > Digest, making sure that the passwords are properly aligned.
> 
> Good point.
> 
> If you've been using transitive trust, though, the URL in the NOTIFY may
> have been encrypted at each hop, so merely using that URL (so long as it 
has
> sufficient randomness encoded in it) provides some amount of 
authentication.
> Not perfect, for sure.

It also means that the notified party has to support TLS to prevent
disclosure of the presence document.

In the pure SIP case, it's viable to have the "WAN" hops use TLS, while
the last hop, hopefully on a more trusted network, may not.

> 
> > Also, how
> > long is the URL valid? Forever? Until the subscription expires?
> 
> We would need to specify that. I would argue that the URL fetches the
> current presence doc until the subscription expires.
> 

Plus caching behavior.

I suspect the biggest problem will be the "get back to notifier" issue.
Effectively, you now have to have a public-Internet web server that the
notifier can control. Since you need to not just create documents but
also delete them after expiration, you need WebDAV or some proprietary
cgi interface, or also implement ftp (and know the file structure of the
server). (Updating the authorization table on the public-Internet web
server will be even messier, since there's no published protocol for
doing that.)

Thus, what seems like a simple proposal ("just include the URL") becomes
just a tad more complicated if you consider all the things that can go
wrong.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Wed, 5 Dec 2001 07:24:57 -0800 (PST)

We call this the "Accept" header. It is very
straightforward. I don't think this is any more
difficult to deploy than a pure SIP solution and
it very nicely solves the problem of large messages.

/sean

--- Avshalom Houri <[email-masked]> wrote:
>         Subject:        Re: AW: [Simple] RE:
> Question regarding NOTIFY messages using UDP.
> 
>  
> 

=====
--
Sean Olson <[email-masked]>
This is from me. Assume nothing else.

__________________________________________________
Do You Yahoo!?
Buy the perfect holiday gifts at Yahoo! Shopping.
http://shopping.yahoo.com