Subject: [Simple] notify after terminating subscription

From: "sal"<[email-masked]>
Date: Tue, 9 Oct 2001 10:55:29 +0200

Hi,

i'm looking, on the presence's draft,
the flow messages "Client to Client Subscription
 with Presentity State Change"

why when the watcher terminating the subscription
it receive after a 200OK also an other NOTIFY from
that presentity?
i don't understood ... 

thanks

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 23 Oct 2001 20:45:29 -0400

The reason that a NOTIFY is still sent is that we want the behavior of
SUBSCRIBE to be consistent; a 200 OK response to SUBSCRIBE always generates
a NOTIFY, independent of the duration of the subscription. This allows a
single primitive to be used for fetch, terminating a subscription, creating
one, and refreshing one. 

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: sal [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 4:55 AM
> To: [email-masked]
> Subject: [Simple] notify after terminating subscription
> 
> 
> Hi,
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>