Subject: RE: [Simple] ungraceful shutdwon of presence clients

From: [email-masked]
Date: Fri, 6 Sep 2002 10:25:50 +0300

Hi,

Inline:

-----Original Message-----
From: ext Himanshoo Kumar Saxena [mailto:[email-masked]]
Sent: 06 September, 2002 05:23
To: Jonathan Rosenberg; Paul Kyzivat
Cc: [email-masked]
Subject: [Simple] ungraceful shutdwon of presence clients

Hi,

A simple question to confirm my understanding...

Consider subscriber A having REGISTERED via. REGISTER.. Now another subscriber B subscribes for A's presence information.
Based on the duration in expires header field of A's subscription, till that time, A is considered online.

Yes, this can be done but it is presence system implementation issue.

 In the meantime, A goes down ( I mean ungraceful shutdwon e.g. machine shutdown) But for presence server A is still online since the expires period hasn't yet ended.

SIP or SIMPLE do not in this case provide PS any means to detect that A has shutdown. You system might  for example use some layer 2 mechanisms to detect that user A's device is not  active anymore but that is again implementation issue.

 So if B tries to send a message to A , then presence server will send a SIP MESSAGE to A . Only upon expiry of response timeout to this MESSAGE request , the presence server will know that A is offline....

Probably the PS has nothing to do with the MESSAGE request (request is not routed through it). User B would send message straight to user A and would then notice that request times out. 

best regards
- Mikko

Is this understanding correct ?

Regards
----------------------------------------------------------
Himanshoo Kumar Saxena
IN service department
Huawei Technologies Company Limited
Shenzhen - 518000
P.R.China

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 06 Sep 2002 10:41:00 -0400

comments inline.

[email-masked] wrote:
 > Hi,
 >
 > Inline:
 >
 > -----Original Message----- From: ext Himanshoo Kumar Saxena
 > [mailto:[email-masked]] Sent: 06 September, 2002 05:23 To:
 > Jonathan Rosenberg; Paul Kyzivat Cc: [email-masked]
 > In the meantime, A goes down ( I mean ungraceful shutdwon e.g.
 > machine shutdown) But for presence server A is still online since the
 > expires period hasn't yet ended.
 >
 > SIP or SIMPLE do not in this case provide PS any means to detect that
 > A has shutdown. You system might  for example use some layer 2
 > mechanisms to detect that user A's device is not  active anymore but
 > that is again implementation issue.

There are several answers here.

The first, and most important statement, is that the presence server can 
use any techniques at its disposal to determine the presence state of 
the users it represents.

So, what can a presence server do to handle failures of the hosts the 
users are connected to?

1. Use a lower registration refresh interval, so that the failure is 
detected faster (this is possible when the presence server and registrar 
are colocated)

2. The presence server can "ping" the client with periodic OPTIONS 
requests to check for liveness.

3. The presence server, if its also the proxy, can look for timeouts in 
messages which are sent to that client, as you suggest below.

I am sure there are other possibilities. The spec doesn't say what you 
can or cannot do. Any of the above three will interoperate with any 
SIMPLE compliant endpoint.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com