Subject: RE: [Simple] Implicit MESSAGE sessions revisited

From: "Mark Watson" <[email-masked]>
Date: Mon, 17 Sep 2001 15:39:52 +0100

Dean,

Do you mean that you don't see the advantage of using INVITE to set up an IM
'session' (indicating this in the SDP), or just that once such a session is
set up, there is no need for the 'media' to use any different protocol than
that used for 'paging' ?

I think there are a lot of reasons why IM 'sessions' set up using INVITE
just like any other SIP session, make sense. I don't care much yet what the
transport protocol then is for the IMs in the session.

Sorry if this is covering old ground.

...Mark

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: 15 September 2001 05:31
> To: Patil Basavaraj (NET/Dallas); 'ext Ben Campbell'
> Cc: simple
> Subject: Re: [Simple] Implicit MESSAGE sessions revisited
> 
> 
> 
> Just as MESSAGE for sessions has all the wasted overhead of 
> headers and
> routing mechanisms designed to find users and traverse 
> firewalls (assuming
> you think this is a waste), so does BEEP.
> 
> I personally have yet to see the need for message sessions as 
> a specialized
> transport.
> 
> I think "pager" messages carrying a session-ID and sequence number can
> provide the same user experience.
> 
> --
> dean
> 
> 
> ----- Original Message -----
> From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
> To: "'ext Ben Campbell'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, September 14, 2001 1:07 PM
> Subject: RE: [Simple] Implicit MESSAGE sessions revisited
> 
> 
> >
> > One of the protocols that has been suggested for use instead of
> > MESSAGE is BEEP. Are there any serious concerns *at this time*
> > why BEEP would not be good eniugh for IM Sessions?
> >
> > -Basavaraj
> >
> >
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> >
> >
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: "Dean Willis" <[email-masked]>
Date: Mon, 17 Sep 2001 11:32:14 -0500

RE: [Simple] Implicit MESSAGE sessions revisitedBoth, actually. I believe the issues are independent.

--
Dean

  ----- Original Message ----- 
  From: Mark Watson 
  To: 'Dean Willis' ; Patil Basavaraj (NET/Dallas) ; 'ext Ben Campbell' 
  Cc: simple 
  Sent: Monday, September 17, 2001 9:39 AM
  Subject: RE: [Simple] Implicit MESSAGE sessions revisited

  Dean, 

  Do you mean that you don't see the advantage of using INVITE to set up an IM 'session' (indicating this in the SDP), or just that once such a session is set up, there is no need for the 'media' to use any different protocol than that used for 'paging' ?

  I think there are a lot of reasons why IM 'sessions' set up using INVITE just like any other SIP session, make sense. I don't care much yet what the transport protocol then is for the IMs in the session.

  ...Mark