Subject: [Simple] CPIM and Presence

From: Torrey Searle <[email-masked]>
Date: Thu, 22 Nov 2001 03:07:15 -0800

In the 01 version of the CPIM draft, it appears to indicate that the presentity element is a required element of the presence element, however the call flows in the Presence RFC omit this element, should this element be added in future versions of the Draft?

Also in the Presence call flows, an element called detail appears in the status element to indicate im status, however it appears to be the same as the value element in the CPIM draft, the only difference being that the type paraleter has a value of "urn:ietf:params:cpim-presence:status-type:im" can the presence draft be updated to match?

Torrey

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Nov 2001 16:05:36 -0500

> -----Original Message-----
> From: Torrey Searle [mailto:[email-masked]]
> Sent: Thursday, November 22, 2001 6:07 AM
> To: [email-masked]
> Subject: [Simple] CPIM and Presence
> 
> 
> In the 01 version of the CPIM draft, it appears to indicate 
> that the presentity element is a required element of the 
> presence element, however the call flows in the Presence RFC 
> omit this element, should this element be added in future 
> versions of the Draft?

Yes. Thanks for pointing this out.

> 
> Also in the Presence call flows, an element called detail 
> appears in the status element to indicate im status, however 
> it appears to be the same as the value element in the CPIM 
> draft, the only difference being that the type paraleter has 
> a value of "urn:ietf:params:cpim-presence:status-type:im" can 
> the presence draft be updated to match?

Yes. I didn't fix the flows to get them up to speed with cpim-pidf.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com