Subject: RE: [Simple] Another idea for presence authorization

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 18 Jul 2001 12:39:17 -0400

> -----Original Message-----
> From: James Undery [mailto:[email-masked]]
> Sent: Wednesday, July 18, 2001 12:37 PM
> To: Jonathan Rosenberg
> Cc: Daniel Starin; 'Michael Hammer'; 'Rosen, Brian';
> [email-masked]
> Subject: Re: [Simple] Another idea for presence authorization
> 
> 
> 
> 
> Jonathan Rosenberg wrote:
> 
> >
> >
> > > -----Original Message-----
> > > From: James Undery [mailto:[email-masked]]
> > > Sent: Wednesday, July 18, 2001 4:36 AM
> > > To: Daniel Starin
> > > Cc: 'Jonathan Rosenberg'; 'Michael Hammer'; 'Rosen, Brian';
> > > [email-masked]
> > > Subject: Re: [Simple] Another idea for presence authorization
> > >
> > >
> > >
> > >
> > > Daniel Starin wrote:
> > >
> > > > PLEASE disregard the other message and read this one... I
> > > missed a typo
> > > > which could ruin my argument...
> > > >
> > > > So we are all on the same level...
> > > >
> > > > As I understand it... there are 6 possible states when user
> > > A makes a
> > > > subscription request to user B...
> > > >
> > > > User B is?/The response to the subscription was?
> > > >
> > > > 1. Present/Accepted
> > > > 2. Present/Pending
> > > > 3. Present/Rejected
> > > > 4. Not Present/Accepted
> > > > 5. Not Present/Pending
> > > > 6. Not Present/Rejected
> > > >
> > > > If we send "Offline" notifies every time...
> > > >
> > > > If User A gets an Offline notifies...
> > > > he knows the state is one of the following
> > > >
> > > > 2. Present/Pending
> > > > 3. Present/Rejected
> > > > 4. Not Present/Accepted
> > > > 5. Not Present/Pending
> > > > 6. Not Present/Rejected
> > > >
> > >
> > > 6 is not an option a rejected subscription will not 
> generate a NOTIFY
> > >
> > > >
> > > > If User A gets an Online notify..
> > > > He knows the state is...
> > > >
> > > > 1. Present/Accepted
> > > >
> > > > The "Offline" notify method does indeed hide whether 
> User A knows
> > > > whether or not his subscription was Accepted or not.  BUT...
> > > > mathematically, it gives User A something else to play
> > > with.... If the
> > > > probability of all six options are equal... User A knows
> > > that when he
> > > > gets an "Offline" notify that the percent chance that User
> > > B is really
> > > > Offline is 60% (3/5).
> > >
> > > But the probabilities are nowhere near equal (and you are
> > > still wrong about
> > > 6), assuming there are 1 million people in the world, the
> > > fraction of them
> > > I'd authorise is minimal, meaning only 2 and 5 are likely 
> if I pick a
> > > presentity at random to subscribe to, giving a 50/50 chance.
> >
> > Even better, the presence server can randomly change 
> whether the first
> > NOTIFY contains an "offline" or "online" status. This also 
> pushes you back
> > to 50/50.
> 
> I'd rather not ever send "online" as they then might expect 
> responses from
> MESSAGEs ;-)

Actually, I'm online all the time and don't respond to messages.. I've
walked away from my desk, for example. 

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: James Undery <[email-masked]>
Date: Wed, 18 Jul 2001 17:47:19 +0100

> walked away from my desk, for example.

Well I'd rather have "offline" but I am unconvinced by Daniel's argument,
so it's a moot point about the random answer in my view.

James Undery

---

From: "Daniel Starin" <[email-masked]>
Date: Wed, 18 Jul 2001 14:48:00 -0400

> walked away from my desk, for example. 

So now we are going to send out a random online or offline notify
whether or not a subscription is accepted?? This makes the whole point
of an accepted subscription (if User B accepts User A's subscription
request) moot... Even if you start getting online notifys, you don’t
know if they are real or fake... isnt the whole point of presence to let
other users know your status... not whether or not you are currently
sending messages.... If I accept a subscription request from someone, I
want them to know without a doubt my current presence.... I want them to
know this regardless of if I am at my desk or not.... This is another
argument I could make against the "offline notify" method.... 

Dan+