Subject: RE: [Simple] Another idea for presence authorization

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 17 Jul 2001 17:25:09 -0400

> -----Original Message-----
> From: Subir Saha [mailto:[email-masked]]
> Sent: Tuesday, July 17, 2001 4:58 PM
> To: 'Michael Hammer'; Jonathan Rosenberg
> Cc: 'Rosen, Brian'; 'Daniel Starin'; [email-masked]
> Subject: RE: [Simple] Another idea for presence authorization
> 
> 
> 
> 
> > > Keep in mind that some folks want to be able to
> > > keep A in the dark about an authorization disposition.
> > > Johnathan's sequence has the subscription accepted
> > > with a 202, and subsequent receipt of a Notify
> > > without a 200.  While I questioned that, if you
> > > send a 200 for the Subscribe always, or send
> > > 202 for the Subscribe always, it's okay.  What
> > > you can't do if you want to keep A in the dark
> > > is to send a 202 before you get authorization,
> > > and a 200 for a subsequent Subscribe after
> > > authorization.
> >
> >Correct. We've discussed this issue extensively on this 
> list, and the impp
> >list previously. The agreement was that it should be possible for a
> >mechanism to exist by which the subscriber cannot tell whether their
> >subscription was approved or rejected, or neither. So, the 
> agreed upon flow
> >was:
> >
> >SUB------->
> ><-------202
> >
> ><------NOTIFY
> >200------>
> >
> >In the case of an authorized subscription, the NOTIFY contains valid
> >presence data. In the case of a denied or pending 
> subscription, it contains
> >syntactically valid, but incorrect or uninteresting 
> information (i.e.,
> >always offline).
> 
> It's still not clear to me what value is gained by a garbage 
> message in 
> return for the bandwidth wasted.  It only seems to add 
> confusion to readers 
> of call flows.
> 
> [Subir]Also this gives excelent way for DOS attack on my 
> presence server. 
> Subir
> 

In what way? By making it send a single extra NOTIFY? You already make it
send a response to the SUBSCRIBE when you're not authorized. Should we
disallow responses to SUBSCRIBE as well? I don't think so. Remember, the
NOTIFY is only sent if the subscriber is AUTHENTICATED, so you get
traceability. That helps a lot to discourage attacks.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Zane Thomas" <[email-masked]>
Date: Wed, 25 Jul 2001 22:33:14 -0700

Jonathan,

> Remember, the

It seems to me to be susceptible to the sorts of distributed DoS attacks
we've seen recently.  In those sorts of attacks the attacker doesn't really
care if the attack is traced, it won't find him directly that way.

Zane