Subject: RE: [Simple] IM: A session or not

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 30 Mar 2001 22:14:36 -0500

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Friday, March 30, 2001 7:28 PM
> To: Jonathan Rosenberg
> Cc: [email-masked]'
> Subject: Re: [Simple] IM: A session or not
> 
> 
> At 01:23 PM 3/30/01, Jonathan Rosenberg wrote:
> >Folks,
> >
> >At the IETF meeting, we discussed the main open issue 
> surrounding the IM
> >draft: whether or not to view IM as a session, as a 
> signaling path message,
> >or both. I presented some slides that discussed this, which 
> you can obtain
> >at:
> >
> >http://www.cs.columbia.edu/~jdrosen/papers/simple_open_mar01.ppt
> >
> >We need to resolve this issue asap.
> >
> >I'd like to work from the following proposal:
> >
> >1. We support the ability to establish IM as a session. This 
> is accomplished
> >through some SDP parameter registrations to signal whatever 
> is needed to set
> >it up, which we need to think about.
> 
> YUK!

A truly compelling technical argument. 

> 
> Why is this needed?
> Why not just REGISTER a Contact with a methods paramater (as below)?
>          Contact: <sip:[email-masked]>;methods=MESSAGE

Because, we don't want to be sending IMs across the proxy network. The above
approach would allow MESSAGE to go someplace different than INVITE, but it
still goes over the proxy network. 

Furthermore, there is a lot of value in viewing IM as a session set up with
SIP. Many of the reasons are outlined in the slides. To summarize:

1. forking actually works
2. you can actually clean up state in end systems which are automata (like
an IM conference server, which you cannot build without this!)
3. you can avoid sending 5meg MP3 "IMs" over proxies
4. you can reuse alot of the sip tools we have constructed for sessions -
transfers, multiparty conferencing, etc.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 30 Mar 2001 22:22:09 -0500

> still goes over the proxy network.

If we treat MESSAGE as being part of an INVITE session, but not as a
media stream, such MESSAGES would also go directly to the Contact
address, bypassing proxies (unless they insist on record-routing). I
guess this is another variation. (I still prefer the messages-as-media,
since it makes it easier to have text and audio chat at the same time.)

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs