Subject: [Simple] Re-use of Call leg information in SUBCRIBE-NOTIFY

From: "Lessing, Francois" <[email-masked]>
Date: Mon, 08 Oct 2001 17:35:25 -0700

Hi everyone,

The event notification drafts 'discourages' re-use of
call leg information [1] (see quote from draft at end of mail)

Does this mean we sometimes allow a SUBSCRIBE
request on an existing  call leg created by INVITE ?

To me this would not make sense, it seems to
go against the broader intention of the draft.

The only reason I can think where this might be
useful, is to SUBSCRIBE to a resource that is
associated with an existing call leg.

But, an event is only allowed to be identified
by event type, Request URI, and message body
as per the event notification draft [2]

If this behaviour is allowed, it also opens the door
for other questions that have not been addressed:

Q.How would a subscription terminate ?
A.When its associated call leg dies due to BYE ?
A. Wen it receives a SUBSCRIBE with expires = 0 ?
etc.

Is there a reason that we cannot replace the 'discouraged'
at the end of  [1] with a "NOT ALLOWED" ?

Any thoughts would be apreciated,

Francois Lessing
Trillium Digital Systems, an Intel company.

References:

[1] SIP-Specific Event Notification, Section 5.1.1:
"The relationship between subscriptions and (INVITE-initiated)
 sessions sharing the same call leg identification information is
 undefined. Re-using call leg information for subscriptions is
 discouraged."

[2] SIP-Specific Event Notification, Section 5.1.1:
Identification of events is provided by three pieces of
information: Request URI, Event Type, and (optionally)
message body.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 13 Oct 2001 10:29:06 -0400

We have debated this before, with the general conclusion that a SUBSCRIBE
within a call leg should behave no differently than one outside of the leg.
The fact that its already within a leg simply means that the route sets and
CSeq are established, rather than needing to have been established by an
initial INVITE. The fact that its in a call leg would change nothing about
identifying whats being subscribed to.

I see no particular benefit to placing a subscription within a call leg
(although I do see benefit in using the route headers from an existing call
leg), but I see no strong reason to forbid it.

-Jonathan R.

> -----Original Message-----
> From: Lessing, Francois [mailto:[email-masked]]
> Sent: Monday, October 08, 2001 8:35 PM
> To: [email-masked]
> Subject: [Simple] Re-use of Call leg information in SUBCRIBE-NOTIFY
> 
> 
> Hi everyone,
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Brian Stucker" <[email-masked]>
Date: Mon, 15 Oct 2001 17:45:38 -0500

What about tag matching from forking interactions? I figured that the
requirement to keep in the same call leg was simply put there to help out
with tag matching.

Brian

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Saturday, October 13, 2001 9:29 AM
To: 'Lessing, Francois'; [email-masked]
Subject: RE: [Simple] Re-use of Call leg information in SUBCRIBE-NOTIFY

-Jonathan R.

---

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 22 Oct 2001 21:13:51 -0400

I'm not sure I know what you mean by this. 

If you want to subscribe to some state associated with a call leg, then the
subscribe has to identify that call leg. This identification should be
explicit (i.e., carried somewhere in the subscription), rather than implicit
based on the fact that it arrived on a particular call leg.

-Jonathan R.

---

-----Original Message----- 
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Saturday, October 13, 2001 9:29 AM 
To: 'Lessing, Francois'; [email-masked] 
Subject: RE: [Simple] Re-use of Call leg information in SUBCRIBE-NOTIFY 

---