Subject: RE: [Simple] DNS SRV query example

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 9 May 2001 01:04:32 -0400

-----Original Message-----
From: Vasilis Polychronidis [mailto:[email-masked]]
Sent: Thursday, May 03, 2001 7:01 PM
To: Jonathan Rosenberg
Cc: 'Ajay Chitturi'; [email-masked]
Subject: Re: [Simple] DNS SRV query example

>
>Hi Jonathan, 
>Please see my comments below: 
>Jonathan Rosenberg wrote: 
>  
>> -----Original Message----- 
>> From: Ajay Chitturi [mailto:[email-masked]] 
>> Sent: Monday, April 30, 2001 6:48 PM 
>> To: [email-masked] 
>> Subject: [Simple] DNS SRV query example 
>> 
>> 
>> Hi, 
>> 
>>The usage of SRV for this translation is still being debated within IMPP.
If 
>>SRV is used,
>
>It has been decided in IMPP wg to use SRV! 

There was a preference, for simplicities sake, although it wasn't clear it
really works from the list discussions that followed IETF 50. Indeed, based
on Christian's most recent note on impp, it looks like there was significant
pushback from the DNS experts, who feel that NAPTR is more correct.

>>The result of the SRV query 
>>will contain the SRV RR and may contain the Additional field with the IP
address of the 
>>Target. 
>>If the Name Server does not contain the IP address of the Target a second
DNS query will 
>>be performed on the Target. 
>>it will not be exactly as specified in rfc2782.

>Why not? 

rfc2782 defines the protocol field as a transport protocol - tcp, udp. The
proposed approach does not use it that way.

-Jonathan R. 
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Vasilis Polychronidis <[email-masked]>
Date: Tue, 08 May 2001 23:13:02 -0700

Hi Jonathan,

Regards,

Vasilis Polychronidis

> pushback from the DNS experts, who feel that NAPTR is more correct.

I agree with you I was just trying to remind you of the resolution that was
agreed in the 50th IETF.
Here is a direct quote from the meeting minutes (IETF 50):

    Issue: Address resolution in multiprotocol context

    Proposal:
            SRV at edge?
            NAPTR at edge?

    How would NAPTR records be used?
        Weight/Priority
        Flags to control the process
        Services: end point differentiation
        Regexp: end point identifier "factory"
        Replacement: (a DNS shortcut if regex is just domainname)

        Additional info section contains the SRV and A records

    Michael Mealling presents a brief overview of how NAPTR might be applied to
the situation.  Some concerns from the floor that NAPTR are
    expressive and potentially quite complex.  The counter argument is that the
CPIM application would define a very restrictive application of their use
    (as does ENUM).

    Now that NAPTR was explained and discussed, return to the question, do we
want to go with some variant of SRV or NAPTR?

    General feeling of the room is that the potential of NAPTR doesn't buy
enough over SRV, and the concern over additional complexity remains.

    Resolution: Use SRV records for first-round lookups:
                _<proto>._im.domain. (e.g. _simple._im.domain.)

    Christian will make proposal for revised CPIM text

> proposed approach does not use it that way.

Well the proto field can be anything you want.
The following is a direct quote from rfc2782:
   Proto
        The symbolic name of the desired protocol, with an underscore
        (_) prepended to prevent collisions with DNS labels that occur
        in nature.  _TCP and _UDP are at present the most useful values
        for this field, though any name defined by Assigned Numbers or
        locally may be used (as for Service).  The Proto is case
        insensitive.