Subject: [Simple] Possible IM Message solution??

From: ames brown <[email-masked]>
Date: Fri, 5 Oct 2001 14:18:34 -0700 (PDT)

hello,

 What do you all think about the following:

- IM session established as a regular sip session
- SDP contains m=message line
- SDP also contains a message server line
  ms=x.x.x.x, port (invite,200ok)

- All signalling flows as follows:

	e <---> proxies <---> e

- Media as follows:

	e <---> message server <---> e

*  proxy server communicates to messaging server as to
which sessions (ip address/udp-tcp port numbers) are
active.
 
advantages:

	- CPU utilization ok on proxy
	- IM with sessions
	- can do monitoring on the media server 
          if needed
	- conferencing should work
	- ??

comments?

ames

=====

__________________________________________________
Do You Yahoo!?
NEW from Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Mon, 8 Oct 2001 12:31:22 -0400

Hi, Ames:

On theory, you are extending the signaling layer (e.g., SDP) and, are not
violating the protocol layering.

The extension that you have proposed in SDP is entirely a different
dimension: Routing of Media via the media (application) server(s). You can
think a scenario where multiple servers may also be involved. (I hope that
you are NOT proposing routing of media via network layer devices like
routers.)

I imagine that it will open entirely a new area for SDP: Routing of media
via media (application) servers (similar to routing of signaling messages
via SIP proxies).

What are the implications of such extensions in SDP?

Experts opinions are needed.

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: ames brown [mailto:[email-masked]]
Sent: Friday, October 05, 2001 5:19 PM
To: [email-masked]
Subject: [Simple] Possible IM Message solution??

hello,

	e <---> proxies <---> e

- Media as follows:

 
advantages:

comments?

ames

=====

__________________________________________________
Do You Yahoo!?
NEW from Yahoo! GeoCities - quick and easy web site hosting, just
$8.95/month.
http://geocities.yahoo.com/ps/info1
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple