Subject: [Simple] Message Delivery Notification

From: "Henrik Gustafsson" <[email-masked]>
Date: Mon, 17 Dec 2001 15:10:28 +0100

The paging model for messages will probably often
be used to gateway to SMS in the mobile network.
Delivery notification is a very useful service
in such a scenario. I would like a similar support
in the SIMPLE system. This proposal is not that
very thought through and I can see a number of
problems already with this proposal but the
initial requirement is still valid.

Message Progress Notification:
------------------------------
If a MESSAGE is sent with a contact and an
allow-events header:

  MESSAGE sip:[email-masked] SIP/2.0
  ...
  Allow-Events: messageprogress
  Contact: <sip:hegu@host>;methods="NOTIFY"
  ...

That could be an implicit subscription and later
on different notifications could be sent.

  NOTIFY sip:hegu@host SIP/2.0
  ...
  Event: messageprogress
  ...

  The mobile phone did not accept the message.
  Stored in server.

Later a notification with  "Message delivered.",
"Message read." or "Messages transformed to SMS.
The Message (400 characters) was split into 3
separate messages." could be sent.

This is controversial since the message draft clearly
states that contacts are not allowed in a MESSAGE.
However, this contact will not be used to establish a
message session.

The 200-response is used to end the MESSAGE SIP
transaction. If the receiving element supports
the message progress event package it MAY send
a notification. But you cannot depend on it.

Open Issues:
------------
Is it ok to add a contact to the MESSAGE? Could an
implicit subscription be used this way? How do you
know that the contact is still valid when the event
occurs? When does the "subscription" expire? Could
different elements in the message path generate
notifications? Would that be different to-tags and
would that look like notifies after a forked
subscribe?

This message progress notifications could also be
relevant in a message session ... but considering
non-SIP message transport like IMTP I don’t dare
to start that discussion. But today are well-known
IM user agents sending events like "the other party
is writing on a reply" within the message session.

I have recently started writing a draft on this.
I would really like some input, especially how this
could be done over IMTP or should an explicit
subscription be used? In the paging model I believe
an implicit subscription is the way to go.

/Henrik

---

From: "Henrik Gustafsson" <[email-masked]>
Date: Mon, 17 Dec 2001 22:45:45 +0100

I believe this is part of the core. If we decide to not 
allow the contact header, the pager model MESSAGE cannot 
work as an implicit subscription. 

And getting notifications about what is happening on 
the other side of the dialog are something today's im 
users expects from an im service. Of course, that could 
be done by sending INFO messages in the message session 
invitation dialog. But the requirements for these 
notifications will be the same as for the messages. If 
we choose IMTP, should the notifications be sent over 
IMTP? Maybe the notifications are MESSAGE requests with 
a special content type. Anyway I believe it is a relevant 
requirement on IMTP. Personally I prefer the 
Allow-Events - Notify model, that gives more control.

/Henrik

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Monday, December 17, 2001 17:33
> To: 'Henrik Gustafsson'; [email-masked]
> Subject: RE: [Simple] Message Delivery Notification
> 
> 
> We need to be careful not to break more new ground until
> our core effort is complete. We should make sure
> we aren't overly limiting MESSAGE's future extensibility.
> We should think about the gateway to non-instant systems 
> problem you bring up to make sure we aren't boxing ourselves
> in, but I don't think we should take on solving it as a group
> until we're done with the basic presence and messaging efforts 
> (at least).
> 
> RjS
> 
> > -----Original Message-----
> > From: Henrik Gustafsson [mailto:[email-masked]]
> > Sent: Monday, December 17, 2001 8:10 AM
> > To: [email-masked]
> > Subject: [Simple] Message Delivery Notification
> > 
> > 
> > non-SIP message transport like IMTP I don't dare
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > 
>