Subject: RE: [Simple] Contact header Usage in subsequent MESSAGE Requests

From: "Sriram Parameswar" <[email-masked]>
Date: Thu, 14 Jun 2001 09:37:34 -0500

Jonathan - you refer to a new approach using INVITE rather than MESSAGE.
Could you please point me to the latest version the document that reflects
this? 

Regards,

Sriram

__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Wireless IP MultiMedia (WIPMM)   Fax: 972-685-3563
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 4:28 AM
To: 'Hisham Khartabil'; [email-masked]
Subject: RE: [Simple] Contact header Usage in subsequent MESSAGE
Requests

In the older MESSAGE approach (where MESSAGE sort-of was INVITE), the
Contact header had the same semantics as in INVITE - it would be used to set
up the route for subsequent messages in the same IM session.

However, in the current proposal, whereby INVITE establishes the session,
the Contact in MESSAGE no longer serves a purpose.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com
  
-----Original Message-----
From: Hisham Khartabil [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 5:15 AM
To: [email-masked]
Subject: [Simple] Contact header Usage in subsequent MESSAGE Requests

Hi,

Section 6.2 or draft-ietf-simple-im-00.txt specifies that a MESSAGE request
MUST contain a Contact header.
Section 6.7 does not specify how this Contact should be used.
The example is section 8 simply says that user2 can send the IM directly to
the address in the Contact header send in the initial MESSAGE request.

The use of the Contact header in subsequent requests is not clear. Can I
conclude that the use of the Contact header is only a MAY?

Regards,
Hisham Khartabil
Hotsip Finland
www.hotsip.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 02 Jul 2001 10:41:59 -0500

Hi Sriram,

There will be a new MESSAGE draft including this prior to the London 
meeting. For the moment, the thinking is only documented in the mail 
archives.

Thanks!

Ben Campbell

Sriram Parameswar wrote:

> Could you please point me to the latest version the document that 
> reflects this?
> 
> Regards,
> 
> Sriram
>