Subject: RE: [Simple] 200 vs. 202

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Dec 2001 13:22:26 -0500

Adam,

Assuming that the consensus is to use this approach when you want to accept
only a single notification, you agree this belongs in sip-events, right?

Thanks,
Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, December 07, 2001 12:33 PM
> To: 'Jonathan Rosenberg'; [email-masked]; 'Brazier Lachlan';
> ''Paul Kyzivat ' '
> Cc: '''Brian Stucker' ' '; ''simple ' '
> Subject: RE: [Simple] 200 vs. 202
> 
> 
> Sorry for the confusion.
> 
> I was talking about an earlier suggestion -- the one Brian
> reiterates as "Only accept NOTIFY's which fit to the response".
> 
> Your revision of my earlier proposal -- which allows SUBSCRIBE
> responses to create dialogs -- is the best solution I've seen
> proposed so far.
> 
> /a
> 
> > -----Original Message-----
> > From: Jonathan Rosenberg [mailto:[email-masked]]
> > Sent: Friday, December 07, 2001 11:09 AM
> > To: [email-masked]'; 'Brazier Lachlan'; ''Paul 
> Kyzivat ' ';
> > Jonathan Rosenberg
> > Cc: '''Brian Stucker' ' '; ''simple ' '
> > Subject: RE: [Simple] 200 vs. 202
> > 
> > 
> > What was the problem with my proposal to accept what comes 
> > first (200 or
> > NOTIFY)? Seems to consistently work and be really simple...
> > 
> > -Jonathan R.
> > 
> > ---
> > Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> > Chief Scientist                             First Floor
> > dynamicsoft                                 East Hanover, NJ 07936
> > [email-masked]                     FAX:   (973) 952-5050
> > http://www.jdrosen.net                      PHONE: (973) 952-5000
> > http://www.dynamicsoft.com
> >  
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Friday, December 07, 2001 11:52 AM
> > > To: 'Brazier Lachlan'; [email-masked]; ''Paul 
> Kyzivat ' ';
> > > ''Jonathan Rosenberg ' '
> > > Cc: '''Brian Stucker' ' '; ''simple ' '
> > > Subject: RE: [Simple] 200 vs. 202
> > > 
> > > 
> > > Ah. In that case, I'm going to have to disagree for the
> > > exact same reasons that I objected when Jonathan proposed
> > > this: it's more complicated to implement, and the NOTIFY
> > > that corresponds to the final response doesn't have any
> > > special meaning. It's no better than any other NOTIFY.
> > > 
> > > Keep it simple. (No pun intended).
> > > 
> > > /a
> > > 
> > > > -----Original Message-----
> > > > From: Brazier Lachlan [mailto:[email-masked]]
> > > > Sent: Friday, December 07, 2001 10:44 AM
> > > > To: [email-masked] '; Brazier Lachlan; ''Paul 
> > Kyzivat ' ';
> > > > ''Jonathan Rosenberg ' '
> > > > Cc: '''Brian Stucker' ' '; ''simple ' '
> > > > Subject: AW: [Simple] 200 vs. 202
> > > > 
> > > > 
> > > > Ups, sorry,
> > > > 
> > > > I meant
> > > > 1) Only accept NOTIFY's which fit to the response
> > > > 
> > > > Lachlan 
> > > > 
> > > > -----Originalnachricht-----
> > > > Von: [email-masked]
> > > > An: 'Brazier Lachlan'; 'Paul Kyzivat '; 'Jonathan Rosenberg '
> > > > Cc: [email-masked]; ''Brian Stucker' '; 'simple '
> > > > Gesendet: 07.12.01 17:13
> > > > Betreff: RE: [Simple] 200 vs. 202
> > > > 
> > > > Brian:
> > > > 
> > > > I can't tell what you're proposing, since you have two points
> > > > labelled as "1)." I like the second "1)" just fine, and the
> > > > variant in which the first dialog-establishing message (2xx
> > > > or NOTIFY) just as well.
> > > > 
> > > > /a
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brazier Lachlan [mailto:[email-masked]]
> > > > > Sent: Friday, December 07, 2001 5:14 AM
> > > > > To: 'Paul Kyzivat '; 'Jonathan Rosenberg '
> > > > > Cc: [email-masked] '; ''Brian Stucker' '; 'simple '
> > > > > Subject: AW: [Simple] 200 vs. 202
> > > > > 
> > > > > 
> > > > > Hello,
> > > > > 
> > > > > I believe the subscriber SHOULD keep all NOTIFY messages 
> > > > > which arrive before
> > > > > the response to the SUBSCRIBE arives. After receiving the 
> > > > response the
> > > > > subscriber can decide which way to handle the NOTIFY's.
> > > > > 
> > > > > 1) Only accept NOTIFY's which fit to the response
> > > > > 
> > > > > 2) Accept all NOTIFY's (problem with DoS? - Is it one with 
> > > > firewalls?)
> > > > > 
> > > > > 3) Accept only a subset of the NOTIFY's (based on some 
> > > local policy)
> > > > > 
> > > > > If the subscriber doesn't want to wait for the response to 
> > > > > the SUBSCRIBE,
> > > > > and NOTIFY's arrive before the response, it has the 
> > possibilities:
> > > > > 
> > > > > 1) Accept the first NOTIFY and ignore the response
> > > > > 
> > > > > 2) Accept all NOTIFY's and ignore the response
> > > > > 
> > > > > 3) Accept only a subset of the NOTIFY's
> > > > > 
> > > > > 4) Accept no NOTIFY. When the response to the SUBSCRIBE 
> > > > > arrives, subscribe
> > > > > again, but then accept the NOTIFY from the sender from the 
> > > > > first SUBSCRIBE.
> > > > > ( NOTE: I DON'T propose that)
> > > > > 
> > > > > There was the proposal to accept the dialog which arrives 
> > > > first, be it
> > > > > response or NOTIFY.
> > > > > 
> > > > > 
> > > > > Did I forget another possibility? I think all of them work. 
> > > > > Basically all of
> > > > > them depend on a kind of local policy and on the kind of 
> > > > > application, which
> > > > > shouldn't be controlled anyway by the protocol.
> > > > > 
> > > > > So I vote for 1) as default procedure.
> > > > > 
> > > > > Lachlan
> > > > > 
> > > > > 
> > > > > -----Originalnachricht-----
> > > > > Von: Paul Kyzivat
> > > > > An: Jonathan Rosenberg
> > > > > Cc: [email-masked]; 'Brian Stucker'; simple
> > > > > Gesendet: 06.12.01 22:58
> > > > > Betreff: Re: [Simple] 200 vs. 202
> > > > > 
> > > > > [SNIP]
> > > > > 
> > > > > > 
> > > > > > Do we have consensus though? I'd like to declare this issue 
> > > > > resolved.
> > > > > Adam's
> > > > > > proposal was to accept the first NOTIFY, and ignore the 
> > > > > 2xx. I'd like
> > > > > to
> > > > > > suggest a mild variant to that that I think is even 
> > simpler. My
> > > > > proposal is
> > > > > > to accept whatever comes first. If you get a 2xx to 
> > > > SUBSCRIBE first,
> > > > > that
> > > > > > establishes a dialog. All other NOTIFYs are 481d. If a 
> > > > NOTIFY comes
> > > > > first,
> > > > > > you accept that. Any other NOTIFY are 481'd. The 2xx to 
> > > > > SUBSCRIBE may
> > > > > or may
> > > > > > not be for the dialog that was accepted; it doesn't 
> > > really matter.
> > > > > > 
> > > > > > Agreement?
> > > > > 
> > > > > I don't have a preference between those two alternatives.
> > > > > 
> > > > > I won't stop progress by continuing to argue, but I don't 
> > > > find either
> > > > > solution very appealing. 
> > > > > 
> > > > > 	Paul
> > > > > _______________________________________________
> > > > > simple mailing list
> > > > > [email-masked]
> > > > > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > > > > 
> > > > 
> > > 
> > 
>

---

From: [email-masked]
Date: Fri, 7 Dec 2001 13:22:54 -0600

Yes. The consensus on this topic will be described in detail in sip-events,
and does not need to be reiterated in any SIMPLE documents.

/a

> Sent: Friday, December 07, 2001 12:22 PM
> To: [email-masked]'; Jonathan Rosenberg; 'Brazier Lachlan';
> ''Paul Kyzivat ' '