Subject: RE: [Simple] MESSAGE sessions - over TCP

From: [email-masked]
Date: Wed, 26 Sep 2001 17:35:22 +0300

Hi,

> However, SIP MESSAGE over TCP should be ok. Message overhead is an 
> issue only in wireless environment, but SIP compression (even 
> UDPcomp) 
> eliminates the overhead. 

If we have SIP MESSAGEs over TCP directly between UAs, is SIP compression
applicable? Usually the compression is meant to be used between a UA and the
(outbound) proxy, but is there anything hindering the End-to-End case? I
suppose the UAs would have to agree to use compression in SDP as part of the
transport description?

Is this part of the signaling compression requirements?

Rgs,
	Markus

> -----Original Message-----
> From: ext Petri K. Koskelainen [mailto:[email-masked]]
> Sent: 25 September, 2001 18:39
> To: [email-masked]
> Subject: [Simple] MESSAGE sessions - over TCP
> 
> 
> 
> There hasn't been any conclusion or rough consensus relating to 
> the SIP MESSAGE session model.
> 
> It seems that there are two main proposals:
> 
> 1: Implicit MESSAGE session (no INVITE, just MESSAGEs).
> 
> 2: Use of INVITE to establish a SIP session and then using
> some protocol X to carry the messages. The X protocol
> may be SIP MESSAGE, BEEP-based, some new protocol etc.
> IESG has ruled out SIP MESSAGE mainly because of three reasons:
> - large message overhead in SIP headers 
> - lack of congestion control (in UDP only)
> - size limitation (in UDP only)
> However, SIP MESSAGE over TCP should be ok. Message overhead is an 
> issue only in wireless environment, but SIP compression (even 
> UDPcomp) 
> eliminates the overhead. 
> TCP has also other advantages (like the use of TLS).
>  
> I really think that something should be decided asap. Option 
> 2 with SIP 
> MESSAGE over TCP seems to be ok. It does not have to be the 
> one-and-only
> format for next 100 years. If someone really wants it, he can specify 
> BEEP-based or whatever additional formats inside a SIP 
> session - just like it is possible to create new RTP formats. 
> However, SIP session model and MESSAGE over TCP is sufficient for 
> many applications and therefore it would be really useful 
> to continue at least with that (and have something to use asap).
> 
> Since other formats inside a session may be defined later, the real
> question is whether the INVITE established session is needed or not.
> I think yes. This is similar to audio/video sessions, and it 
> allows e.g.
> the use of record-route, mobility etc.
> 
> --
> Petri
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Lawrence Conroy <[email-masked]>
Date: Wed, 26 Sep 2001 16:51:59 +0100

>Is this part of the signaling compression requirements?
Hi there,
   my understanding was that: Initially, the end systems agree "out of band"
(e.g the SUAS listens on a particular port for compressed messages).
This should work for TCP or UDP.

Don't believe that anyone has seriously suggested yet another addition to
SDP to indicate compressed SIP should be used (i.e. to negotiate).
The goal is to compress even the initial SIP message; this would not be
possible if negotiation were carried in SDP (carried inside a SIP message :).

BR,
   Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>: