Subject: RE: [Simple] who changes im: pres: to sip:

From: [email-masked]
Date: Wed, 20 Nov 2002 22:18:51 +0200

Hi,

inline.

> It sounds like the text you reference answers 
> the question. Do it as soon as possible, 
> preferably before you send the request. Different
> environments and clients may do this at different
> times depending on your view of "as soon as possible".
> I think (1) is the right answer, though that might
> be identical to (2) is some rare cases.

Well, I would argue that the translation can *never* happen before the request is sent. We can't mandate a direct translation from an IM URI to a SIP URI, and any other translation would be local policy to the GW.

So the Request-URI would always need to have the original im: URI in it. This of course causes problems for proxies that don't recognize the im URI scheme.

My proposal is that the client uses a translation similar to when translating tel URIs. Namely, the im URI is translated into a SIP URI by simply replacing the scheme. Additionally, the URI parameter 'user' is populated with the original scheme which in this case is 'im'.

If I need to contact 'im:[email-masked]', I resolve the next hop using SRV, and in the request line have the following: 

	MESSAGE sip:[email-masked];user=im SIP/2.0

This will enable both cases (1 and 2 below) since a GW can fall back to the direct translation by ignoring the user param. If the local policy dictates some other translation, the user parameter gives enough information to also do that at the GW.

> The SRV resolution that was discussion in IMPP
> solves the next hop problem. It did not directly
> address translation of an im: *URI* to a sip: *URI*.
> Shouldn't this be left to local policy/implementation?

I think the above translation would solve this problem.

Thoughts?

Cheers,
Aki

> --- [email-masked] wrote:
> > Hi,
> > 
> > Most of us heard the discussion at impp wg meeting
> > about schemes, but there was no consensus on who
> > changes the scheme.
> > 
> > There are 2 suggestions:
> > 
> > 1. change it to sip as soon as possible, as
> > instructed by presence-07
> > 2. Leave it to the terminating domain. I.e. the
> > domain responsible.
> > 
> > Which one of the above should we do? If we choose 2,
> > should presence I-D be changed to reflect that?
> > 
> > I'm referring to the text:
> > 
> > "When subscribing to a presentity, the subscription
> > can be addressed
> >    using the protocol independent form or the SIP or
> > SIPS URI form. In
> >    the SIP context, "addressed" refers to the
> > Request-URI. It is
> >    RECOMMENDED that if the entity sending a
> > SUBSCRIBE is capable of
> >    resolving the protocol independent form to the
> > SIP form, this
> >    resolution is done before sending the request"
> > 
> > Regards,
> > Hisham
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> >
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Web Hosting - Let the expert host your site
> http://webhosting.yahoo.com
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Sean Olson <[email-masked]>
Date: Wed, 20 Nov 2002 13:30:30 -0800 (PST)

To take your analogy for tel: URIs to completion,
wouldn't we want to represent the entire im: URI in
the user portion of the sip: URI and tack on a
"user=im" parameter?

This seems like an interesting approach but I'm
concerned that the user=im parameter would *have*
to be interpreted by the proxies to do the right
thing. In that case, we would be better off with
sticking with an im: URI in the Request-URI. 

/sean

--- [email-masked] wrote:
> Well, I would argue that the translation can *never*
> happen before the request is sent. We can't mandate
> a direct translation from an IM URI to a SIP URI,
> and any other translation would be local policy to
> the GW.
> 
> So the Request-URI would always need to have the
> original im: URI in it. This of course causes
> problems for proxies that don't recognize the im URI
> scheme.
> 
> My proposal is that the client uses a translation
> similar to when translating tel URIs. Namely, the im
> URI is translated into a SIP URI by simply replacing
> the scheme. Additionally, the URI parameter 'user'
> is populated with the original scheme which in this
> case is 'im'.
> 
> If I need to contact 'im:[email-masked]', I resolve the
> next hop using SRV, and in the request line have the
> following: 
> 
> This will enable both cases (1 and 2 below) since a
> GW can fall back to the direct translation by
> ignoring the user param. If the local policy
> dictates some other translation, the user parameter
> gives enough information to also do that at the GW.
>