Subject: RE: [Simple] authorization for presence

From: Neil Deason <[email-masked]>
Date: Fri, 15 Jun 2001 03:52:28 -0400

> 
> > There are also important open issues in this area:
> > 
> > 9.1 Must a MESSAGE actually include a message?
> > 9.5 What would a body in a 200 OK to a MESSAGE mean?
> 
> We addressed 9.5 in Minnesota. A MESSAGE response may
> not contain a body - it would break cpim. 

Sorry I had to miss SIMPLE WG that time.

> Issue 9.1 from the document was asking a different
> question from what you might have meant. Basically,
> it boiled down to "Is it ok to have a MESSAGE request
> with and empty body?". We can derive the answer to that
> from the consensus we already acheived that while an
> implementation MUST be able to receive message/cpim,
> it MAY send text/plain. Thus it MAY send an empty
> text/plain document. I suspect you rather wanting to
> ask "Can a MESSAGE have a payload that isn't a message?".
> Outside of the message, and message meta-data like
> we have with message/cpim, I hope the answer is no.

That is actually another question and the answer
to it that I hoped to hear. If text covering these
3 points can make it into the draft I think the
semantics of MESSAGE will be a lot clearer.

Cheers,
Neil

---

From: Ben Campbell <[email-masked]>
Date: Mon, 02 Jul 2001 10:38:18 -0500

> semantics of MESSAGE will be a lot clearer.

I will add this to the next MESSAGE draft revision.

Thanks!

Ben.