Subject: [Simple] What if a PUA crashed, but the registration of the PUA still valid

From: Xiaotao Wu <[email-masked]>
Date: Thu, 17 Oct 2002 14:09:22 -0400 (EDT)

Hi,

For a Presence Server (PA colocated with proxy), if the PUA which the
Presence Server proxys the SUBSCRIBE to crashed, but the registration of
the PUA is still valid (since PUA crashed, the PUA did not unregister
itself), for an incoming SUBSCRIBE, what's the status should be in the
notification from the Presence Server?

  PUA (a)     Presence Server         PUA (b)

    |               |                 |
    |               +<-- REGISTER ----+
    |               |                 |
    +--- SUBSCRIBE->+                 |
    |               |                 |
    |               +---- SUBSCRIBE -->
    |               |                 |
    |               +<---- 200 OK ----+
    |               |                 |
    +<-- 200 OK ----+                 |
    |               |               \ | /
    |               |                \|/
    |               |                 X  CRASH!!!
    | (subscription |                /|\
    |  expired)     |               / | \
    |               |                 |
    +-- SUBSCRIBE ->+                 |
    |               |                 |
    |               +--- SUBSCRIBE -->+
    |               |                 |
    |               |                 |
    |               |    (timeout)    |
    |               |                 |
    |               |                 |
    |               |                 |
    |     202???    |                 |
    +<--- ??? ------+                 |
    |     200???    |                 |

-Xiaotao

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 21 Oct 2002 23:38:14 -0400

inline.

> notification from the Presence Server?

There is no notification. The SUBSCRIBE refresh from the client will 
result in a 408 from the presence server (this is normal proxy 
behavior). That, based on 3261, will cause the client to terminate the 
dialog. So, if it still wants the subscription, it has to subscribe with 
a brand new request. This reaches the presence server, which can now 
accept the subscription, migrating it from the PUA back to the server.

-Jonathan R.

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com