Subject: RE: [Sipping] RE: [Simple] Multimedia message adaptationInternet- Drafts

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 8 Nov 2002 07:58:21 -0500

It seems to me that these filtering drafts concern the modification of MIME
bodies in SIP messages by intermediaries. This is not exactly an
uncontroversial topic in SIP circles, and therefore I don't think it is a
foregone conclusion that this is work that some SIP-related WG should
charter. At a high level, these drafts also argue that capability
negotiation should be administered by intermediaries rather than through an
end-to-end process; this approach may attract some similar controversy.

Provided that this is work the community would like to pursue, the
applicability and impact of this mechanism is larger than the problem of
instant messaging and presence. While clearly, from the framework, instant
messaging and presence cases are driving this work, it is applicable to the
general use of SIP events (messaging, I think, is something of a corner
case). While SIMPLE could certainly spend some time refining the framework
and requirements related to IM & presence, I imagine that at a mechanism
stage this work would need to take place in SIPPING.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, November 08, 2002 3:47 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Sipping] RE: [Simple] Multimedia message
> adaptationInternet-Drafts
> 
> 
> Hi,
> 
> Actually this thread is about two separate things:
> - Event filtering
> - Multimedia message adaptation
> 
> Neither of them appears currently on any sippish WG charter 
> currently. 
> 
> Event filtering has been discussed several times and it is 
> even mentioned in (but out of scope of) SIP Events RFC. My 
> impression has been that people think that it is needed, but 
> there has been debate about scope and feasibility. I hope the 
> requirements draft will help in that discussion. My own 
> opinion is that what is concretely needed in short term is 
> some simple filtering definitions for Presence event package. 
> More wide-scoped and complex things could be worked upon as 
> the understanding accumulates.
> 
> Multimedia message adaptation hasn't been yet discussed much. 
> I think it is in general a desirable feature, especially for 
> relatively small and dumb terminals, which are not easily 
> upgradable and may not understand all media formats.
> 
> So I propose the WG chairs think where these items would be 
> appropriate, and if there is enough interest for them, let's 
> put them on the charters.
> 
> Markus
> 
> > -----Original Message-----
> > From: ext Dean Willis [mailto:[email-masked]]
> > Sent: 08 November, 2002 5:11
> > To: Drage, Keith (Keith)
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [Sipping] RE: [Simple] Multimedia message
> > adaptationInternet-Drafts
> > 
> > 
> > Well, I'd like to hear opinions from the participants here . . .
> > 
> > Clearly they aren't explicitly on the charter for either 
> > group. Do we as
> > yet have a consensus that we need to work on these 
> problems? If so, we
> > can consider WHERE to work on them. I suspect SIPPING is closer to a
> > matching scope than is SIMPLE, but the relevant ADs may have 
> > suggestions
> > to make there as well.
> > 
> > --
> > Dean
> > 
> > On Wed, 2002-11-06 at 12:51, Drage, Keith (Keith) wrote:
> > > I am getting a bit confused as to which group should be 
> > discussing these filtering issues.
> > > 
> > > Could we have a statement from the WG chairs of SIPPING or 
> > SIMPLE as to whether this, and the moran drafts, are part of 
> > the scope of SIPPING or SIMPLE.
> > > 
> > > And before you say these are both author drafts, I think we 
> > do need to charter one of the WGs to do some work in this 
> > area - I am just not sure of the exact scope yet.
> > > 
> > > Keith
> > > 
> > > Keith Drage
> > > Lucent Technologies
> > > Tel: +44 1793 776249
> > > Email: [email-masked] 
> > > 
> > > > -----Original Message-----
> > > > From: Pekka Pessi [mailto:[email-masked]]
> > > > Sent: 06 November 2002 18:24
> > > > To: [email-masked]; [email-masked]
> > > > Subject: [Simple] Multimedia message adaptation Internet-Drafts
> > > > 
> > > > 
> > > > 	While these drafts concern event filtering, 
> too, the subject was
> > > > 	a bit misleading because I lazily just followed 
> up Tim's e-mail.
> > > > 
> > > > 					Pekka
> > > > 
> > > > http://www.ietf.org/internet-drafts/draft-coulombe-message-ada
> > > > ptation-framework-00.txt
> > > > 
> > > > http://www.ietf.org/internet-drafts/draft-coulombe-message-ada
> > > > ptation-requirements-00.txt
> > > > 
> > > > Pekka Pessi <[email-masked]> writes:
> > > > >We have submitted two drafts regarding multimedia message
> > > > >adaptation. A multimedia message is typically a message
> > > > >containing images, audio or video clips and their presentation
> > > > >information, e.g., smil. Also, even XML-formatted text may
> > > > >require adaptation in some cases.
> > > > 
> > > > >Our goal is to have a framework using SIP, HTTP and MIME that
> > > > >allows a person sending multimedia message to adapt the message
> > > > >contents suitable to all the recipients. In some cases the
> > > > >adaptation can be done by the sending terminal, but we also see
> > > > >that an adaptation service would be very useful in many cases. 
> > > > >Such an adaptation mechanism is used by MMS service provided by
> > > > >cellular networks nowadays.
> > > > 
> > > > >The message adaptation work concerns both SIPPING and SIMPLE,
> > > > >the requirements I-D lists use cases and requirements for
> > > > >multimedia messaging and message adaptation solutions and the
> > > > >framework I-D tries to explore possible solutions.
> > > > 
> > > > _______________________________________________
> > > > simple mailing list
> > > > [email-masked]
> > > > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP
> > > Use [email-masked] for questions on current sip
> > > Use [email-masked] for new developments of core SIP
> > > 
> > 
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 08 Nov 2002 10:34:29 -0600

I don't think it is a foregone 
> conclusion that this is work that some SIP-related WG should 
> charter.

I agree that anything that conflicts with e2e should not be ligitimized
by any IETF WG. Think of NATs and firewalls...

If folks want to implement B2BUA, it should be done on their own
responsibility and then live with the consequences. My two cents.

Thanks, Henry

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Peterson, Jon
> Sent: Friday, November 08, 2002 6:58 AM
> To: [email-masked]'; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> It seems to me that these filtering drafts concern the 
> modification of MIME bodies in SIP messages by 
> intermediaries. This is not exactly an uncontroversial topic 
> in SIP circles, and therefore I don't think it is a foregone 
> conclusion that this is work that some SIP-related WG should 
> charter. At a high level, these drafts also argue that 
> capability negotiation should be administered by 
> intermediaries rather than through an end-to-end process; 
> this approach may attract some similar controversy.
> 
> Provided that this is work the community would like to 
> pursue, the applicability and impact of this mechanism is 
> larger than the problem of instant messaging and presence. 
> While clearly, from the framework, instant messaging and 
> presence cases are driving this work, it is applicable to the 
> general use of SIP events (messaging, I think, is something 
> of a corner case). While SIMPLE could certainly spend some 
> time refining the framework and requirements related to IM & 
> presence, I imagine that at a mechanism stage this work would 
> need to take place in SIPPING.
> 
> Jon Peterson
> NeuStar, Inc.
> 
> > > suggestions to make there as well.
> > > 
> > > --
> > > Dean
> > > 
> > > > This list is for NEW development of the application of SIP Use 
> > > > [email-masked] for questions on 
> current sip Use 
> > > > [email-masked] for new developments of core SIP
> > > > 
> > > 
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 8 Nov 2002 09:12:48 -0800

Folks,

lets keep this on one list please....

thanks,
-rohan

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 08 Nov 2002 10:34:29 -0600

Thanks, Henry