Subject: RE: [Simple] MESSAGE sessions - over TCP

From: "Sean Olson (EUS)" <[email-masked]>
Date: Fri, 28 Sep 2001 09:53:21 -0500

>> I'd appreciate staying with Petri's question:
>> > > Is there a consensus that INVITE-established IM messaging
>> > > session idea is ok ? (in addition to one shot MESSAGEs)
>
>I think that INVITE-established IM sessions are essential. 
>Especially when
>dealing with multi-party chat.

I keep hearing statements like this, but it seems
that multi-party chat is actually easier to implement
using a paging model and a implicit session concept.

If you want a chat session, what is wrong with the 
RTP text stuff (ignoring the unicode/MIME issues)

I am personally in favor of INVITE-established IM
messaging as well, but I think its principal 
purpose is efficiency.

Sean Olson
Ericsson Inc.

---

From: "Petri K. Koskelainen" <[email-masked]>
Date: Fri, 28 Sep 2001 11:19:24 -0400 (EDT)

> RTP text stuff (ignoring the unicode/MIME issues)

Reliability, for instance.

--
Petri

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 28 Sep 2001 11:36:59 -0400

> "Sean Olson (EUS)" wrote:
> 

- having an IM session is needed so that you can make a
  call that associates IM and other media that are
  intended to be used together

- having an IM session negotiated with sip invite means
  you can use standard sip call control techniques to
  request transfer, conferencing, etc. This becomes
  especially interesting when the call involves multiple
  media, because then the call control switches all the
  media in a parallel, coordinated way.

It may be possible to simulate the above features using
paging mode IM with no IM session, but doing so will
require new call control techniques that treat IM as a
special case.

	Paul Kyzivat
	Cisco Systems