Subject: [Simple] Comment: draft-ietf-simple-presence-02

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Fri, 14 Sep 2001 14:59:34 -0500

Non-critical issue:

Section 5.3 (Paragraph 3) defines a default filter. However
I do not see the need for bullet 3 wherein additional markup
is sent (if < 50 bytes). It is better to have a consistent mechanism
of sending any markup (irrespective of size) only if explicitly
requested
by the subscriber or just send all the markup as the default.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Sep 2001 06:57:17 -0400

my apologies for an extensive absence from the list... I've been on
vacation. Comments below.

> -----Original Message-----
> From: Patil Basavaraj (NET/Dallas) [mailto:[email-masked]]
> Sent: Friday, September 14, 2001 4:00 PM
> To: [email-masked]
> Subject: [Simple] Comment: draft-ietf-simple-presence-02
> 
> 
> 
> Non-critical issue:
> 

The problem is that in rfc2778, "additional markup" can be almost anything.
Always sending it might imply, down the road, sending huge jpeg files with
pictures of the user. I'm not sure you want that to be the default.

Never sending it also has problems. Looking at draft-ietf-impp-cpim-pidf,
this would mean that the "note" element would never be sent unless
explicitly requested, since it is neither status or contact information. I
suspect the note will be used often, and I want to make sure its included in
the normal case. 

So, I put this middle-ground sentence in to make sure that the small stuff
goes, and the bigger stuff needs to be requested.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Thu, 20 Sep 2001 14:34:38 -0500

>pictures of the user. I'm not sure you want that to be the default.

I agree. I was leaning towards not sending anything being the default.

>goes, and the bigger stuff needs to be requested.

It just does not seem to be a consistent way for doing things. So
while today it may be "note" that is useful to be carried in the
NOTIFY, there may be an other parameter that someone else might deem
important enough to be carried in the NOTIFY. Maybe there needs to be
a set of parameters that can be agreed upon as ones that pass through
the default filter irrespective of size.

-Basavaraj

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 Sep 2001 00:32:47 -0400

> Sent: Thursday, September 20, 2001 3:35 PM
> To: 'ext Jonathan Rosenberg'; [email-masked]
> Subject: RE: [Simple] Comment: draft-ietf-simple-presence-02
> 
> 
> >> 
> >> 
> >> Non-critical issue:
> >> 

I would also be fine for that, except for the technicality that in the
cpim-pidf format, the note element would then not be sent by default.

> the default filter irrespective of size.

The problem is that I don't want the spec to be specific to cpim-pidf as a
data format. If it did, I could simply say "send the note, but not
extensions", and we would be done. But, rfc2778 is more generic, and its all
clumped together.

I would welcome an alternate proposal.

-Jonathan R.
---

---

From: Robert Sparks <[email-masked]>
Date: Fri, 21 Sep 2001 12:20:31 -0400

Here's an alternate proposal.

The concept of filter is vague, and the default filter
written in this document is presuming that all future
presence documents will be tuple based (probably not
a wrong assumption, but an assumption non-the-less).
I suspect that the form of filters will depend on the
form of the presence documents.

I propose that the default filter is the identity function
(i.e. filter nothing), and control oversized additional
markup through other mechanisms until the filter concept
is made more concrete.

RjS

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, September 20, 2001 11:33 PM
> To: 'Patil Basavaraj (NET/Dallas)'; [email-masked]
> > >Always sending it might imply, down the road, sending huge 
> jpeg files
> > with
> > >So, I put this middle-ground sentence in to make sure that 
> the small
> > stuff
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 Sep 2001 13:05:26 -0400

Actually, I like that better since its less arbitrary.

Let us go with that.

-Jonathan R.

---

> From: Robert Sparks 
> Sent: Friday, September 21, 2001 12:21 PM
> To: Jonathan Rosenberg; 'Patil Basavaraj (NET/Dallas)';

---

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Fri, 21 Sep 2001 17:27:03 -0500

> Actually, I like that better since its less arbitrary.

Better than what is specified in the I-D today. I agree.

-Basavaraj

> > > > >The problem is that in rfc2778, "additional markup" 
> can be almost
> > > > anything.
> > > > >suspect the note will be used often, and I want to 
> make sure its
> > > > included in
> > > > >the normal case. 
> > > > >