Subject: RE: [Simple] IM: A session or not

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 2 Apr 2001 22:33:16 -0400

> -----Original Message-----
> From: Henning G. Schulzrinne [mailto:[email-masked]]
> Sent: Monday, April 02, 2001 2:14 PM
> To: [email-masked]
> Cc: 'Christian Huitema'; Jonathan Rosenberg; Rohan Mahy;
> [email-masked]
> Subject: Re: [Simple] IM: A session or not
> 
> 
> [email-masked] wrote:
> > 
> > > From: Christian Huitema [mailto:[email-masked]]
> > >
> > >...if we go forward with the plan of
> > > documenting an "m=message" media in SDP, we will need to 
> specify at
> > > least three options:
> > >
> > > 1) Send messages to a specified TCP-IP (or UDP-IP) address,
> > > 2) Send messages to a SIP URL,
> > > 3) Send messages "on this channel", i.e. using the same 
> route as other
> > > signaling messages in this session.
> > 
> > I think (1) and (2) are basically the same situation, and 
> are covered
> > by Jonathan's proposal. Situation (3) -- an instant 
> messaging session
> > with a distinct beginning and end, but using the proxy network -- is
> > a new case that needs to have syntax defined for it.
> 
> This is basically one or more MESSAGE within the call-id/call-leg
> context of an INVITE. Or am I missing something here?

No, thats exactly it. The question is how (and if!) the SDP can convey that
"you should send the MESSAGE in the sip signaling path, not directly". One
could argue that a client can always send the MESSAGE through the proxy
network; do we actually need a way for the called party, for example, to
tell the caller that they have to use the proxy network?

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com
> 
> 
> 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
>

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Mon, 02 Apr 2001 22:35:40 -0400

Jonathan Rosenberg wrote:

> tell the caller that they have to use the proxy network?

It would seem to be sufficient to deduce that if there's no entry for
m=message in the caller/callee SDP and either feels the urge to send a
message, it can do this. Obviously, either side can also re-INVITE if it
wants to add a streaming message media session, rather than a
proxy-routed message.