Subject: RE: [Simple] problem: how upload presence document?

From: "Brian Stucker" <[email-masked]>
Date: Fri, 2 Nov 2001 14:09:38 -0600

Well, REGISTER is already out there and in use, and there's a lot to be
said to sticking with something that's already been developed (for CPL)
to do basically the same thing that we need as a general mechanism. I 
would posit that this alone makes it a good candidate for a default 
mechanism to upload presence fragments into the network. 

Brian

-----Original Message-----
From: Håkan Jonsson [mailto:[email-masked]]
Sent: Friday, November 02, 2001 5:05 AM
To: 'sal'; simple; sdonovan
Subject: SV: [Simple] problem: how upload presence document?

I think that the letting the PA subscribe to the PUAs presence document
is a nice approach, since you can use it as it is. One thing you would
need to add to the NOTIFY is an Expires header and interpret that as the
expiration time for a soft state, to satisfy the requirements in
draft-donovan..., but I think that is allowed by the current sip-events
draft.

The PUA can manipulate presence information in a number of ways, which
is good. For presence documents I don't think we should limit ourselves
to one way, but specifying a mechanism to upload service data using SIP
in general as suggested in Donovan's draft is desirable, and should be
one of the ways to upload presence documents.

As Donovan suggests in his draft, the actions to be taken using the
uploaded data could be put in the body or in an extension of SIP
methods, headers etc. I think defining a new event type for each type of
data would result in a lot of event types. Using NOTIFY, SUBSCRIBE with
one new event type: servicedata, and letting the actual body contain the
specific data manipulation actions to be done in a service specific
language, is the most general and clear-cut way to do it. On the other
hand, if there only a few service data types needed, we could define
specific event types for these. Donovan mentions presence documents and
CPL scripts; what other types are needed?

Håkan
-----------------
Håkan Jonsson              Drottninggatan 18
BlueLabs South AB          21189 Malmö
http://www.bluelabs.se     Sweden

> -----Ursprungligt meddelande-----
> Från: [email-masked] 
> [mailto:[email-masked]] För sal
> Skickat: den 2 november 2001 11:00
> Till: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Kopia: [email-masked]
> Ämne: [Simple] problem: how upload presence document?
> 
> 
> i think that this question: "upload presence document" is a 
> critical issue.
> 
> there isn't a standard procedure to upload and to modify the 
> presence document, but it is the source of the presence status ... 
> if the UA... if the PUA change its media capability, or 
> change its status, it MUST refresh the presence document.
> 
> 
> the upload must be made through the protocol sip!!!
> and not push the presence doc via another protocol, such as HTTP POST.
> 
> 
> I agree with Steven Donovan when he says in the draft 
> "Requirement for Pubblication of SIP related service data"
> : "... it is felt that the SIP REGISTER request is NOT the 
> appropriate mechanisme for handing this loading od SIP 
> service information..." but i'm not sure that a 
> generalization of the REGISTER function, as proposed in the 
> draft, is a good idea
> 
> 
> The use of the method REGISTER, for the upload,introduces one 
> series of problems, just one example: the expiration of the 
> Presence document and the expiration of the current 
> communication addresses (i.e. Contact Addres) are different...
> 
> I have instead a proposed other:
> the use of method NOTIFY...
> this method is already used for send the presence state to
> a particular subscriber... 
> the its generalization for the upload or refresh of Presence 
> Document is very simple and has the advantage of not 
> modify/generalization a very important message for sip as REGISTER...
> 
> 
> which is your opinion ? 
> _______________________________________________
> simple mailing list
> [email-masked] 
> http://mailman.dynamicsoft.com/mailman/listinf> o/simple
> 

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Robert Sparks <[email-masked]>
Date: Fri, 2 Nov 2001 16:26:29 -0500

We have as a group identified that it is not a good enough thing.
 
We have a defined mechanism that uses REGISTER for now,
but we recognize that that is not the proper long term solution.
 
We've explored its shortcomings before, and don't need to do so
here again - they are captured in Steve Donovan's draft. We were
on the path to taking on defining a method for publishing presence
data in SIMPLE when we realized there was a more general need,
so we've handed that work off to SIP by way of SIPPING (which finally
officially exists). We will have an item on our revised agenda to
specify how this mechanism will be used for presence publication
once its available.
 
In the meantime, we'll use Register and work around the warts.
 
RjS 
 
 -----Original Message-----
From: Brian Stucker [mailto:[email-masked]]
Sent: Friday, November 02, 2001 2:10 PM
To: Håkan Jonsson; 'sal'; simple; sdonovan
Subject: RE: [Simple] problem: how upload presence document?

Brian 

-----Original Message----- 
From: Håkan Jonsson [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Friday, November 02, 2001 5:05 AM 
To: 'sal'; simple; sdonovan 
Subject: SV: [Simple] problem: how upload presence document? 

Håkan 
----------------- 
Håkan Jonsson              Drottninggatan 18 
BlueLabs South AB          21189 Malmö 
http://www.bluelabs.se <http://www.bluelabs.se>      Sweden 

> [ mailto:[email-masked]
<mailto:[email-masked]> ] För sal 
> http://mailman.dynamicsoft.com/mailman/listinf
<http://mailman.dynamicsoft.com/mailman/listinf> > o/simple 

_______________________________________________ 
simple mailing list 
[email-masked] 
http://mailman.dynamicsoft.com/mailman/listinfo/simple
<http://mailman.dynamicsoft.com/mailman/listinfo/simple>

---

From: "Brian Stucker" <[email-masked]>
Date: Fri, 2 Nov 2001 15:47:48 -0600

Good enough. So this will appear in IETF-52, then?
 
Brian

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: Friday, November 02, 2001 3:26 PM
To: Stucker, Brian [NGB:B621:EXCH]; Håkan Jonsson; 'sal'; simple; Steve
Donovan

 

RjS 
 
 -----Original Message-----
From: Brian Stucker [mailto:[email-masked]]
Sent: Friday, November 02, 2001 2:10 PM
To: Håkan Jonsson; 'sal'; simple; sdonovan
Subject: RE: [Simple] problem: how upload presence document?

Brian 

-----Original Message----- 

Håkan 
-----------------

---

From: "Sriram Parameswar" <[email-masked]>
Date: Fri, 2 Nov 2001 15:49:42 -0600

Robert:
 
Is there a PUBLISH - 200 OK in the works? If so, lets discuss its merits and
de-merits in the SIMPLE list. This will avoid a whole lot of backwards
compatibility issues down the road.
 
Regards,
 
Sriram
__________________________________________ 
Sriram Parameswar              Phone: 972-685-8540 
Interactive Multimedia Server (IMS) Fax: 972-685-3563 
Nortel Networks, Richardson USA  Email: [email-masked] 

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: Friday, November 02, 2001 3:26 PM
To: Stucker, Brian [NGB:B621:EXCH]; Håkan Jonsson; 'sal'; simple; Steve
Donovan

 

RjS 
 
 -----Original Message-----
From: Brian Stucker [mailto:[email-masked]]
Sent: Friday, November 02, 2001 2:10 PM
To: Håkan Jonsson; 'sal'; simple; sdonovan
Subject: RE: [Simple] problem: how upload presence document?

Brian 

-----Original Message----- 

Håkan 
-----------------

---

From: Robert Sparks <[email-masked]>
Date: Fri, 2 Nov 2001 17:07:33 -0500

The time for discussing it here is passed. It started here,
but has moved to the SIPPING working group. We have
been very careful make sure the requirements for presence
publication are communicated there, starting with 
draft-donovan-publish-requirements-00.txt and continuing
through the participation of several members from this group.
 
If you have a vested interest the outcome of that work and
are not already on the sipping list, go join it.
(see http://www.ietf.org/html.charters/sipping-charter.html
<http://www.ietf.org/html.charters/sipping-charter.html> )
Be sure to comment on the donovan draft if you see something
missing.
 
I notice that its new charter doesn't explicitly call out
working on the publish mechanism - I'm in the process
of finding out what happened to it. 
 
RjS

-----Original Message-----
From: Sriram Parameswar [mailto:[email-masked]]
Sent: Friday, November 02, 2001 3:50 PM
To: 'Robert Sparks'; Brian Stucker; 'Håkan Jonsson'; 'sal'; 'simple'; 'Steve
Donovan'

Robert:

Regards,
 
Sriram

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: Friday, November 02, 2001 3:26 PM
To: Stucker, Brian [NGB:B621:EXCH]; Håkan Jonsson; 'sal'; simple; Steve
Donovan

 

RjS 
 
 -----Original Message-----
From: Brian Stucker [mailto:[email-masked]]
Sent: Friday, November 02, 2001 2:10 PM
To: Håkan Jonsson; 'sal'; simple; sdonovan
Subject: RE: [Simple] problem: how upload presence document?

Brian 

-----Original Message----- 

Håkan 
-----------------