Subject: RE: [Simple] NOTIFY and application/cpim-pidf+xml

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 8 Aug 2001 16:46:30 -0400

> -----Original Message-----
> From: Hisham Khartabil [mailto:[email-masked]]
> Sent: Monday, July 30, 2001 3:03 PM
> To: [email-masked]
> Subject: [Simple] NOTIFY and application/cpim-pidf+xml
> 
> 
> Hi,
> 
> The example of NOTIFY in draft-ietf-simple-presence-01.txt 
> does not use
> content-type: message/cpim nor application/cpim-pidf+xml. I 
> can understand
> why. 

At the time of writing, these were not available.

> The question is:
> 
> In application/cpim-pidf+xml has the elements <value> and 
> <detail>. Which
> one is represented by the description attribute in the 
> contact header? and
> how do you represent the other?

I actually think that the description attribute of the contact header would
map to the note tag, not detail.

The value would be set by whether the contact is active or not. I had a
conversation with a few folks about this today. Normally, if you have a
registered contact, its going to be "open". When it expires, instead of
being closed, it simply disappears. So, the "closed" attribute is never
used.

Another possibility is that if the contact is registered with a q value of
zero, that means "closed".

No, there is a higher level issue here, which is what we do and don't want
to say about constructing pidf documents from registers. To a large extent,
its a local implementation choice, since it doesn't impact interoperability.
For example, choosing never to use closed, or using it when a q value of
zero is used, are both reasonable choices. Any sane mapping will do fine.
So, on one extreme, we can leave the entire mapping up to the
implementation.

At the other extreme, we specify the entire thing.

I'm not sure where in there is the right answer, but I suspect its closer to
specifying nothing, as opposed to the entire mapping.

Comments?

> 
> If the Presence Server is treating the GW as just another PUA 
> (presence
> server only accepts SUBSCRIBE and REGISTER requests, it sends 
> out NOTIFY),
> then the GW needs to map the cpim notify into a SIP REGISTER. 
> does it not?

No; cpim is server to server, not server to client.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Ben Campbell <[email-masked]>
Date: Wed, 08 Aug 2001 23:25:06 -0500

Jonathan Rosenberg wrote:
[snip]

> specifying nothing, as opposed to the entire mapping.

I lean toward saying it is a matter of local implementation. There may 
be many ways to synthesis presence data from various sources, and I can 
easily imagine a service that maps registers to presence in a less 
direct way. At most, it might be worth an informational draft when we 
don't have more important work to do :-p

---

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 9 Aug 2001 12:32:30 +0300

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jonathan
> Rosenberg
> Sent: Wednesday, 8 August 2001 11:47 PM
> To: 'Hisham Khartabil'; [email-masked]
> Subject: RE: [Simple] NOTIFY and application/cpim-pidf+xml
>
>
>
>
>
>

I have a client that sends REGISTER with q value of 0 in the contact to
indicate "closed", and my Presence Server only understands "closed" when the
registration has expired. The NOTIFY sent to my watchers in that case would
have value "open" in <value>. This is simply because the PS does not
interpret the q value as "closed". Is that an interoperability issue?

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>