Subject: AW: [Simple] 200 vs. 202

From: Brazier Lachlan <[email-masked]>
Date: Fri, 7 Dec 2001 12:14:17 +0100

Hello,

I believe the subscriber SHOULD keep all NOTIFY messages which arrive before
the response to the SUBSCRIBE arives. After receiving the response the
subscriber can decide which way to handle the NOTIFY's.

1) Only accept NOTIFY's which fit to the response

2) Accept all NOTIFY's (problem with DoS? - Is it one with firewalls?)

3) Accept only a subset of the NOTIFY's (based on some local policy)

If the subscriber doesn't want to wait for the response to the SUBSCRIBE,
and NOTIFY's arrive before the response, it has the possibilities:

1) Accept the first NOTIFY and ignore the response

2) Accept all NOTIFY's and ignore the response

3) Accept only a subset of the NOTIFY's

4) Accept no NOTIFY. When the response to the SUBSCRIBE arrives, subscribe
again, but then accept the NOTIFY from the sender from the first SUBSCRIBE.
( NOTE: I DON'T propose that)

There was the proposal to accept the dialog which arrives first, be it
response or NOTIFY.

Did I forget another possibility? I think all of them work. Basically all of
them depend on a kind of local policy and on the kind of application, which
shouldn't be controlled anyway by the protocol.

So I vote for 1) as default procedure.

Lachlan

-----Originalnachricht-----
Von: Paul Kyzivat
An: Jonathan Rosenberg
Cc: [email-masked]; 'Brian Stucker'; simple
Gesendet: 06.12.01 22:58
Betreff: Re: [Simple] 200 vs. 202

[SNIP]

> 
> Do we have consensus though? I'd like to declare this issue resolved.
Adam's
> proposal was to accept the first NOTIFY, and ignore the 2xx. I'd like
to
> suggest a mild variant to that that I think is even simpler. My
proposal is
> to accept whatever comes first. If you get a 2xx to SUBSCRIBE first,
that
> establishes a dialog. All other NOTIFYs are 481d. If a NOTIFY comes
first,
> you accept that. Any other NOTIFY are 481'd. The 2xx to SUBSCRIBE may
or may
> not be for the dialog that was accepted; it doesn't really matter.
> 
> Agreement?

I don't have a preference between those two alternatives.

I won't stop progress by continuing to argue, but I don't find either
solution very appealing. 

	Paul
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: [email-masked]
Date: Fri, 7 Dec 2001 10:13:33 -0600

Brian:

I can't tell what you're proposing, since you have two points
labelled as "1)." I like the second "1)" just fine, and the
variant in which the first dialog-establishing message (2xx
or NOTIFY) just as well.

/a

> -----Original Message-----
> From: Brazier Lachlan [mailto:[email-masked]]
> Sent: Friday, December 07, 2001 5:14 AM
> To: 'Paul Kyzivat '; 'Jonathan Rosenberg '
> Cc: [email-masked] '; ''Brian Stucker' '; 'simple '
> Subject: AW: [Simple] 200 vs. 202
> 
> 
> Hello,
>