Subject: RE: [Simple] Implicit MESSAGE sessions revisited

From: "Mark Watson" <[email-masked]>
Date: Mon, 17 Sep 2001 18:02:37 +0100

Dean,
 
I agree that they're independent. On the first one, I had thought that the
idea of IM 'sessions' fulfilled two key requirements:
 
1) I want to find my desired called party, and then exchange multiple
messages with this person
 
Some of these things which can happen (in the network/UEs) as a SIP message
finds the desired end-user may take time/cost money/require user
interaction, and I don't want to repeat them once I have found the person I
want to chat to. Also, there is no guarantee that repeating the process at a
later time will get me to the same end-user. So, I want to be able to do a
'session setup' and then send messages directly to the person I've found.
 
Of course, I could just treat the first message as an implicit session
setup, but this seems to be out of fashion.
 
2) I want IM to be just another media that I can negotiate, add & remove
from a session etc.
 
Again, I could do something clever with Call IDs to connect a MESSAGE
message with a pre-existing session etc. etc., but why should I make an
exception for this one kind of media. If I do that, then no capabilities
that I have now or invent in the future which are supposed to be 'media type
independent', will work for IM, and I will have to be hacking the IM system
constantly to keep up.
 
Did you disagree with these requirements, or just with the implementation ?
 
Regards...Mark

-----Original Message-----
From: Dean Willis [mailto:[email-masked]]
Sent: 17 September 2001 17:32
To: Watson, Mark [MAIFP:EP11:EXCH]; Patil Basavaraj (NET/Dallas); 'ext Ben
Campbell'
Cc: simple
Subject: Re: [Simple] Implicit MESSAGE sessions revisited

Both, actually. I believe the issues are independent.
 
--
Dean

----- Original Message ----- 
From: Mark Watson <mailto:[email-masked]>  
To: 'Dean Willis' <mailto:[email-masked]>  ; Patil Basavaraj
(NET/Dallas) <mailto:[email-masked]>  ; 'ext
<mailto:[email-masked]> Ben Campbell' 
Cc: simple <mailto:[email-masked]>  
Sent: Monday, September 17, 2001 9:39 AM
Subject: RE: [Simple] Implicit MESSAGE sessions revisited

Dean, 

Do you mean that you don't see the advantage of using INVITE to set up an IM
'session' (indicating this in the SDP), or just that once such a session is
set up, there is no need for the 'media' to use any different protocol than
that used for 'paging' ?

I think there are a lot of reasons why IM 'sessions' set up using INVITE
just like any other SIP session, make sense. I don't care much yet what the
transport protocol then is for the IMs in the session.

Sorry if this is covering old ground. 

...Mark 

> -----Original Message----- 
> From: Dean Willis [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: 15 September 2001 05:31 
> To: Patil Basavaraj (NET/Dallas); 'ext Ben Campbell' 
> Cc: simple 
> Subject: Re: [Simple] Implicit MESSAGE sessions revisited 
> 
> 
> 
> Just as MESSAGE for sessions has all the wasted overhead of 
> headers and 
> routing mechanisms designed to find users and traverse 
> firewalls (assuming 
> you think this is a waste), so does BEEP. 
> 
> I personally have yet to see the need for message sessions as 
> a specialized 
> transport. 
> 
> I think "pager" messages carrying a session-ID and sequence number can 
> provide the same user experience. 
> 
> -- 
> dean 
> 
> 
> ----- Original Message ----- 
> From: "Patil Basavaraj (NET/Dallas)" <[email-masked]> 
> To: "'ext Ben Campbell'" <[email-masked]> 
> Cc: <[email-masked]> 
> Sent: Friday, September 14, 2001 1:07 PM 
> Subject: RE: [Simple] Implicit MESSAGE sessions revisited 
> 
> 
> > 
> > One of the protocols that has been suggested for use instead of 
> > MESSAGE is BEEP. Are there any serious concerns *at this time* 
> > why BEEP would not be good eniugh for IM Sessions? 
> > 
> > -Basavaraj 
> > 
> > 
> > _______________________________________________ 
> > simple mailing list 
> > [email-masked] 
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
<http://mailman.dynamicsoft.com/mailman/listinfo/simple>  
> > 
> > 
> 
> _______________________________________________ 
> simple mailing list 
> [email-masked] 
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
<http://mailman.dynamicsoft.com/mailman/listinfo/simple>

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 18 Sep 2001 09:46:11 -0500

RE: [Simple] Implicit MESSAGE sessions revisited
I agree with #1,sortof. The best (only?) justfication for INVITE-bounded message sessions is the use of Record-Route to allow proxies that don't need to be in the route to opt out. This allows the SIP-network to be "self optimizing" for message routing. However, such SIP paths may be necessarily NOT end-to-end. For example, putting a SIP UA behind a firewall proxy will require that messages transit the firewall proxy. This is easily accomplished with record-route. Remember, all the "signaling privacy" requirements like  calling-party-ID and address-hiding apply to SIP messages. We already have mechanisms to meet those requirements for SIP traffic -- reusing them for messages is obviously functional.

I disagree with requirement #2 -- SIP messages are inherently NOT media. They are, in effect "user to user signaling". This is consistent with my earlier position on the use of phone input (DTMF) as "user to system signaling", not media.

--
Dean
  ----- Original Message ----- 
  From: Mark Watson 
  To: 'Dean Willis' ; Patil Basavaraj (NET/Dallas) ; 'ext Ben Campbell' 
  Cc: simple 
  Sent: Monday, September 17, 2001 12:02 PM
  Subject: RE: [Simple] Implicit MESSAGE sessions revisited

  Dean,

  I agree that they're independent. On the first one, I had thought that the idea of IM 'sessions' fulfilled two key requirements:

  1) I want to find my desired called party, and then exchange multiple messages with this person

  Some of these things which can happen (in the network/UEs) as a SIP message finds the desired end-user may take time/cost money/require user interaction, and I don't want to repeat them once I have found the person I want to chat to. Also, there is no guarantee that repeating the process at a later time will get me to the same end-user. So, I want to be able to do a 'session setup' and then send messages directly to the person I've found.

  Of course, I could just treat the first message as an implicit session setup, but this seems to be out of fashion.

  2) I want IM to be just another media that I can negotiate, add & remove from a session etc.

  Again, I could do something clever with Call IDs to connect a MESSAGE message with a pre-existing session etc. etc., but why should I make an exception for this one kind of media. If I do that, then no capabilities that I have now or invent in the future which are supposed to be 'media type independent', will work for IM, and I will have to be hacking the IM system constantly to keep up.

  Regards...Mark
    -----Original Message-----
    From: Dean Willis [mailto:[email-masked]]
    Sent: 17 September 2001 17:32
    To: Watson, Mark [MAIFP:EP11:EXCH]; Patil Basavaraj (NET/Dallas); 'ext Ben Campbell'
    Cc: simple
    Subject: Re: [Simple] Implicit MESSAGE sessions revisited

    --
    Dean

      ----- Original Message ----- 
      From: Mark Watson 
      To: 'Dean Willis' ; Patil Basavaraj (NET/Dallas) ; 'ext Ben Campbell' 
      Cc: simple 
      Sent: Monday, September 17, 2001 9:39 AM
      Subject: RE: [Simple] Implicit MESSAGE sessions revisited

      Dean, 

      Do you mean that you don't see the advantage of using INVITE to set up an IM 'session' (indicating this in the SDP), or just that once such a session is set up, there is no need for the 'media' to use any different protocol than that used for 'paging' ?

      I think there are a lot of reasons why IM 'sessions' set up using INVITE just like any other SIP session, make sense. I don't care much yet what the transport protocol then is for the IMs in the session.

      ...Mark