Subject: [Simple] Regarding SIPS

From: [email-masked]
Date: Mon, 18 Nov 2002 10:46:03 +0530

Hi

According to the RFC 3261,

     If the Request-URI contains a SIPS URI, or the topmost Route header
     field value (after the post processing of bullet 6) contains a
     SIPS URI, the URI placed into the Record-Route header field
     MUST be a SIPS URI. Furthermore, if the request was not
     received over TLS, the proxy MUST insert a Record-Route header
     field

How can this scencario occur.

how can it happen that request uri ( or top most route header) is sips and
request receiving on other than TLS.

Thanks in advance

With Regds
Ajay Kumar Kasam

---

From: [email-masked]
Date: Mon, 18 Nov 2002 11:05:38 +0530

Hi

Here is one scenario where we can expect this to occur.

Supposed  sip: atlanta.com , sips: bilboxi.com be pre-configured route-set at
ClientA
and let sip:[email-masked] be the request uri.
Now when the request reaches atlanta.com, after processing route header, the top
most route
header will be sips, but is received the request on other than TLS.

but why doubt is why it is MUST for atlanta.com to record-route.

waiting for ur response.

thanks in advance
ajay kumar kasam