Subject: [Simple] Re: MESSAGE sessions

From: "Petri K. Koskelainen" <[email-masked]>
Date: Fri, 7 Sep 2001 17:25:46 -0400 (EDT)

This is a good idea. 
Only problem which is not solved by TCP
is the message overhead (unnecessary SIP
headers inside a session).

However, there must be some kind of payload
headers  anyway (at least the Content-Type, Content-Lenght)
so the difference between SIP and whatever
new format is not that big.
Moreover, in low-speed links such as wireless
there will be compression anyway so message
overhead is not an issue.

Therefore it would make a lot of sense to
finalize the MESSAGE sessions draft asap
with "TCP-only" label. 
Other media formats may be defined
in addition to MESSAGE sessions,
but it would be great to have this finalized
asap.

Petri

-----------

While the use of MESSAGE-based sessions over UDP is 'out', I wonder
whether this also implies that MESSAGE over TCP is unacceptable. It
seems to satisfy the minimum requirements for any mechanism:

+ congestion and flow control
+ no size limitation for bodies
+ each message must allow a different content type
+ support of multipart MIME bodies
  for easy gatewaying to email, among other reasons
+ allow use of TLS (or similar) for security
* if possible, avoid yet more parsers
* extensible, i.e., allow additional labeling through
  headers (useful for various gateways)
* possibly make use of existing compression mechanisms
* allow multiplexing, i.e., re-use one "pipe" for multiple
  sessions (this simplifies various mixing functions, for example) 

(+ are, in my view, must-haves, while * are nice-to-have)

I'm way backlogged on email, so my apologies if this has been discussed
to death.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: "Christian Huitema" <[email-masked]>
Date: Fri, 7 Sep 2001 15:53:54 -0700

In fact, you need the equivalent of the SIP header anyhow; they are
needed if you want to write a proxy, and they are handy if you are doing
a multi-party chat.

> -----Original Message-----
> From: Petri K. Koskelainen [mailto:[email-masked]]
> Sent: Friday, September 07, 2001 2:26 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Simple] Re: MESSAGE sessions
> 
> 
> This is a good idea.
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple