Subject: [Simple] RE: [SIP] Provisional response for MESSAGE

From: Tan Ya-Ching ICM N PG U ID A 1 <[email-masked]>
Date: Mon, 1 Jul 2002 15:54:23 +0200

Hi,

I refer to the last paragraph of Section 9 of draft-ietf-sip-message-05.txt
:

   It has been suggested that provisional responses should 
   not be allowed for pager-model MESSAGE requests.  
   However, it is not possible to require special treatment for 
   MESSAGE, since many proxy servers will not be aware 
   of the MESSAGE method.  Therefore MESSAGE requests 
   will receive the same provisional response treatment as 
   any other non-INVITE method, as described in the SIP 
   specification.

The paragraph seems to imply that provisional responses are normally
generated for MESSAGE requests, which is not the case, as the SIP
specification states that provisional response SHOULD NOT be issued for a
non-INVITE request. I was actually hoping that the draft would relax the
non-method-specific guideline by allowing the generation of the 100 (Trying)
provisional response for MESSAGE by UAS and stateful proxies. The reason
being that some UAS may not respond with a final respond immediately even
though they SHOULD. For example, if a message relay receives a MESSAGE with
Expires:0, instead of sending a 202 immediately, it may (incorrectly?)
decide to check if the final user is available in order to forward the
message immediately (and even awaits the 200 OK from the final user). This
can result in a lot of retransmissions on hops where the MESSAGE has been
forwarded over UDP, causing unnecessary congestions.

Regards,
Ya-Ching

| -----Original Message-----
| From: Ben Campbell [mailto:[email-masked]]
| Sent: 29 May 2002 15:46
| To: Tan Ya-Ching ICM N PG U ID A 1
| Subject: Re: [SIP] Provisional response for MESSAGE
| 
| 
| Thanks! The first part of the paragraph was geared towards 
| 2543 proxies, 
| but I was not explicit about it. Also, a "SHOULD NOT" does not 
| effectively prohibit anything. It means you shouldn't do it 
| unless you 
| have a good, clear reason to do so. In some networks, it _might_ be 
| reasonable to violate the should not if you have a problem 
| with lots of 
| retransmissions.
| 
| I will re-word the paragraph to make it clearer in terms of 3261.
| 
| Thanks!
| 
| Ben.
| 
| Tan Ya-Ching ICM N PG U ID A 1 wrote:
| > Hi,
| > 
| > The last paragraph of draft-ietf-sip-message-04 section 9 
| states that :
| > 
| > "It has been suggested that provisional responses should not be used
| > for pager-model MESSAGE requests.  However, this is not possible, as
| > many proxy servers will not be aware of the MESSAGE method, and will
| > treat MESSAGE requests using the standard non-invite transaction.
| > Additionally, prohibiting provisional responses may in some cases
| > increase the number of retries, and actually make 
| congestion problems
| > worse.  Therefore MESSAGE requests SHOULD receive the same
| > provisional response treatment as any other non-INVITE method, as
| > described in the SIP specification."
| > 
| > But RFC 3261 (8.2.6.1 for UAS, 16.2 for stateful proxy, 
| 16.11 stateless
| > proxy) states that provisional response SHOULD NOT be issued for a
| > non-INVITE request. So this is effectively 'prohibiting provisional
| > responses' and 'may in some cases increase the number of retries'.
| > 
| > 
| > Regards,
| > Ya-Ching
| > 
| > 
| 
| 
|

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Jul 2002 19:50:50 -0400

I would like to continue this train of thought. I can see cases when a proxy might want to return a 182 Queued response to a message. For instance, a specialized proxy that
selects among alternative destinations for the message based upon presence. If none of the alternatives is Open to accept the message, it may wish to return Queued until it
can pick a destination and deliver the message.

This could be done using a B2BUA that stores the message persistently, returns 202, and then waits to deliver the message. But if it doesn't want to be stateful, the Queud
tactic is interesting, even though it requires another interim status to be returned fairly often.

	Paul