Subject: [Simple] Contact in 1xx for SUBSCRIBE

From: "Ngo, Dai (c)" <[email-masked]>
Date: Thu, 31 May 2001 20:45:33 +0000

Hi all,

When reviewing the draft-roach-sip-subscribe-notify-03.txt I notice that in
section 4.1 "New Methods"  Table 4 the Contact header is required for 1xx
response to a SUBSRIBE.

Could anyone explain to me what the 1xx here is used for? and why it's
required?

Thank you in advance.

Dai Ngo

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 31 May 2001 19:02:11 -0400

1xx for non-INVITE methods is allowed, but generally not too useful, since a
final response should come right away. For presence in particular, sending a
202 right away is the preferred behavior, so the 1xx serves no purpose.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com
  
-----Original Message-----
From: Ngo, Dai (c) [mailto:[email-masked]]
Sent: Thursday, May 31, 2001 4:46 PM
To: [email-masked]
Subject: [Simple] Contact in 1xx for SUBSCRIBE

Hi all,

---

From: Robert Sparks <[email-masked]>
Date: Fri, 1 Jun 2001 13:48:57 -0400

If you are sending a subscribe, an intervening proxy could
send you a 100 as it passes the subscribe along to squelch
your retransmits. If you are receiving a subscribe, you should
be able to get a final response out quickly, and if its within
the first T1 or so from receiving the request, skipping the 
provisional would be good. If you _know_ you're going to have a
response delayed to the latter part of the legal non-invite
transaction period, sending a 100 would be a good idea.

I can't think of why Contact is listed as a mandatory header
for 1xx responses to SUBSCRIBE.

RjS

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, May 31, 2001 6:02 PM
> To: 'Ngo, Dai (c)'; [email-masked]
> Subject: RE: [Simple] Contact in 1xx for SUBSCRIBE
> 
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 3 Jun 2001 01:23:26 -0400

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Friday, June 01, 2001 1:49 PM
> To: Jonathan Rosenberg; 'Ngo, Dai (c)'; 
> [email-masked];
> [email-masked]'
> your retransmits. 

Right; I was only considering the hop before the presence agent.

-Jonathan R.

---