Subject: [Simple] Response to Notify

From: "Ngo, Dai (c)" <[email-masked]>
Date: Fri, 27 Apr 2001 19:43:56 +0000

The following paragraph is extracted from the draft-ietf-impp-cpim-01.txt:

"Regardless, there is no application response to the notify operation (i.e.,
the application does not invoke a response operation when a notify operation
occurs)."

What does it mean? Does it mean there is no "200 OK" to be expected?

Please help.
Thanks,

Dai Ngo
WCOM

---

From: "Ngo, Dai (c)" <[email-masked]>
Date: Fri, 27 Apr 2001 21:42:35 +0000

My interpretation of the paragraph: 

which is extracted from the draft-ietf-impp-cpim-01.txt, page 10 of section
3.1 "Overview of the Presence Service", is:
that the NOTIFY operation requires no application response. The "200 OK" is
related to the SIP protocol.
 
Am I on the right track?
Thanks.
 
Dai Ngo 

-----Original Message-----
From: Ngo, Dai (c) 
Sent: Friday, April 27, 2001 2:44 PM
To: [email-masked]'
Subject: [Simple] Response to Notify

Please help. 
Thanks, 

Dai Ngo 
WCOM

---

From: Robert Sparks <[email-masked]>
Date: Fri, 27 Apr 2001 17:57:43 -0400

It means there is no explicit acknowledgement of NOTIFY in the
abstract common protocol. 
 
In SIMPLE we require an acknowledgement (because we are using
SIP and that's SIPs reliability mechanism). Some other realization of
CPIM can get that reliability through some other means.
 
We also get some other side effects out of using SIP (such as causing
subscriptions to terminate if the NOTIFY received an error response).
A gateway to some other realization of CPIM would have to map these 
ideas into their protocol.
 
RjS

-----Original Message-----
From: Ngo, Dai (c) [mailto:[email-masked]]
Sent: Friday, April 27, 2001 2:44 PM
To: [email-masked]'
Subject: [Simple] Response to Notify

Please help. 
Thanks, 

Dai Ngo 
WCOM

---

From: "Arnaud Weil" <[email-masked]>
Date: Mon, 30 Apr 2001 11:44:22 +0200

Excuse me if my question looks stupid, but I couldn't get a copy of the
SIMPLE specifications.
 
I'd like to know whether the acknowledgement that's required in SIMPLE
is required only for server/server interaction or also for client/server
one.
 
Thanks,
Arnaud Weil

 -----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: vendredi 27 avril 2001 23:58
To: [email-masked]'
Subject: RE: [Simple] Response to Notify

 
 
RjS

-----Original Message-----
From: Ngo, Dai (c) [mailto:[email-masked]]
Sent: Friday, April 27, 2001 2:44 PM
To: [email-masked]'
Subject: [Simple] Response to Notify

The following paragraph is extracted from the
draft-ietf-impp-cpim-01.txt: 

"Regardless, there is no application response to the notify operation
(i.e., the application does not invoke a response operation when a
notify operation occurs)."

Please help. 
Thanks, 

Dai Ngo 
WCOM

---

From: Robert Sparks <[email-masked]>
Date: Mon, 30 Apr 2001 09:53:51 -0400

The response is part of the basic SIP transaction. For this
case, it doesn't matter what roles the participants are serving -
the response is always required.

RjS

> From: Arnaud Weil [mailto:[email-masked]]
> Sent: Monday, April 30, 2001 4:44 AM
> To: Robert Sparks; [email-masked]

---

From: "Arnaud Weil" <[email-masked]>
Date: Mon, 30 Apr 2001 15:55:37 +0200

Thank you for your answer.

Considering that an aknowledgement response is always needed, isn't this
penalazing for devices with a low bandwith (e.g. cellular phones)?

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: lundi 30 avril 2001 15:54
To: Arnaud Weil; [email-masked]
Subject: RE: [Simple] Response to Notify

RjS

---

From: "Sean Olson (EUS)" <[email-masked]>
Date: Mon, 30 Apr 2001 09:24:46 -0500

Not really. Any good communications protocol 
includes acknowledgements. The overhead in this
case is minimal.

/sean

>Sent: Monday, April 30, 2001 8:56 AM
>_______________________________________________
>simple mailing list
>[email-masked]
>http://mailman.dynamicsoft.com/mailman/listinfo/simple
>