Subject: Re: [Simple] Can I sent a message to him/her when he/she is off line?

From: [email-masked]
Date: Wed, 15 Aug 2001 12:49:10 +0300

Should this be part of the protocol? It seems more architectural issue. The
IMPP model does not seem to indicate that receiving a message from a
presence indicates it being online.

avshalom

                    Simon                                                                                                       
                    <[email-masked]        To:     [email-masked]                                    
                    m>                                cc:                                                                       
                    Sent by:                          Subject:     [Simple] Can I sent a message to him/her when he/she is off  
                    [email-masked]        line?                                                                     
                    icsoft.com                                                                                                  

                    15/08/2001 04:25                                                                                            

I did not find any statement about this in the instant message protocol
requirement. But I enjoy sending messages to my friends while they are
off line, since it is much more convenient than composing a email.
To enable this, the messages need to be stored in the server and to be
forwarded as soon as possible when the receiptor comes to be online. It
is not difficult to implement this function but it can bring us a lot.

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 20 Aug 2001 09:27:32 -0500

I don't think it belongs in protocol. There are a lot of ways an 
application can accomplish this, if they wish. For example, you could 
set your presence info to point to a store and forward server. You might 
even put a mailto: url in your presence info when offline.

Receiving a message does not imply anything at all about your presence 
state.

> presence indicates it being online.

[snip]