Subject: [Simple] Presence : Content-Length header field value

From: Kedar Patil <[email-masked]>
Date: Wed, 17 Jul 2002 19:14:12 -0500

Hi,

I need some clarification about what Content-Length header
field value can be.

Documnet : draft-ietf-simple-presence-07.txt
Section : 8. Example message flow
Page : 18

=======================================================
When the value of the Content-Length header is "..." this means that
the value should be whatever the computed length of the body is.
=======================================================

In the first reading, this statement indicates that the string
"..." (thre dots) is a valid Content-Length header field value.
Co-incidentally, the examples that follow in that section also
seems to be supporting this interpretation :)

Please let me know, if this interpretation is correct.

thanks,
= Kedar =

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Jul 2002 11:23:16 -0500

> Section : 8. Example message flow

No, it is not. I believe the "..." is simply a documentation convention 
that means, "in a real message, there would be a real value here." That 
is, it is a rather tedious task to make sure the content-length headers 
are correct in example flows, and the editor chose not to do it.

A real message would be generated by a machine, which generally do not 
find counting octets to be quite so tedious :-)

---

From: Robert Sparks <[email-masked]>
Date: 23 Jul 2002 07:10:12 +0900

No. "..." is only an editorial convention used in the document.
A message on the wire must have an integer value equal to
the number of octets in the body. The body starts after the
null line at the end of the headers. See rfc3261 if you need
more detail.

RjS