Subject: [Simple] Multiple 200 Ok

From: Brazier Lachlan <[email-masked]>
Date: Tue, 2 Oct 2001 11:41:42 +0200

Hello,
I refer to "5.10 Handling of Forked Requests" in
"draft-ietf-simple-presence-03.txt".
.....
....Some of these may respond with a 2xx response to the SUBSCRIBE. Based on
the forking rules in SIP, only one of these
   responses is passed to the subscriber. ...
.....

As far as I remember, a proxy always passes a 2xx response upstream. Even if
a forking proxy cancels other branches on receiving a 2xx, the CANCEL can
still cross on the line with a 2xx response. A scenario would be, that one
branch returns a 202 response first, and then another branch returns a 200
Ok response.

So, if the proxy passes all 2xx message upstream, does the subscriber have
finally subscribed to more than one user? How can a subscriber realize, that
a forking proxy forked to a different user (this can happen when I am on
holiday, and I register my working collegue with my working SIP Url - and
then somebody wants to subscribe for me)?

Please excuse if I messed a discussion about this. If yes, could you please
point me there.

Thanks is advance

Lachlan Brazier

mailto:[email-masked]

---

From: "Neil Deason" <[email-masked]>
Date: Tue, 2 Oct 2001 12:35:41 +0100

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Brazier
> Lachlan
> Sent: 02 October 2001 10:42
> To: 'SIMPLE Mailinglist'
> Subject: [Simple] Multiple 200 Ok
> 
> 
> Hello,

For non-INVITEs a proxy must forward only a single response 
upstream, 2xx or otherwise. INVITEs are a special case
where all 2xxs must be forwarded. This is because of the
different reliability mechanisms at play. Non-INVITEs 
requests are retransmitted until a response is received.
Therefore only a single response can ever be transmitted
reliably. 2xxs for INVITEs have end to end reliability 
so all of them must be sent back so they can be ACK'd
by the UAC. See section 14 of bis for the full details.

Cheers,
Neil
--
Ubiquity Software Corporation, UK        http://www.ubiquity.net

> Please excuse if I messed a discussion about this. If yes, 
> could you please point me there.