Subject: RE: [Simple] SIP & Presence - Joined@Hip?

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Fri, 27 Jul 2001 11:48:00 -0400

Hi Zane,

Included in the SIP architecture is a Presence Server.
It seems likely that the Presence Server will get messages
from other sources besides SIP endpoints.  A face recognition
system might register my presence with a Presence Server.
It doesn't make sense to register the camera associated with
this capability with the SIP Registrar since it can't be
used for communications.

Dave
 > -----Original Message-----
> From: Zane Thomas [mailto:[email-masked]]
> Sent: Thursday, July 26, 2001 5:21 PM
> To: [email-masked]
> Subject: Re: [Simple] SIP & Presence - Joined@Hip?
> 
> 
> Ben,
> 
> > Well, the SIMPLE working group charter mandates presence and instant
> > messaging over SIP.
> 
> I'd like to make it clear that I'm not *arguing* that the charter is
> problematic,  however it could be the case that it just 
> doesn't work out in
> the long run.  That - correct or not - was the impression I 
> got as I read
> the past few months emails.
> 
> Well, however it works out, here's one of my favorite 
> all-time sayings:
> 
>    "The nice thing about standards is that there are so many 
> of them to
> choose from."
> 
> 
> Zane
> 
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: "Zane Thomas" <[email-masked]>
Date: Fri, 27 Jul 2001 11:06:36 -0700

RE: [Simple] SIP & Presence - Joined@Hip?Hi David,

If you're refering to SIMPLE then I agree that the effort is to introduce presence into SIP.  However I don't read the current SIP spec as providing *presence* information, what it does provide is Contact information.  Knowing how to contact someone does not tell you whether they are actually present - at least until they accept the initiation of a session; the current contact information could be a voicemail box, email, or even a fax - if I read 10.14 of SIP correctly.

  It seems likely that the Presence Server will get messages 
  from other sources besides SIP endpoints. 

That seems to me to argue that Presence is fundamentally distinct from SIP ...

  A face recognition 

For instance, a face recognition system could be used to track the presence of people in secure facilities and that has nothing to do with initiating a Session, unless an armed guard is going to be dispatched for that purpose. :-) 

Zane