Subject: RE: [Simple] IM over the signaling connection

From: "Christian Huitema" <[email-masked]>
Date: Tue, 9 Oct 2001 10:08:45 -0700

Note that my point was not to ignore the lessons of the past, but to
point out that widely deployed systems such as SMS are not going to
disappear in a day, or in a year -- they are with us for at least one or
two upgrade cycles, i.e. at least 4 to 6 years.
 
Also note that if the usage is actually a page, then a "message" is less
taxing on the infrastructure than an "invite" + the necessary session
clean-up. Let's compare:
 
1) Message: one signalling message + one response per IM.
 
2) Session: INVITE + response; ACK; BYE+response; + additional cost of
setting the message channel; IM messages on channel.
 
From a pure signalling point of view, the session mode is only
beneficial when there are at least 3 IM exchanged in a session.
 
-- Christian Huitema
 
-----Original Message-----
From: Roy, Radhika R, ALCTA [mailto:[email-masked]] 
Sent: Tuesday, October 09, 2001 6:23 AM
To: Vasilis Polychronidis; Christian Huitema
Cc: Ben Campbell; Jonathan Rosenberg; Henning Schulzrinne; Peterson,
Jon; [email-masked]; [email-masked]
Subject: RE: [Simple] IM over the signaling connection

	Hi, Vasilis:
	 
	Good that you have reminded the very important lesson from the
past.
	 
	Would please let us know your opinion what do we do in the case
of "Paging" in SIP?
	 
	Of course, we have another scheme: MESSAGE as session.
	 
	Radhika

		-----Original Message-----
		From: Vasilis Polychronidis
[mailto:[email-masked]]
		Sent: Monday, October 08, 2001 4:43 PM
		To: Christian Huitema
		Cc: Ben Campbell; Jonathan Rosenberg; Henning
Schulzrinne; Peterson, Jon; [email-masked];
[email-masked]
		Subject: Re: [Simple] IM over the signaling connection

		Christian Huitema wrote: 

			There are two points that I keep in mind in this
debate: 

			1) SMS, the messaging service of cell phones,
uses the page mode and is 
			carried at least in part over the signaling
channel.

		Correct. However Operators realized that SMS was the
wrong (was very successful financially) technical solution for
messaging. 
		Remind you that when the people designed (late 80s) SMS
they did not have any idea of how successful commercial service will be.

		That is why the next generation of multimedia messaging
is using HTTP as the transport. 
		I understand that this is a difficult point to
understand with some people in the list. 
		Let me remind you that the telephony people with more
than hundred years of experience realized in the late seventies that 
		in order to scale and have very reliable networks you
had to separate signaling from transport (initially signaling was mixed
with transport - 
		that is the current case for all the analog lines going
from home to the local switch --> DTMF) and they created SS7 and ISUP. 
		Actually people invented SIP using ISUP as their guide. 
		That was one of the initial arguments of SIP: separate
proxies from transport of user data. 
		It seems to me that certain people want to regress in
time and mix signaling and user data. 
		Let us please learn from the history and lets try not to
repeat the same mistakes. 

			2) CPIM's Message function looks a lot like the
page mode. 

			It seems that the first step forward is to
recognize this and assume 
			that we will indeed use "MESSAGE over SIP" in
the page mode for a 
			significant fraction of our exchanges. I suggest
that the first order 
			action of SIMPLE is to just nail this one, so it
be behind us. 

			The page mode has well known limitations: it
creates a lot of overhead 
			in long sessions, and it does not extend easily
to multi-party 
			operation. This is the rationale for the "IM
session" extensions, i.e. 
			IM after INVITE. However, whatever we do in the
session mode, we will 
			have to go on interworking with SMS and with
CPIM; this means that we 
			will have to bring in the session some members
who can only use the page 
			mode. Obviously, a "session of messages" makes
this very easy. 

			-- Christian Huitema 
			_______________________________________________

---

From: Ben Campbell <[email-masked]>
Date: Tue, 09 Oct 2001 14:39:45 -0500

I agree with Christian here--I really want to discourage session mode 
unless one expects a stream of messages. One shot text messages should 
normally be page mode.

Christian Huitema wrote:

> *From:* Roy, Radhika R, ALCTA [mailto:[email-masked]]
> *Sent:* Tuesday, October 09, 2001 6:23 AM
> *To:* Vasilis Polychronidis; Christian Huitema
> *Cc:* Ben Campbell; Jonathan Rosenberg; Henning Schulzrinne; Peterson, 
> *Subject:* RE: [Simple] IM over the signaling connection
> 
>     Hi, Vasilis:
> 
>      
> 
>     Good that you have reminded the very important lesson from the past.
> 
>      
> 
>     Would please let us know your opinion what do we do in the case of
>     "Paging" in SIP?
> 
>      
> 
>         *From:* Vasilis Polychronidis
>         *Sent:* Monday, October 08, 2001 4:43 PM
>         *To:* Christian Huitema
>         *Cc:* Ben Campbell; Jonathan Rosenberg; Henning Schulzrinne;
>         Peterson, Jon; [email-masked]; [email-masked]
>         *Subject:* Re: [Simple] IM over the signaling connection
> 
>         Christian Huitema wrote:
> 
>             There are two points that I keep in mind in this debate:
> 
>             1) SMS, the messaging service of cell phones, uses the page
>             mode and is
>             carried at least in part over the signaling channel.
> 
>         Correct. However Operators realized that SMS was the wrong (was
>         very successful financially) technical solution for messaging.
>         Remind you that when the people designed (late 80s) SMS they did
>         not have any idea of how successful commercial service will be.
>         That is why the next generation of multimedia messaging is using
>         HTTP as the transport.
>         I understand that this is a difficult point to understand with
>         some people in the list.
>         Let me remind you that the telephony people with more than
>         hundred years of experience realized in the late seventies that
>         in order to scale and have very reliable networks you had to
>         separate signaling from transport (initially signaling was mixed
>         with transport -
>         that is the current case for all the analog lines going from
>         home to the local switch --> DTMF) and they created SS7 and ISUP.
>         That was one of the initial arguments of SIP: separate proxies
>         from transport of user data.
>         It seems to me that certain people want to regress in time and
>         mix signaling and user data.
>         Let us please learn from the history and lets try not to repeat
>         the same mistakes.
> 
>              
> 
>             2) CPIM's Message function looks a lot like the page mode.
> 
>             It seems that the first step forward is to recognize this
>             and assume
>             that we will indeed use "MESSAGE over SIP" in the page mode
>             for a
>             significant fraction of our exchanges. I suggest that the
>             first order
>             action of SIMPLE is to just nail this one, so it be behind us.
> 
>             The page mode has well known limitations: it creates a lot
>             of overhead
>             in long sessions, and it does not extend easily to multi-party
>             operation. This is the rationale for the "IM session"
>             extensions, i.e.
>             IM after INVITE. However, whatever we do in the session
>             mode, we will
>             have to go on interworking with SMS and with CPIM; this
>             means that we
>             will have to bring in the session some members who can only
>             use the page
>             mode. Obviously, a "session of messages" makes this very easy.
> 
>             -- Christian Huitema

---

From: Michael Hammer <[email-masked]>
Date: Tue, 09 Oct 2001 16:36:01 -0400

Ben,

Whether a message appears as a single IM or a stream of IM right now 
appears to be more of an implementation detail, absent a maximum IM 
size.  (Did I miss that definition?) Given that an application may send a 1 
Mbyte message as:

1) one 1 M IM,
2) two 512 K IMs,
3) four 256 K IMs,
...
n-2) 256 4 K IMs
n-1) 512 2 K IMs
n) 1024 1K IMs

Does IM size count at all or just message and response counts?
Do we care that SIP may need to segment to some max message size, say 1500 
bytes?
Do we care that a lower layer may need to segment the message prior to 
transmission?
Do we care if the IP layer has to fragment during transmission?
Are there some unstated assumptions in your calculation?

Mike

At 02:39 PM 10/9/2001 -0500, Ben Campbell wrote:
>simple mailing list
>http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Vasilis Polychronidis <[email-masked]>
Date: Tue, 09 Oct 2001 13:33:22 -0700

Christian Huitema wrote:

> disappear in a day, or in a year -- they are with us for at least one
> or two upgrade cycles, i.e. at least 4 to 6 years.

I agree but I do not understand what IM has to do with SMS.
If you referring on how to interface a SIMPLE IM system with SMS this
will be accomplished via a gateway and on the one
side of the GW you will speak SMS and the other side SIMPLE (session or
page mode).
If you mean that having the page mode simplifies the GW function I agree
but I do not see this as a big driver for choosing page mode over
session mode.
Anyway I am not against the page mode (I promised not to talk about it
anymore) and my understanding is that we agreed to have a
session mode too. I am happy if we provide both options.

> Also note that if the usage is actually a page, then a "message" is
> less taxing on the infrastructure than an "invite" + the necessary
> session clean-up. Let's compare:1) Message: one signalling message +
> one response per IM.2) Session: INVITE + response; ACK; BYE+response;
> + additional cost of setting the message channel; IM messages on
> channel.From a pure signalling point of view, the session mode is only
> beneficial when there are at least 3 IM exchanged in a session.--
> Christian Huitema-----Original Message-----
>      Hi, Vasilis:Good that you have reminded the very important
>      lesson from the past.Would please let us know your opinion
>      what do we do in the case of "Paging" in SIP?Of course, we
>      have another scheme: MESSAGE as session.Radhika
>
>           Correct. However Operators realized that SMS was
>           the wrong (was very successful financially)
>           technical solution for messaging.
>           Remind you that when the people designed (late
>           80s) SMS they did not have any idea of how
>           successful commercial service will be.
>           That is why the next generation of multimedia
>           messaging is using HTTP as the transport.
>           Let me remind you that the telephony people with
>           more than hundred years of experience realized in
>           the late seventies that
>           in order to scale and have very reliable networks
>           you had to separate signaling from transport
>           (initially signaling was mixed with transport -
>           that is the current case for all the analog lines
>           going from home to the local switch --> DTMF) and
>           they created SS7 and ISUP.
>           That was one of the initial arguments of SIP:
>           separate proxies from transport of user data.
>           It seems to me that certain people want to regress
>           in time and mix signaling and user data.
>           Let us please learn from the history and lets try
>           not to repeat the same mistakes.
>
>          >
>          >

---

From: Ben Campbell <[email-masked]>
Date: Wed, 24 Oct 2001 17:09:48 -0500

I think I should have said "series" of messages, rather than "stream" of 
messages, because I think I conveyed the wrong idea. The current draft 
assumes a one to one correspondence between MESSAGE requests and IMs. It 
does mention that if you want to send something larger than the maximum 
UDP size, you should use TCP.

If we are talking about MESSAGE as a file transfer protocol, I think 
this would be better modeled using an INVITE initiated file transfer 
session of some sort.

Michael Hammer wrote:

> size.  (Did I miss that definition?) Given that an application may send 
> a 1 Mbyte message as:
> 
> 1) one 1 M IM,
> 2) two 512 K IMs,
> 3) four 256 K IMs,
> ...
> n-2) 256 4 K IMs
> n-1) 512 2 K IMs
> n) 1024 1K IMs
> 
> Do we care that SIP may need to segment to some max message size, say 
> 1500 bytes?
>>> session clean-up. Let's compare:
>>>
>>> 2) Session: INVITE + response; ACK; BYE+response; + additional cost 
>>> of setting the message channel; IM messages on channel.
>>>