Subject: RE: [Simple] Sessions of MESSAGEs

From: "Robert Brown" <[email-masked]>
Date: Thu, 6 Sep 2001 11:14:22 -0700

> I completely agree that SIP is great for IM (based on my exp.), but
when the
> messages start to use the signal path for back and forth sessions of
> messages, it seems futile to use SIP?
> 

Joshua, I'm clear on how you drew the conclusion of futility here?

> I believe you could argue that the sessions of messages should use the
> signal path when necessary, but e2e in other cases.
> 

Signaling can be e2e.  There is no reason to use the same path as the
INVITE unless a route has been recorded.

---

From: "Dean Willis" <[email-masked]>
Date: Fri, 7 Sep 2001 00:55:38 -0500

Absolutely correct. There may, of course, be a reason to Record-Route, and
"hiding" or "firewall proxies" generally do so. But in the absence of a
Route header, signaling transactions after the initial INVITE sequence are
end-to-end anyhow.

--
Dean

----- Original Message -----
From: "Robert Brown" <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, September 06, 2001 1:14 PM
Subject: RE: [Simple] Sessions of MESSAGEs

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>
>