Subject: Re: [Simple] Status summary

From: "Avshalom Houri" <[email-masked]>
Date: Tue, 14 May 2002 11:20:36 +0300

It seems that there is a place for another state - Do Not Disturb (DND).
DND means that although I am online messages sent to me will not reach me.
Thus, the blocking of the messages can be done in the client of the 
originator.

So the states that we will have are:
* Free (Available)
* Busy (Open but I am busy)
* DND (Closed for communication)
* Away, for an
    indeterminate amount of time (used also by automatic away sensed by 
the client)
    short time (set manually)
    long time (set manually)

Avshalom Houri
Presence and Instant Messaging Architect
Lotus Sametime, IBM Software Group

Henning Schulzrinne <[email-masked]>
Sent by: [email-masked]
14/05/2002 03:52
Please respond to Henning Schulzrinne

        To:        Tony Hansen <[email-masked]>
        cc:        [email-masked]
        Subject:        Re: [Simple] Status summary

> Your "on the phone" is just another version of Busy.

Agreed; the only reason I kept it separate is that a SIP device may know 
this condition specifically. It might be useful to have a two-level 
hierarchy of labels, as in busy.phone and busy.meeting.

> 
> I see the following set:
> 
>     Free (Available)
>     Busy
>     Away, for an
>         indeterminate amount of time
>         short time
>         long time
> 
> Each could also be annotated with additional text.
> 
> Busy means "I'm doing stuff, so may not respond right away. Annotations 
> for Busy would be things such as "On the phone" and "In a meeting".
> 
> The time based settings are purely subjective values, not concrete 
> values. The indeterminate time would be appropriate for use by an idle 
> timer.

It would be nice to be able to provide an explicit time of return. With 
calendar integration, this wouldn't be too hard. Obviously, this would 
be optional.

> 
>     Tony Hansen
>     [email-masked]
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Michael Hammer <[email-masked]>
Date: Tue, 14 May 2002 10:38:17 -0400

Avshalom,

So what is the difference between a busy and a DND?  Some of this
seems to boil down to the explicit not available (Busy, DND) and the
implicit (Away).  So essentially there is:

Closed-permanent (Explicit:  De-registration)

Closed-temporary (Explicit:  Busy, DND, Out to lunch, etc.)

Open-Active      (Implicit:  Actively
using)

Open-Inactive    (Implicit:  Away so Maybe).

One last comment:  Since some of this may reveal presence, it may be
a good idea to recommend a default that must be manually over-ridden to
allow that type of information to be sent (protect privacy).

Mike

At 11:20 AM 5/14/2002 +0300, Avshalom Houri wrote:

It seems that there is a
place for another state - Do Not Disturb (DND).

DND means that although I am online messages sent to
me will not reach me.

Thus, the blocking of the messages can be done in the
client of the originator.

So the states that we will have
are:

* Free (Available)

* Away, for an

indeterminate amount of time (used also by automatic away
sensed by the client)

long time (set manually)

Avshalom Houri

Presence and Instant Messaging
Architect

Lotus Sametime, IBM Software
Group

Henning Schulzrinne
<[email-masked]>

Sent by:
[email-masked]

14/05/2002 03:52

Please respond to Henning
Schulzrinne

To:        Tony Hansen
<[email-masked]>

cc:

Subject:        Re: [Simple] Status
summary

be optional.

simple mailing list

---

From: Michael Hammer <[email-masked]>
Date: Tue, 14 May 2002 10:42:04 -0400

Try again hitting the right button.

Avshalom,

So what is the difference between a busy and a DND?  Some of this seems to 
boil down to the explicit not available (Busy, DND) and the implicit 
(Away).  So essentially there is:

Closed-permanent (Explicit:  De-registration)
Closed-temporary (Explicit:  Busy, DND, Out to lunch, etc.)
Open-Active      (Implicit:  Actively using)
Open-Inactive    (Implicit:  Away so Maybe).

One last comment:  Since some of this may reveal presence, it may be a good 
idea to recommend a default that must be manually over-ridden to allow that 
type of information to be sent (protect privacy).

Mike

---

From: "Ben Campbell" <[email-masked]>
Date: Mon, 20 May 2002 15:09:18 -0500

I would suggest that DnD does not necessarily mean that I will not receive a
message. It means I am asking you not to send me a message. What happens if
you send one anyway is entirely a matter of my local policy.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Avshalom Houri
Sent: Tuesday, May 14, 2002 3:21 AM
To: [email-masked]; Henning Schulzrinne
Subject: Re: [Simple] Status summary

   indeterminate amount of time (used also by automatic away sensed by the
client)

Avshalom Houri