Subject: [Simple] Possible IM Message solution??

From: a c <[email-masked]>
Date: Mon, 8 Oct 2001 13:51:34 -0700 (PDT)

It is something like the IN call model where the
Service Logic Layer is instructing the SSP to do
certain things. With SIP, you would like to have all
the features implemented at the endpoints but it is
not always possible without compromising other things.

alex

hello Radhika,

>(I hope that you are NOT proposing routing of media
via network layer devices like routers.)

no. This is an application server which processes 
IM messages and routes them to their endpoints. 
It cannot be used for voice due to the realtime
constraints. But it can definetly be used for 
IM traffic. It can do much more than  just 
passing traffic. For example : language 
translation,  calea, etc..

The only requirement is that it talks to 
the proxy. The proxy can instruct the 
application server to implement a certain feature 
per call. 

other advantages:

- drastically cuts down on header tags (no header 
  tags. Why do we need them when signalling 
  is taking care of it). 
- If no headers in the message, then it is easier 
  to convert to other protocols (e.g. cpim). No 
  parsing of headers for each message
- congestion control (app server initiated 
  congestion control)
- capability to do end to end or thru server

Addresses Brian Rosen's 4 variables:

        Direct UA-to-UA routing - can do both
        TCP transport - / udp
        SIP Headers - not necessary
        cpim Body - no problem

alex

__________________________________________________
Do You Yahoo!?
NEW from Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Tue, 9 Oct 2001 08:47:36 -0400

Hi, Alex:

The way I understand your proposal is as follows:

1. Routing information of the MESSAGE signaling is pushed back to SDP.

2. Based on the routing information of the MESSAGE signaling path, one needs
to find out the media routing path over the message servers.

The question is: Why can we not generalize it so that we can see the big
picture where this proposal will lead us analyzing all implications? For
example, there can be multiple proxies and multiple media servers. It will
not be used for point-to-point communications, but will also be for
multipoint communications. Why can this principle not be used for other
media as well? Will this create conflicts with the already established
notions in SDP?

Radhika

-----Original Message-----
From: a c [mailto:[email-masked]]
Sent: Monday, October 08, 2001 4:43 PM
To: [email-masked]
Subject: [Simple] Possible IM Message solution?? 

hello Radhika,

other advantages:

alex

__________________________________________________
Do You Yahoo!?
NEW from Yahoo! GeoCities - quick and easy web site hosting, just
$8.95/month.
http://geocities.yahoo.com/ps/info1
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple