Subject: [Simple] Contact header Usage in subsequent MESSAGE Requests

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 14 Jun 2001 12:15:19 +0300

Hi,

Section 6.2 or draft-ietf-simple-im-00.txt specifies that a MESSAGE request
MUST contain a Contact header.
Section 6.7 does not specify how this Contact should be used.
The example is section 8 simply says that user2 can send the IM directly to
the address in the Contact header send in the initial MESSAGE request.

The use of the Contact header in subsequent requests is not clear. Can I
conclude that the use of the Contact header is only a MAY?

Regards,
Hisham Khartabil
Hotsip Finland
www.hotsip.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 14 Jun 2001 05:27:45 -0400

In the older MESSAGE approach (where MESSAGE sort-of was INVITE), the
Contact header had the same semantics as in INVITE - it would be used to set
up the route for subsequent messages in the same IM session.

However, in the current proposal, whereby INVITE establishes the session,
the Contact in MESSAGE no longer serves a purpose.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com
  
-----Original Message-----
From: Hisham Khartabil [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 5:15 AM
To: [email-masked]
Subject: [Simple] Contact header Usage in subsequent MESSAGE Requests

Hi,

Regards,
Hisham Khartabil
Hotsip Finland
www.hotsip.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 14 Jun 2001 10:43:07 -0400

-----Original Message-----
From: Sriram Parameswar [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 10:38 AM
To: 'Jonathan Rosenberg'; 'Hisham Khartabil'; [email-masked]
Subject: RE: [Simple] Contact header Usage in subsequent MESSAGE Requests

>Jonathan - you refer to a new approach using INVITE rather than MESSAGE.
Could 
>you please point me to the latest version the document that reflects this? 

There is none yet. It has been discussed and (I think) agreed upon only
recently on the list. The email which explains the idea can be found at:

http://mailman.dynamicsoft.com/pipermail/simple/2001-March/000119.html

-Jonathan R. 

---

---

From: Robert Sparks <[email-masked]>
Date: Thu, 14 Jun 2001 10:49:41 -0400

The draft is being revised and will be out in the next few weeks.
RjS

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, June 14, 2001 9:43 AM
> To: 'Sriram Parameswar'; 'Hisham Khartabil';
> [email-masked]
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: Mayerhofer Andreas A <[email-masked]>
Date: Mon, 18 Jun 2001 11:07:10 +0200

Hello,

in this email there is a link for some slides,
which explains the idea.
But this link doesn´t work.
Where can i find these slides?

Mayerhofer Andreas

> -----Ursprüngliche Nachricht-----
> Von: Jonathan Rosenberg [mailto:[email-masked]]
> Gesendet am: Donnerstag, 14. Juni 2001 16:43
> An: 'Sriram Parameswar'; 'Hisham Khartabil';
> Betreff: RE: [Simple] Contact header Usage in subsequent MESSAGE
> Requests
> 
> 
> 
>   

-Jonathan R. 

---

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Jun 2001 17:06:17 -0400

> From: Mayerhofer Andreas A [mailto:[email-masked]]
> Sent: Monday, June 18, 2001 5:07 AM
> To: 'Jonathan Rosenberg'
> Cc: [email-masked]'
> Subject: AW: [Simple] Contact header Usage in subsequent MESSAGE
> Requests
> 
> 
> Hello,
> 

Sorry, my web site moved since that email was posted. The slides are at:

http://www.jdrosen.net/papers/simple_open_mar01.ppt

-Jonathan R.

---