Subject: [Fwd: Re: [Simple] Implicit MESSAGE sessions revisited]

From: Paul Kyzivat <[email-masked]>
Date: Wed, 19 Sep 2001 18:07:58 -0400

Dean,

> Joe sends a message to Ann.> Ann forwards to Bob.> Bob replies to Joe.
This reply carries the sessionID from Joe's original message.> Joe's app
realizes his session is now with Bob and sends further messages in the
session to Bob.> Joe and Bob exchange many messages in this session.>
Ann has a life.

Bunch of problems with this scenario:

1) how does Bob reply to Joe? Does Bob's IM client offer a reply
function that extracts Joe's address? Or does Bob manually initiate a
new IM session with Bob?

If the former, then clearly the IM protocol must have a more or less
complete call control mechanism of its own, duplicating what is in SIP.

If the latter, then how does the sessionID get into the reply?
Presumably Bob would have to type it in. Not likely in the real world.

2) How is this case distinguished from one where Ann wants to conference
Bob in? Ann may be acting as a local mixer, passing Joe's messages on to
Bob after reading them. In your scenario, this would look exactly the
same to Bob, but the action he should take is different - he should
reply to Ann, so that she can see the reply and relay it back to Joe.

Your proposed solution can't deal with the multiple possibilities. There
are many useful topologies that can be established using SIP. Do you
propose to have SIMPLE reinvent all of them independently?

    Paul

-------- Original Message --------
   Subject: Re: [Simple] Implicit MESSAGE sessions revisited
      Date: Wed, 19 Sep 2001 14:29:34 -0500
      From: "Dean Willis" <[email-masked]>
        To: "Mark Watson" <[email-masked]>,"simple"
            <[email-masked]>
References: <[email-masked]>

 Assume page-mode messages have a "sessionID" in their payload. Joe
sends a message to Ann.Ann forwards to Bob.Bob replies to Joe. This
reply carries the sessionID from Joe's original message.Joe's app
realizes his session is now with Bob and sends further messages in the
session to Bob.Joe and Bob exchange many messages in this session.Ann
has a life. -_
Dean

     ----- Original Message -----
     From: Mark Watson
     To: 'Dean Willis' ; simple
     Sent: Tuesday, September 18, 2001 12:59 PM
     Subject: RE: [Simple] Implicit MESSAGE sessions revisited
      (1), it's not just a question of optimising the message
     routing, it's also that in routing the initial INVITE I may
     use up certain resources or require user intervention, and I
     don't want to repeat all that for every message in the 'chat
     session'.
     For example, Ann has all incoming sessions presented to their
     SIP client but can hit a key to forward them to her assistant
     Bob. If it's an IM chat session, and Bob gets into a long
     conversation, Ann does not want to see every message, and have
     to hit a key to forward it.Anns client could forward
     'subsequent' messages automatically, but then Ann's client is
     implicitly taking on a notion of a 'session' and we are into
     the implicit session setup debate again - how does it detect
     when this session has ended and a new one started ? What
     happens if Ann turns her client off before Bob has finished
     chatting ? Ann could instruct her proxy to forwared SIP
     requests to Bob, but perhaps she doesn't want to. Perhaps she
     wants new calls to go to her mobile, but the rest of Bob's
     chat session to continue unaffected.So it's not just a message
     routing optimisation, there are other resources being
     optimised too (Ann's time).(2) SIP messages are not media,
     sure, but Instant Messages are. Instant Messages are not 'user
     to user signalling' either, because they are not signalling -
     they are a communication between the human end-users, not
     between the equipment facilitating that communication (which
     is how I would characterise 'signalling' here). So perhaps SIP
     messages should not be used to carry Instant Messages - but
     this is a different point entirely....Mark

          -----Original Message-----
          From: Dean Willis [mailto:[email-masked]]

          Sent: 18 September 2001 15:46
          To: simple
          Subject: Re: [Simple] Implicit MESSAGE sessions
          revisited

           I agree with #1,sortof. The best (only?)
          justfication for INVITE-bounded message sessions is
          the use of Record-Route to allow proxies that don't
          need to be in the route to opt out. This allows the
          SIP-network to be "self optimizing" for message
          routing. However, such SIP paths may be necessarily
          NOT end-to-end. For example, putting a SIP UA behind
          a firewall proxy will require that messages transit
          the firewall proxy. This is easily accomplished with
          record-route. Remember, all the "signaling privacy"
          requirements like  calling-party-ID and
          address-hiding apply to SIP messages. We already
          have mechanisms to meet those requirements for SIP
          traffic -- reusing them for messages is obviously
          functional. I disagree with requirement #2 -- SIP
          messages are inherently NOT media. They are, in
          effect "user to user signaling". This is consistent
          with my earlier position on the use of phone input
          (DTMF) as "user to system signaling", not media. --
          Dean

               ----- Original Message -----
               From: Mark Watson
               To: 'Dean Willis' ; Patil Basavaraj
               (NET/Dallas) ; 'ext Ben Campbell'
               Cc: simple
               Sent: Monday, September 17, 2001 12:02 PM
               Subject: RE: [Simple] Implicit MESSAGE
               sessions revisited
                Dean,I agree that they're independent. On
               the first one, I had thought that the idea
               of IM 'sessions' fulfilled two key
               requirements:1) I want to find my desired
               called party, and then exchange multiple
               messages with this personSome of these
               things which can happen (in the
               network/UEs) as a SIP message finds the
               desired end-user may take time/cost
               money/require user interaction, and I
               don't want to repeat them once I have
               found the person I want to chat to. Also,
               there is no guarantee that repeating the
               process at a later time will get me to the
               same end-user. So, I want to be able to do
               a 'session setup' and then send messages
               directly to the person I've found.Of
               course, I could just treat the first
               message as an implicit session setup, but
               this seems to be out of fashion.2) I want
               IM to be just another media that I can
               negotiate, add & remove from a session
               etc.Again, I could do something clever
               with Call IDs to connect a MESSAGE message
               with a pre-existing session etc. etc., but
               why should I make an exception for this
               one kind of media. If I do that, then no
               capabilities that I have now or invent in
               the future which are supposed to be 'media
               type independent', will work for IM, and I
               will have to be hacking the IM system
               constantly to keep up.Did you disagree
               with these requirements, or just with the
               implementation ?Regards...Mark

                    -----Original Message-----
                    From: Dean Willis
                    [mailto:[email-masked]]

                    Sent: 17 September 2001 17:32
                    To: Watson, Mark
                    [MAIFP:EP11:EXCH]; Patil
                    Basavaraj (NET/Dallas); 'ext Ben
                    Campbell'
                    Cc: simple
                    Subject: Re: [Simple] Implicit
                    MESSAGE sessions revisited

                    Both, actually. I believe the
                    issues are independent. --
                    Dean

                         ----- Original Message
                         -----
                         From: Mark Watson
                         To: 'Dean Willis' ;
                         Patil Basavaraj
                         (NET/Dallas) ; 'ext
                         Ben Campbell'
                         Cc: simple
                         Sent: Monday,
                         September 17, 2001
                         9:39 AM
                         Subject: RE: [Simple]
                         Implicit MESSAGE
                         sessions revisited
                          Dean,

                         Do you mean that you
                         don't see the
                         advantage of using
                         INVITE to set up an IM
                         'session' (indicating
                         this in the SDP), or
                         just that once such a
                         session is set up,
                         there is no need for
                         the 'media' to use any
                         different protocol
                         than that used for
                         'paging' ?

                         I think there are a
                         lot of reasons why IM
                         'sessions' set up
                         using INVITE just like
                         any other SIP session,
                         make sense. I don't
                         care much yet what the
                         transport protocol
                         then is for the IMs in
                         the session.

                         Sorry if this is
                         covering old ground.

                         ...Mark

                         > -----Original
                         Message-----
                         > From: Dean Willis
                         [mailto:[email-masked]]

                         > Sent: 15 September
                         2001 05:31
                         > To: Patil Basavaraj
                         (NET/Dallas); 'ext Ben
                         Campbell'
                         > Cc: simple
                         > Subject: Re:
                         [Simple] Implicit
                         MESSAGE sessions
                         revisited
                         > Just as MESSAGE for
                         sessions has all the
                         wasted overhead of
                         > headers and
                         > routing mechanisms
                         designed to find users
                         and traverse
                         > firewalls (assuming
                         > you think this is a
                         waste), so does BEEP.
                         > I personally have
                         yet to see the need
                         for message sessions
                         as
                         > a specialized
                         > transport.
                         > I think "pager"
                         messages carrying a
                         session-ID and
                         sequence number can
                         > provide the same
                         user experience.
                         > --
                         > dean
                         > ----- Original
                         Message -----
                         > From: "Patil
                         Basavaraj
                         (NET/Dallas)"
                         <[email-masked]>

                         > To: "'ext Ben
                         Campbell'"
                         <[email-masked]>

                         > Cc:
                         <[email-masked]>

                         > Sent: Friday,
                         September 14, 2001
                         1:07 PM
                         > Subject: RE:
                         [Simple] Implicit
                         MESSAGE sessions
                         revisited
                         > > One of the
                         protocols that has
                         been suggested for use
                         instead of
                         > > MESSAGE is BEEP.
                         Are there any serious
                         concerns *at this
                         time*
                         > > why BEEP would not
                         be good eniugh for IM
                         Sessions?
                         > > -Basavaraj
                         _______________________________________________

                         > > simple mailing
                         list
                         [email-masked]

                         http://mailman.dynamicsoft.com/mailman/listinfo/simple

                         _______________________________________________

                         > simple mailing list
                         [email-masked]

                         http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Dean Willis" <[email-masked]>
Date: Fri, 21 Sep 2001 10:34:55 -0500

Response:

1) Bob's IM client responds to the address indicated in the "From:" field of the received message.
2) Ann creates a new "paging conference session", understood only on her system which is doing the mixing/replicating. The message to Bob has a "From:" of "ann" and ann's application handles the replicating to Joe.

--
Dean

  ----- Original Message ----- 
  From: Paul Kyzivat 
  To: simple 
  Sent: Wednesday, September 19, 2001 5:07 PM
  Subject: [Fwd: Re: [Simple] Implicit MESSAGE sessions revisited]

  Dean, 
  > Joe sends a message to Ann.> Ann forwards to Bob.> Bob replies to Joe. This reply carries the sessionID from Joe's original message.> Joe's app realizes his session is now with Bob and sends further messages in the session to Bob.> Joe and Bob exchange many messages in this session.> Ann has a life. 

  1) how does Bob reply to Joe? Does Bob's IM client offer a reply function that extracts Joe's address? Or does Bob manually initiate a new IM session with Bob? 

  If the former, then clearly the IM protocol must have a more or less complete call control mechanism of its own, duplicating what is in SIP. 

  If the latter, then how does the sessionID get into the reply? Presumably Bob would have to type it in. Not likely in the real world. 

  2) How is this case distinguished from one where Ann wants to conference Bob in? Ann may be acting as a local mixer, passing Joe's messages on to Bob after reading them. In your scenario, this would look exactly the same to Bob, but the action he should take is different - he should reply to Ann, so that she can see the reply and relay it back to Joe. 

  Your proposed solution can't deal with the multiple possibilities. There are many useful topologies that can be established using SIP. Do you propose to have SIMPLE reinvent all of them independently? 

      Paul 

  -------- Original Message -------- Subject:  Re: [Simple] Implicit MESSAGE sessions revisited 
        Date:  Wed, 19 Sep 2001 14:29:34 -0500 
        From:  "Dean Willis" <[email-masked]> 
        To:  "Mark Watson" <[email-masked]>,"simple" <[email-masked]> 
        References:  <[email-masked]> 

   Assume page-mode messages have a "sessionID" in their payload. Joe sends a message to Ann.Ann forwards to Bob.Bob replies to Joe. This reply carries the sessionID from Joe's original message.Joe's app realizes his session is now with Bob and sends further messages in the session to Bob.Joe and Bob exchange many messages in this session.Ann has a life. -_ 
  Dean  

    ----- Original Message -----
    From: Mark Watson
    To: 'Dean Willis' ; simple
    Sent: Tuesday, September 18, 2001 12:59 PM
    Subject: RE: [Simple] Implicit MESSAGE sessions revisited
     (1), it's not just a question of optimising the message routing, it's also that in routing the initial INVITE I may use up certain resources or require user intervention, and I don't want to repeat all that for every message in the 'chat session'. 
    For example, Ann has all incoming sessions presented to their SIP client but can hit a key to forward them to her assistant Bob. If it's an IM chat session, and Bob gets into a long conversation, Ann does not want to see every message, and have to hit a key to forward it.Anns client could forward 'subsequent' messages automatically, but then Ann's client is implicitly taking on a notion of a 'session' and we are into the implicit session setup debate again - how does it detect when this session has ended and a new one started ? What happens if Ann turns her client off before Bob has finished chatting ? Ann could instruct her proxy to forwared SIP requests to Bob, but perhaps she doesn't want to. Perhaps she wants new calls to go to her mobile, but the rest of Bob's chat session to continue unaffected.So it's not just a message routing optimisation, there are other resources being optimised too (Ann's time).(2) SIP messages are not media, sure, but Instant Messages are. Instant Messages are not 'user to user signalling' either, because they are not signalling - they are a communication between the human end-users, not between the equipment facilitating that communication (which is how I would characterise 'signalling' here). So perhaps SIP messages should not be used to carry Instant Messages - but this is a different point entirely....Mark 
      -----Original Message----- 
      From: Dean Willis [mailto:[email-masked]] 
      Sent: 18 September 2001 15:46 
      To: simple 
      Subject: Re: [Simple] Implicit MESSAGE sessions revisited 
       
       I agree with #1,sortof. The best (only?) justfication for INVITE-bounded message sessions is the use of Record-Route to allow proxies that don't need to be in the route to opt out. This allows the SIP-network to be "self optimizing" for message routing. However, such SIP paths may be necessarily NOT end-to-end. For example, putting a SIP UA behind a firewall proxy will require that messages transit the firewall proxy. This is easily accomplished with record-route. Remember, all the "signaling privacy" requirements like  calling-party-ID and address-hiding apply to SIP messages. We already have mechanisms to meet those requirements for SIP traffic -- reusing them for messages is obviously functional. I disagree with requirement #2 -- SIP messages are inherently NOT media. They are, in effect "user to user signaling". This is consistent with my earlier position on the use of phone input (DTMF) as "user to system signaling", not media. -- 
      Dean 
        ----- Original Message -----
        From: Mark Watson
        To: 'Dean Willis' ; Patil Basavaraj (NET/Dallas) ; 'ext Ben Campbell'
        Cc: simple
        Sent: Monday, September 17, 2001 12:02 PM
        Subject: RE: [Simple] Implicit MESSAGE sessions revisited
         Dean,I agree that they're independent. On the first one, I had thought that the idea of IM 'sessions' fulfilled two key requirements:1) I want to find my desired called party, and then exchange multiple messages with this personSome of these things which can happen (in the network/UEs) as a SIP message finds the desired end-user may take time/cost money/require user interaction, and I don't want to repeat them once I have found the person I want to chat to. Also, there is no guarantee that repeating the process at a later time will get me to the same end-user. So, I want to be able to do a 'session setup' and then send messages directly to the person I've found.Of course, I could just treat the first message as an implicit session setup, but this seems to be out of fashion.2) I want IM to be just another media that I can negotiate, add & remove from a session etc.Again, I could do something clever with Call IDs to connect a MESSAGE message with a pre-existing session etc. etc., but why should I make an exception for this one kind of media. If I do that, then no capabilities that I have now or invent in the future which are supposed to be 'media type independent', will work for IM, and I will have to be hacking the IM system constantly to keep up.Did you disagree with these requirements, or just with the implementation ?Regards...Mark 
          -----Original Message----- 
          From: Dean Willis [mailto:[email-masked]] 
          Sent: 17 September 2001 17:32 
          To: Watson, Mark [MAIFP:EP11:EXCH]; Patil Basavaraj (NET/Dallas); 'ext Ben Campbell' 
          Cc: simple 
          Subject: Re: [Simple] Implicit MESSAGE sessions revisited 
           
          Both, actually. I believe the issues are independent. -- 
          Dean  
            ----- Original Message -----
            From: Mark Watson
            To: 'Dean Willis' ; Patil Basavaraj (NET/Dallas) ; 'ext Ben Campbell'
            Cc: simple
            Sent: Monday, September 17, 2001 9:39 AM
            Subject: RE: [Simple] Implicit MESSAGE sessions revisited
             Dean, 
            Do you mean that you don't see the advantage of using INVITE to set up an IM 'session' (indicating this in the SDP), or just that once such a session is set up, there is no need for the 'media' to use any different protocol than that used for 'paging' ? 

            I think there are a lot of reasons why IM 'sessions' set up using INVITE just like any other SIP session, make sense. I don't care much yet what the transport protocol then is for the IMs in the session. 

            Sorry if this is covering old ground. 

            ...Mark 

            > Sent: 15 September 2001 05:31 
            > To: Patil Basavaraj (NET/Dallas); 'ext Ben Campbell' 
            > Cc: simple 
            > Just as MESSAGE for sessions has all the wasted overhead of 
            > headers and 
            > routing mechanisms designed to find users and traverse 
            > firewalls (assuming 
            > you think this is a waste), so does BEEP. 
            > 
            > I personally have yet to see the need for message sessions as 
            > a specialized 
            > transport. 
            > 
            > I think "pager" messages carrying a session-ID and sequence number can 
            > provide the same user experience. 
            > 
            > -- 
            > dean 
            > 
            > 
            > From: "Patil Basavaraj (NET/Dallas)" <[email-masked]> 
            > To: "'ext Ben Campbell'" <[email-masked]> 
            > Cc: <[email-masked]> 
            > Sent: Friday, September 14, 2001 1:07 PM 
            > > One of the protocols that has been suggested for use instead of 
            > > MESSAGE is BEEP. Are there any serious concerns *at this time* 
            > > why BEEP would not be good eniugh for IM Sessions? 
            > > 
            > > -Basavaraj 
            > > 
            > >