Subject: RE: [Simple] authorization for presence

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 7 Jun 2001 01:37:23 -0400

> -----Original Message-----
> From: Theodore Havinis [mailto:[email-masked]]
> Sent: Wednesday, June 06, 2001 12:02 AM
> To: Jonathan Rosenberg; [email-masked]
> Subject: RE: [Simple] authorization for presence
> 
> 
> 
> As I am trying to understand better the proposed solution I 
> am confused as
> to whether
> the automatic notification to all watchers as soon as a new 
> watcher tries to
> subscribe to the event is just *how a buddy list would work* 
> or whether its
> a *a generic requirement* when dealing with subscriptions to events.

The set of folks that get notified (because they are allowed to subscribe)
when my watcherinfo changes (because someone subscribed to my presence), is
a matter of local policy. Typically, I expect that local policy would allow
only one entity to subscribe to changes in my watcherinfo, and that would be
me.

> 
> I assume, for protecting the presentity's privacy, it would
> be enough only for the presentity to be notified everytime a 
> new watcher
> requests subscription to the presentity, unless the 
> presentity explicitly
> allows the presence server to notify every (or some of them) 
> watcher about
> which other watcher is in the list.

Right; as I said, its a matter of policy. Remember, there are watchers at
two levels here. There are the set of folks who subscribed to my presence.
Then, there are the set of folks who subscribed to changes in my
watcherinfo. That is, the set of folks that want to get notified when
someone tries to subscribe to my presence. These two sets of watchers are
not the same. 

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Theodore Havinis" <[email-masked]>
Date: Tue, 12 Jun 2001 10:55:24 -0700

AS>-----Original Message-----
AS>From: [email-masked]
AS>[mailto:[email-masked]]On Behalf Of Jonathan
AS>Rosenberg
AS>Sent: Wednesday, June 06, 2001 10:37 PM
AS>To: 'Theodore Havinis'; [email-masked]
AS>Subject: RE: [Simple] authorization for presence
AS>
AS>
AS>
AS>
AS>
AS>
AS>> -----Original Message-----
AS>> From: Theodore Havinis [mailto:[email-masked]]
AS>> Sent: Wednesday, June 06, 2001 12:02 AM
AS>> To: Jonathan Rosenberg; [email-masked]
AS>> Subject: RE: [Simple] authorization for presence
AS>>
AS>>
AS>>
AS>> As I am trying to understand better the proposed solution I
AS>> am confused as
AS>> to whether
AS>> the automatic notification to all watchers as soon as a new
AS>> watcher tries to
AS>> subscribe to the event is just *how a buddy list would work*
AS>> or whether its
AS>> a *a generic requirement* when dealing with subscriptions to events.
AS>
AS>The set of folks that get notified (because they are allowed to
AS>subscribe)
AS>when my watcherinfo changes (because someone subscribed to my
AS>presence), is
AS>a matter of local policy. Typically, I expect that local policy
AS>would allow
AS>only one entity to subscribe to changes in my watcherinfo, and
AS>that would be
AS>me.

Understood. Thanks

AS>>
AS>> I assume, for protecting the presentity's privacy, it would
AS>> be enough only for the presentity to be notified everytime a
AS>> new watcher
AS>> requests subscription to the presentity, unless the
AS>> presentity explicitly
AS>> allows the presence server to notify every (or some of them)
AS>> watcher about
AS>> which other watcher is in the list.
AS>
AS>Right; as I said, its a matter of policy. Remember, there are watchers at
AS>two levels here. There are the set of folks who subscribed to my
AS>presence.
AS>Then, there are the set of folks who subscribed to changes in my
AS>watcherinfo. That is, the set of folks that want to get notified when
AS>someone tries to subscribe to my presence. These two sets of watchers are
AS>not the same.
AS>

I guess what confuses me is why do we mix together under the mechanism of
active/pending subscriptions (which is nice approach) with the 'set of folks
to get
notified when someone tries to subscribe to my presence'. The later is a
separate application as far as I am concerned.
ie I subscribe to an application (presentity) that monitors Bob's watchers.

If I am correct in my thinking, could we separate those two issues ?

Kind Rgds
Theo

AS>-Jonathan R.
AS>
AS>---
AS>Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
AS>Chief Scientist                             First Floor
AS>dynamicsoft                                 East Hanover, NJ 07936
AS>[email-masked]                     FAX:   (973) 952-5050
AS>http://www.jdrosen.net                      PHONE: (973) 952-5000
AS>http://www.dynamicsoft.com
AS>_______________________________________________
AS>simple mailing list
AS>[email-masked]
AS>http://mailman.dynamicsoft.com/mailman/listinfo/simple
AS>