Subject: RE: [Simple] DNS SRV query example

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 2 May 2001 09:23:05 -0400

> -----Original Message-----
> From: Ajay Chitturi [mailto:[email-masked]]
> Sent: Monday, April 30, 2001 6:48 PM
> To: [email-masked]
> Subject: [Simple] DNS SRV query example
> 
> 
> Hi,
> 
> In Section 6.3 of draft-ietf-simple-im-00, the example for the SRV
> query for a url im:user@host is shown as _im._sip.host
> 
> Shouldn't this be _im._sip._transport.host (where transport 
> is udp, tcp,
> tls, etc.)

The usage of SRV for this translation is still being debated within IMPP. If
SRV is used, it will not be exactly as specified in rfc2782. One proposal
was to use a form along the lines of "_im._sip.domain", and then do a sip
srv query on the result. This is still being hammered out on the impp list.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Vasilis Polychronidis <[email-masked]>
Date: Thu, 03 May 2001 16:00:38 -0700

Hi Jonathan,
Please see my comments below:

> > Shouldn't this be _im._sip._transport.host (where transport

Here is the format of the SRV Resource Record (RR):
 _Service._Proto.Domain TTL Class SRV Priority Weight Port Target

According to CPIM --> Service = im or pres
Proto = tcp or udp or prim or sip or apex or http or ...
Target = sip.openwave.com or presence.openwave.com or
prim.openwave.com or apex.openwave.com or openwave.com or ....

> SRV is used,

It has been decided in IMPP wg to use SRV!
The result of the SRV query
will contain the SRV RR and may contain the Additional field with the IP address
of the Target.
If the Name Server does not contain the IP address of the Target a second DNS
query will
be performed on the Target.

> it will not be exactly as specified in rfc2782.

Why not?

> One proposal
> srv query on the result.

This is one way of doing SRV queries which is compliant with rfc2782.

> This is still being hammered out on the impp list.

Are you talking about the walk through that we need to work on?

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple