Subject: RE: [Simple] 487 Request Cancelled

From: "Sean Olson (EUS)" <[email-masked]>
Date: Mon, 23 Apr 2001 16:38:42 -0500

>"draft-roach-sip-subscribe-notify-03.txt" page 9:
>
>     For the purposes of generality, both SUBSCRIBE and NOTIFY MAY be
>     canceled; however, doing so is not recommended. Successfully
>     cancelled SUBSCRIBE and NOTIFY requests MUST be completed with a
>     "487 Request Cancelled" response; the server acts as if the
>     request were never received. In general, since neither SUBSCRIBE
>     nor NOTIFY are allowed to have protracted transactions, attempts
>     to cancel them are expected to fail.
>
>Can anyone explain to me that why to use a 4xx reponse code to 
>indicate a
>successful request (to cancel SUBSCRIBE or NOTIFY)? Doesn't a 2xx class
>response code make more sense? In this case, a "287 Request Cancelled
>Successfully" might be more straightforward than a "487 
>Request Cancelled".
>

This is *not* a successful request. The SUBSCRIBE/NOTIFY
requests are treated as is if they were never received.
The 487 is just to consistently close the transaction.

>Comments?
>Thanks,
>Charles

/sean

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 23 Apr 2001 18:55:16 -0400

-----Original Message-----
From: Sean Olson (EUS) [mailto:[email-masked]]
Sent: Monday, April 23, 2001 5:39 PM
To: 'Charles Chen'; [email-masked]'
Subject: RE: [Simple] 487 Request Cancelled

>The 487 is just to consistently close the transaction. 

I'll also add that responding 487 to transaction thats been cancelled is
standard behavior for all request types, as spelled out in rfc2543bis.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com