Subject: [Simple] DNS SRV query example

From: "Ajay Chitturi" <[email-masked]>
Date: Mon, 30 Apr 2001 15:47:56 -0700

Hi,

In Section 6.3 of draft-ietf-simple-im-00, the example for the SRV
query for a url im:user@host is shown as _im._sip.host

Shouldn't this be _im._sip._transport.host (where transport is udp, tcp,
tls, etc.)

Thanks
Ajay.

---

From: "Ngo, Dai (c)" <[email-masked]>
Date: Tue, 01 May 2001 13:31:44 +0000

Ajay,

Here is the format of the record:

"The format of the SRV RR

   Here is the format of the SRV RR, whose DNS type code is 33:

        _Service._Proto.Domain TTL Class SRV Priority Weight Port Target"

Please see draft-ietf-dnsext-rfc2782bis-00.txt for more information.

Hope this help.

Dai Ngo

-----Original Message-----
From: Ajay Chitturi [mailto:[email-masked]]
Sent: Monday, April 30, 2001 5:48 PM
To: [email-masked]
Subject: [Simple] DNS SRV query example

Hi,

Thanks
Ajay.
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 9 May 2001 08:25:31 -0700

This discussion really belongs in the IMPP group, not SIMPLE. As far as
Simple is concerned, we could very easily just use a basic SRV record
scheme, e.g. 
 	_sip._udp.example.com SRV 1 1 5060 sip.example.com 
Indeed, there may be question of which record we use, i.e. do we look
for "sip" or do we look for "simple", and also a question of which
transport protocol we prefer, e.g. udp, tcp, tls or ssl. 

-- Christian Huitema

-----Original Message-----
From: Vasilis Polychronidis [mailto:[email-masked]] 
Sent: Tuesday, May 08, 2001 11:13 PM
To: Jonathan Rosenberg
Cc: Ajay Chitturi; [email-masked]
Subject: Re: [Simple] DNS SRV query example

Hi Jonathan, 
Please see my comments below: 
Regards, 
Vasilis Polychronidis 
Jonathan Rosenberg wrote: 
  
-----Original Message----- 
From: Vasilis Polychronidis [mailto:[email-masked]] 
Sent: Thursday, May 03, 2001 7:01 PM 
To: Jonathan Rosenberg 
Cc: 'Ajay Chitturi'; [email-masked] 
Subject: Re: [Simple] DNS SRV query example 
> 
>Hi Jonathan, 
>Please see my comments below: 
>Jonathan Rosenberg wrote: 
> 
>> Sent: Monday, April 30, 2001 6:48 PM 
>>The usage of SRV for this translation is still being debated within
IMPP. 
If 
>>SRV is used, 
> 
>It has been decided in IMPP wg to use SRV! 
There was a preference, for simplicities sake, although it wasn't clear
it 
really works from the list discussions that followed IETF 50. Indeed,
based 
on Christian's most recent note on impp, it looks like there was
significant 
pushback from the DNS experts, who feel that NAPTR is more correct.
I agree with you I was just trying to remind you of the resolution that
was agreed in the 50th IETF. 
Here is a direct quote from the meeting minutes (IETF 50): 
    Issue: Address resolution in multiprotocol context 
    Proposal: 
            SRV at edge? 
            NAPTR at edge? 
    How would NAPTR records be used? 
        Weight/Priority 
        Flags to control the process 
        Services: end point differentiation 
        Regexp: end point identifier "factory" 
        Replacement: (a DNS shortcut if regex is just domainname) 
        Additional info section contains the SRV and A records 
    Michael Mealling presents a brief overview of how NAPTR might be
applied to the situation.  Some concerns from the floor that NAPTR are 
    expressive and potentially quite complex.  The counter argument is
that the CPIM application would define a very restrictive application of
their use 
    (as does ENUM). 
    Now that NAPTR was explained and discussed, return to the question,
do we want to go with some variant of SRV or NAPTR? 
    General feeling of the room is that the potential of NAPTR doesn't
buy enough over SRV, and the concern over additional complexity remains.

    Resolution: Use SRV records for first-round lookups: 
                _<proto>._im.domain. (e.g. _simple._im.domain.) 
    Christian will make proposal for revised CPIM text 
  
>>The result of the SRV query 
>>will contain the SRV RR and may contain the Additional field with the
IP 
address of the 
>>Target. 
>>If the Name Server does not contain the IP address of the Target a
second 
DNS query will 
>>be performed on the Target. 
>>it will not be exactly as specified in rfc2782. 
>Why not? 
rfc2782 defines the protocol field as a transport protocol - tcp, udp.
The 
proposed approach does not use it that way.
Well the proto field can be anything you want. 
The following is a direct quote from rfc2782: 
   Proto 
        The symbolic name of the desired protocol, with an underscore 
        (_) prepended to prevent collisions with DNS labels that occur 
        in nature.  _TCP and _UDP are at present the most useful values 
        for this field, though any name defined by Assigned Numbers or 
        locally may be used (as for Service).  The Proto is case 
        insensitive. 

-Jonathan R. 
--- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave. 
Chief Scientist                             First Floor 
dynamicsoft                                 East Hanover, NJ 07936 
[email-masked]                     FAX:   (973) 952-5050 
http://www.jdrosen.net                      PHONE: (973) 952-5000 
http://www.dynamicsoft.com