Subject: Re: [Simple] MESSAGE sessions - over TCP

From: [email-masked]
Date: Wed, 26 Sep 2001 13:24:50 +0200

I think there is yet another option, which I haven't seen discussed, and 
that is to use "direct message first, session later"..

When I'm sending a single message, opening a point-to-point session via 
INVITE has a lot of overhead, and also takes time and some system 
resources. The entire process of creating a session its by far larger than 
my "Hi, meet me for lunch" message. 
also, passing MESSAGE or INVITE from the SIP network perspective is almost 
the same (and mabe a bit in favour of MESSAGE...)
This is why I wouldn't send a email in the first place - since its a 
heavyweight solution.

If the other side will want to start a chat, only then should a full 
messaging session be opened.

Of course, there should be a limitation on the size of this initial 
message, which will require a use of p2p session for sending a message 
above a given size (e.g. equivalent to a single UDP packet) 

"Petri K. Koskelainen" <[email-masked]>
Sent by: [email-masked]
25/09/2001 17:39

        To:     [email-masked]
        cc: 
        Subject:        [Simple] MESSAGE sessions - over TCP

There hasn't been any conclusion or rough consensus relating to
the SIP MESSAGE session model.

It seems that there are two main proposals:

1: Implicit MESSAGE session (no INVITE, just MESSAGEs).

2: Use of INVITE to establish a SIP session and then using
some protocol X to carry the messages. The X protocol
may be SIP MESSAGE, BEEP-based, some new protocol etc.
IESG has ruled out SIP MESSAGE mainly because of three reasons:
- large message overhead in SIP headers
- lack of congestion control (in UDP only)
- size limitation (in UDP only)
However, SIP MESSAGE over TCP should be ok. Message overhead is an
issue only in wireless environment, but SIP compression (even UDPcomp)
eliminates the overhead.
TCP has also other advantages (like the use of TLS).

I really think that something should be decided asap. Option 2 with SIP
MESSAGE over TCP seems to be ok. It does not have to be the one-and-only
format for next 100 years. If someone really wants it, he can specify
BEEP-based or whatever additional formats inside a SIP
session - just like it is possible to create new RTP formats.
However, SIP session model and MESSAGE over TCP is sufficient for
many applications and therefore it would be really useful
to continue at least with that (and have something to use asap).

Since other formats inside a session may be defined later, the real
question is whether the INVITE established session is needed or not.
I think yes. This is similar to audio/video sessions, and it allows e.g.
the use of record-route, mobility etc.

--
Petri
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Petri K. Koskelainen" <[email-masked]>
Date: Wed, 26 Sep 2001 13:20:41 -0400 (EDT)

If you have just one message to send, you don't have to 
establish a session. Just send a MESSAGE. 
No need for INVITE then.

In general, IM session is just another media stream just like 
audio or video stream.
Often it is established at the same time than the
audio and video streams (one m line for each media stream).
This is the ideal situation since it allows all the
control and flexibility of INVITE for IM session 
(e.g. mobility, record-route, multi-party IM..).

Still, one-shot MESSAGEs can be sent if someone does
not want to use the session model.

Is there a consensus that INVITE-established IM messaging 
session idea is ok ? (in addition to one shot MESSAGEs)

If we can agree on that, then we can continue with other problems, like:
- messaging protocol/format inside a session (e.g. SIP MESSAGE over TCP)
- direct end-to-end vs. via signaling proxies vs. via IM servers 
- compression (hopefully this does not have to be discussed here)
 
There should be a resolution on this asap.

--
Petri

> --=_alternative 00443EF042256AD3_=
> Content-Type: text/html; charset="us-ascii"
> 
> 
> <br><font size=2 face="sans-serif">I think there is yet another option, which I haven't seen discussed, and that is to use &quot;direct message first, session later&quot;..</font>
> <br>
> <br><font size=2 face="sans-serif">When I'm sending a single message, opening a point-to-point session via INVITE has a lot of overhead, and also takes time and some system resources. The entire process of creating a session its by far larger than my &quot;Hi, meet me for lunch&quot; message. </font>
> <br><font size=2 face="sans-serif">also, passing MESSAGE or INVITE from the SIP network perspective is almost the same (and mabe a bit in favour of MESSAGE...)</font>
> <br><font size=2 face="sans-serif">This is why I wouldn't send a email in the first place - since its a heavyweight solution.</font>
> <br>
> <br><font size=2 face="sans-serif">If the other side will want to start a chat, only then should a full messaging session be opened.<br>
> </font>
> <br><font size=2 face="sans-serif">Of course, there should be a limitation on the size of this initial message, which will require a use of p2p session for sending a message above a given size (e.g. equivalent to a single UDP packet) </font>
> <br>
> <br>
> <br>
> <br>
> <table width=100%>
> <tr valign=top>
> <td>
> <td><font size=1 face="sans-serif"><b>&quot;Petri K. Koskelainen&quot; &lt;[email-masked]&gt;</b></font>
> <br><font size=1 face="sans-serif">Sent by: [email-masked]</font>
> <p><font size=1 face="sans-serif">25/09/2001 17:39</font>
> <br>
> <td><font size=1 face="Arial">&nbsp; &nbsp; &nbsp; &nbsp; </font>
> <br><font size=1 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; To: &nbsp; &nbsp; &nbsp; &nbsp;[email-masked]</font>
> <br><font size=1 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; cc: &nbsp; &nbsp; &nbsp; &nbsp;</font>
> <br><font size=1 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; Subject: &nbsp; &nbsp; &nbsp; &nbsp;[Simple] MESSAGE sessions - over TCP</font></table>
> <br>
> <br>
> <br>
> <br><font size=2><tt>There hasn't been any conclusion or rough consensus relating to<br>
> the SIP MESSAGE session model.<br>
> </tt></font>
> <br><font size=2><tt>It seems that there are two main proposals:<br>
> </tt></font>
> <br><font size=2><tt>1: Implicit MESSAGE session (no INVITE, just MESSAGEs).<br>
> </tt></font>
> <br><font size=2><tt>2: Use of INVITE to establish a SIP session and then using<br>
> some protocol X to carry the messages. The X protocol<br>
> may be SIP MESSAGE, BEEP-based, some new protocol etc.<br>
> IESG has ruled out SIP MESSAGE mainly because of three reasons:<br>
> - large message overhead in SIP headers<br>
> - lack of congestion control (in UDP only)<br>
> - size limitation (in UDP only)<br>
> However, SIP MESSAGE over TCP should be ok. Message overhead is an<br>
> issue only in wireless environment, but SIP compression (even UDPcomp)<br>
> eliminates the overhead.<br>
> TCP has also other advantages (like the use of TLS).<br>
> </tt></font>
> <br><font size=2><tt>I really think that something should be decided asap. Option 2 with SIP<br>
> MESSAGE over TCP seems to be ok. It does not have to be the one-and-only<br>
> format for next 100 years. If someone really wants it, he can specify<br>
> BEEP-based or whatever additional formats inside a SIP<br>
> session - just like it is possible to create new RTP formats.<br>
> However, SIP session model and MESSAGE over TCP is sufficient for<br>
> many applications and therefore it would be really useful<br>
> to continue at least with that (and have something to use asap).<br>
> </tt></font>
> <br><font size=2><tt>Since other formats inside a session may be defined later, the real<br>
> question is whether the INVITE established session is needed or not.<br>
> I think yes. This is similar to audio/video sessions, and it allows e.g.<br>
> the use of record-route, mobility etc.<br>
> </tt></font>
> <br><font size=2><tt>--<br>
> Petri<br>
> _______________________________________________<br>
> simple mailing list<br>
> [email-masked]<br>
> http://mailman.dynamicsoft.com/mailman/listinfo/simple</tt></font>
> <br>
> <br>
> --=_alternative 00443EF042256AD3_=--
>

---

From: Vasilis Polychronidis <[email-masked]>
Date: Wed, 26 Sep 2001 12:49:26 -0700

Hi Petri,
See comments inline:

BR,

-Vasilis

"Petri K. Koskelainen" wrote:

> session idea is ok ?

I think so.

> (in addition to one shot MESSAGEs)
>

We can minimize the debate on this issue if we can agree on a generic SDP format (m-line, etc.)
that is flexible enough to support multiple options (SIP/TCP, CPIM/TCP, XML/HTTP, etc.) and future extensions.

> - direct end-to-end vs. via signaling proxies vs. via IM servers

Since IM is just another media stream it should should support the
same variety of architectures supported by the current media streams (direct end-to-end, Conferencing Servers, etc.)

> - compression (hopefully this does not have to be discussed here)

I agree.

> There should be a resolution on this asap.

I agree.