Subject: [Simple] Pls give some info in PS operation ?

From: Abdul Rahman Kadir <[email-masked]>
Date: Mon, 04 Mar 2002 17:35:54 +0530

Hi

Can some one help me understanding the foll. in Presence server
operation?

1. Can the SUBSCRIBE request received at the Presence Server be
   REJECTED immediatelty after authentication process is over if    
   there is no access permission for the subscriber or due to any 
   other reason ?.
   
   or SUBSCRIBE request MUST always come to PENDING State before
   getting REJECTED ? - that is, Presence Server will move to pending
   state as no access  permission given for subscriber at present
   (presentity not alive) and will try get it authorized .
   And so after some time slot,it decides to REJECT since subscriber
   not authorized so far.

2. Will there be any access-list present for the subscriber in the
   PS while the presentity is off-line.

thanks
Abdul Rahman

---

From: "Ben Campbell" <[email-masked]>
Date: Mon, 4 Mar 2002 18:27:54 -0600

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Abdul Rahman
> Kadir
> Sent: Monday, March 04, 2002 6:06 AM
> To: [email-masked]
> Subject: [Simple] Pls give some info in PS operation ?
>
>
> Hi
>

If the PS can make an immediate decision on the matter, then there is no
need for a pending state. It can just reject the subscription with an
appropriate 400 or 600 class response.

>    PS while the presentity is off-line.

This depends entirely on the application design and local policy. It is
certainly possible to build a presence service where that is true.

>
>
> thanks
> Abdul Rahman
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
>