Subject: RE: [Simple] IM: A session or not

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 13 May 2001 23:42:16 -0400

> -----Original Message-----
> From: Robert Sparks 
> Sent: Sunday, May 13, 2001 2:28 AM
> To: Jonathan Rosenberg; [email-masked]';
> [email-masked]'
> Subject: RE: [Simple] IM: A session or not
> 
> 
> >
> >> If the conversation forks in
> >> one direction, it will _stay_ forked through the whole 
> conversation.
> >
> >By conversation, are you referring to the sip call, or the 
> message "stream"?
> 
> The stream of MESSAGE requests (the "chat" conversation). 
> Since we do not
> want to make any distinction between a page MESSAGE and a 
> chat MESSAGE, if
> for some reason the stream hits a proxy that forks the chat 
> MESSAGEs, it
> will fork every one. 
> 
> This is an unlikely scenario - in the best of worlds, we've 
> signaled direct
> peer-peer delivery of chat MESSAGEs using the SDP in the 
> INVITE. However, if
> we've been forced to use an outbound proxy, or have 
> introduced a proxy through
> preloaded routes, as mentioned above, there's a chance that 
> something along
> the path will fork the chat MESSAGEs.
> 
> I'm not claiming this is a problem. I just wanted to make 
> sure everyone
> understood the possibility existed.

Yes, it does. Under normal cases, where either Route is used, or where a
direct messaging occurs, it definitely won't. In cases where it does end up
forking, you want to be able to reject the message at all hosts except the
one that was really supposed to get it. The right way to do that is to
include a tag in the To field of all MESSAGE requests. This tag would be set
as part of the URI in the SDP. Doing this is a little bit of a stretch; tag
is really meant for requests that are part of a session. Technically, since
MESSAGE operates like OPTIONS, there is really no SIP session associated
with the collection of MESSAGES. But, I think its probably reasonable to use
tag in any case. We need to explicitly note, in the text, that a UA should
reject a MESSAGE if it contains a to tag that is unrecognized.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Vasilis Polychronidis <[email-masked]>
Date: Sun, 08 Jul 2001 17:39:37 -0700

Hi All,
I think this was the last message on this thread (IM: A session or not).
This was a very interesting discussion.
Can someone summarize the consensus of the group on this important issue?

Thank you in advance,

Vasilis Polychronidis

Jonathan Rosenberg wrote:

> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple