Subject: RE: [Simple] MESSAGE sessions - over TCP

From: "Robert Osborne" <[email-masked]>
Date: Tue, 25 Sep 2001 11:02:56 -0700

Hi,

there is also a third option, which is a combination of the other
two.

3) Use of INVITE to establish an IM session, and then using MESSAGE
over the signalling channel to send the IMs.

This is my preferred option, as it gives all the control and flexibility
of the INVITE, plus the ability to traverse firewalls in a manner that
can be controlled by the administrator.

I agree with you that there should be resolution on this matter as soon
as is possible.

Rob O

>-----Original Message-----
>From: Petri K. Koskelainen [mailto:[email-masked]]
>Sent: Tuesday, September 25, 2001 8:39 AM
>To: [email-masked]
>Subject: [Simple] MESSAGE sessions - over TCP
>
>
>
>There hasn't been any conclusion or rough consensus relating to 
>the SIP MESSAGE session model.
>
>It seems that there are two main proposals:
>
>1: Implicit MESSAGE session (no INVITE, just MESSAGEs).
>
>2: Use of INVITE to establish a SIP session and then using
>some protocol X to carry the messages. The X protocol
>may be SIP MESSAGE, BEEP-based, some new protocol etc.
>IESG has ruled out SIP MESSAGE mainly because of three reasons:
>- large message overhead in SIP headers 
>- lack of congestion control (in UDP only)
>- size limitation (in UDP only)
>However, SIP MESSAGE over TCP should be ok. Message overhead is an 
>issue only in wireless environment, but SIP compression (even UDPcomp) 
>eliminates the overhead. 
>TCP has also other advantages (like the use of TLS).
> 
>I really think that something should be decided asap. Option 2 
>with SIP 
>MESSAGE over TCP seems to be ok. It does not have to be the 
>one-and-only
>format for next 100 years. If someone really wants it, he can specify 
>BEEP-based or whatever additional formats inside a SIP 
>session - just like it is possible to create new RTP formats. 
>However, SIP session model and MESSAGE over TCP is sufficient for 
>many applications and therefore it would be really useful 
>to continue at least with that (and have something to use asap).
>
>Since other formats inside a session may be defined later, the real
>question is whether the INVITE established session is needed or not.
>I think yes. This is similar to audio/video sessions, and it 
>allows e.g.
>the use of record-route, mobility etc.
>
>--
>Petri
>_______________________________________________
>simple mailing list
>[email-masked]
>http://mailman.dynamicsoft.com/mailman/listinfo/simple
>

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 25 Sep 2001 16:41:14 -0400

> over the signalling channel to send the IMs.

This only works if the signaling channel is TCP, per the
congestion-control requirement. It doesn't seem clean to decide that "my
SDP contains a MESSAGE session, I better use TCP for signaling", but I
suppose that's mostly aesthetics.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs