Subject: RE: [Syslog-sec] RE: While you are at it ...

From: "Rainer Gerhards" <[email-masked]>
Date: Fri, 15 Apr 2005 14:42:40 +0200

Sharon,

thanks for the comment. I'll change it to RFC XXXX.

Rainer 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Sharon Chisholm
> Sent: Friday, April 15, 2005 1:58 PM
> To: syslog
> Subject: RE: [Syslog-sec] RE: While you are at it ...
> 
> 
> 
> </Rainer>
> > 
> > b) RFC9999 I find confusing, irritating even; normative
> > references to I-Ds is
> > elementary RFC-editing, they deal with it every day; put in 
> > the I-D name and
> > trust the editor to sort it out:-)
> 
> As far as I have been told, the way it currently is is the 
> way to do it.
> Once it is through the last call, *I* will get a last editing 
> chance at
> which time this is replaced by the actual RFC 1. As far as 
> I've been told, a
> normative RFC must only refer to other RFCs, not I-Ds. If it 
> does, it won't
> be normative until the other I-D has become an RFC.
> </Rainer>
> 
> No, more typically one would say RFCXXXX with a note that the 
> RFC editor
> should fill this in when the number is available. RFC9999 is much less
> likely to be caught before publication. 
> 
> Sharon
> _______________________________________________
> Syslog-sec mailing list
> [email-masked]
> http://www.employees.org/mailman/listinfo/syslog-sec
> 
_______________________________________________
Syslog-sec mailing list
[email-masked]
http://www.employees.org/mailman/listinfo/syslog-sec

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 15 Apr 2005 08:45:52 -0400

Hi,

Sharon's suggestion had two parts:
RFCXXXX rather than RFC9999 - ok.
But also instructions to the RFC Editor in a format the RFC Editor
knows to look for:
-- RFC Ed.: replace XXXX with RFC number and remove this note

dbh

> Rainer Gerhards
> Sent: Friday, April 15, 2005 8:43 AM
> To: syslog

---

From: "Tom Petch" <[email-masked]>
Date: Fri, 15 Apr 2005 21:32:49 +0200

Agreeing with everything Sharon and David said, what about the reference [8] to
 RFC 2373 (for a valid textual representation of an IPv6 address)?

RFC2373 has been superseded by RFC3513 (still PS) which is now being superseded
by
draft-ietf-ipv6-addr-arch-v4-02.txt
and there are changes in this area of textual representation, some additions,
some removals.

So, if you really mean RFC2373, then there is a technical problem which will
stop this work progressing.

If you mean whatever IPv6 comes up with, then a reference to RFC3513 will be
technically ok but will stop progress along the standards track since RFC3513
will not progress but the one that supersedes it may.

So again, I think you want a reference here to work in progress, citing the I-D
name, with a note as David suggests
-- RFC Ed.: replace XXXX with RFC number and remove this note
alongside reference [8].  (I trust the RFC editor to delay publication until the
IPv6 draft makes it to RFC:-)

In passing, you can see a reference of the form I like, albeit without the RFC
editor note,
in
draft-ietf-bmwg-igp-dataplane-conv-app-05.txt

Tom Petch

----- Original Message -----
From: "David B Harrington" <[email-masked]>
To: "'Rainer Gerhards'" <[email-masked]>; "'syslog'"
<[email-masked]>
Sent: Friday, April 15, 2005 2:45 PM
Subject: RE: [Syslog-sec] RE: While you are at it ...

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 15 Apr 2005 17:05:24 -0400

Hi,

Unless there is something in the new I-D that is referenced here, I
would reference one of the already published RFCs. I think that would
cause the least delay in getting this work to RFC.

If thr RFC does not advance from PS when this WG wishes to advance
this document to DS, a new draft can be publsihed with an updated
reference, as part of the process of advancement from PS to DS.

David Harrington
[email-masked]

> [mailto:[email-masked]] On Behalf Of Tom Petch
> Sent: Friday, April 15, 2005 3:33 PM
> To: 'Rainer Gerhards'; 'syslog'
> Subject: Re: [Syslog-sec] RE: While you are at it ...
>