Subject: RE: FW: WebFolders on Intranet

From: "Jim Whitehead" <[email-masked]>
Date: Tue, 9 Jan 2001 17:45:47 -0800

Accidentally caught by the spam filter.  I've added Mac McCusker's email
address to the accept2 filter...

- Jim

-----Original Message-----
From: Mac McCusker [mailto:[email-masked]]
Sent: Tuesday, January 09, 2001 4:25 PM
To: 'Peter Pierrou'; [email-masked]
Subject: [Moderator Action] RE: FW: WebFolders on Intranet

Hey Peter,

We are considering converting our Shared directory to a WebDAV virtual
Directory using IIS.  The hope is that this will improve download times of
files (word, excel...etc) through our Intranet.

One of our concerns is scalability, have you found WebDAV to handle many
simultaneous users well, does this slow down the server significantly?
thanks \
Mac

-----Original Message-----
From: Peter Pierrou [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 12:36 AM
To: [email-masked]; [email-masked]
Subject: Re: FW: WebFolders on Intranet

Hi!

> Interested in getting in touch with any companies that are using WebDAV on
> their Intranet.

We are using WebDAV in our Intranet for all files.

Most of the files are in XML and edited trought the intranet with
Documentor.

Files of outher types (powerpoint, word, excel etc) are aloso edited
over webdav either with webfolders or with
the Documentor client as ActiveX plugins.

We have our own archive; ExcoConf with webdav support. We also use a
little Exchange 2000 server.

Even the source code is edited directly in the archive wia WebDav.

We can also edit the files when working at home over webdav.

Best Regards
Peter Pierrou

========================================================
  Peter Pierrou / Software Project Manager
  Excosoft AB * Electrum 420 * SE-164 40  Kista * Sweden
  Tel: +46 8 633 29 02
========================================================

---

From: "Stewart Hersey" <[email-masked]>
Date: Tue, 9 Jan 2001 22:20:04 -0800

Heya Mac,

No idea regarding IIS. The little testing John Sellens, Phil Scarr and I performed has been with a
Sun Ultra 1 SparcStation 143 mhz CPU 320 MB RAM running:
UNIX(r) System V Release 4.0 with an average of 60 to 80 simultaneous Intranet users.

We found no significant slowdowns...compared with the average speed w/o WebDAV.
Initially, Phil and I shared the editing/versioning of a test HTML file by using Web Folders.
I wrote "Hello" and he wrote "World".
I titled the file "foo.html" and he changed the title to "bar.html".
You know the drill ;-)

He added a folder to the WebDAV test directory and titled it phil Scarr.
I dropped in bar.html and he retitled it index.html .

I hacked some code into it from inside the facility, and Phil picked it up (remotely) and modified it while dialing-in to the
network from home.

He also dumped some folders and their contents into the test directory from another location on the Web tree.
I edited a few of them using several different clients, including Dreamweaver, MS Word, and Photoshop.

Later on, I picked up the original html file on an HP 4150B (PIII) running MS W2KPro Japanese, and added some kanji to it. I
repeated the process via dail-in using Windows Me Japanese Version 4.90.3000 on a Compaq Presario 2298 (AMD K6).

At no time was I prevented from editing the files due to an open as "write only" incident.

FYI this single server handles DHCP for external dial-in, serves up Internal Web pages (including, until very recently, user's home
directories), runs sendmail, and acts as a command-line interface to an Oracle database.

In a testament to UNIX uptime, this particular server has been running for 232 consecutive days.

Perhaps Kevin Wiggin from Xythos could comment about WebDAV scalability on IIS.
We have cooperated in the past on Sharemation Server testing with double-bit character sets.

Regards,

Stewart Hersey
http://www.karuizawa.ne.jp/~farmer/new.html

-----Original Message-----
From: Mac McCusker [mailto:[email-masked]]
Sent: Tuesday, January 09, 2001 4:25 PM
To: 'Peter Pierrou'; [email-masked]
Subject: [Moderator Action] RE: FW: WebFolders on Intranet

Hey Peter,

-----Original Message-----
From: Peter Pierrou [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 12:36 AM
To: [email-masked]; [email-masked]
Subject: Re: FW: WebFolders on Intranet

Hi!

Best Regards
Peter Pierrou

---

From: "Stewart Hersey" <[email-masked]>
Date: Tue, 9 Jan 2001 23:20:48 -0800

Sorry...

Below: "write only" should read "read only".

That about wraps up my day. (-/-) zzz

*S*

----- Original Message ----- 
From: "Stewart Hersey" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Tuesday, January 09, 2001 10:20 PM
Subject: Re: FW: WebFolders on Intranet

Heya Mac,

Regards,

Stewart Hersey

-----Original Message-----
From: Mac McCusker [mailto:[email-masked]]
Sent: Tuesday, January 09, 2001 4:25 PM
To: 'Peter Pierrou'; [email-masked]
Subject: [Moderator Action] RE: FW: WebFolders on Intranet

Hey Peter,

-----Original Message-----
From: Peter Pierrou [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 12:36 AM
To: [email-masked]; [email-masked]
Subject: Re: FW: WebFolders on Intranet

Hi!

Best Regards
Peter Pierrou

---

From: Greg Stein <[email-masked]>
Date: Tue, 9 Jan 2001 23:33:19 -0800

> We found no significant slowdowns...compared with the average speed w/o WebDAV.

Euh... you gave the hardware, but what DAV server were you using?

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/