Subject: DAV conformance tests

From: "Erik Hatcher" <[email-masked]>
Date: Tue, 2 Jan 2001 20:37:45 -0700

Surely folks are doing some kind of spec. conformance tests against their
DAV servers.   How did you do it?

Has anyone fleshed these tests out into something available for others to
use to test against their servers as well?

What about developing some kind of test suite using SkunkDAV code to control
it?

Thanks,
    Erik

---

From: "Jim Whitehead" <[email-masked]>
Date: Mon, 8 Jan 2001 10:08:54 -0800

Accidentally caught by the spam filter -- I've added Karl Best to the
accept2 list, so future emails from him will not be caught.

- Jim

-----Original Message-----
From: Karl Best [mailto:[email-masked]]
Sent: Monday, January 08, 2001 8:14 AM
To: Jacob Smullyan; Norbert Mikula; 'Erik Hatcher'; [email-masked];
[email-masked]
Cc: Karl
Subject: [Moderator Action] RE: DAV conformance tests

OASIS currently has a number of technical committees (TCs) working on
conformance testing, though none of them are working specifically on DAV.
One committee, Interoperability Conformance, is creating guidelines for the
development of conformance tests. (See
http://www.oasis-open.org/committees/committees.shtml for a list of the
current OASIS TCs.)

OASIS would be happy to host a new TC to work on conformance testing for
DAV. The process for creating a new TC is quite simple, and essentially only
requires the sponsorship of three representatives of OASIS member
organizations. (See http://www.oasis-open.org/committees/process.shtml for
the OASIS TC process.) I would be happy to work with any interested parties
to get this set up.

</karl>
============================================================
Karl F. Best
OASIS - Director, Technical Operations
978.667.5115 x206
[email-masked]  http://www.oasis-open.org

> -----Original Message-----
> From: Jacob Smullyan [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 1:00 PM
> To: Norbert Mikula; 'Erik Hatcher'; [email-masked]';
> [email-masked]'
> Cc: [email-masked]'
> Subject: RE: DAV conformance tests
>
>
> Sounds like a fine idea, and as the Skunkdav developer, I'd be
> glad to help in
> any way I can.    The client library is very easy to script with
> J(P)ython -- I
> refer you to the jpython test script which you may find at:
>
> http://cvs.sourceforge.net/cgi-bin/cvsweb.cgi/skunkdav/org/skunk/d
av/client/test.py?rev=1.11&content-type=text/x-cvsweb->
markup&cvsroot=skunkdav
>
> Jacob Smullyan
> [email-masked]
>
> On Thu, 04 Jan 2001, Norbert Mikula wrote:
> >
> > Erik, OASIS has a long history of developing conformance tests. I copy
> > this
> > e-mail to Karl Best of OASIS who can provide you with all the details.
> > I would suggest we all work together on this.
> >
> > . . . . . . . . . . . . . . . . . . . . . . . .
> >
> > Norbert H. Mikula | Chief Technology Officer
> >
> > 600 108th Avenue NE | Suite 900 | Bellevue WA  98004
> >       T 425.974.4118 | F 425.637.1192 | C 425.681.3685
> >             [email-masked]
> > w w w . d a t a c h a n n e l . c om
> >
> >
> >
> >
> > -----Original Message-----
> > From: Erik Hatcher [ mailto:[email-masked]
> > <mailto:[email-masked]> ]
> > Sent: Tuesday, January 02, 2001 7:38 PM
> > To: [email-masked]; [email-masked]
> > Subject: DAV conformance tests
> >
> >
> ----------------------------------------
> Content-Type: text/html; name="unnamed"
> Content-Transfer-Encoding: 7bit
> Content-Description:
> ----------------------------------------
>