Subject: RE: DAV conformance tests

From: Norbert Mikula <[email-masked]>
Date: Thu, 4 Jan 2001 09:45:30 -0800

Erik, OASIS has a long history of developing conformance tests. I copy this
e-mail to Karl Best of OASIS who can provide you with all the details. 
I would suggest we all work together on this.

. . . . . . . . . . . . . . . . . . . . . . . . 
 
Norbert H. Mikula | Chief Technology Officer
 
600 108th Avenue NE | Suite 900 | Bellevue WA  98004
      T 425.974.4118 | F 425.637.1192 | C 425.681.3685 
            [email-masked]
w w w . d a t a c h a n n e l . c om 

-----Original Message-----
From: Erik Hatcher [mailto:[email-masked]]
Sent: Tuesday, January 02, 2001 7:38 PM
To: [email-masked]; [email-masked]
Subject: DAV conformance tests

Surely folks are doing some kind of spec. conformance tests against their
DAV servers.   How did you do it?

Has anyone fleshed these tests out into something available for others to
use to test against their servers as well?

What about developing some kind of test suite using SkunkDAV code to control
it?

Thanks,
    Erik

---

From: Jacob Smullyan <[email-masked]>
Date: Thu, 4 Jan 2001 12:59:57 -0500

Sounds like a fine idea, and as the Skunkdav developer, I'd be glad to help in
any way I can.    The client library is very easy to script with J(P)ython -- I
refer you to the jpython test script which you may find at: 

http://cvs.sourceforge.net/cgi-bin/cvsweb.cgi/skunkdav/org/skunk/dav/client/test.py?rev=1.11&content-type=text/x-cvsweb-markup&cvsroot=skunkdav

Jacob Smullyan
[email-masked]

On Thu, 04 Jan 2001, Norbert Mikula wrote:
> From: Erik Hatcher [ mailto:[email-masked]
> <mailto:[email-masked]> ] 

----------------------------------------
Content-Type: text/html; name="unnamed"
Content-Transfer-Encoding: 7bit
Content-Description: 
----------------------------------------