Subject: webdav help

From: Jamil Kassam <[email-masked]>
Date: Wed, 3 Jan 2001 03:38:23 -0800 (PST)

I'm not sure if this is the right place to post this,
but here goes.  (If it's not, could someone please
guide me in the right direction? thanks!)

We are looking for a program that will run on
WindowsNT that does the following:

We have two servers in our Intranet, a production
server (call it P) and a development/backup (call it
D) server.  The idea is as follows:
A user should be able to get a file from server D,
i.e. check out the file.  (The user is using
Dreamweaver4 for this task.)  A lock should be put on
the file so that no one else can work on the same
file.  After the user has finished modifying this
file, the user should check in the file, thereby
unlocking it.  After this, the user should be able to
tell a person in charge of publishing the webpage that
the page is checked in.  The person in charge of
publishing would use a little application that checks
to see which pages in the web site tree have been
modified and unlocked.  Only if a file within the
directory has been modified AND unlocked does he want
to publish it.  The publishing process involves the
application checking for modified and unlocked files,
and copying them  to 2 locations – the first being the
production server, and the second being the backup
server (which happens to be on the same machine as the
development server).  The application used by the
person in charge of publishing should be quite simple
– all they should have to do is click on a button
called “Publish”, and the application will perform the
check (hopefully with detailed logging of who has
modified the file and who has not locked files that
are not locked), and automatically copy the eligible
files for copying to the two required locations.

Question: is there such a “publishing” application or
tool (preferably that fits in with the webdav
protocol) that will run on windows NT?  The closest
thing I’ve found is “sitecopy” which is for
linux/unix.  I believe there is a Windows port of the
software, but I can’t seem to get my hands on it. 
Does anyone have any suggestions?

Thanks!

- Jamil Kassam

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

---

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 3 Jan 2001 08:02:30 -0800

Jamil,

The Xythos Storage Server may fill your bill -- with a little custom
code.  Our WebDAV server is a platform, so it does all the WebDAV stuff,
lock/unlock, basic versioning, access control, searching, etc.  XSS is
compatible with MS Web Folders clients (haven't done testing with
DreamWeaver4, is it DAV 2 compatible?).  Most importantly, we have a
Java API to allow our customers to apply their own business rules and
APIs.

It sounds like you'd need a little bit of Java servlet code, or two JSP
pages, to finish off the publishing scenario you describe below.
Although there are many ways of skinning a cat, my recent work with JSPs
suggests it would be quite easy to create two JSP-run web pages:  one
for the author to choose their file and click "submit for publishing",
and another for the editor to see all files and click "approve".
Underneath the simple code running these two web pages, XSS can do the
rest for you.

Lisa
Director of Server Development
Xythos Software, INC (http://www.xythos.com)
Redwood City, CA

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jamil Kassam
> Sent: Wednesday, January 03, 2001 3:38 AM
> To: [email-masked]
> Subject: webdav help
>
>
> and copying them  to 2 locations  the first being the
>  all they should have to do is click on a button
> called Publish, and the application will perform the
> Question: is there such a publishing application or
> thing Ive found is sitecopy which is for
> software, but I cant seem to get my hands on it.