Subject: RE: Frontpage and webdav

From: David Engberg <[email-masked]>
Date: Mon, 29 Jan 2001 12:42:32 -0800

On a similar note ... has anyone found a good way to display WebDAV within
Outlook?  WebFolders shows up in the file dialog box under Outlook2000, but
files from there can't be used.  Has anyone found a way to display a WebDAV
path as a folder/tab within Outlook?

-----Original Message-----
From: Jim Whitehead [mailto:[email-masked]]
Sent: Monday, January 29, 2001 10:35 AM
To: Serge J. Goldstein; [email-masked]
Subject: RE: Frontpage and webdav

No, FrontPage 2000 only supports the FrontPage server extensions.  Web
Folders support both DAV and the FrontPage server extensions -- FrontPage
supports Web Folders as a UI, but only the FPSE aspects of them on the
protocol side.

- Jim

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Serge J. Goldstein
> Sent: Monday, January 29, 2001 7:22 AM
> To: [email-masked]
> Subject: Frontpage and webdav
>
>
> Probably been asked and answered (I couldn't find an answer in the list
> arhcive, or anywhere at the Microsoft site).  Does Frontpage 2000
> support webdav?
>
> Serge Goldstein
> Princeton University CIT

---

From: "S. Matthew Hersey" <[email-masked]>
Date: Mon, 29 Jan 2001 14:28:17 -0800

David,

You might want to examine Microsoft (R) Digital Dashboard to flesh out a solution to your issue.
http://www.microsoft.com/business/digitaldashboard/default.asp

The following article caught my eye, last summer.
http://msdn.microsoft.com/library/periodic/period00/dashboard.htm

This article on KM Solutions mentions interoperability of Outlook 2000 & DAV.
http://msdn.microsoft.com/library/techart/designkmsols.htm

Finally, please have a look at the recent article From the January 2001 issue of MSDN Magazine by Maarten Mullender, "Digital
Dashboards: Web Parts Integrate with Internet Explorer and Outlook to Build Personal Portals ", who suggests DDRK as a solution for
interoperability between WebDAV & Outlook.
http://msdn.microsoft.com/library/periodic/period01/DDRK2.htm

Excerpt 1:

"The factory assembles the contents of all the Web Parts, guided by the properties that tell it where to put each part, and then
sends the parts to the browser. The factory uses standard HTTP to communicate with the content providers and it uses Web Distributed
Authoring and Versioning (WebDAV) to communicate with the store. For more information on WebDAV, see the WebDAV interview with Jim
Whitehead at http://msdn.microsoft.com/workshop/standards/webdav.asp. "

Excerpt 2:

"The solution I have used may not be elegant, but it works. I have added an ActiveX® component that raises an event whenever the
selection changes in Outlook. This method will also work if the selection changes in the Outlook View control, but only if the view
control is hosted in a Web page that is hosted in Outlook. The code in Figure 14 shows a minimal implementation of such an ActiveX
control in Visual Basic®. It can easily be extended to send notifications only when a certain type of object, such as a contact, is
selected, or only when selections are being made in a specific folder."

Mr. Mullender's article concludes:

"By using the techniques shown in this article, you will be able to create Web Parts that can communicate with those created by
other developers. As a result, you will be able to write Web Parts that can be used in ways you haven't yet anticipated, making your
solution both flexible and scalable."

Might be worth a more in-depth analysis.

Stewart

-----Original Message-----
From: Jim Whitehead [mailto:[email-masked]]
Sent: Monday, January 29, 2001 10:35 AM
To: Serge J. Goldstein; [email-masked]
Subject: RE: Frontpage and webdav

- Jim