Subject: RE: trouble connecting to IIS5 from OS X PB

From: "Benn, Paul" <[email-masked]>
Date: Fri, 2 Mar 2001 14:45:24 -0800

Perhaps this is an OSX-ism which will be fixed when it is released this
month..??

-----Original Message-----
From: John Stracke [mailto:[email-masked]]
Sent: Friday, March 02, 2001 6:12 AM
To: Benn, Paul
Cc: [email-masked]'
Subject: Re: trouble connecting to IIS5 from OS X PB

But in 2616/4.4 (which discusses how to determine the length of the body),
the
only way I see to infer that no body is present is to know that the message
MUST NOT have a body (e.g., if it's a GET request or a HEAD response), or
else
to see that the server closed the connection after the message (does not
work
for requests).  So I think IIS5 is probably within its rights to require
Content-Length: 0...though I personally would have written it to be more
forgiving, and assume that no Content-Length: and no Transfer-Encoding:
implies
no body.

---

From: Clark Warner <[email-masked]>
Date: Sat, 3 Mar 2001 18:42:16 -0800

The Mac OS X, webdavfs has been updated.  It now actually sends
a PROPFIND body a request the specific properties that
it is interested in and thus sends the  content-length as well.  I think
there is still one case with a bug, however.  Does anyone know of
a public IIS5 webdav server that I can test against ?

- Clark

> forgiving, and assume that no Content-Length: and no Transfer-Encoding:

Clark H. Warner
Manager
CoreOS File Systems Engineering
[email-masked]
--------------------------------