Subject: RE: Issue: XML_LANG_CLARIFY

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 25 Apr 2001 16:46:41 -0400

To keep things simple, I would just disallow the xml:lang attribute
on the D:prop node.  In fact, I would indicate that all attributes 
on the D:prop node are ignored unless explicitly defined by the
protocol as being allowed there.

This allows a client to ignore attributes on the D:prop node, and
just store all attributes on the property node, without having to
understand the inheritance semantics of those attributes.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 3:44 PM
To: Clemm, Geoff
Cc: WebDAV WG
Subject: RE: Issue: XML_LANG_CLARIFY

To be persistant, I think we all agree the xml:lang attribute can be on the
property node and doesn't have to be on a child.  Do we agree that it can
even be on the parent of the property node and still be persistant?
Should we discourage the client from doing this though?

<D:set>
 <D:prop xml:lang="NL">
   <D:displaynname>Kikkers in de koek</D:displayname>
 </D:prop>
</D:set>

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 25 Apr 2001 23:01:23 +0200

I don't see any advantage as long as the inheritence rules are clearly
specified, such as in

<http://www.w3.org/TR/2001/REC-xml-c14n-20010315#DocSubsets>

-----Ursprüngliche Nachricht-----
Von: [email-masked]
[mailto:[email-masked]]Im Auftrag von Clemm, Geoff
Gesendet: Mittwoch, 25. April 2001 22:47
An: WebDAV WG
Betreff: RE: Issue: XML_LANG_CLARIFY

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 3:44 PM
To: Clemm, Geoff
Cc: WebDAV WG
Subject: RE: Issue: XML_LANG_CLARIFY

<D:set>
 <D:prop xml:lang="NL">