Subject: Re: Issue: PROP_ATTR

From: Greg Stein <[email-masked]>
Date: Fri, 13 Apr 2001 13:20:39 -0700

On Fri, Apr 13, 2001 at 03:28:46PM -0400, Jason Crawford wrote:
> 
> 
> <<
> <D:prop>
>   <theprop attr1="foo"/>
>   <theprop attr1="bar"/>
>   <theprop attr2="fee"/>
> </D:prop>
> >>
> I agree that this is not acceptable unless attr1 and attr2 are namespace
> attributes that alter the effective tag name of the property name tags.
> 
> This does lead me to another question though.  If in the PROPPATCH call
> there are xmlns attributes on the propertyupdate, set, or prop tags that
> could potentially affect the tags within the property value, is the server
> responsible for collecting those and representing those in PROPPATCH
> responses?   Or should we require that the client put any xmlns attributes
> that it cares about on the propertyname tag and within?

No way... we should not be demanding that an xmlns attribute lives in a
specific area. That seems to run completely counter to the notion of
namespaces and their scoping.

At a specific point in the XML body, an xmlns set and an xml:lang are "in
scope", and the server better be storing those.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: "Jason Crawford" <[email-masked]>
Date: Fri, 13 Apr 2001 15:28:46 -0400

<<
<D:prop>
  <theprop attr1="foo"/>
  <theprop attr1="bar"/>
  <theprop attr2="fee"/>
</D:prop>

J.

---

From: "Julian F. Reschke" <[email-masked]>
Date: Sat, 14 Apr 2001 12:23:04 +0200

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Friday, April 13, 2001 9:29 PM
> To: Kevin Wiggen
> Cc: WebDAV WG
> Subject: RE: Issue: PROP_ATTR
>
> ...
>

I think by choosing XML+Namespaces as transport protocol, WebDAV must adhere
to those rules. For the XML Infoset of a request, it makes little difference
where a particular namespace declaration occured.