Subject: Re: WRITE_DAV_PROP: Summary of consensus

From: "Jim Amsden" <[email-masked]>
Date: Mon, 16 Apr 2001 16:26:43 -0400

getlastmodified needs to be updatable to do a UNIX-like touch command. Sets
the modified date on a resource so dependent relationships are processed by
builders or make.

                    "Jim Whitehead"                                                                              
                    <[email-masked]>       To:     "WebDAV WG" <[email-masked]>                          
                    Sent by:                 cc:                                                                 
                    w3c-dist-auth-requ       Subject:     WRITE_DAV_PROP: Summary of consensus                   
                    [email-masked]                                                                                   

                    04/16/2001 03:20                                                                             
                    PM                                                                                           

Let me see if I can summarize the points of consensus on this issue:

Consensus:

- protected (i.e. properties that MUST NOT be modifiable with PROPPATCH)
  creationdate
  getcontentlength
  getetag
  lockdiscovery
  supportedlock
  resourcetype

- not protected (i.e. properties that MUST be modifiable by PROPPATCH)
  displayname
  source

Still under discussion:

  getlastmodified
  getcontenttype
  getcontentlanguage

There are two open issues:

1. Changing get* properties requires the server to perform a property
lookup
when processing a GET method request, and this is a performance hit for
some
servers.

2. It is unclear why getlastmodified needs to be writeable.

Let's see if we can resolve these remaining issues over the next 1-2 days,
so we can wrap this one up.

- Jim

---

From: "Jim Whitehead" <[email-masked]>
Date: Mon, 16 Apr 2001 13:52:19 -0700

> the modified date on a resource so dependent relationships are

There are two choices for building - client side and server side.  In client
side builds, the files are locally cached on client machine, and so the
existing "touch" command coul djust be used.

For server-side builds, the existence of a rich property mechanism means
that we can do much better than the "touch" hack.

This isn't a compelling scenario for me.

- Jim

---

From: "John Glavin" <[email-masked]>
Date: Mon, 16 Apr 2001 17:00:14 -0700

It doesn't really matter to me if the getlastmodified time can be written to
as long as there is some mechanism in DAV for allowing

1) A time stamp property that gets updated by the server whenever the file
contents are changed.  I suppose it could be debated about what other
changes to the file/properties might cause this property to change.

2) Allow the time stamp property to be modified by a client.

John Glavin
RiverFront Software
[email-masked]
http://www.webdrive.com