Subject: Re: Issue: PROP_ATTR

From: "Jim Amsden" <[email-masked]>
Date: Fri, 13 Apr 2001 18:20:36 -0400

I agree with Greg. One clarification. The property name may need a
namespace too. In this case, the usual XML rules should apply. Define a
namespace for the name. WebDAV specifies what this means: replace the
namespace prefix with it namespace value and concatenate it to the front of
the property name to create the key. This rule however DOES NOT APPLY to
the value. It is up to the application to determine how to handle the
namespace and prefix for the value. If the value doesn't specify a
different namespace, again the usual XML rules apply and the property name
namespace is also applied to element tags in the value, if they use the
prefix. If this is not what is desired, the clients can put a different
namespace on the value.

The only issues is what does the server store for the property key? The
name after prefix substitution? The namespace and prefix so they can be
reconstructed on a PROPFIND? I think the server needs to store all
namespace information on the property name because WebDAV says propery
names are XML tags.

On storing the property name (key) with the value: if its in the value,
store it with the value. If not, don't.

                    Greg Stein                                                                                   
                    <[email-masked]>        To:     WebDAV WG <[email-masked]>                            
                    Sent by:                 cc:                                                                 
                    w3c-dist-auth-requ       Subject:     Re: Issue: PROP_ATTR                                   
                    [email-masked]                                                                                   

                    04/13/2001 04:46                                                                             
                    PM                                                                                           

The issue is that <theprop> provides the name. The stuff inside that is the
property value. Attributes on the root are associated with the name, not
the
value.

Haven't we always tried to use element nesting as a means of structure?
Don't we tend to say that attributes are modifiers for the element they
occur on?

I'd rather not see attributes on the name supported. On the value, sure.

Maybe people are thinking that the name element is stored with the value. I
see it more as the name is a key, which then maps to the value. Further,
the
name (key) is broken into a tuple of (localpart, namespace-uri, xml:lang),
so I don't see it as stored as XML with the rest of the value. And since it
isn't in XML format, it becomes very difficult to store things such as
attributes.

Let's say that you *do* choose to store the name with the XML value. How do
you manage the namespace and xml:lang. Does the property always have to
store a private namespace to ensure that you don't get prefix clashes? For
example:

  <P:myprop xmlns:P="private-namespace-prefix-marker">value</P:myprop>

(as opposed to collecting a union of all namespace prefixes and placing
them
 on a higher element)

In the store-with-value approach, you're duplicating the data from the key
to the value. Maybe the word "normalization" is too loud in my head :-),
but
I prefer not to do that.

Cheers,
-g

On Fri, Apr 13, 2001 at 02:34:36PM -0400, Clemm, Geoff wrote:
> For dead properties, I don't see the issue wrt storing attribute values
> for the root element.  If you are storing attributes on all the nested
> elements (as I believe everyone has agreed), it should be trivial
> to store it on the root element as well.
>
> For live properties, where the server can take advantage of its knowledge
> of the value space for the live property values, then I agree that it
> could be an issue.
>
> So I still prefer saying MUST on all attributes of dead properties,
> and "as specified in the property definition" for live properties.
>
> Cheers,
> Geoff
>
> -----Original Message-----
> From: Kevin Wiggen [mailto:[email-masked]]
> Sent: Friday, April 13, 2001 12:02 PM
> To: Greg Stein; WebDAV WG
> Subject: RE: Issue: PROP_ATTR
>
>
>
> I agree with Greg et all that "attr2" needs to be stored.
>
> I believe that allowing "attr1" could lead to some interop problems, or
we
> need to spec this out a little better:
>
> <D:prop>
>   <theprop attr1="foo"/>
>   <theprop attr1="bar"/>
>   <theprop attr2="fee"/>
> </D:prop>
>
> Is that legal?  Does the attribute make the property unique?  Does simply
> the value of an attribute make it unique?  Or do we (like xmllang) simply
> store one set of attributes for a property?
>
> Also how does one use Dasl with attributes on properties?
>
> I would like to see attributes on the property name not be supported.
>
> Kevin
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Greg Stein
> Sent: Wednesday, April 11, 2001 1:06 AM
> To: WebDAV WG
> Subject: Re: Issue: PROP_ATTR
>
>
> The question isn't about attributes in general, it is about *which*
> attributes. Consider the following:
>
>   <D:prop>
>     <theprop attr1="foo">
>       thevalue
>       <subelem attr2="bar"/>
>     </myprop>
>   </D:prop>
>
> I believe everybody would agree that attr2 gets stored. The real question
is
> about attr1. I see that attribute as part of the element that *names* a
> property, but it isn't part of the property *value*.
>
> IMO, PROP_ATTR is about defining the boundary between property naming,
and a
> property's value.
>
> Cheers,
> -g
>
> On Tue, Apr 10, 2001 at 10:58:21PM -0700, Eric Sedlar wrote:
> > I agree.  There is no reason not to persist attributes.
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Mark A. Hale
> > > Sent: Tuesday, April 10, 2001 6:29 PM
> > > To: WebDAV WG
> > > Subject: RE: Issue: PROP_ATTR
> > >
> > >
> > > Jim:  Thanks for getting the issues list started.
> > >
> > > I believe that WebDAV must permit properties to have attributes.
> > > As you've
> > > pointed out, RDF and PRISM do use them extensively.  A server can
> reformat
> > > the attributes in a subsequent PROPFIND request.  Attrbiutes should
be
> > > persistent.
> > >
> > >           Thanks,
> > >
> > >           Mark
> > >
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]]On Behalf Of Jim Whitehead
> > > > Sent: Tuesday, April 10, 2001 5:54 PM
> > > > To: WebDAV WG
> > > > Subject: Issue: PROP_ATTR
> > > >
> > > >
> > > > As mentioned in a previous post, now is the time to start
> > > resolving issues
> > > > on the RFC 2518 issues list.  As fate would have it, the first
> > > > issue on the
> > > > list is one that has been contentious in the past. Can we come to
> > > > consensus
> > > > on it now?
> > > >
> > > > Issue: PROP_ATTR
> > > >
> > > > Description:
> > > >
> > > > What is a WebDAV server required to do with XML attributes other
than
> > > > xml:lang submitted with a PROPPATCH?  This affects how well
> > > WebDAV will be
> > > > able to support RDF, since RDF uses attributes extensively.
> > > >
> > > > Greg Stein originally raised this issue:
> > > >
> > > >
http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0089.html
> > > > See also:
http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0092.html
http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0094.html
http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0095.html
> > > >
> > > >
> > > >
> > > >
> > > >
> > >
> > >
>
> --
> Greg Stein, http://www.lyra.org/

--
Greg Stein, http://www.lyra.org/

---

From: "Julian F. Reschke" <[email-masked]>
Date: Sat, 14 Apr 2001 12:24:00 +0200

> [mailto:[email-masked]]On Behalf Of Jim Amsden
> Sent: Saturday, April 14, 2001 12:21 AM
> To: [email-masked]

Which contradicts the namespace spec and as far as I understand will be
removed from the RFC. Namespace name and local name NEVER should be
concatenated (that is, without well-defined delimiters), they are a pair,
that's it (see issue "XML_NS").

> prefix. If this is not what is desired, the clients can put a different

What you say is that namespaces within the contents of a property should
behave as defined in the XML namespaces recommendation, right?

> store it with the value. If not, don't.

That's an implementation issue, not a specification issue, correct?

---

From: Greg Stein <[email-masked]>
Date: Sat, 14 Apr 2001 17:26:33 -0700

On Sat, Apr 14, 2001 at 12:24:00PM +0200, Julian F. Reschke wrote:
> concatenated

Actually, it doesn't contradict the namespace spec. The spec is silent on
the issue of how to handle the URI and the localpart when used as an
identifier or key. In practice, everybody uses them as a tuple. However,
before this practice was really "observed", RFC 2518 took the position of
concatenation.

[ the WebDAV final draft went to the RFC Editor before XML Namespaces were
  finalized, and certainly before standard practices were identified ]

> (that is, without well-defined delimiters), they are a pair,

Yes, RFC 2518 will be changing to that interpretation for a number of
reasons.

Cheers,
-g