Subject: lock and access control lists on (working) versions

From: "Pill, Juergen" <[email-masked]>
Date: Tue, 15 May 2001 18:27:45 +0200

Hello,
 
1) Would it be possible with DETA-V to have different access control list
for different versions of a resource, e.g. V1 of resource /foo will allow
user A to modify and read, but V2 of resource /foo will allow user A to read
read only?
 
2) Would it be possible to have two distinct locks on two different
(working) resources?

Does that make sense at all?

Best regards
 
Juergen Pill

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 21 May 2001 11:18:28 +0200

Hi,

we are currently doing interoperability testing with our WebDAV server.

We found that GoLive 5.0 (evaluation version) seems to do a validation of
PROPFIND responses based on an internal DTD (or something similar).

For properties in the DAV: namespace that contain a child element "href"
(something completely legal), it reports:

"DAV-server response is not correct according to the DAV-Protocol, you will
probably lose some important information", with the details "Predecessor of
a Href-Tag must be a Response-, Locktoken, or Owner-Tag."

Do we have Adobe employees reading this list?

Julian

---

From: Hartmut Warncke <[email-masked]>
Date: Mon, 21 May 2001 11:33:54 +0200

Julian,

could you send the significant part of your server response so that we are able
to check what is going on?

Best, Hartmut

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 21 May 2001 11:57:01 +0200

OK,

here we go. This is a response to a PROPFIND with depth 1 on a collection
resource:

<multistatus xmlns="DAV:"
xmlns:dt="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <response>
    <href>/wcm/webdav/test/</href>
    <propstat>
      <prop>
        <supportedlock>
          <lockentry>
            <lockscope>
              <exclusive/>
            </lockscope>
            <locktype>
              <write/>
            </locktype>
          </lockentry>
        </supportedlock>
        <getlastmodified dt:dt="dateTime.rfc1123">Mon, 21 May 2001 09:50:49
GMT</getlastmodified>
        <lockdiscovery/>
        <resourcetype>
          <collection/>
        </resourcetype>
        <creationdate
dt:dt="dateTime.tz">2001-05-21T09:50:49Z</creationdate>
        <displayname>/</displayname>
        <orderingtype>
          <unordered/>
        </orderingtype>
        <getetag>"-18707824559904386492400"</getetag>
      </prop>
      <status>HTTP/1.1 200 OK</status>
    </propstat>
  </response>
  <response>
    <href>/wcm/webdav/test/ANSI.TXT</href>
    <propstat>
      <prop>
        <supportedlock>
          <lockentry>
            <lockscope>
              <exclusive/>
            </lockscope>
            <locktype>
              <write/>
            </locktype>
          </lockentry>
        </supportedlock>
        <getlastmodified dt:dt="dateTime.rfc1123">Fri, 18 May 2001 17:39:34
GMT</getlastmodified>
        <lockdiscovery/>
        <resourcetype/>
        <getcontentlength>29</getcontentlength>
        <creationdate
dt:dt="dateTime.tz">2001-05-18T17:39:34Z</creationdate>
        <displayname>ANSI.TXT</displayname>
        <getcontenttype>text/plain</getcontenttype>
        <getetag>"983715736990207574624990438302415"</getetag>
        <julian>
          <href>mailto:[email-masked]</href>
        </julian>
      </prop>
      <status>HTTP/1.1 200 OK</status>
    </propstat>
  </response>
</multistatus>

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Hartmut Warncke
> Sent: Monday, May 21, 2001 11:34 AM
> To: Julian Reschke
> Cc: [email-masked]
> Subject: Re: Problem with Adobe GoLive 5.0's parsing of PROPFIND
>
>
>
> Julian,
>

---

From: Hartmut Warncke <[email-masked]>
Date: Mon, 21 May 2001 13:11:59 +0200

The problem is probably caused by ...

    <julian>

... because we do some rough checks against the WebDAV DTD of RFC2518; a
DAV-href-tag is not expected in the user defined tag "julian".

An error message is displayed but this should actually not have any further
consequences.

Best, Hartmut

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 21 May 2001 13:28:18 +0200

I agree with your analysis.

Do you intend to fix this?

> From: Hartmut Warncke [mailto:[email-masked]]
> Sent: Monday, May 21, 2001 1:12 PM
> To: Julian Reschke
> Cc: [email-masked]

---

From: Hartmut Warncke <[email-masked]>
Date: Mon, 21 May 2001 14:41:13 +0200

I think we will try to improve that situation in future releases,

Best, Hartmut

---

From: Laurie Harper <[email-masked]>
Date: Tue, 22 May 2001 12:07:05 -0400

>           <href>mailto:[email-masked]</href>

Just to be clear: the element 'julian' appears in the default namespace,
which is the DAV namespace.  Since that namespace doesn't define an element
named 'julian' this is likely to cause trouble.

You probably want to place that element in a different namespace, one
controlled by you.

L.
-- 
http: www.holoweb.net/~zodiac/   |   jabber: zodiac(@)jabber!org
email: zodiac(@)holoweb!net      |   icq: #78724820
-----------------------------------------------------------------
   condom: general protection error, child process produced.

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 24 May 2001 23:49:24 +0200

> [mailto:[email-masked]]On Behalf Of Laurie Harper
> Sent: Tuesday, May 22, 2001 6:07 PM
> To: Julian Reschke
> Cc: Hartmut Warncke; [email-masked]

Contrary to some big company in Redmond, I am well aware of the fact that
the DAV: namespace shouldn't be abused with proprietary extensions. This was
just an example.

Moving it to some other namespace doesn't change GoLive's behaviour (and
even if it would, it would still be a problem for GoLive because other
WebDAV specs (ACL for instance) *do* use DAV:href in DAV properties where
GoLive doesn't expect them).