Subject: RE: Status code for creating lock-null resource

From: "Hall, Shaun" <[email-masked]>
Date: Thu, 21 Jun 2001 09:20:21 +0100

> -----Original Message-----
> From: Jim Whitehead [mailto:[email-masked]]
> Sent: 21 June 2001 00:50
> To: WebDAV WG
> Subject: RE: Status code for creating lock-null resource

[snipped]

> > > Since a lock null resource has state, I would claim it is a
> > > resource. By the act of a client taking out a lock, they have
> > > likely made a mapping of a URL to a conceptual resource, and
> > > are int he process of fleshing out the computer representation
> > > of the conceptual resource.
> >
> > Agreed.  Moving the server state of an 'unmapped-URL where 
> the immediate
> > parent exists' from no resource to a resource should, IMHO, 
> respond with
> > 201 Created.
> 
> This makes sense to me. My concern is that it would still be 
> nice for the
> first PUT after a lock-null is created to also return a 201.
> 
> - Jim
> 

Just double checked MKCOL. It of course returns 201 upon success, never 200.
So your above suggestion would match MKCOL as well. Assuming no errors,
expected behaviour would be:

1) Client issues LOCK, "creating" an LNR, returns 201.
2) Client issues PUT or MKCOL on the LNR, either of which return 201.

Which of course is consistent, duh.

Regards

Shaun Hall
Xerox Europe

---

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 21 Jun 2001 09:53:21 -0700

> 2) Client issues PUT or MKCOL on the LNR, either of which return 201.

That certainly would be my preference for the behavior.  I've added a note
in the issues list about this.

- Jim