Subject: Error Messages

From: "Fuller, Dan" <[email-masked]>
Date: Thu, 21 Jun 2001 12:46:36 -0500

I am a Newbie, but I am using WebDAV in my work and I have been
following the thread for a couple of weeks now.  Would it be possible to
make the error for 400: Bad Request a little more specific?  It would be
nice to have something along the lines of the following examples:
 
40x: Bad Request: Metatag '<foo>' not supported
 
40x: Bad Request: Metatag start tag '<prop>' does not match end tag
'</propertyupdate>'
 
40x: Bad Request: Request not well-formed

---

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 21 Jun 2001 12:10:11 -0700

There's a proposal on the table for adding more detail to status codes like
400 Bad Request, without allocating new numbers. Instead, it adds extensible
codes to the body of the error response (where legal).  Please see:

http://lists.w3.org/Archives/Public/w3c-dist-auth/2000OctDec/0130.html
http://lists.w3.org/Archives/Public/w3c-dist-auth/2000OctDec/0137.html

I'd be willing to pursue this if there's sufficient interest from other
implementors.

lisa

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Fuller, Dan
> Sent: Thursday, June 21, 2001 10:47 AM
> To: [email-masked]
> Subject: Error Messages
>
>