Subject: RE:MOVE fails on collection when IP address is used in the Destination header.

From: "Sung Kim" <[email-masked]>
Date: Tue, 26 Jun 2001 01:02:21 +0900 (KST)

>Hi Folks,
> I'm running into something that I could use some help with. I'm
>trying to rename a collection and am receiving a 502 Bad Gateway.

I think this is misimplement of the server.
As you know the RFC dosen't say about the using IP address or
hostname in Destination header.

But you must use the same host name(ot IP address) 
in Host and Destination header.

IP address destination header works on Microsoft-IIS/5.0.

MOVE /hunkim HTTP/1.1
Host: hunkim.kebi.com
Destination: http://12.99.96.140/hunkim2
   
HTTP/1.1 207 Multi-Status
Server: Microsoft-IIS/5.0
Date: Mon, 25 Jun 2001 15:48:45 GMT
Content-Type: text/xml
Transfer-Encoding: chunked

b5
<?xml version="1.0"?><a:multistatus xmlns:a="DAV:"><a:response><a:href>http://12.99.96.140/hunkim2</a:href><a:status>HTTP/1.1 502 Bad Gateway</a:status></a:response></a:multistatus>
0

MOVE /hunkim HTTP/1.1
Host: 12.99.96.140
Destination: http://12.99.96.140/hunkim2

HTTP/1.1 201 Created
Server: Microsoft-IIS/5.0
Date: Mon, 25 Jun 2001 15:52:39 GMT
Location: http://12.99.96.140/hunkim2/
Content-Type: text/xml
Content-Length: 0

-- 
"Dreams become reality!" 
[email-masked] 

            Free webmail hosting service MNARA.NET
-- This e-mail was sent by FREE KEBI Mail at http://kebi.com/--

---

From: "Keith Wannamaker" <[email-masked]>
Date: Mon, 25 Jun 2001 11:08:27 -0400

This is only true for servers which lack support for cross-server copies.
Xythos, for example, supports this so the host and destination header 
can be different.

Keith

| -----Original Message-----

| I think this is misimplement of the server.
| As you know the RFC dosen't say about the using IP address or
| hostname in Destination header.
| 
| But you must use the same host name(ot IP address) 
| in Host and Destination header.