Subject: Re: MSIE question related to WebDAV

From: "Tim Ellison" <[email-masked]>
Date: Wed, 4 Jul 2001 10:36:34 +0100

Alan Kent <[email-masked]> wrote:

> This is not really a WebDAV question, but more of a
> question of integrating WebDAV nicely with Web
> browsers (such as MSIE).
>
> I think the answer is no, but is there any way to tell
> Microsoft Internet Explorer (or Netscape for that
> matter I guess) that a URL in a <A HREF="..."> or
> similar is in a DAV folder, so it should use the
> application to natively load the document.
>
> For example, if I have a Word document in a DAV web
> folder, and I have a web page with a <A HREF="...">
> pointing to the document, then if the user clicks on
> the link, IE will download the file, put it into a
> temporary directory, then start up Word on the
> downloaded file. So Word does not talk to the WebDAV
> repository. I would rather give Word the URL and say
> 'hey, you load it yourself'. That way Word can save
> the changes directly back to the Web DAV folder.
>
> My best solution so far is to put on the web page a
> URL to a document that contains the URL of the DAV
> resource to be edited, give the first URL a file
> extension of .xyz, get the user to associate a small
> program to the .xyz file extension which starts up
> Word with the second URL on the command line.
>
> Any other brilliant ways of doing this without having
> to reconfigure the user's web browser first?

For an IE-specific solution you can use the FOLDER attribute of an href.

The description is given here
http://msdn.microsoft.com/library/default.asp?url=/workshop/author/behaviors/overview/WebFolder.asp

As far as I am aware there is no equivalent in Netscape.

Regards,

Tim Ellison
Java Technology Centre, MP146
IBM UK Laboratory, Hursley Park, Winchester, UK. SO21 2JN
tel: +44 (0)1962 819872  internal: 249872  MOBx: 270452

---

From: Alan Kent <[email-masked]>
Date: Thu, 5 Jul 2001 16:15:18 +1000

> http://msdn.microsoft.com/library/default.asp?url=/workshop/author/behaviors/overview/WebFolder.asp

Thanks for the link. From my reading of this, it seems I can get IE
to open up a folder. Can I get it to immediately launch Word on a
particular document? Or do I have to open the folder then ask the
user to double-click on the correct document in the folder?

In case others are listening, I used the following HTML

    <A STYLE="behavior:url('#default#AnchorClick')" ID="sID"
	HREF="http://localhost:4444/foo/myslides.ppt"
	FOLDER="http://localhost:4444/foo/"
	TARGET="_top">
	    My Slides
    </A>

Clinking on 'My Slides' in IE5 brought up the directory (inside IE) with
the file in it. Double clicking on the file in the web folder caused
Power Point to load the document via WebDAV, then save the changes back
when I was finished. Quite nice really, but not the user had to click
on the particular file in the folder - I cannot get it to start
power point directly on the myslides.ppt file from a web page.

Note: I tried changing the FOLDER="..." to ../foo/myslides.ppt and
IE just ignored the file name on the end (dropped it). I then tried
.../foo/myslides.ppt/ (OK, I am a hacker at heart). IE said "Not enough
memory to complete your operation."

Alan