Subject: RE: issue: XML Namespace Concatenation

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 29 Nov 2001 18:30:59 -0500

I would want us to remove any reference to concatentation,
and to just say that a tag name is identified by the pair:
<namespace-URI, xml-node-name>

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Thursday, November 29, 2001 6:09 PM
To: [email-masked]
Subject: issue: XML Namespace Concatenation

In a recent discussion, several people expressed dissatisfaction with
rfc2518  section 23.4 which says that the Namespace URI and the local part
are concatenated to determine the qualified tag name.  I think someone even
suggested that it was on the issues list and was going to be changed.  As I
look at the issues list, there is an item for it, but it doesn't look like
it was resolved to take any action.

What's the verdict on this issue?

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 30 Nov 2001 09:42:39 +0100

Correction: <namespace-URI, xml-local-node-name>

This is basically what the XML namespace rec says.

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Friday, November 30, 2001 12:31 AM
> To: [email-masked]
> Subject: RE: issue: XML Namespace Concatenation
>
>

---

From: Greg Stein <[email-masked]>
Date: Fri, 30 Nov 2001 01:56:04 -0800

I agree with Geoff.

mod_dav certainly treats the namespace/name thing as a tuple, rather than a
concatenation. In other words, ns="DAV:" name="foo" is different from
ns="DAV:f" name="oo".

It seems that I recall one conversation that said that most clients and
servers treated it that way.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 30 Nov 2001 10:59:27 +0100

There's a summary in:

http://lists.w3.org/Archives/Public/w3c-dist-auth/1999OctDec/0343.html

> [mailto:[email-masked]]On Behalf Of Greg Stein
> Sent: Friday, November 30, 2001 10:56 AM
> To: [email-masked]
> Subject: Re: issue: XML Namespace Concatenation
> 
> 
> I agree with Geoff.
>