Subject: web folders incompatibility?

From: Greg Stein <[email-masked]>
Date: Sun, 4 Nov 2001 19:52:00 -0800

It seems that I just ran into a problem with Web Folders and wondered if
anybody else has seen this. Or if my assumptions are mistaken :-)

I set a property on a file like so:

    <prop3 xml:lang="de">x</prop3>

There is no default namespace defined. When I select "Properties" in a Web
Folder, it pops up an error dialog saying "Unable to display properties."

I've narrowed it down to exactly this property. Just setting this one single
property on a file will do it.

Has anybody else seen this? Or duplicate it?

The User-Agent is "Microsoft Data Access Internet Publishing Provider DAV 1.1"

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 5 Nov 2001 09:45:51 +0100

If you are doing this with mod_dav, you might be hitting the bug (in
mod_dav) I have reported recently:

<http://lists.w3.org/Archives/Public/w3c-dist-auth/2001OctDec/0041.html>

Do you have a trace to verify?

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Greg Stein
> Sent: Monday, November 05, 2001 4:52 AM
> To: [email-masked]
> Subject: web folders incompatibility?
>
>

---

From: Greg Stein <[email-masked]>
Date: Mon, 5 Nov 2001 04:22:44 -0800

Totally unrelated to that.

Sheesh. And I left out the most important part. The setting of xml:lang is
what blows it up.

Cheers,
-g

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 5 Nov 2001 14:44:20 +0100

Indeed.

I can reproduce your problem with IE6 + Sharepoint Client. It seems that the
webfolder client gets the namespace Uri and fails to foresee the case that
it may be null.

What's interesting is that the client is asking for all properties, although
it will only display a hardwired set.

Julian

> Sent: Monday, November 05, 2001 1:23 PM
> To: Julian Reschke
> Cc: [email-masked]
> Subject: Re: web folders incompatibility?
>
>