Subject: RE: [ACL] Principal Identity

From: "Lisa Dusseault" <[email-masked]>
Date: Mon, 19 Nov 2001 22:39:33 -0800

> The nice thing about allprop is that you get all the dead properties.
> The bad thing about allprop is that you cannot see if a resource is
> versioned/version or which methods it does support.

How do you know you can get all the dead properties?  'allprop' as defined
in RFC2518 seems to have to change, yet we've not clearly defined a new
behaviour.  In the meantime, I don't believe clients can rely on getting
anything back in 'allprop' except the live properties defined in RFC2518.

Lisa

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 20 Nov 2001 21:26:13 +0100

Lisa,

I think that's a bit pessimistic.

Neither deltaV nor ACL say anything about a behavorial change in PROPFIND
for dead properties.

I agree that better protocol over selection (exclude lists? by namespace?)
might be nice.

Julian

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> Sent: Tuesday, November 20, 2001 7:40 AM
> To: Stefan Eissing; Jim Whitehead; Webdav WG
> Subject: RE: [ACL] Principal Identity
>
>
>
>

---

From: "Stefan Eissing" <[email-masked]>
Date: Wed, 21 Nov 2001 14:15:23 +0100

> From: Lisa Dusseault [mailto:[email-masked]]

Since no new behaviour is defined, I would expect servers to return all
dead properties on <allprop/>, yes.

I agree that the <propfind> mechanism should be enhanced. Therefore
our <include/> proposal, which does not claim to solve all issues.

//Stefan