Subject: RE: RFC2518 (WebDAV) / RFC2396 (URI) inconsistency

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 28 Nov 2001 18:13:42 -0500

I do not understand your point here.

WebDAV uses XML namespaces to provide extensibility for
property names, not because it lets the examples
be shorter.

If you are going to use namespaces,
you have to have an xmlns declaration, and "D:" is as good
a choice for a namespace identifier as any other.

Cheers,
Geoff

-----Original Message-----
From: Roy T. Fielding [mailto:[email-masked]]

I still think it is incredibly stupid for the webdav examples to be using
"D:" as an xmlns, since the only thing that accomplishes is an unnecessary
dependency on XML namespaces.

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 28 Nov 2001 15:55:53 -0800

> property names, not because it lets the examples

Maybe that should be said in the spec.

> a choice for a namespace identifier as any other.

Ah, finally an explanation that makes some sense!  I should have known it
was something as simple as XML being, well, XML-ish.

....Roy