Subject: RE: RFC2518 (WebDAV) / RFC2396 (URI) inconsistency

From: [email-masked]
Date: Thu, 29 Nov 2001 14:21:32 +0200

> In other words, I think that "scheme:" is only a valid 
> identifier for the
> namespace if the scheme defines it as such.

Fair enough. Though it seems that an RFC revision would
still be in order to permit schemes to define "scheme:"
as a valid absolute URI -- and also once some schemes
adopt such a practice, it will be pretty darn hard to
keep folks from presuming that "foo:" is the canonical,
official URI denoting the scheme.

It may be more practical to just state it once and
for all in a revision of the RFC. Otherwise, all
existing schemes that would like to use "scheme:" would
themselves have to be revised.

Clearly, though, namespace and other sub-scheme identifiers
(e.g. "urn:issn:" etc.) are the domain of each particular
scheme as to whether they are meaninful or allowed.

Cheers,

Patrick

--
               
Patrick Stickler              Phone: +358 50 483 9453
Senior Research Scientist     Fax:   +358 7180 35409
Nokia Research Center         Email: [email-masked]

---

From: "Larry Masinter" <[email-masked]>
Date: Thu, 29 Nov 2001 09:21:03 -0800

> official URI denoting the scheme.

It's pretty darn hard to keep folks from presuming that the
moon is made from cheese, too, despite the fact that it
wasn't when we got there. So if the official RFC says
that an undecorated "scheme:" is only valid if the scheme
definition says it is, and it only means what the scheme
definition says it means, well, we'll just have to put up
with those cheesy jokers who decide it means something else.

> themselves have to be revised.

How does a URI scheme 'want' to do something? 

If YOU want to identify the URI scheme itself, you need
something else. I would suggest using the process in
  http://www.ietf.org/draft/draft-mealling-iana-urn-02.txt
making a "uri-scheme" space, and then using, say, 

      urn:ietf:uri-scheme:http

if you want to talk about the "http" URI scheme.
I think it must be the case that "http:" remains illegal
as a URI even though "DAV:" would be allowed.