Subject: Re: Purpose of Namespace

From: "Jason Crawford" <[email-masked]>
Date: Thu, 29 Nov 2001 01:01:03 -0500

On Wed, Nov 28, 2001 at 06:13:42PM -0500, Clemm, Geoff wrote:
> > I do not understand your point here.
> >
> > WebDAV uses XML namespaces to provide extensibility for
> > property names, not because it lets the examples
> > be shorter.
> Maybe that should be said in the spec.

I can add that to the issues/todo list, but I think I've heard Jim and a
few other people mention something about the prefered style of prose in the
spec, so I thought I'd check first...

Is this something we want to put in the spec... or would we put that in a
meta document?... like an annotated spec?

If latter, I'm sure I can denote that in the issues list.

J.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 29 Nov 2001 09:51:16 +0100

I don't think that the spec should make any attempt to explain how XML
works.

What *could* be done is to vary the XML style in the examples. For instance,

<multistatus xmlns="DAV:" />

is even shorter, and as readable (at least in those examples where no mixing
with other namespaces is needed).

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Thursday, November 29, 2001 7:01 AM
> To: Roy T. Fielding
> Cc: Clemm, Geoff; 'WebDAV'
> Subject: Re: Purpose of Namespace
>
>
>
>