Subject: RE: DASL - who wants to use it? (requirements spec?)

From: "Pill, Juergen" <[email-masked]>
Date: Fri, 7 Dec 2001 19:42:32 +0100

Hello Alan,

You mentioned it, DASL define a mini query language to query property mostly
and "server-defined" query languages, that can do want they want (the only
thing those languages need is clients supporting those languages).

I have the feeling, that also the mini query language should be extendable
to define additional content operators. A query covering both content and
properties is required to my understanding (again the question of available
clients).

An extendable mini query language would reduce the need to define an own
"server-defined" query language and you get both content and property query
in a more "standard" way.

Best regards,

juergen pill

 -----Original Message-----
From: 	Alan Kent [mailto:[email-masked]] 
Sent:	Friday, December 07, 2001 09.25 AM
To:	WebDAV
Subject:	DASL - who wants to use it? (requirements spec?)

I remember the recent question about DASL (was it this list?).
I was wondering if part of the problem with DASL is the question
of whether it addresses a need, or addresses it appropriately.

We have a text searching engine that can do lots of funky searches
etc. on the content of resources using fields (lets say dublin
core elements). But this would be quite a different thing to
querying on WebDAV properties.

Hence I was interested to understand better the goal of DASL.
Is it to be able to query WebDAV properities (and nothing else).
Or was it intended to be broader and cover the harder problem
of querying content as well?

Just curious to understand the intended scope better before
I jump in. I found a reference to a dasl requirements document
(I have not looked it up yet). But is it still valid? I ask
only because if its been a while and if no one has implemented
it, is it because they have been busy, or because DASL has
missed the mark in some way?

Alan

ps: I noticed that DASL seems to allow other queries to be
plugged in. While this is good, for the above I am not after
an answer like "you can do anything you like". I am more
interested in "what do people like/want?"

pps: I also noticed that the "basic" query langauge looked
rather long when you got down to it - orderby, contains, like,
three value logic... Convienient if you have an SQL engine around
I guess.

---

From: "Adam Freeman" <[email-masked]>
Date: Fri, 7 Dec 2001 11:04:55 -0800

Is that a rhetorical question?  I would think anybody with a searchable
website would want to use DASL...

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Pill, Juergen
Sent: Friday, December 07, 2001 10:43 AM
To: 'Alan Kent'; WebDAV
Subject: RE: DASL - who wants to use it? (requirements spec?)

Hello Alan,

Best regards,

juergen pill

 -----Original Message-----
From: 	Alan Kent [mailto:[email-masked]]
Sent:	Friday, December 07, 2001 09.25 AM
To:	WebDAV
Subject:	DASL - who wants to use it? (requirements spec?)

Alan

---

From: "Jim Whitehead" <[email-masked]>
Date: Fri, 7 Dec 2001 14:47:00 -0800

> (I have not looked it up yet). But is it still valid?

In the past, we produced both a Scenarios and a Requirements specification.
I believe that both are still largely valid.  The only significant new
factor that has emerged since these documents were initially drafted is the
XML Query effort.

The scenarios and requirements documents can be found at:
http://www.webdav.org/dasl/

- Jim

---

From: Ilya Kirnos <[email-masked]>
Date: Fri, 07 Dec 2001 17:31:59 -0800

That's what I would think as well... Both properties and content searchability
would be good.