Subject: RE: Purpose of Namespace

From: "Clemm, Geoff" <[email-masked]>
Date: Sun, 2 Dec 2001 14:05:11 -0500

I'd vote for the latter (i.e. just refer to the property without
the namespace), but either is OK by me.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Saturday, December 01, 2001 6:09 PM
To: [email-masked]
Subject: RE: Purpose of Namespace

<<
So I'd say all that needs to be done is to get rid of the sentence that
refers to concatenating the namespace URL with the local node name,
and we are done with this issue.
Sounds good.

One other thing is that in places where it refers to a property with it's
concatenated name, I'll have to change
the reference to use a [URI, local name] pair.

For example section 8.2.2...

   In this example, the client requests the server to set the value of
   the http://www.w3.com/standards/z39.50/Authors property, and to
   remove the property http://www.w3.com/standards/z39.50/Copyright-
   Owner.  Since the Copyright-Owner property could not be removed, no

becomes

   In this example, the client requests the server to set the value of
   the [http://www.w3.com/standards/z39.50/,Authors] property, and to
   remove the property [http://www.w3.com/standards/z39.50/,Copyright-
   Owner].  Since the Copyright-Owner property could not be removed, no

or perhaps

   In this example, the client requests the server to set the value of
   the Authors
property, and to
   remove the property      Copyright-
   Owner.  Since the Copyright-Owner property could not be removed, no

If you have a preference for this, let me know, otherwise I'll just figure
it out.

J.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Stefan Eissing" <[email-masked]>
Date: Mon, 3 Dec 2001 10:07:38 +0100

I also think the latter is better readable.

As an alternative (I think) James Clark once proposed
to use a wording like
  {http://www.w3.com/standards/z39.50/}Authors
if a name with namespace needs to be mentioned.

But if the namespace is clear from the context, why bother...

//Stefan

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Sunday, December 02, 2001 8:05 PM
> To: [email-masked]