Subject: Issue: IS_HREF_A_CHILD_OF_KEEPALIVE

From: "Jason Crawford" <[email-masked]>
Date: Wed, 30 Jan 2002 23:16:03 -0500

I've added this to my local copy of the issues list.  Anyone want to
comment on it?  Support?  Dissent?

Julian alluded to the possibility of keepalive going away.    FWIW... I
don't see anything like that listed on the issues list.

J.

------------------------------ Julian wrote... --------------------
Hi.

Currently, RFC2518 says in 12.12.1 [1]:

   <!ELEMENT keepalive (#PCDATA | href+) >

So individual properties are identified by "href" (which doesn't make sense
in the general case).

So (assuming that propertybehaviour/keepalive isn't dropped anyway), this
will need to be changed to:

   <!ELEMENT keepalive (#PCDATA | prop+) >

where DAV:prop contains property elements.

Julian

[1] <http://www.greenbytes.de/tech/webdav/rfc2518.html#ELEMENT_keepalive>

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Stefan Eissing" <[email-masked]>
Date: Thu, 31 Jan 2002 16:49:39 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> [...]

The issue is not explicitly on the list, however it is related
to COPY_LIVE_PROPS. 
The issues I have with keepAlive are
a) how does the client know which property is live in the first place?
b) deltaV copy semantics forbid using keepAlive on version properties
c) If the destination is on another server, WebDAV has no means to
   fulfill keepAlive. It is not possible to know if the remote server
   knows the requested live props.
d) Is there any server/client using it? (I have not seen any)

I would propose to 
1) remove keepalive, maybe allow omit
2) change default copy behaviour to _not_ copy live properties

//Stefan

---

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 31 Jan 2002 10:05:16 -0800

There is a much deeper issue with keepalive, and that is that no client at
the interop claimed to use the  feature.  Therefore interoperability has not
been, and cannot easily be, demonstrated.

Are there now clients out there that can demonstrate that keepalive works?
Or is it one of those ideas that just isn't useful enough to clients for
them to implement?

If its not useful enough for clients to implement, then it should be removed
from WebDAV so the protocol can go to the next phase of standardization.

Lisa

> -----Original Message-----
> [mailto:[email-masked]]On Behalf Of Stefan Eissing
> Sent: Thursday, January 31, 2002 7:50 AM
> To: Jason Crawford; Julian Reschke
> Cc: [email-masked]
> Subject: RE: Issue: IS_HREF_A_CHILD_OF_KEEPALIVE
>
>
> > [1]
<http://www.greenbytes.de/tech/webdav/rfc2518.html#ELEMENT_keepalive>