Subject: FW: How do I make my app DAV-aware?

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 10 Jan 2002 12:26:47 -0800

Accidentally caught by the spam filter.  I have added <[email-masked]> to
the accept2 list.

- Jim

-----Original Message-----
From: Michael Datuin [mailto:[email-masked]]
Sent: Wednesday, January 09, 2002 6:53 PM
To: [email-masked]
Subject: [Moderator Action] How do I make my app DAV-aware?

Hi!

I'm a newbie to WebDAV and have just recently started
looking at some WebDAV resources.

I have an application that prompts the user for the
filename and location to where he/she wants to save
the
data file that my app creates.  This prompt is just
the
common save dialog and works well if the data file is
being saved to the local drive of the user's PC.  But,
when the location is on webfolder, I get the following
message

  "You cannot save in the folder you specified.
Please choose another location."

I've tried creating a dummy text file with both MS
WordPad and
Notepad (on a PC using Win2K), and tried to save (via
the common
save dialog) to the webfolder.  Both cases give the
above message.

But, when I tried to do the same test using Microsoft
Word 2000, the
save operation works.

Also, I tried another test with Webdrive
(www.webdrive.com) and mapped a
drive letter to the webfolder, used that drive letter
and filename
in my app, and that worked.

So, my question is, how do I make my app work like
Microsoft Word in
it's use of the common save dialog?  Or do I have to
write a network
redirector (which I have no idea how to do yet) to
mimic what the
Webdrive software is doing?

I just want to allow my app to support the user's
action of
browsing to the webfolder (in the common save dialog
of my app) and
clicking on the Save button.

Any info would greatly be appreciated!

Thanks!

-Michael

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 10 Jan 2002 13:06:49 -0800

> Webdrive software is doing?

Yes, you would have to write a network redirector, which might involve
modifying the application, or install WEbDrive.  I don't believe Microsoft
makes its Web Folders API available for common use, but you might look into
that as well.

The reason Word works but Notepad doesn't, is because Word has special code
to use Web Folders (part of Network Places in some Windows OS) and Notepad
doesn't have that special code.

In other words, Web Folders can't be used by just any application
automatically -- special code has to be added.

Lisa

---

From: "Dennis E. Hamilton" <[email-masked]>
Date: Thu, 10 Jan 2002 14:18:23 -0800

I did a search on Web Folders on Microsoft's MSDN Online and found

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/off2000/htm
l/ppconAboutWebFolders.asp
	About Web Folders (remember to concatenate this URL to use it)

and
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/off2000/htm
l/fpobjWebFolder.asp
	documents the Web Folder object, which you should be able to use.

I stopped on this one, but there should be more, especially in Office
Developer if not elsewhere.

You might want to look at making your application ODMA compliant as well.
(Word 2000 is.  Sometimes.)

This won't get you to Web Folders directly, but we are looking at building
an ODMA DMS Driver that provides Web Folders / WebDAV access.

I don't have a promise on when we will have done that, though I would like
prototype code running by AIIM 2002 in the first full week of March.

Let me know whether the C Language ODMA API is something that is usable in
your application.  (There is a dormant project to make an ActiveX /
Automation interface, but I need to put a bomb in that volcano.)

If the API is usable, I can sketch a way to migrate if you are interested.
Otherwise, you might dig into using Web Folders directly.  It may take some
work.

-- Dennis

Dennis E. Hamilton
AIIM DMware Technical Coordinator
------------------
mailto:[email-masked]  tel. +1-206-932-6970
http://www.dmware.org           cel. +1-206-779-9430
     ODMA Support http://www.infonuovo.com/odma

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jim Whitehead
Sent: Thursday, January 10, 2002 12:27
To: WebDAV
Subject: FW: How do I make my app DAV-aware?

- Jim

-----Original Message-----
From: Michael Datuin [mailto:[email-masked]]
Sent: Wednesday, January 09, 2002 6:53 PM
To: [email-masked]
Subject: [Moderator Action] How do I make my app DAV-aware?

Hi!

Thanks!

-Michael

---

From: "Simon Hill" <[email-masked]>
Date: Thu, 10 Jan 2002 22:35:20 -0000

Hi all

Some of you have helped me out in the past, so I am hoping this group will
help me again.

I need to build an IIS database-based webDAV server, for want of a better
description.

My fundamental problem seems to be that I can't stop IIS from taking the
webDAV request, and, i) on the one hand, locking my script files as if they
were the files to be manipulated rather than a script to be run, and ii) on
the other (if I lock webDAV down in attempt to let the header rewrite pass
to my script), forbidding passage of any webDAV HTTP at all to my
header-rewriting ISAPI filter.

I have to pass the webDAV traffic to a script where I can parse the headers
and translate them into database calls.

I don't want to have to write my own webDAV client to do this, as I would
like the system to interface with Dreamweaver 4 and Homesite 5 webDAV
clients, where the locking phenomena appears.

I don't see any other way of implementing the multi-user, version-controlled
asset management that my application needs.

yours hopefully

Simon

---

From: "Henrik Genssen" <[email-masked]>
Date: Fri, 11 Jan 2002 09:28:02 +0100

Do you want to handle the Webdav calls by a script or an ISAPI extension?
I think the ASP-dll won't let you do this - maybe perl or php via cgi or isapi...

but what you can do is:
build an ISAPI-filter manipulating the requested file by adding a new extension - saying ".dav" and than let IIS handel all incomming calls by a second ISAPI extension that does your job.
This works fine throughout IIS3+.

Henrik

---

From: "Steve Lomicka" <[email-masked]>
Date: Fri, 11 Jan 2002 12:36:57 -0500

If by script you mean .ASP script, I don't think .ASP will let you intercept
HTTP requests soon enough in the IIS chain of events.  I'm feel pretty
confident that you will have to get inside of IIS via ISAPI filters and C++.

HTH, Steve

> [mailto:[email-masked]]On Behalf Of Simon Hill
> Sent: Thursday, January 10, 2002 5:35 PM
> To: 'WebDAV'