Subject: RE: HOW_TO_IDENTIFY_LOCK_OWNER

From: "Jason Crawford" <[email-masked]>
Date: Tue, 29 Jan 2002 09:36:14 -0500

> (b) Add it to a DAV extension.

Given the current grammar, have we left a route to do this?   Not as a
child of DAV:lockinfo I believe.  Perhaps as a child of DAV:owner?

I believe one of the things we were going to do was define what it meant
for the server to maintain DAV:owner.  At least one person thought there
was some ambiguity there.  Do we still feel that this is an issue?

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 29 Jan 2002 15:49:23 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Tuesday, January 29, 2002 3:36 PM
> To: Lisa Dusseault
> Cc: Daniel Brotsky; Clemm, Geoff; Julian Reschke; [email-masked]
> Subject: RE: HOW_TO_IDENTIFY_LOCK_OWNER
>
>
>

Sure. WebDAV explicitly states that servers and clients MUST ignore unknown
element.

> was some ambiguity there.  Do we still feel that this is an issue?

Yes.

1) The examples in RFC2518 do *not* preserve DAV:owner (watch out for
whitespace!).

2) We currently don't have a clear definition about *what* needs to
preserved as a property value (this is already on the issues list). Whatever
applies to a property value should reply to the DAV:owner element as well.

Julian

---

From: Daniel Brotsky <[email-masked]>
Date: Tue, 29 Jan 2002 11:36:26 -0800

>Sure. WebDAV explicitly states that servers and clients MUST ignore unknown

What does this "Sure" apply to, Julian?  Do you mean that new 
children of <DAV:lockinfo> can still be introduced?  Or do you mean 
of <DAV:owner>?

>applies to a property value should reply to the DAV:owner element as well.

That's why I used my language about "dead properties" in the earlier 
message: we need to make sure the resolution to that issue drives the 
DAV:owner issue.

     dan
-- 
Daniel Brotsky, Adobe Systems
tel 408-536-4150, pager 877-704-4062
2-way pager email: <mailto:[email-masked]>

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 29 Jan 2002 20:40:57 +0100

> [mailto:[email-masked]]On Behalf Of Daniel Brotsky
> Sent: Tuesday, January 29, 2002 8:36 PM
> To: Julian Reschke
> Cc: Jason Crawford; [email-masked]

Sorry :-)

Sure, we can extend DAV:lockinfo, because we *don't* want to introduce
semantice for for DAV:owner.

> message: we need to make sure the resolution to that issue drives the

Agreed. Good plan.