Subject: RE: Interest in standardizing Batch methods?

From: "Clemm, Geoff" <[email-masked]>
Date: Tue, 15 Jan 2002 12:30:37 -0500

It probably makes sense to include both,
i.e. "better support for pipelining" and "transactions"
I personally am more optimistic that we can agree on
an interoperable way of improving pipelining than that we
can agree on an interoperable way of doing transactions.

Cheers,
Geoff

-----Original Message-----
From: Daniel Brotsky [mailto:[email-masked]]
Sent: Wednesday, January 09, 2002 6:46 PM
To: Jim Whitehead
Cc: WebDAV
Subject: RE: Interest in standardizing Batch methods?

At 9:57 AM -0800 1/9/02, Jim Whitehead wrote:
>  > That said, it's still not clear batch methods are so necessary they'd
>>  preempt other work we've got to do.
>
>I agree that other work, especially the revision of RFC 2518, has higher
>priority than this.  But, since we'll be revising our charter soon, I was
>mostly interested to see if it should be added as a charter to-do item.
>
>- Jim

I would say "yes" if you phrase it in terms of general 
transactionality, not batch operations in particular.

     dan
-- 
Daniel Brotsky, Adobe Systems
tel 408-536-4150, pager 877-704-4062
2-way pager email: <mailto:[email-masked]>

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 25 Jan 2002 13:36:42 +0100

Hi,

when running the Litmus test suite against our server, we came across the
following problem for lock test 8 (COPY):

In this test case, a non-locked resource is copied to a locked resource
without giving the lock token in the If: header.

Litmus expects the server to return 423 LOCKED (and this is what moddav
does).

Both our server and IIS however return a 207 MULTISTATUS, and have a
response element for the *destination URI* with an 423 LOCKED status.

I think the latter is correct, because the problem isn't with the request
URI.

In the section about COPY behaviour for *collections*, RFC2518 says [1]:

"If an error in executing the COPY method occurs with a resource other than
the resource identified in the Request-URI then the response MUST be a 207
(Multi-Status)."

I think this should apply to copying non-collections as well.

Julian

[1] <http://www.greenbytes.de/tech/webdav/rfc2518.html#rfc.section.8.8.3>