Subject: FW: Multiple resourcetypes?

From: "Jim Whitehead" <[email-masked]>
Date: Fri, 25 Jan 2002 10:14:38 -0800

Accidentally caught by the spam filter. I have added
<[email-masked]> to the accept2 list.

- Jim

-----Original Message-----
From: Hermann, Eckehard [mailto:[email-masked]]
Sent: Friday, January 25, 2002 3:58 AM
To: [email-masked]
Cc: Pill, Juergen
Subject: [Moderator Action] Multiple resourcetypes?

Hi,

the Webdav Access Control Protocol standard says under "4 Principal
Properties":

Additionally, a principal MUST report the DAV:principal empty XML element in
the value of the DAV:resourcetype property in addition to all other reported
elements. For example, a collection principal would report DAV:collection
and DAV:principal elements.

Do I understand it right, that a resource can have more as one
DAV:resourcetype?

regards

Eckehard

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 25 Jan 2002 19:36:01 +0100

> Do I understand it right, that a resource can have more as one

No, but the DAV:resourcetype property may contain more than one child
element, such as:

<resourcetype xmlns="DAV:">
  <collection/>
  <principal/>
  <somethingelse xmlns="whatever" />
</resourcetype>