Subject: RE: Issue: IS_HREF_A_CHILD_OF_KEEPALIVE

From: [email-masked]
Date: Thu, 31 Jan 2002 12:44:01 -0500

I do remember a discussion of keepalive going away
because it appears not to be implemented (and I 
certainly support it going away).  That is my preferred
solution to this issue.

In any case "REMOVING_KEEPALIVE" (or some other appropriate
name for it) should be on the issues list.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 11:16 PM
To: Julian Reschke
Cc: [email-masked]
Subject: Issue: IS_HREF_A_CHILD_OF_KEEPALIVE

I've added this to my local copy of the issues list.  Anyone want to
comment on it?  Support?  Dissent?

Julian alluded to the possibility of keepalive going away.    FWIW... I
don't see anything like that listed on the issues list.

J.

------------------------------ Julian wrote... --------------------
Hi.

Currently, RFC2518 says in 12.12.1 [1]:

   <!ELEMENT keepalive (#PCDATA | href+) >

So individual properties are identified by "href" (which doesn't make sense
in the general case).

So (assuming that propertybehaviour/keepalive isn't dropped anyway), this
will need to be changed to:

   <!ELEMENT keepalive (#PCDATA | prop+) >

where DAV:prop contains property elements.

Julian

[1] <http://www.greenbytes.de/tech/webdav/rfc2518.html#ELEMENT_keepalive>

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: [email-masked]
Date: Thu, 31 Jan 2002 12:49:38 -0500

I agree with Stefan's proposal.  (I would get rid of "omit" as well).

Cheers,
Geoff

-----Original Message-----
From: Stefan Eissing [mailto:[email-masked]]
The issues I have with keepAlive are
a) how does the client know which property is live in the first place?
b) deltaV copy semantics forbid using keepAlive on version properties
c) If the destination is on another server, WebDAV has no means to
   fulfill keepAlive. It is not possible to know if the remote server
   knows the requested live props.
d) Is there any server/client using it? (I have not seen any)

I would propose to 
1) remove keepalive, maybe allow omit
2) change default copy behaviour to _not_ copy live properties