Subject: RFC2518: depth XML element: Infinite

From: "Pill, Juergen" <[email-masked]>
Date: Mon, 28 Jan 2002 15:45:28 +0100

Hello,

The depth XML element is used throughout the examples in RFC2518 with a
capital "i" (e.g. Infinity, page 36; 8.10.8.), but in the xml definition it
is spelled with a small "i".

What would be the preferred way for a server to deliver 
the infinite value within the XML document back?

Best regards

Juergen Pill

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 28 Jan 2002 16:07:35 +0100

I'd say the examples are wrong and need to be fixed (after checking current
implementations).

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Pill, Juergen
> Sent: Monday, January 28, 2002 3:45 PM
> To: [email-masked]
> Subject: RFC2518: depth XML element: Infinite
>
>
> Hello,
>

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 28 Jan 2002 18:22:32 +0100

BTW:

this is already on the open issues list as [1]: INFINITY_USE_IN_XML

[1] <http://www.webdav.org/wg/rfcdev/issues.htm>

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 28 Jan 2002 18:45:53 +0100

Hi.

Currently, RFC2518 says in 12.12.1 [1]:

   <!ELEMENT keepalive (#PCDATA | href+) >

So individual properties are identified by "href" (which doesn't make sense
in the general case).

So (assuming that propertybehaviour/keepalive isn't dropped anyway), this
will need to be changed to:

   <!ELEMENT keepalive (#PCDATA | prop+) >

where DAV:prop contains property elements.

Julian

[1] <http://www.greenbytes.de/tech/webdav/rfc2518.html#ELEMENT_keepalive>