Subject: [Q] - making a Win32 app DAV-aware...

From: Michael Datuin <[email-masked]>
Date: Tue, 15 Jan 2002 12:47:08 -0800 (PST)

Thanks for the information.  I've done a little more
digging on the Web and found some tidbits of
information.

From an article on www.extremetech.com
(http://www.extremetech.com/article/0,3396,apn%253D10%2526s%253D1027%2526a%253D2473%2526app%253D8%2526ap%253D9,00.asp),
it appears that WinXP contains an 
integrated WebDAV redirector.  According to the 
article, "you can open a file on the web with notepad,

make changes, and if you have write permission, save 
it back...When you open a file from the Web, the file 
is copied locally to Internet Explorer's cache.  Once 
you make your mchanges and close the file, Windows XP 
automatically puts the updated file back to the Web
location."

I tried to open a file in Notepad and save it (via the
common save dialog) to the web folder (that I just 
created in My Network Places to point to an Apache 
server), and it doesn't work.  So, you really can't 
get WebDAV "for free" using XP, right?

How does the redirector actually work?  Does it work 
similarly to WebDrive (www.webdrive.com), where a user

can map a drive letter to a web folder (created in 
WinXP's My Network Places) or ftp site?  

Actually, this is all I really need. It would be ideal

to just be able to let the user of my application 
enter in the common save dialog the following possible

filenames for the file they want to save 

   \\my_remote_machine\filename.txt

   http:\\my_remote_machine\filename.txt

   my_remote_machine_shortcut\filename.txt 
    (where "shortcut" is a web folder)

   X:\filename.txt (where "X" is the drive letter 
     mapped to the web folder)

and have the file be saved on the remote machine.

WebDrive is a great tool, but I don't like the idea of

telling the users of my application that they have to 
go out and buy another piece of software to be able to

save to a web folder.  I thought the WebDAV redirector

in WinXP is supposed to handle this.  

Anyone have any suggestions?  I understand that 
writing a network redirector is a significant 
undertaking, something I currently do not have the 
opportunity (nor the time and resources) to work on.  

Without having to write my own version of WebDrive, is

there any other solution without having to 
significantly modify my existing Win32 app code to 
support saving (or writing directly via file I/O 
calls) to a web server?

Thanks!

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 15 Jan 2002 22:00:33 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Michael Datuin
> Sent: Tuesday, January 15, 2002 9:47 PM
> To: [email-masked]
> Subject: [Q] - making a Win32 app DAV-aware...
>
>
> (http://www.extremetech.com/article/0,3396,apn%253D10%2526s%253D10
> 27%2526a%253D2473%2526app%253D8%2526ap%253D9,00.asp),

Yes, you can.

Problem is, there are no less then four different Microsoft WebDAV clients:

- web folders
- web folders as updated by the Sharepoint client software
- the libraries used by Office
- the XP redirector

All have different kinds of known bugs, and haven't been updated for a long
time (except obviously for the XP stuff).

The XP WebDAV redirector is not available from "network places", nor from
IE.

You'll have to use the command line tool "net", for instance:

net use * URI passwrd /user:username

> WinXP's My Network Places) or ftp site?

Yes.

Hope this helps,

Julian