Subject: Re: Using DAV namespace for proprietary properties

From: "Jason Crawford" <[email-masked]>
Date: Fri, 22 Feb 2002 13:43:36 -0500

Let me phrase this differently... :-)

Does anyone besides Julian... :-)

...feel there is a change in the 2518 spec needed in regard to the
following posting by Julian...   :-)

Please speak up.

> currently RFC2518 is silent on this issue.
>
> However, deltaV says 1.5 [1]: "Although WebDAV request and
> response bodies
> can be extended by arbitrary XML elements, which can be ignored by the
> message recipient, an XML element in the DAV namespace MUST NOT
> be used in
> the request or response body of a versioning method unless that
> XML element
> is explicitly defined in an IETF RFC."
>
> I think something similar needs to be added to the revision to RFC2518.

----------------------------------------------------------------------

To: [email-masked]
Message-ID: <[email-masked]>
From: "Jason Crawford" <[email-masked]>
Date: Wed, 20 Feb 2002 15:29:33 -0500
Subject: Re: Using DAV namespace for proprietary properties

Do we feel there is a change in the 2518 spec needed in regard to the
following posting by Julian...

> currently RFC2518 is silent on this issue.
>
> However, deltaV says 1.5 [1]: "Although WebDAV request and response
bodies
> can be extended by arbitrary XML elements, which can be ignored by the
> message recipient, an XML element in the DAV namespace MUST NOT be used
in
> the request or response body of a versioning method unless that XML
element
> is explicitly defined in an IETF RFC."
>
> I think something similar needs to be added to the revision to RFC2518.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Jim Whitehead" <[email-masked]>
Date: Fri, 22 Feb 2002 16:45:20 -0800

I strongly feel that a revision of RFC 2518 should state that the "dav:"
property namespace is reserved for use by IETF-approved Standards-Track
specifications, and that client implementations MUST NOT use this namespace
for application-specific properties.

Pragmatically, I think existing exceptions to this rule should be
grandfathered.

- Jim

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Friday, February 22, 2002 10:44 AM

---

From: "Julian Reschke" <[email-masked]>
Date: Sat, 23 Feb 2002 09:52:13 +0100

So,

going back to my original question...: it *is* permissible for a server to

- deny setting the property DAV:contentclass (until it is defined in an IETF
specification) and to
- report "not found" upon PROPFIND without actually *checking* dead
properties.

Right?

> [mailto:[email-masked]]On Behalf Of Jim Whitehead
> Sent: Saturday, February 23, 2002 1:45 AM
> To: Jason Crawford; [email-masked]
> Subject: RE: Using DAV namespace for proprietary properties
>
>