Subject: RE: Using DAV namespace for proprietary properties

From: "Babich, Alan" <[email-masked]>
Date: Tue, 19 Feb 2002 15:46:50 -0800

I don't think it is or should be a requirement that all 
proprietary properties be live properties.

Alan

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Monday, February 18, 2002 11:47 PM
To: Babich, Alan; [email-masked]
Subject: RE: Using DAV namespace for proprietary properties

I see.

Could you please explain this position?

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Babich, Alan
> Sent: Monday, February 18, 2002 9:25 PM
> To: [email-masked]
> Subject: RE: Using DAV namespace for proprietary properties
>
>
> "Would it be permissible to assume that properties in the DAV: namespace
> *never* are dead properties, allowing to skip this step?"
>
> I don't think so.
>
> Alan Babich
>
> -----Original Message-----
> From: Julian Reschke [mailto:[email-masked]]
> Sent: Monday, February 18, 2002 6:29 AM
> To: [email-masked]
> Subject: Using DAV namespace for proprietary properties
>
>
> Hi,
>
> currently RFC2518 is silent on this issue.
>
> However, deltaV says 1.5 [1]: "Although WebDAV request and response bodies
> can be extended by arbitrary XML elements, which can be ignored by the
> message recipient, an XML element in the DAV namespace MUST NOT be used in
> the request or response body of a versioning method unless that
> XML element
> is explicitly defined in an IETF RFC."
>
> I think something similar needs to be added to the revision to RFC2518.
>
> Looking at current implementations I notice that the Microsoft Webfolder
> client (sigh!) does a PROPFIND on no less than then 10 proprietary
> properties placed into the DAV: namespace ([2]), of which it only seems to
> *use* one (DAV:ishidden). Without wiring special knowledge about these
> attributes into a server, it will usually have to consult the resource's
> dead properties (just to find out that these don't exist). Would it be
> permissible to assume that properties in the DAV: namespace
> *never* are dead
> properties, allowing to skip this step?
>
> Julian
>
>
> [1]
> <http://www.webdav.org/deltav/protocol/draft-ietf-deltav-versionin
g-20.1.htm
#_Toc524830510>
[2]
<http://www.greenbytes.de/tech/webdav/webdavfaq.html#ANSWER-mswebfolder-prop
rietary-properties>

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 22 Feb 2002 09:48:36 +0100

Alan,

that's fine.

My position is that proprietary properties MUST not use the DAV: namespace.
If my server can rely on this, it can report all DAV: properties it doesn't
know as "not found" without even bothering to ask the persistence layer.

Julian

> Sent: Wednesday, February 20, 2002 12:47 AM
rietary-properties>