Subject: Re: [dav-dev] Re: Problem with OfficeXP and Accented characters

From: "Jim Whitehead" <[email-masked]>
Date: Fri, 22 Feb 2002 09:19:29 -0800

Accidentally caught by the spam filter.

- Jim

-----Original Message-----
From: Chris Sharp [mailto:[email-masked]]
Sent: Friday, February 22, 2002 8:02 AM
To: Taisuke Yamada
Cc: [email-masked]; [email-masked]
Subject: [Moderator Action] Re: [dav-dev] Re: Problem with OfficeXP and
Accented characters

The only reason we had to do this is that we translate UTF8 into MacOS 
Roman on the backend. One of the requirements was for OS9 users to be 
able to interop with OSX and vica versa via the iDisk service.

In most cases, we use this hint "x-mac-japanese" to unambiguously 
translate UTF8 into Mac OS Roman. Further, for some reason OSX prefers 
fully decomposed UTF8 on the return trip. Based on a suggestion from 
Julian, I believe, we only provide this functionality to non OSX based 
User-Agents.

Chris
On Friday, February 22, 2002, at 03:22 AM, Taisuke Yamada wrote:

> Just FYI, WebDAV client that comes with MacOS X speaks things like
>
>   PROPFIND /?charset=X-MAC-JAPANESE HTTP/1.1

---

From: "Larry Masinter" <[email-masked]>
Date: Sun, 24 Feb 2002 13:35:41 -0800

It is important for the WebDAV group to come up with
a WebDAV spec that defines character encodings for
file names and the relationship of filenames and encodings
to URL strings.

Don't expect this to be handled by changes to HTTP
or URI specifications.