Subject: Issue: DAV_WITH_COLON_IS_NOT_A_URI

From: "Julian Reschke" <[email-masked]>
Date: Wed, 6 Feb 2002 11:44:17 +0100

Jason,

I think we should add: "if a decision is made not to change the namespace
name for DAV, the new spec should explain that a) defining a new URI scheme
and b) using the scheme name as namespace name were bad design decisions and
shouldn't be repeated".

(I mention this because I just found yet another example of this abuse, and
it seems to be inspired by WebDAV)

Julian

---

From: "Josh" <[email-masked]>
Date: Thu, 7 Feb 2002 01:31:08 -0800

This is an interesting point.  It makes me wonder what a better
solution would have been ?  Im not suggesting invalidating the
current scheme, but Im curious, what would be the right
way to do it if we had the choice today ?

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 7 Feb 2002 11:12:02 +0100

Just don't invent a new URI scheme (it's not needed, and no semantics have
been defined by RFC2518 for it).

	"http://webdav.org/"

would have been perfect instead :-).

> -----Original Message-----
> From: Josh [mailto:[email-masked]]
> Sent: Thursday, February 07, 2002 10:31 AM
> To: Julian Reschke; Jason Crawford; [email-masked]
> Subject: Re: Issue: DAV_WITH_COLON_IS_NOT_A_URI
>
>