Subject: RE: Using DAV namespace for proprietary properties

From: "Clemm, Geoff" <[email-masked]>
Date: Sun, 24 Feb 2002 00:44:09 -0500

I would answer "yes" to both questions.  Although some servers may
have gone ahead and defined some custom live properties in the DAV:
namespace, are there any clients that depend on the ability to set
dead properties in the DAV: namespace?

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Saturday, February 23, 2002 3:52 AM
To: Jim Whitehead; Jason Crawford; [email-masked]
Subject: RE: Using DAV namespace for proprietary properties

So,

going back to my original question...: it *is* permissible for a server to

- deny setting the property DAV:contentclass (until it is defined in an IETF
specification) and to
- report "not found" upon PROPFIND without actually *checking* dead
properties.

Right?

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jim Whitehead
> Sent: Saturday, February 23, 2002 1:45 AM
> To: Jason Crawford; [email-masked]
> Subject: RE: Using DAV namespace for proprietary properties
>
>
> I strongly feel that a revision of RFC 2518 should state that the "dav:"
> property namespace is reserved for use by IETF-approved Standards-Track
> specifications, and that client implementations MUST NOT use this
> namespace
> for application-specific properties.
>
> Pragmatically, I think existing exceptions to this rule should be
> grandfathered.
>
> - Jim
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Jason Crawford
> > Sent: Friday, February 22, 2002 10:44 AM
> > To: [email-masked]
> > Subject: Re: Using DAV namespace for proprietary properties
> >
> >
> > Let me phrase this differently... :-)
> >
> > Does anyone besides Julian... :-)
> >
> > ...feel there is a change in the 2518 spec needed in regard to the
> > following posting by Julian...   :-)
> >
> > Please speak up.
> >
> >
> > > currently RFC2518 is silent on this issue.
> > >
> > > However, deltaV says 1.5 [1]: "Although WebDAV request and
> > > response bodies
> > > can be extended by arbitrary XML elements, which can be ignored by the
> > > message recipient, an XML element in the DAV namespace MUST NOT
> > > be used in
> > > the request or response body of a versioning method unless that
> > > XML element
> > > is explicitly defined in an IETF RFC."
> > >
> > > I think something similar needs to be added to the revision
> to RFC2518.
> >
> > ----------------------------------------------------------------------
> >
> >
> >
> > To: [email-masked]
> > Message-ID: <[email-masked]>
> > From: "Jason Crawford" <[email-masked]>
> > Date: Wed, 20 Feb 2002 15:29:33 -0500
> > Subject: Re: Using DAV namespace for proprietary properties
> >
> > Do we feel there is a change in the 2518 spec needed in regard to the
> > following posting by Julian...
> >
> >
> > > currently RFC2518 is silent on this issue.
> > >
> > > However, deltaV says 1.5 [1]: "Although WebDAV request and response
> > bodies
> > > can be extended by arbitrary XML elements, which can be ignored by the
> > > message recipient, an XML element in the DAV namespace MUST
> NOT be used
> > in
> > > the request or response body of a versioning method unless that XML
> > element
> > > is explicitly defined in an IETF RFC."
> > >
> > > I think something similar needs to be added to the revision
> to RFC2518.
> >
> >
> > ------------------------------------------
> > Phone: 914-784-7569,   [email-masked]
> >
>

---

From: "Julian Reschke" <[email-masked]>
Date: Sun, 24 Feb 2002 17:10:20 +0100

> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Sunday, February 24, 2002 6:44 AM

That woulb really interesting. Guess I'll find out soon :-)