Subject: read/write privileges

From: "Hermann, Eckehard" <[email-masked]>
Date: Thu, 21 Feb 2002 13:36:01 +0100

Hi all,

 the ACL Standard says under 3.7 that the DAV:write privileg MUST NOT
contain the DAV:read privileg. What sense does it make to give someone the
right for doing updates or delete a resource but not to allow to read the
resource? What is the reason that a DAV:write most not contain a DAV:read?

regards

Eckehard

---

From: "Clemm, Geoff" <[email-masked]>
Date: Sat, 23 Feb 2002 18:53:37 -0500

This definition is an attempt to provide some (minimal) common 
semantics to DAV:read and DAV:write.  Without this definition,
some servers would implement them as orthogonal privileges,
and others would (as you suggest) implement DAV:write as a
composite privilege that includes DAV:read.

There are some cases where
it is reasonable to give DAV:write but not DAV:read privilege to
a resource (e.g. a "closed-bid" resource that you can append to,
but not see what else has been written there).  If a resource is
both readable and writeable, then just return both DAV:read and
DAV:write as granted privileges.

Cheers,
Geoff

-----Original Message-----
From: Hermann, Eckehard [mailto:[email-masked]]
Sent: Thursday, February 21, 2002 7:36 AM
To: [email-masked]
Subject: read/write privileges

Hi all,

regards

Eckehard