Subject: FW: href in where clause

From: "Julian Reschke" <[email-masked]>
Date: Thu, 28 Feb 2002 20:02:42 +0100

(moving it to the right list)

So maybe the RFC should say that "DAV:displayname" is a computed property
based on the name of the collection member? Does anybody have a problem with
this?

Julian

> -----Original Message-----
> From: Lisa Dusseault [mailto:[email-masked]]
> Sent: Thursday, February 28, 2002 7:57 PM
> To: 'Julian Reschke'; 'dasl'
> Subject: RE: href in where clause
>
>
> In the server implementations I'm aware of:
>  - displayname is not writable, because making it writable would be
> equivalent in these systems to a MOVE (rename)
>  - displayname must be unique within a collection
>
> Lisa
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Julian Reschke
> > Sent: Thursday, February 28, 2002 10:29 AM
> > To: 'dasl'
> > Subject: RE: href in where clause
> >
> >
> > Correct.
> >
> > Is it writable? Do all members of a collection have different
> > displaynames?
> >
> > Julian
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> > > Sent: Thursday, February 28, 2002 6:36 PM
> > > To: 'Julian Reschke'; 'dasl'
> > > Subject: RE: href in where clause
> > >
> > >
> > > A related problem, perhaps for RFC2518, is how displayname
> > should be used.
> > > If displayname is only the final path segment or filename of a
> > > href (as most
> > > products seem to be implemented), then displayname might be
> > sufficient for
> > > most of the kinds of searches you could do with href.
> > >
> > > Lisa
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]]On Behalf Of Julian Reschke
> > > > Sent: Thursday, February 28, 2002 6:20 AM
> > > > To: dasl
> > > > Subject: DAV:href in where clause
> > > >
> > > >
> > > > DAV:href isn't a property, so it can't be used in queries.
> > > >
> > > > Is this a problem? Examples where DAV:displayname is queried
> > > > instead seem to
> > > > indicate that. A possible solution would be to allow DAV:href
> > > > whereever
> > > > DAV:prop is allowed in the where clause.
> > > >
> > > > For instance:
> > > >
> > > > <D:where>
> > > >   <D:like>
> > > >     <D:href/>
> > > >     <D:literal>%.doc</D:literal>
> > > >   </D:like>
> > > > </D:where>
> > > >
> > > > Of course it would be a problem that WebDAV is silent about
> > > > the allowed
> > > > formats that can appear in the href element (authority
> > > > mandatory? which
> > > > forms of relative URI references are allowed and interoperable?).
> > > >
> > >
> >
>

---

From: "Eric Sedlar" <[email-masked]>
Date: Thu, 28 Feb 2002 11:44:10 -0800

I thought the intent of dav:displayname was to be able to hold information
like the <title> element that could be parsed out of an HTML file.  I think
that the collection member name is more of a default value for displayname
than something that is required to correspond to the appropriate piece of
the URL.

I don't think we should make such a change.

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Julian Reschke
> Sent: Thursday, February 28, 2002 11:03 AM
> To: [email-masked]
> Subject: FW: href in where clause
>
>