Subject: How do you get the URL of a MS web folder?

From: Michael Datuin <[email-masked]>
Date: Mon, 25 Mar 2002 19:58:25 -0800 (PST)

This is a another question regarding Microsoft's 
webfolders.  

I see that when you create a web folder under WinXP,
and you open up the "My Network Places" dialog, you
can see your current list of network connections
and web folders, along with the URL that is associated
with each web folder on your system.  The URL appears
in the "Comments" column of the dialog box if you have
the display settings set to "Details" (as opposed to 
Thumbnails, Tiles, Icons, and List).  Also, if you
right-click on one of your web folders and select
"Properties", another dialog box will appear showing
the URL as the "Target" of your web folder.  

What APIs are available to get the "Target" or 
"Comments" strings?  Or more directly, how do you 
obtain the URL "programmatically" via a VC++ Win32 
API to get the URL of your webfolder.  

I have sample VC++ code that I whipped up that opens 
that displays the common file dialog.  If you navigate
via the dialog to your web folder, and select a file
(for example, a text document), on the return from
selecting the file and the closing of the dialog,
the path/filename is set to something like 

  c:\Documents and Settings\datuin\Local
Setting\Temporary Internet
Files\Content.IE.5\8X6FOLYF\test[1].txt

Now, if I make modifications to this file and want to
save the file back to the web folder, I don't know 
programmatically where/how to put the file back.
Clearly, I can't just save the file back to the 
above directory on my PC.  I have to do a "put" back
to the original URL.  

Actually, in my application, I would rather have the
user navigate to the web folder using the common
file dialog, instead of having them enter in the URL
and making my code remember the URL.  The common file 
dialog must "somehow" know that the folder the user
navigated to is a web folder, right?  So, all I care
about is where (i.e., the URL) the user wants to save
(or open) his file.  Does such an API exist?

Sorry if this isn't the right forum to ask this
question.  I don't know of a MS-related forum/resource
to ask webfolder-related questions.  

Any help would be appreciated!  Thanks!

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

---

From: Joachim Feise <[email-masked]>
Date: Tue, 26 Mar 2002 01:23:52 -0800

>Any help would be appreciated!  Thanks!

This is all accessed through the shell COM interfaces. To my knowledge, 
the Webfolders UI is implemented
as a shell extension. You interact with it like with any other shell 
extension. Nothing specific to Webfolders,
except that the target is a URL and not a file.
Point your newsreader to news.microsoft.com, the newsgroup is 
news:microsoft.public.platformsdk.shell

-Joe

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 28 Mar 2002 16:27:42 +0100

From the abstract:

"Recent specifications extending the Web Distributed Authoring Protocol
(WebDAV) restrict the set of properties returned automatically upon a
PROPFIND/allprop request. This specification defines a method to add
specific properties to the set of properties returned upon
PROPFIND/allprop."

From the change log:

"Moved <include> element out of "DAV:" namespace.
Updated reference to deltaV (now RFC3253).
Changed examples to explicitly use utf-8 encoding for HTTP content type and
XML encoding.
Updated WebDAV ACL reference to draft 07.
Made sure figures fit in 72 columns.
Split references into "Normative" and "Informative". "

Links:

Submitted version in HTML format:
<http://greenbytes.de/tech/webdav/draft-reschke-webdav-allprop-include-01.ht
ml>
Current version:
<http://greenbytes.de/tech/webdav/draft-reschke-webdav-allprop-include-lates
t.html>