Subject: RE: space

From: "Babich, Alan" <[email-masked]>
Date: Fri, 1 Mar 2002 12:59:29 -0800

Julian:

SEARH must take a position on spaces. It is a critical
issue for string literals. I agree that we're defining a 
protocol -- something processed by software. The readability 
of the protocol string is secondary. However, examples are
presented in specs., and there is some benefit to having
these examples be readable. For many elements, extra 
whitespace doesn't matter. So including whitespace for 
such elements is good idea to enhance the presentation
of the example in the spec. (but not on the wire). For 
string literals, however, whitespace is critical.

Upon reflection, I agree with you that SEARCH should say
that all characters, including all whitespace (i.e., spaces,
tabs, carriage returns, vertical form feeds, etc.) in string 
literals are part of the string literal. 

Simpler is better.

Alan Babich

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Friday, March 01, 2002 3:08 AM
To: [email-masked]; [email-masked]
Subject: xml:space

Hi.

The WebDAV SEARCH draft currently has an issue regarding treatment of
xml:space [1]: it says, that the basicsearch grammer should respect
xml:space="default" in a literal element, so that

	<prop>
		<foobar xml:space="default">
			xyz
		</foobar>
	</prop>

would really be equivalent to:

	<prop>
		<foobar>xyz</foobar>
	</prop>

That's compatible with XML, but it's not consistent with WebDAV (which
doesn't say anything about xml:space). The only benefit of xml:space for
WebDAV I'm aware of is that you could have indented "beautified" message
bodies and have the receiver care about whitespace removal. However, as both
WebDAV request and response bodies are generated/consumed by code (not human
readers), that's hardly important.

So my proposal would be:

1) In WebDAV, state that whitespace *is* significant,

2) Drop the feature in WebDAV SEARCH's DAV:literal.

Comments?

[1]
<http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-latest.html#rf
c.issue.JW14>

---

From: "Julian Reschke" <[email-masked]>
Date: Sun, 3 Mar 2002 15:08:24 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Babich, Alan
> Sent: Friday, March 01, 2002 9:59 PM
> Subject: RE: space

Thanks, Alan.

Just for the record: you can't have any control characters except TAB, CR
and LF in an XML string (and preservation of the type of line break is not
guaranteed).

Julian

---

From: Erik Seaberg <[email-masked]>
Date: 03 Mar 2002 11:45:52 -0800

Julian Reschke <[email-masked]> writes:

> Just for the record: you can't have any control characters except
> TAB, CR and LF in an XML string (and preservation of the type of
> line break is not guaranteed).

Preservation is forbidden, since parsers are required to replace
unencoded CRLF or CR in an XML document (or other external parsed
entity) with LF.  AFAIK you can use &#xd; to embed a CR in a search
string, and it might be safest to encourage clients to avoid line
breaks in search strings and use &#xd; and/or &#xa; rather than rely
on every XML parser to handle line breaks correctly.

---

From: "Julian Reschke" <[email-masked]>
Date: Sun, 3 Mar 2002 20:54:45 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Erik Seaberg
> Sent: Sunday, March 03, 2002 8:46 PM
> To: [email-masked]
> Subject: Re: space
>
>

Just ti make sure everbody is aware of this: this is a basic limitation of
XML character content und thus restricts the possible contents of all
(text-based) WebDAV properties.