Subject: [w3c-dist-auth] <none>

From: akhil gupta <[email-masked]>
Date: Tue, 5 Mar 2002 07:07:40 -0800 (PST)

Hi 
   Can you please tell me how using the webdav we can
save files on internet, means i want to write a
program for opening a file through a site of the
format of MS Word or Excel, edit it and save it back
on the remote computer, from where it was opened.
Please tell me urgently how to do it, using webdav or
else.
Thanks
Akhil Gupta

__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

---

From: "Jim Whitehead" <[email-masked]>
Date: Tue, 5 Mar 2002 14:22:18 -0800

> Please tell me urgently how to do it, using webdav or

There are many libraries that can be used to access a WebDAV repository and
achieve the goals you describe. A list of these APIs can be found at:

http://www.ics.uci.edu/pub/ietf/webdav/
(look about 1/2 way down the page)

The file can be retrieved using the GET method (standard HTTP/1.1). Using
the WebDAV LOCK method will ensure that only one person can edit the file at
a time.

As for actually editing a .doc or .xls file, this requires knowledge of the
internal structure of these file formats. The WebDAV protocol does not know
anything about these file formats -- it's out of scope.

Reading the following paper may give you some insight into the high-level
design goals for WebDAV:

http://www.cs.ucsc.edu/~ejw/papers/dav-ecscw.pdf

- Jim