Subject: Anyone have any MS web folder/Rosebud sample code?

From: Michael Datuin <[email-masked]>
Date: Thu, 21 Mar 2002 16:43:28 -0800 (PST)

Does anyone have any experience/knowledge on using 
MS OLE DB Provider for Internet Publishing (aka,
Rosebud)?

I'm looking for C/C++ (not VB) sample code that shows 
how to open files from and save files to a MS web 
folder.  

I've looked high and low on msdn.microsoft.com for
"understandable and useful" information regarding web 
folders, but to no avail. The link to the sample 
Sample1 program on the MS website for OLE DB Provider 
for Internet Publishing doesn't even provide a link to
download the example!!!

I found references to the WebFolder objects and such,
but all I want is a C/C++ example that I can use to
add
to my Win32 application.  Are there any sample code
that shows how to open/save files with MS web 
folders?!?!?!  

I've seen many requests for help regarding sample code
to programmatically (using C/C++) access MS web
folders, and MS web folders in general, but never any
responses.  Frustrating!

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

---

From: Joachim Feise <[email-masked]>
Date: Thu, 21 Mar 2002 23:42:18 -0800

>folders, and MS web folders in general, but never any
I have used it in a commercial application. But it is rather painful to 
use and quite limited,
so we are no longer using it and rolled our own library.
Essentially, you need to use the interfaces specificed in the OLE DB 2.5 
SDK:
IRootBinder, IBindResource,  IRowset, ICreateRow, etc.
For example, for a PROPFIND, you get the IRootBinder interface, from 
that the IBindResource interface,
then you call Bind on that, with a request for an IRowset interface.
You can then use the standard OLE DB functions to operate on the rowset.
File reading/writing is done through an IStream interface.
So you have to think in database terms, and, of course, COM knowledge is 
required.

-Joe