Subject: Open a WebDav Document with IE by URL

From: "Michael Michalowski" <[email-masked]>
Date: Tue, 16 Apr 2002 08:57:35 +0200

Hi!

I want to open a link to a webdav document (for example
http://www.example.com/this.doc). But if this URL is opened by
Internet Explorer and then MS Word launched, the document opens
a local copy and so no webdav support is given.
If I open this document directly with MS Word by URL it is
opened as a webdav document and it can directly be saved back on the server.

My question:
How can I tell the Internet Explorer that a link to a document
points to a webdav source and that the full doucument path must be
passed to MS Word?

The only method of resolution I found is an JScript workaround:
http://support.microsoft.com/default.aspx?scid=kb;DE;q178222
But that's not what I might prefer. Isn't there another
solution?

(I'm not sure whether this is the right mailinglist for my topic)

regards,
Michael

---

From: [email-masked]
Date: Tue, 16 Apr 2002 08:16:43 -0400

Michael,

This is a problem with the Microsoft implementation  of Office and WebDAV.  Many
months ago I had an open problem ticket with Microsoft about this; however,
based on the discussions with Microsoft there are no clean solutions.   The
script you cite is one option, another option from Microsoft is what they term a
plugable protocol (which is very similar to the script solution) -- either way
the solution is to launch the application and pass the URL as a parameter.

Interestingly, in one of the earlier releases of Office  2000 (before SP1) this
functionality worked.  That is, if a link pointed to a file that had WebDAV
support it would open in edit mode.  Microsoft removed this functionality
because of errors generated when opening files that were not on WebDAV (or
FrontPage/Office extensions) supported servers.

My suggestion is to continue to push Microsoft to fix this problem at the
application level.   By the way, Office XP does not fix this problem, either.

Regards,

Jim

 Internet Mail Message                                          
 Received from host:                                            

                  [email-masked]                                                          
                                  Sent                To:  "[email-masked]"               
                                   by:        <[email-masked]>                            
          [email-masked]        cc:     (bcc: Jim Hanna-JI/PGI)                   
                                              Subject:     Open a WebDav Document with IE by    
                   04/16/2002 02:56 AM        URL                                               
            Please respond to "Michael                                                          
                          Michalowski"                                                          

Hi!

My question:

regards,
Michael