Subject: RE: need clarification about COPY to locked resource response cod e

From: "Clemm, Geoff" <[email-masked]>
Date: Sun, 21 Apr 2002 20:40:48 -0400

From: Julian Reschke [mailto:[email-masked]]

   Actually, I'd prefer to change/clarify multistatus error reporting to:

   - MUST contain response elements for each source resource that wasn't
   moved/copied/deleted as specified (however keeping the current
optimization
   for 424 on ancestors)

I agree.

   - MAY contain response elements for targets that caused the failure.

That would be OK with me but I'd prefer to nest the information
about targets that caused the failure in the response element for the
source resource that wasn't moved/copied/deleted.  This is a change
from RFC 2518, but I think it is warranted.

   It might be woth thinking to also add some kind of linkage between the
two
   response elements.

I agree.  That is the purpose for nesting the information about the
targets that caused the failure in the response for the target that
was not copied.

Cheers,
Geoff

---

From: Stefan Eissing <[email-masked]>
Date: Mon, 22 Apr 2002 10:05:43 +0200

>    From: Julian Reschke [mailto:[email-masked]]
[...]
> targets that caused the failure in the response for the target that

So, as usual I propose a format which will make everyone scream and
come up with a much better one.

...
<D:response>
   <D:href>/bla/...</D:href>
   <D:status>HTTP/1.1 409 CONFLICT</D:status>
   <D:cause>
     <D:href>/other/...</D:href>
     <D:status>HTTP/1.1 423 LOCKED</D:status>
   </D:cause>
</D:response>

//Stefan