Subject: Re: 54th IETF Meeting Information, and RFC2518 open issues

From: "Jason Crawford" <[email-masked]>
Date: Thu, 25 Apr 2002 11:36:54 -0400

My preference is not strong, but I do agree with Geoff that we should
consider removing ETAG support from the IF: header unless someone steps
forward for a good reason to keep it.

The discussion has bounced around a bit, so I'll try to point out what
hasn't been covered.

As Geoff said... The functionality of ETags in IF: headers appear to
already be available via other means.

Stephan's question about whether any *clients* submit Etags in IF: headers
hasn't been answered.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Jason Crawford" <[email-masked]>
Date: Thu, 25 Apr 2002 15:39:02 -0400

Stefan,
   Greg's posting didn't point out anything that can't be done without the
ETag support in the IF: header.   That's why he ended his posting with:

> Arguably, the semantic could be manufactured with other combinations, but
> I'd suggest that is your use case.

If you know of another case that he told you about off line, please share
it.

If anyone actually knows of a client that actually uses the IF: etag
feature, then please point it out.

J.

                                                                                                                                         
                      Stefan Eissing                                                                                                     
                      <stefan.eissing@gre        To:       Jason Crawford/Watson/IBM@IBMUS                                               
                      enbytes.de>                cc:       "'Webdav WG (E-mail)'" <[email-masked]>                                
                      Sent by:                   Subject:  Re: 54th IETF Meeting Information, and RFC2518 open issues                    
                      w3c-dist-auth-reque                                                                                                
                      [email-masked]                                                                                                          

                      04/25/2002 01:14 PM                                                                                                

Am Donnerstag den, 25. April 2002, um 17:38, schrieb Jason Crawford:

>
>>>> Having never encountered a client using them, I propose to
>>>> drop ETags in IF headers.
>>>
>>> OK; if we drop ETags in If headers how are servers intended to handle
>>> requests using the old syntax, or do you believe that is not an
>>> issue (if
>>> so, why)?
>>
>> We can handle this similar to the "keepalive" body for COPY requests.
>
> Obviously if no clients use it, it's not a big issue, but please
> explain
> further.

As I wrote earlier today, Greg changed my mind on this matter.
There is a use case which cannot be covered by existing HTTP features.

So I'd vote for keeping the If: header as it is.

//Stefan