Subject: RE: displayname vs. Microsoft webfolders

From: "Clemm, Geoff" <[email-masked]>
Date: Sun, 21 Apr 2002 12:22:10 -0400

I agree.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]

we just noticed the following bug in Microsoft's web folder implementation:
when displaying the contents of a collection, it will use (when present) the
DAV:displayname property as internal member name. Furthermore, the URI
displayed in the "tabular view" will use the collection's URI + the
displayname to build the member's URI.

This is obviously wrong, because there's no guarantee that the individual
DAV.displayname values in a property are distinct.

IMHO, the RFC2518 revision should say:

"User agents MUST not use the DAV:displayname to identify the individual
collection members (because the value may not be unique across the members
of a collection). However, they MAY use it to display additional information
about a collection member".

---

From: "Jason Crawford" <[email-masked]>
Date: Sun, 21 Apr 2002 17:04:59 -0400

Actually, I tend to be of the other camp.  I feel the spec should avoid UI
imperatives if possible, the spec is clear enough about what the possible
negative repercusions of this UI approach are, and if a client wants to
experiment at the UI level, let them... as long as they comply at the
protocol level.  (I assume Msft complies at the protocol level, but I
haven't verified that.)

I don't feel strongly though and will go with the flow.

J

------------------------------------------
Phone: 914-784-7569,   [email-masked]

                      "Clemm, Geoff"                                                                                                   
                      <gclemm@Rational.        To:       WebDAV <[email-masked]>                                                 
                      Com>                     cc:                                                                                     
                      Sent by:                 Subject:  RE: displayname vs. Microsoft webfolders                                      
                      w3c-dist-auth-req                                                                                                
                      [email-masked]                                                                                                      

                      04/21/2002 12:22                                                                                                 
                      PM                                                                                                               

I agree.

Cheers,
Geoff

-----Original Message-----

when displaying the contents of a collection, it will use (when present)
the

"User agents MUST not use the DAV:displayname to identify the individual
collection members (because the value may not be unique across the members
of a collection). However, they MAY use it to display additional
information
about a collection member".