Subject: RE: Issue: COPYMOVE_LOCKED_STATUS_CODE_CLARIFICATION

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 6 May 2002 15:11:14 -0400

I don't think that it makes sense to try to re-use
DAV:response in the "explanation" part of the error message,
because you don't need another responsedescription,
and it is not clear that the HTTP status codes are a
useful way of characterizing what about the state of
the other resource contributed to the error being described.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Sunday, May 05, 2002 10:39 AM
To: Jason Crawford; Clemm, Geoff
Cc: WebDAV
Subject: RE: Issue: COPYMOVE_LOCKED_STATUS_CODE_CLARIFICATION

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Thursday, May 02, 2002 10:41 PM
> To: Clemm, Geoff
> Cc: WebDAV
> Subject: Issue: COPYMOVE_LOCKED_STATUS_CODE_CLARIFICATION
>
>
>
> The recent thread entitled
> RE: need clarification about COPY to locked resource response cod       e
>   and
> RE: need clarification about COPY to locked resource response cod e
> recently died down with the following posting.
> http://lists.w3.org/Archives/Public/w3c-dist-auth/2002AprJun/0043.html
>
> I just want to bring it to conclusion and get it on the ISSUES list.
>
>
> So we have a proposal on the table regarding error reporting for lock
> conflicts
> during COPY/MOVE.  I'll try to describe it below.
>
> If a portion of the destination is locked and preventing a portion of the
> COPY/MOVE,
> then a 207 Multistatus MUST be returned by the server.   That MultiStatus
> response should
> indicate (with 409 Conflict status) what source resource could not be
> copied/moved and
> optionally say something about the locked destination resource the locked
> that prevented
> the copy.
>
> <D:response>
>     <D:href>/bla/source</D:href>
>     <D:status>HTTP/1.1 409 CONFLICT</D:status>
>     <D:responsedescription>
>       <D:error>
>          <D:locked-destination>
>            <D:href>/other/destref...</D:href>
>          </D:locked-source>
>       </D:error>
>     </D:responsedescription>
>  </D:response>
>
> That D:error tag is optional.  And clearly we'd need the add definitions
> for the
> D:error tag and the descendent tags listed in the example above.
> We should work out if the dest URL listed is the root of the lock or the
> locked resource
> that was directly affecting the operation.  We should possibly clarify
> "protected URL"
> status codes and what URL is depicted.

How about a more generic version:

<D:response>
    <D:href>/bla/source</D:href>
    <D:status>HTTP/1.1 409 CONFLICT</D:status>
    <D:responsedescription>
      <D:dependant-status>
        ... complete DAV:response element for resource causing the conflict
      </D:dependant-status>
   </D:responsedescription>
</D:response>

This would avoid having to define a whole new set of error conditions...

> ...

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 6 May 2002 21:29:53 +0200

> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Monday, May 06, 2002 9:11 PM
> To: WebDAV

Well, we need 

- the URI and
- error information (be it an HTTP status or a DAV:error element).

DAV:response is a container that can hold both, so why not re-use it?