Subject: RE: Issue: SOURCE_PROPERTY_UNDERSPECIFIED

From: "Clemm, Geoff" <[email-masked]>
Date: Tue, 14 May 2002 07:50:28 -0400

I would prefer keeping everything an element (e.g. an href element and
a sourcetype element), e.g.:

<D:prop>
 <D:source-set>
  <D:source>
    <D:href>"http://example.com/dav/source.xml"</D:href>
    <D:sourcetype>Source</D:sourcetype> </D:source>
  <D:source>
    <D:href>"http://example.com/dav/render.xsl"</D:href>
    <D:sourcetype>Stylesheet</D:sourcetype> </D:source>
  <D:source>
    <D:href>"http://example.com/dav/etc.etc"</D:href/> </D:source>
 </D:source-set>
</D:prop>

for the standard reasons why elements are preferable to attributes.

Cheers,
Geoff

-----Original Message-----
From: Jim Whitehead [mailto:[email-masked]]
Sent: Monday, May 13, 2002 7:56 PM
To: Webdav WG (E-mail)
Subject: RE: Issue: SOURCE_PROPERTY_UNDERSPECIFIED

Joe Orton writes:
> I just dropped the xlink: from the href attribute, and got rid of the
> xlink:role attribute entirely, giving e.g.:
>
> <D:prop>
>  <D:source-set>
>   <D:source href="http://example.com/dav/source.xml">Source</D:source>
>   <D:source href="http://example.com/dav/render.xsl">Stylesheet</D:source>
>   <D:source href="http://example.com/dav/etc.etc"/>
>  </D:source-set>
> </D:prop>
>

I like this, except for the "Source" and "Stylesheet" not being individual
elements or attributes. The i18n characteristics of the approach above are
not great -- I can just see a Kanji UI popping up a pick list of English
words, ugh. What was the perceived problem with using the xlink:role
attribute (and Xlink syntax in general?)

- Jim

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 16 May 2002 07:36:55 +0200

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Tuesday, May 14, 2002 1:50 PM
> To: Webdav WG (E-mail)

Geoff,

- there's plainly no consensus in the XML developer community about that,

- what's the *benefit* of marking up a URI as element instead of an
attribute, and if there is one, why do you think that XLink ignore this
fact,

- your proposal doesn't include a standard way for definining the type of a
link (an XLink feature that my proposal simple inherits).

Julian