Subject: RE: Microsoft WebFolders and resource type

From: Hiren Shah-SSI <[email-masked]>
Date: Thu, 9 May 2002 09:45:07 -0700

Hi,

I am totally new to DAV. I am just trying to find my way out. We have to use
DAV in our application so I am searching abt it on google and got few links
but can anyone let me know more abt it  or can you send me any other links
which are good .

Thanks alot,
Aarti

-----Original Message-----
From: Clemm, Geoff [mailto:[email-masked]]
Sent: Thursday, May 09, 2002 5:28 AM
To: WebDAV
Subject: RE: Microsoft WebFolders and resource type

Not only is DAV:version as a resourcetype not in RFC-3253,
it is explicitly forbidden in RFC-3253 (the DAV:resourcetype
of a version must be the same as the DAV:resourcetype of the
version-controlled resource that was checked in to create it).

And also note that this one done to some extent with the
WebFolders problem in mind ...  In particular RFC-3253 only
gives non-null DAV:resourcetype values to resources that have
no content (which means that it should cause no problem to
have them be treated as "folders" by WebFolders).

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Thursday, May 09, 2002 6:19 AM
To: WebDAV
Subject: RE: Microsoft WebFolders and resource type

> From: Konstantin Knizhnik [mailto:[email-masked]]
> Sent: Wednesday, May 08, 2002 3:34 AM
> To: [email-masked]
> Subject: [Moderator Action] Microsoft WebFolders and resource type
>
>
> Looks like, MS-Explorer treat each resource with not empty
> <DAV:resourcetype> as collection. For example, if resource type is
>
> <DAV:resourcetype>
> <DAV:version/>
> </DAV:resourcetype>
>
> this version is displayed as folder.
> Does anybody knows how to solve the problem and make
> this version visible as normal file (not folder) in MS-Explorer?

a) AFAIK, there's no workaround for this particular problem in Microsoft's
compliant. Keep complaing to them.

b) But: why are you trying to specify a resourcetype of DAV:version at the
first place? That's not in RFC3253...

---

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 9 May 2002 10:26:03 -0700

RE: Microsoft WebFolders and resource typeThe WebDAV.org site is the best
overall source of information about WebDAV. The WebDAV working group site
also has a wealth of information:

http://www.webdav.org/
http://www.ics.uci.edu/pub/ietf/webdav/

But, since you've done a Google search, you undoubtedly have already found
these pages...

- Jim
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Hiren Shah-SSI
  Sent: Thursday, May 09, 2002 9:45 AM
  To: 'Clemm, Geoff'; WebDAV
  Subject: RE: Microsoft WebFolders and resource type

  Hi,

  I am totally new to DAV. I am just trying to find my way out. We have to
use DAV in our application so I am searching abt it on google and got few
links but can anyone let me know more abt it  or can you send me any other
links which are good .

  Thanks alot,
  Aarti

  -----Original Message-----
  From: Clemm, Geoff [mailto:[email-masked]]
  Sent: Thursday, May 09, 2002 5:28 AM
  To: WebDAV
  Subject: RE: Microsoft WebFolders and resource type

  Cheers,
  Geoff