Subject: [w3c-dist-auth] <none>

From: "Rajiv A V" <[email-masked]>
Date: Tue, 11 Jun 2002 20:33:19 +0530

Hi, 
  I have a very trival issue in the use of lock tokens. reading about the use of lock tokens from the RFC it seems that a process (user)should be aware of the resources he is deleting. But let us assume that my client fetches lock tokens (performs lock discovery) on a need basis. Now assume that I want to delete a folder resource inside which I have some stuff that I have locked myself. I have 2 ways to implement it

a) dont delete the resouce since the user hasnt seen the resource yet and wait for the user to see all the resources that he has locked (effectively meaning that then he has a lock token for all the needed resources because thats when the lock discovery is done)
b) when i recieve that detail from the server that tells me that some resouce is locked, just inform the user that there are locks inside        the folder. then on user confirmation the client would interally fetch all the lock tokens for resources that are locked inside the folder and goes ahead with the delete. this would be transparent to the user but the user knows that he is deleting resources that he has a lock on.

I know this is a implementation issue but please let me know which is the right way to do it and would be more webdav compliant.

 thanks and regards,
     rajiv

---

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 11 Jun 2002 09:58:38 -0700

Do not simply rely on fetching lock tokens with the lockdiscovery property.
Your client will risk deleting locks which have been created by other WebDAV
software used by the same user.  For example, if your client deletes a lock
which the user's Microsoft Word software created, Microsoft Word will be
unable to save the file and will give the user an error.

This means that all WebDAV client software must keep and maintain its own
list of what resources it has locked.

The only exception is when you can prompt the user to ask "Is it OK to
remove the lock on this resource?  Are you sure it isn't being locked by
another process?"

Lisa

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rajiv A V
> Sent: Tuesday, June 11, 2002 8:03 AM
> To: [email-masked]
> Subject: [w3c-dist-auth] <none>
> 
> 
> Hi, 
>   I have a very trival issue in the use of lock tokens. 
> reading about the use of lock tokens from the RFC it seems 
> that a process (user)should be aware of the resources he is 
> deleting. But let us assume that my client fetches lock 
> tokens (performs lock discovery) on a need basis. Now assume 
> that I want to delete a folder resource inside which I have 
> some stuff that I have locked myself. I have 2 ways to implement it
> 
> a) dont delete the resouce since the user hasnt seen the 
> resource yet and wait for the user to see all the resources 
> that he has locked (effectively meaning that then he has a 
> lock token for all the needed resources because thats when 
> the lock discovery is done)
> b) when i recieve that detail from the server that tells me 
> that some resouce is locked, just inform the user that there 
> are locks inside        the folder. then on user confirmation 
> the client would interally fetch all the lock tokens for 
> resources that are locked inside the folder and goes ahead 
> with the delete. this would be transparent to the user but 
> the user knows that he is deleting resources that he has a lock on.
> 
> I know this is a implementation issue but please let me know 
> which is the right way to do it and would be more webdav compliant.
> 
>  thanks and regards,
>      rajiv
>