Subject: Re: New RFC2518bis draft, LOCK_REFRESH_BY_METHODS

From: "Jason Crawford" <[email-masked]>
Date: Thu, 27 Jun 2002 12:25:03 -0400

The current wording is difficult to understand.  I'd suggest that the
wording be changed from...

 The timeout counter SHOULD NOT be restarted any time an owner of the lock
sends a method to any member of the lock, including unsupported methods, or
methods which are unsuccessful.  However the lock MUST be refreshed if a
refresh LOCK method is successfully received.

To simply say...

The timeout counter SHOULD only be restarted  if a refresh LOCK method is
successfully received.

If you like, we can mention that this is a change from 2518.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 27 Jun 2002 13:25:16 -0400

That sounds good to me.

Cheers,
Geoff
-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Thursday, June 27, 2002 12:25 PM
To: Lisa Dusseault
Cc: Webdav WG (E-mail)
Subject: Re: New RFC2518bis draft, LOCK_REFRESH_BY_METHODS

The current wording is difficult to understand. I'd suggest that the wording
be changed from...

To simply say...

---

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 27 Jun 2002 13:27:40 -0400

Yes, I agree that is better.
 
Cheers,
Geoff

-----Original Message-----
From: Lisa Dusseault [mailto:[email-masked]]
Sent: Thursday, June 27, 2002 12:46 PM
To: Jason Crawford
Cc: [email-masked]
Subject: RE: New RFC2518bis draft, LOCK_REFRESH_BY_METHODS

I'm not so sure about the wording you suggest. It drops the requirement that
the lock MUST be refreshed if a refresh LOCk method is successful.  How
about this:

"The timeout counter MUST be restarted if a refresh LOCK request is
successful.  The timeout counter SHOULD NOT be restarted at any other time."

Lisa

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]] 
Sent: Thursday, June 27, 2002 8:25 AM
To: Lisa Dusseault
Cc: Webdav WG (E-mail)
Subject: Re: New RFC2518bis draft, LOCK_REFRESH_BY_METHODS

To simply say...