Subject: RE: root of a lock, was HOW_TO_IDENTIFY_LOCK_OWNER

From: "Julian Reschke" <[email-masked]>
Date: Mon, 8 Jul 2002 13:24:43 +0200

> To: Daniel Brotsky <[email-masked]>
> Cc: "Clemm, Geoff" <[email-masked]>, [email-masked]
> Message-ID: <[email-masked]>
> From: "Jason Crawford" <[email-masked]>
> Date: Mon, 14 Jan 2002 15:19:50 -0500
> Subject: RE: root of a lock, was HOW_TO_IDENTIFY_LOCK_OWNER
>
>
> > In addition to Geoff's answer:
> > If you are an administrator trying to unlock a resource obtained by
> > someone else, you have to be able to figure out which resource to
> > unlock.  You can't unlock an internal member of a collection that's
> > locked by a depth-inifinity lock without knowing which collection was
> > actually locked.
>
> CAN'T?

(going back to an old discussion...)

RFC2518, 8.11 says [1]:

"The UNLOCK method removes the lock identified by the lock token in the
Lock-Token request header from the Request-URI, and all other resources
included in the lock. If all resources which have been locked under the
submitted lock token can not be unlocked then the UNLOCK request MUST fail.
"

So do we have agreement that *any* of the URIs affected by a deep lock can
be used to do the UNLOCK operation?

[1] <http://greenbytes.de/tech/webdav/rfc2518.html#METHOD_UNLOCK>

---

From: Dan Brotsky <[email-masked]>
Date: Mon, 8 Jul 2002 08:37:17 -0700

> be used to do the UNLOCK operation?

Yes.  (My earlier wording reflected a different confusion about the 
conversation Geoff and I were having. :^)

     dan

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 8 Jul 2002 17:45:53 +0200

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Dan Brotsky
> Sent: Monday, July 08, 2002 5:37 PM
> To: [email-masked]
> Subject: Re: root of a lock, was HOW_TO_IDENTIFY_LOCK_OWNER
>
>
>

In the meantime I can confirm that indeed this is what moddav and Xythos
implement (IIS doesn't seem to support deep locks).