Subject: RE: Doubt in error response

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 24 Jul 2002 16:49:45 -0400

We use 412 Precondition Failed, which seems to be appropriate because
having a lock is a precondition to being able to unlock.  

Any objections to adding that in RFC2518bis?

Lisa

> -----Original Message-----
> From: ganesh_k [mailto:[email-masked]]
> Sent: Thursday, July 04, 2002 1:03 AM
> To: [email-masked]
> Subject: Doubt in error response
> 
> 
> Hi all
> What error response is the WebDAV server supposed to send if it
receives
> an UNLOCK request on a resource which is not locked in the first
place?
> Is it it 403- forbidden or method failed or something else?
> 
> Regds
> Ganesh

---

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 25 Jul 2002 14:10:03 -0700

> Any objections to adding that in RFC2518bis?

This is a good error code to use in this case.

- jim