Subject: RE: Issue: URI_URL, proposed changes

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 31 Jul 2002 14:27:46 -0400

So how can you in any sense "use the URI to effectively
author the resource" (which you agree below is the purpose of
the DAV:dst field) if you can't even locate the resource
identified by the URI?

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]

> From: [email-masked]
>
> It appears below that Julian and I agree on most aspects of
> this issue, with the only remaining question being "what kind
> of URI should be placed in a DAV:dst field".
>
> I believe that the answer will always be somewhat vague, and
> of the form "a URI that the user can effectively use to
> author (i.e. modify the content of) the resource".

Yes, that's vague, and I don't think this is a problem.

> In order to author a resource via the DAV:dst URI,
> minimally, you have to locate the resource (i.e. the

I don't agree that it's a requirement that the resource being referred to
must be authorable. For a server, it's almost impossible to decide which
kinds of URIs are useful to an authoring client. So I wouldn't restrict them
at all.

>  ...

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 31 Jul 2002 21:14:35 +0200

> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Wednesday, July 31, 2002 8:28 PM
> To: 'Webdav WG (E-mail)'
> Subject: RE: Issue: URI_URL, proposed changes
>
>
>

As I said before, even a URN (for instance identifying a book or a RFC) may
be a useful piece of information. I can't change *that* resource (at least
not using HTTP), but it may be useful to know that the destination resource
depends on it.