Subject: RE: I-D ACTION:draft-mealling-iana-xmlns-registry-04.txt

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 3 Jul 2002 16:01:29 -0400

Well, one possibility is that a set of custom WebDAV properties (or at
the limit, just one) could be expressed in an XML schema, and that
schema could be registered. Another possibility is that committed
individuals could work with Mealling to see if it's feasible for the
registry specification to include specific element names. 

lisa

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]] 
Sent: Wednesday, July 03, 2002 12:13 PM
To: Lisa Dusseault; Webdav WG
Subject: RE: I-D ACTION:draft-mealling-iana-xmlns-registry-04.txt

I'm not sure... this is a registry for namespace names, DTD identifiers,
XML
schemas or RDF schemas -- not for specific element names. How do you
think
it can be applied to WebDAV properties?

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> Sent: Wednesday, July 03, 2002 8:45 PM
> To: Webdav WG
> Subject: FW: I-D ACTION:draft-mealling-iana-xmlns-registry-04.txt
>
>
> FYI - I don't think Mealling's XML registry draft has been discussed
on
> the list yet, so I wanted to point it out. It may be useful to
register
> custom WebDAV properties.
>
> Lisa
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, July 03, 2002 3:30 AM
> Subject: I-D ACTION:draft-mealling-iana-xmlns-registry-04.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: The IETF XML Registry
> 	Author(s)	: M. Mealling
> 	Filename	: draft-mealling-iana-xmlns-registry-04.txt
> 	Pages		: 7
> 	Date		: 02-Jul-02
>
> This documenet describes an IANA maintained registry for IETF
> standards which use XML related items such as Namespaces, DTD,
> Schemas, and RDF Schemas.
>
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-mealling-iana-xmlns-registry-0
> 4.txt
>
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the
> message.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-mealling-iana-xmlns-registry-04.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE
> /internet-drafts/draft-mealling-iana-xmlns-registry-04.txt".
>
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 3 Jul 2002 22:10:59 +0200

I know that a property registry has been on the to-do list for a long time,
yet I'm not sure what the goal would be.

For DAV: properties, I think we have established that they MUST be defined
in a WebDAV related RFC. It may make sense to come up with an informational
document that lists all RFC2518/RFC3253/RFC(ACL) properties, but do
third-party properties really need a registry?

In the general case, I'd expect that the creator of a new property will use
it's namespace name to make a namespace description document (for instance
in RDDL) available. Do we really need more?

> From: Lisa Dusseault [mailto:[email-masked]]
> Sent: Wednesday, July 03, 2002 10:01 PM
> To: Julian Reschke; Webdav WG