Subject: RE: BIND vs. non-movable resources in RFC3253

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 21 Oct 2002 13:27:02 -0400

The purpose of a stable URL for a version and a version
history is to guarantee that that URL will always identify
that resource.  This provides the client with two benefits:

The first is that it can just pass that URL around
and not have to worry about getting the wrong
resource because that URL has been remapped to another
resource.

The second is to give the client a "reliable" way to locate
the resource (i.e. a mapping that only goes away when the
resource no longer exists).

I believe the second benefit is worth the added complexity
of saying "the stable binding cannot be deleted if there
are multiple entries in the DAV:parent-set".

Whether or not this is a a significant benefit of course
depends on whether your client takes advantage of it, but I
think the cost is minimal, especially since these kinds of
bindings are already constrained to never be remapped to
another resource.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Monday, October 21, 2002 12:57 PM
To: Clemm, Geoff; 'Webdav WG'
Subject: RE: BIND vs. non-movable resources in RFC3253

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Clemm, Geoff
> Sent: Monday, October 21, 2002 6:37 PM
> To: 'Webdav WG'
> Subject: RE: BIND vs. non-movable resources in RFC3253
>
>
> It is also desireable that a client be able to use
> the original URL as long as that resource exists.

But why? It *is* allowed to delete the resource, so there's no guarantee
that the version/VHR will be kept eternally. From a client's point of view,
it's completely irrelevant whether it's getting the 404 because the resource
was deleted or because it was moved.

> Stefan's proposal ensures that is the case.

Yes, but it makes the model more complicated with little benefit. Forbidding
a DELETE on a binding just because other bindings continue to exist seems to
contradict the intent of the BIND spec. Therefore I'd like to see better
reasons why we really need that. In doubt, we should *simplify* things, not
make them more complicated.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 21 Oct 2002 19:48:06 +0200

> Sent: Monday, October 21, 2002 7:27 PM
> To: 'Webdav WG'

Agreed and not controversial.

> resource no longer exists).

And here I still don't see the benefit. Forbidding MOVE just to achieve this
seems to be unnecessarily restrictive. The client can't rely on the resource
being available anyway -- what difference does it make *why* it's not
available anymore behind the request URI?

> are multiple entries in the DAV:parent-set".

You just introduced the new term "the stable binding" :-)

Again: if there's a choice between simplying and complicating things, we
should try to simplify the model, unless an *essential* feature requires
this. I fail to see why the second benefit would be essential.

> depends on whether your client takes advantage of it, but I

(*) *How* would a client take advantage of this benefit?

> bindings are already constrained to never be remapped to

Why is this relevant? The ability not to re-use a previously assigned
binding is a property of the collection containing the binding. If my server
allows deletion of VHRs and/or versions, it will have to be able to take
care of this anyway -- it doesn't matter at all whether the binding
disappeared because of a DELETE or a MOVE.

So, I'm still unconvinced.

Can we concentrate on the question marked (*)?