Subject: RE: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 23 Oct 2002 13:32:13 -0400

The current draft states that the
quota values do not vary by user.  I believe that this
should be changed to explicitly state that they *are* per
user quota values.  A server that only maintains global
quotas would then just return the same value for every
authenticated user.

Cheers,
Geoff

-----Original Message-----
From: Eric Sedlar [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 1:21 PM
To: Julian Reschke; Lisa Dusseault; 'Stefan Eissing'; Webdav WG
Subject: Re: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

It seems like this draft is fine with a user-based rather than a
collection-based
system--the server will report the same usage & quota for any collection,
but
will return different results depending on who is authenticated, no?

----- Original Message -----
From: "Julian Reschke" <[email-masked]>
To: "Lisa Dusseault" <[email-masked]>; "'Stefan Eissing'"
<[email-masked]>; "Webdav WG" <[email-masked]>
Sent: Wednesday, October 23, 2002 10:05 AM
Subject: RE: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

>
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> > Sent: Wednesday, October 23, 2002 6:56 PM
> > To: 'Stefan Eissing'; Webdav WG
> > Subject: Re: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt
> >
> > ...
> >
> > Quota is applied to a collection, *not* a user, specifically because of
> > the model where a user doesn't just put documents in their own home
> > directory.  That's explicit in the draft, and it's an important feature
> > to allow directories to be shared by many users and still have quota
> > applied.  So if a quota of 1000MB is applied to the "/sales/"
> > collection, the server is free to report that quota, and count space
> > consumed by resources in the "/sales/" collection in whatever way its
> > policy decides.
>
> This kind of quota system is incompatible with the quota system in a Unix
> filesystem (where AFAIK it's per user) -- a standard proposal must be able
> to handle these kinds of systems as well.
>
> > ...
>
> Julian
>
> --
> <green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760
>
>

---

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 23 Oct 2002 11:09:40 -0700

1.  Is there general consensus to agree with Geoff?  
2.  Is there actually an implementation need for this?

I'm a little dubious about altering the draft to say this, because it
starts to get really unclear what space-used-bytes means when it can
vary from user to user.

lisa

-----Original Message-----
From: Eric Sedlar [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 1:21 PM
To: Julian Reschke; Lisa Dusseault; 'Stefan Eissing'; Webdav WG
Subject: Re: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

It seems like this draft is fine with a user-based rather than a
collection-based
system--the server will report the same usage & quota for any
collection,
but
will return different results depending on who is authenticated, no?

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 23 Oct 2002 20:51:46 +0200

> Sent: Wednesday, October 23, 2002 8:10 PM
> To: 'Clemm, Geoff'; 'Webdav WG'

If it *does* vary by user (and it does in many quota systems), we'll have to
live with that. Alternatively, don't make it a live property but define a
new report instead.

Julian