Subject: RE: BIND method response codes

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 9 Oct 2002 16:19:37 -0400

A problem with 200/201, is that 201 means "a new resource
was created", but a BIND never creates a new resource, but
just creates a new binding to an existing resource.  We could
of course still use 200/201, but I'd be concerned that it would
be misleading.

If a client has asked that BIND overwrite any existing binding
for that segment, why would it care whether or not there was
already a binding there?

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Wednesday, October 09, 2002 2:55 PM
To: [email-masked]
Subject: BIND method response codes

Hi,

similarily to the PUT method, I'd like to be able to distinguish between

- a new BIND was created (201)
- an existing BIND was overwritten (200)

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: Stefan Eissing <[email-masked]>
Date: Thu, 10 Oct 2002 10:05:55 +0200

Maybe it would be more appropriate to reuse the response codes as
defined for MOVE in RFC 2518:

201: newly created
204: replaced existing resource
etc.

//Stefan

Am Mittwoch, 09.10.02, um 22:19 Uhr (Europe/Berlin) schrieb Clemm, 

> of course still use 200/201, but I'd be concerned that it would

Ohoh. resources, uris and representations. That's www-tag ground
we're treating on here. I think one needs at least 8 years experience
in HTTP and Apache development to talk about that topic... ;)

Anyway: a BIND creates a mapping for an URI to a representation
exactly like PUT does. That the representation is not supplied by
the client, but reused from another URI, is not relevant.

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 10 Oct 2002 10:37:01 +0200

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Clemm, Geoff
> Sent: Wednesday, October 09, 2002 10:20 PM
> To: [email-masked]
> Subject: RE: BIND method response codes
>
>

That's correct with the WebDAV/BIND definition of a resource, but not with
the generic (RFC2396) one -- the binding itself has a unique identifier (and
thus has identity), therefore *can* be considered a resource.

> for that segment, why would it care whether or not there was

Well, why would it care in the case of PUT or MOVE? I'm just looking for
consistency with other methods.

Julian