Subject: Re: BIND method response codes, new header?

From: Jason Crawford <[email-masked]>
Date: Thu, 10 Oct 2002 11:06:04 -0400

Or.... how about....  (get your tomatoes ready...)

A new header, whereby the client can submit
assertions that it wants the server to test.  These tests
need not prevent an operation from occuring, but
they can inform the user of the situation just before
(or after) the operation occured.   It could test for things 
like etags and locks.  And in this case it could test if
a resource existed.

This header would not be bind specific.  And it
need not go in the spec now.  But if we are anticipating 
something like this, we wouldn't need to spend time defining
a new status code now or even debating which one to use.

J.

------------------------------------------
Phone: 914-784-7569

---

From: Stefan Eissing <[email-masked]>
Date: Fri, 11 Oct 2002 11:16:13 +0200

Am Donnerstag, 10.10.02, um 17:06 Uhr (Europe/Berlin) schrieb Jason 

> Or.... how about....  (get your tomatoes ready...)

I prefer eggs. Old eggs. ;)

> a new status code now or even debating which one to use.

If it affects the response, but not the spec, any result of the
test would need to be returned in a specific response header, right?

So, you'd introduce a separate communication channel on top of/
sideways to HTTP. This is... let's say, hummm,... interesting.

I wouldn't bet my money on its success, though.

//Stefan