Subject: RE: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 24 Oct 2002 08:52:47 -0400

I'm happy to just have the two properties, and reword the
description so that they are clearly the quota for the
current user,
where a given implementation can choose to have all files
(not just the files created by that user) use up that quota.

I'd suggest most of the content of the draft just be deleted
since I believe its major problem at the moment is overspecification.
There is no need for much motivation, since the concept is
quite straightforward and familiar to most people.  In particular,
Stefan's suggested wording is fine with me.  I don't think I'd
bother with giving the quota space an identifier, but I wouldn't
object to defining a property for it.

Cheers,
Geoff

-----Original Message-----
From: Stefan Eissing [mailto:[email-masked]]
Sent: Thursday, October 24, 2002 4:44 AM
To: Clemm, Geoff
Cc: Webdav WG
Subject: Re: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt

Am Mittwoch, 23.10.02, um 21:39 Uhr (Europe/Berlin) schrieb Clemm, 
Geoff:

> Possibly we should have two pairs of standard properties:
>
> DAV:quota
> DAV:quota-used

That would be "space-left-on-device" and not a quota. Certainly
every file system has it, but clients are more concerned
with the per-user quotas. Do you see a need to define these
properties?

> DAV:current-user-quota
> DAV:current-user-quota-used
>
> (analogous to the way the ACL draft as current-user privileges)
>
> Cheers,
> Geoff
>
> -----Original Message-----
> From: Julian Reschke [mailto:[email-masked]]
> Sent: Wednesday, October 23, 2002 3:00 PM
> To: Brian Korver
> Cc: Webdav WG
> Subject: RE: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt
>
>
>
> Brian,
>
> > From: Brian Korver [mailto:[email-masked]]
> > Sent: Wednesday, October 23, 2002 8:56 PM
> > To: Julian Reschke
> > Cc: Webdav WG
> > Subject: Re: FW: I-D ACTION:draft-dusseault-dav-quota-01.txt
> >
> >
> > On Wednesday, October 23, 2002, at 10:05 AM, Julian Reschke wrote:
> > > This kind of quota system is incompatible with the quota system in 
> a
> > > Unix
> > > filesystem (where AFAIK it's per user) -- a standard proposal must 
> be
> > > able
> > > to handle these kinds of systems as well.
> >
> > In BSD anyhow, quotas are applied to users and/or groups.  That said,
> > "collection quotas" (if we can even call them that) are generally 
> enforced
> > by mounting appropriately-sized partitions.  Just FYI.
>
> Interesting. So if we take groups into account, we'll need a more 
> flexible
> reporting mechanism, right?
>
> Julian
>
> --
> <green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760
>

---

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 24 Oct 2002 09:48:04 -0400

I agree with Julian.

Cheers,
Geoff

-----Original Message-----

I think that the distinction between collections and non-collections is
essentially meaningless -- the properties defined here apply to the quota
space, not to a particular resource. Therefore they should be defined on all
resources that are quota-controlled.

>     This property is OPTIONAL on collections and SHOULD NOT exist on
>     non-collection resources.  When a new collection is created, it is
>     up to the server to initialize the value appropriately if it chooses
>     to.

Completely remove this paragraph.