Subject: RE: BIND response codes

From: Jason Crawford <[email-masked]>
Date: Tue, 15 Oct 2002 16:39:16 -0400

On Tuesday, 10/15/2002 at 07:49 ZE2, "Julian Reschke"  wrote:
> For the same reason a Unix file system by default behaves this way.
> 
> Hard links to collections are dangerous (loops) and in most cases 
required
> (symlinks aka redirect refs to collections in most cases are all that's
> required).

For example, garbage collecting a file system in the presence of 
loops can be relatively expensive.

I really don't want a new status code, but if we can't find an appropriate 

existing one, I'm tentatively supportive of Julian's proposal to add one.

---

From: "Matthew Murphy" <[email-masked]>
Date: Tue, 15 Oct 2002 13:50:44 -0700

How can I get off this list? Its not what I thought it would be about.

Matthew Murphy
Cop N Proc
1528 N Williams St
Stockton, Ca. 95205
209.271.6639 Fax 209.464.0381
----- Original Message -----
From: "Jason Crawford" <[email-masked]>
To: "Julian Reschke" <[email-masked]>
Cc: "Jim Whitehead" <[email-masked]>; "'Webdav WG'"
<[email-masked]>
Sent: Tuesday, October 15, 2002 1:39 PM
Subject: RE: BIND response codes

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 15 Oct 2002 23:05:55 +0200

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Tuesday, October 15, 2002 10:39 PM
> To: Julian Reschke
> Cc: Jim Whitehead; 'Webdav WG'

I think it's clear that there *will* be implementations that do not allow
additional bindings on collections (for instance those that are
Unix-filesystem based).

We don't need a new status code, I was just trying to figure out whether to
return 405 (not allowed) or 403 (forbidden) with a well-defined
pre-condition (DAV:collection-binds-supported?).

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760