Subject: RE: BIND draft -- error conditions

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 14 Oct 2002 10:08:49 -0400

Good catch.  We are missing a DAV:bound-resource-exists
condition (I'll add one).  The 404 refers to the request-URL
not existing, so that clearly does not apply to this case.
As for case (1), 404 seems to be the most meaningful status
to return.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Monday, October 14, 2002 9:44 AM
To: WebDAV (E-mail)
Subject: BIND draft -- error conditions

1) What is the expected response for the case where the request URI is not
mapped?

1a) 404 NOT FOUND?
1b) 409 Conflict with DAV:error/DAV:bind-into-collection?

2) What is the expected response code for the case where the resource to be
bound does not exist (DAV:href in the request is unmapped)?

2a) 404 NOT FOUND?
1b) 409 Conflict with DAV:error/DAV:???

Obviously, I'd prefer not to have 1a) and 2a).

Julian

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 14 Oct 2002 16:32:14 +0200

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Clemm, Geoff
> Sent: Monday, October 14, 2002 4:09 PM
> To: WebDAV (E-mail)
> Subject: RE: BIND draft -- error conditions
> 
> 

Perfect.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: "Jim Whitehead" <[email-masked]>
Date: Tue, 15 Oct 2002 10:38:08 -0700

Sounds good to me as well.

- Jim

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Julian Reschke
> Sent: Monday, October 14, 2002 7:32 AM
> To: Clemm, Geoff; WebDAV (E-mail)