Subject: RE: BIND vs. non-movable resources in RFC3253

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 31 Oct 2002 08:56:45 -0500

From: Julian Reschke [mailto:[email-masked]]

   > From: Clemm, Geoff
   > A COPY would have to check for any
   > resource that has multiple entries in its DAV:parent-set, to see if it
   > has already been copied (in which case a second binding to the copy is
   > created).

   This COPY behaviour makes sense, but can we really require it?
   Right now it seems completely legal to just create multiple plain
   new resources with same content and dead properties...

If the binding relationships are acyclic, creating multiple
plain new resources with the same content and dead properties
seems reasonable to me (i.e. I don't think the spec should
forbid it), but this would be a somewhat expensive approach if
there are cycles (:-).

Cheers,
Geoff

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 31 Oct 2002 15:06:31 +0100

RE: BIND vs. non-movable resources in RFC3253On the other hand, doing that
would make the question about response codes moot.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Clemm, Geoff
  Sent: Thursday, October 31, 2002 2:57 PM
  To: [email-masked]
  Subject: RE: BIND vs. non-movable resources in RFC3253

  Cheers,
  Geoff