Subject: RE: BIND vs. non-movable resources in RFC3253

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 21 Oct 2002 12:37:15 -0400

It is also desireable that a client be able to use
the original URL as long as that resource exists.

Stefan's proposal ensures that is the case.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Monday, October 21, 2002 11:15 AM
To: Clemm, Geoff; 'Webdav WG'
Subject: RE: BIND vs. non-movable resources in RFC3253

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Clemm, Geoff
> Sent: Monday, October 21, 2002 4:42 PM
> To: 'Webdav WG'
> Subject: RE: BIND vs. non-movable resources in RFC3253
>
>
> I agree with Stefan's proposal.
> The key semantics that we wanted to maintain is that "if the
> resource exists, it exists at the original URL".  Stefan's

Do we agree that *the* key semantics is that a URL that has been assigned to
a version or a VHR never is assigned to anything else?

In which case I don't understand why the special MOVE semantics (that we're
causing me to start this thread) are relevant. Why don't we gust get rid of
them?

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 21 Oct 2002 18:57:19 +0200

> Sent: Monday, October 21, 2002 6:37 PM
> To: 'Webdav WG'

But why? It *is* allowed to delete the resource, so there's no guarantee
that the version/VHR will be kept eternally. From a client's point of view,
it's completely irrelevant whether it's getting the 404 because the resource
was deleted or because it was moved.

> Stefan's proposal ensures that is the case.

Yes, but it makes the model more complicated with little benefit. Forbidding
a DELETE on a binding just because other bindings continue to exist seems to
contradict the intent of the BIND spec. Therefore I'd like to see better
reasons why we really need that. In doubt, we should *simplify* things, not
make them more complicated.

Julian