Subject: Re: Bindings and Locks (was: bind draft issues)

From: Jason Crawford <[email-masked]>
Date: Wed, 5 Mar 2003 02:25:28 -0500

On Tuesday, 03/04/2003 at 05:33 PST, Brian Korver
<[email-masked]> wrote:
> On Tuesday, March 4, 2003, at 12:13  PM, Clemm, Geoff wrote:
> > The only argument for not doing so is that being more
> > specific probably requires including the entire GULP
> > document, since that is needed to clearly define the difference
> > between locking a resource and protecting a URL.
> > But I don't think we want to include that information by
> > copy in each protocol extension document, so I think it
> > is more appropriate to get it into 2518bis, and refer to
> > it from the other documents.
> >
> > Cheers,
> > Geoff
>
> Geoff,
>
> As GULP frequently defines things in terms of bindings,
> the text as-is seems more appropriate to the binding
> spec.

Yah.  That's a toughie.  It lists things that are both important to the
binding spec and the base 2518 spec.  But it also apparently
covers things that are outside the realm of each of these specs.
It might need to be submitted as a seperate document that clarifies
(and "unifies") both specs after they come out.

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 5 Mar 2003 09:40:11 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Wednesday, March 05, 2003 8:25 AM
> To: Brian Korver
> Cc: WebDAV
> Subject: Re: Bindings and Locks (was: bind draft issues)
>
>
>
>
>
>

Again strong disagreement.

Each of the paragraphs in GULP is needed to correctly explain RFC2518
locking semantics. If you think there's something which *isn't* needed for
RFC2518, please point to it :-)

Julian
--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760