Subject: RE: Bindings and Locks (was: bind draft issues)

From: Jason Crawford <[email-masked]>
Date: Mon, 3 Mar 2003 16:00:42 -0500

On Monday, 03/03/2003 at 03:31 EST, "Clemm, Geoff"
<[email-masked]> wrote:
> OK, since the bind protocol only introduces one
> new method, with simple behavior in the presence of
> locks, I'm happy to add the appropriate precondition
> to the BIND definition.  In particular, I propose to
> add the following precondition:
>
> (DAV:locked-update-allowed): if the collection identified by the
Request-URL
> is write-locked, then the appropriate token MUST be specified in an If
> request header.
>
> Anyone object to this addition?

I don't object, but I feel if we do add this, we'll also have to list the
possibility
of the binding being protected by a lock in the subtree.   I think that
isn't covered
by the wording above.    I'm not sure if you want to reword this one or add
another
precondition.

J.

---

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 3 Mar 2003 16:24:18 -0500

Good point!

I assume by "the binding being protected", you mean in the
case where the binding already exists, and the Overwrite:T
header is specifed?  If so, I agree that we need another
precondition to handle this.  How about:

(DAV:locked-overwrite-allowed): If the collection already contains a binding
with the specified path segment, and if that binding is protected by a
write-lock, then the appropriate token MUST be specified in an If request
header.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Monday, March 03, 2003 4:01 PM
To: Clemm, Geoff
Cc: WebDAV
Subject: RE: Bindings and Locks (was: bind draft issues)

Request-URL

J.

---

From: "Verma, Nitin" <[email-masked]>
Date: Wed, 5 Mar 2003 09:36:21 +0200

Is anybody tell me... how to unsubscribe from this group. Am sick and tired
of getting useless mails.

Thanks and Regards,
Nitin

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]] 
Sent: Wednesday, March 05, 2003 9:25 AM
To: Brian Korver
Cc: WebDAV
Subject: Re: Bindings and Locks (was: bind draft issues)

On Tuesday, 03/04/2003 at 05:33 PST, Brian Korver
<[email-masked]> wrote:
> On Tuesday, March 4, 2003, at 12:13  PM, Clemm, Geoff wrote:
> > The only argument for not doing so is that being more
> > specific probably requires including the entire GULP
> > document, since that is needed to clearly define the difference
> > between locking a resource and protecting a URL.
> > But I don't think we want to include that information by
> > copy in each protocol extension document, so I think it
> > is more appropriate to get it into 2518bis, and refer to
> > it from the other documents.
> >
> > Cheers,
> > Geoff
>
> Geoff,
>
> As GULP frequently defines things in terms of bindings,
> the text as-is seems more appropriate to the binding
> spec.

Yah.  That's a toughie.  It lists things that are both important to the
binding spec and the base 2518 spec.  But it also apparently
covers things that are outside the realm of each of these specs.
It might need to be submitted as a seperate document that clarifies
(and "unifies") both specs after they come out.

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: Jason Crawford <[email-masked]>
Date: Wed, 5 Mar 2003 11:22:43 -0500

> Again strong disagreement.
Is it ever not "strong"? :-)

> Each of the paragraphs in GULP is needed to correctly explain RFC2518
> locking semantics. If you think there's something which *isn't* needed
for
> RFC2518, please point to it :-)

I step back from what I said.  I think it is possible to put the current
GULP
document in 2518bis.