Subject: RE: Move and Delete (was: bind draft issues)

From: "Clemm, Geoff" <[email-masked]>
Date: Fri, 7 Mar 2003 18:34:16 -0500

I still vote for "SHOULD".  In particular, given the problems
partial DELETE and partial MOVE can produce in a multiple binding
context, a server that supports multiple bindings to a resource
SHOULD do those operations atomically unless it
has a very good reason to do otherwise (e.g. the scenario I
posted earlier).

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Friday, March 07, 2003 3:38 PM
To: Brian Korver; 'WebDAV'
Subject: RE: Move and Delete (was: bind draft issues)

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Brian Korver
> Sent: Friday, March 07, 2003 9:15 PM
> To: 'WebDAV'
> Subject: Re: Move and Delete (was: bind draft issues)
>
> ...
>
> Geoff,
>
> My reading of the consensus was that the atomic behavior should
> be a "MAY", not a "SHOULD" as you suggest, but I don't have religion
> on the issue.

I think Brian is right here. SHOULD is really strong in RFC-speak, and if we
really expect servers to show this behaviour, ir probably needs to be
specified as "MAY".

Julian
--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: Brian Korver <[email-masked]>
Date: Fri, 7 Mar 2003 16:53:37 -0800

Geoff,

Other than loops, what are the problems unique to multiple
bindings and partial MOVE?

-brian
[email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Sat, 8 Mar 2003 08:42:07 +0100

Geoff,

I think we should get back to this issue once we do agree whether or not the
problem you mentioned really exists (see separate thread).

Julian

> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Saturday, March 08, 2003 12:34 AM
> To: 'WebDAV'