Subject: RE: Move and Delete (was: bind draft issues)

From: Jason Crawford <[email-masked]>
Date: Fri, 7 Mar 2003 12:17:55 -0500

> I've posted a revised version of the binding draft to the
> binding web site.  Let me know what you think.
> <http://www.webdav.org/bind/draft-ietf-webdav-bind-01.2.htm>

Sorry to be a pain, but the reason we say that we are splitting in to
DELETE and UNBIND is
because some people claim that clients prefer the non-atomic DELETE
functionality.    But the
new bindings document says that if the server can implement UNBIND, then
DELETE should
be implemented that way.    This leaves me scratching my head.

1) Do users ever want the old DELETE functionality if they can have UNBIND?

2) If we really believe that they do, why do we suggest that the server do
the UNBIND anyway?

It sounds like we really haven't decided (1).   Let's really decide that
and then spec this to match
what we resolve.

J.

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 7 Mar 2003 19:10:59 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Friday, March 07, 2003 6:18 PM
> To: Clemm, Geoff
> Cc: 'WebDAV'
> Subject: RE: Move and Delete (was: bind draft issues)
>
>
>
>
>
>
DELETE and UNBIND is
functionality.    But the
DELETE should
> 1) Do users ever want the old DELETE functionality if they can

I think so. Where it's not really (only) about what the user (client) wants,
but it also depends on what the server is willing to offer. It maybe
technically possible to implement UNBIND (that's very likely if you have a
proper BIND implementation), yet still undesired.

> 2) If we really believe that they do, why do we suggest that the server do

Do we? I think what the spec says is that if a server supports UNBIND on a
collection, DELETE should behave the same. So the choice is on the server's
side. This doesn't give the *client* the ability to decide, though. Do we
need that?

> what we resolve.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760