Subject: RE: Move and Delete (was: bind draft issues)

From: "Clemm, Geoff" <[email-masked]>
Date: Fri, 7 Mar 2003 13:07:53 -0500

My reading of the consensus of the working group (although certainly
not universal agreement) is that atomic behavior
on the part of the server is preferable when the server is capable of
doing so, especially when multiple bindings to a resource is possible.
But since some servers cannot guarantee atomic behavior, this
was made a "SHOULD" instead of a "MUST".  Similarly, any server implementors
that feel their clients want non-atomic behavior can present non-atomic
behavior and still be compatible with the spec (because it is a SHOULD,
not a MUST).

In addition, I believe there was consensus that allowing the
client to explicitly request atomic behavior was desireable, and this
is achieved through the introduction of UNBIND/REBIND.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]

> I've posted a revised version of the binding draft to the
> binding web site.  Let me know what you think.
> <http://www.webdav.org/bind/draft-ietf-webdav-bind-01.2.htm>

Sorry to be a pain, but the reason we say that we are splitting in to
DELETE and UNBIND is
because some people claim that clients prefer the non-atomic DELETE
functionality.    But the
new bindings document says that if the server can implement UNBIND, then
DELETE should
be implemented that way.    This leaves me scratching my head.

1) Do users ever want the old DELETE functionality if they can have UNBIND?

2) If we really believe that they do, why do we suggest that the server do
the UNBIND anyway?

It sounds like we really haven't decided (1).   Let's really decide that
and then spec this to match
what we resolve.

J.

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: Brian Korver <[email-masked]>
Date: Fri, 7 Mar 2003 12:14:57 -0800

> is achieved through the introduction of UNBIND/REBIND.

Geoff,

My reading of the consensus was that the atomic behavior should
be a "MAY", not a "SHOULD" as you suggest, but I don't have religion
on the issue.

-brian
[email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 7 Mar 2003 21:37:45 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Brian Korver
> Sent: Friday, March 07, 2003 9:15 PM
> To: 'WebDAV'
> Subject: Re: Move and Delete (was: bind draft issues)
>
> ...
>
> Geoff,
>

I think Brian is right here. SHOULD is really strong in RFC-speak, and if we
really expect servers to show this behaviour, ir probably needs to be
specified as "MAY".

Julian
--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760