Subject: RE: Bindings and Locks (was: bind draft issues)

From: Jason Crawford <[email-masked]>
Date: Mon, 3 Mar 2003 16:35:21 -0500

On Monday, 03/03/2003 at 04:24 EST, "Clemm, Geoff"
<[email-masked]> wrote:
> Good point!
>
> I assume by "the binding being protected", you mean in the
> case where the binding already exists, and the Overwrite:T
> header is specifed?  If so, I agree that we need another
> precondition to handle this.  How about:
>
> (DAV:locked-overwrite-allowed): If the collection already contains a
binding
> with the specified path segment, and if that binding is protected by a
> write-lock, then the appropriate token MUST be specified in an If request
> header.

I suppose that covers it.  Hopefully the reader understands the situations
that
that covers.

One question though... does it have to be a write-lock?  I suspect
this precondition even applies to non-write locks.

---

From: Brian Korver <[email-masked]>
Date: Tue, 4 Mar 2003 10:41:01 -0800

> I suppose that covers it.  Hopefully the reader understands the 

I'd like to vote in favor of providing enough specificity
that the reader will understand the situations it covers.
Are there any good arguments for not doing so?

> this precondition even applies to non-write locks.
-brian
[email-masked]