Subject: RE: Bindings and Locks (was: bind draft issues)

From: "Clemm, Geoff" <[email-masked]>
Date: Mon, 3 Mar 2003 15:31:56 -0500

OK, since the bind protocol only introduces one
new method, with simple behavior in the presence of
locks, I'm happy to add the appropriate precondition
to the BIND definition.  In particular, I propose to
add the following precondition:

(DAV:locked-update-allowed): if the collection identified by the Request-URL
is write-locked, then the appropriate token MUST be specified in an If
request header.

Anyone object to this addition?

Cheers,
Geoff

-----Original Message-----
From: Brian Korver [mailto:[email-masked]]
Sent: Monday, March 03, 2003 1:57 PM
To: WebDAV
Subject: Re: Bindings and Locks (was: bind draft issues)

On Saturday, March 1, 2003, at 06:27  AM, Clemm, Geoff wrote:
>    Bindings and Locks
>
>    The relationship between bindings and locks is missing
>    from the draft.  I think the behavior of locks and the
>    lock methods should be fully specified in this draft.
>
> RFC2518bis is in the process of finalizing the behavior of
> locks, and we do not want the bind draft to say anything that
> conflicts with this.  Instead, we will make sure that the
> locking model in RFC2518bis clearly defines locking behavior
> in the presence of multiple bindings.

It probably isn't a good idea to introduce a dependency
such as this, especially since 2518bis doesn't have any
notion of bindings.  I don't believe that the binding
document can move forward.

-brian
[email-masked]

---

From: Stefan Eissing <[email-masked]>
Date: Tue, 4 Mar 2003 09:33:20 +0100

Ok with me.

---

From: Brian Korver <[email-masked]>
Date: Tue, 4 Mar 2003 15:21:00 -0800

Geoff and I had a short out-of-band conversation to discuss
the issue I raised when I mentioned "URL properties".
Geoff pointed out that there had been text in the binding
spec that explained the behavior of properties in the
face of different operation, and that it might be good
to revisit the issue and include such explanatory material
in draft.

Would someone like to volunteer to draft that text?
Since I'm not familiar with the previous text and the
discussion that ensued, perhaps Geoff could explain
what the text should include?

-brian
[email-masked]