Subject: Re: FW: ETags again - basic question

From: Jason Crawford <[email-masked]>
Date: Sat, 1 Mar 2003 17:15:00 -0500

Okay, I'll take a stab at this one...

> When does an (strong) etag of a resource change?
>
> 1) when the content of a resource has changed (e.g. after a PUT)
> 2) when one of the properties has changed (e.g. after a PROPPATCH)
> 3) in both cases 1) and 2)

I think the answer is whenever the GET response changes.  So for most
resources the answer is almost always (1), not (2) or (3).   If you have a
live
resource that is dependent on other info, the answer might vary.

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: Jason Crawford <[email-masked]>
Date: Tue, 4 Mar 2003 17:13:12 -0500

> > Unless this were part of the spec, I'm not sure clients would notice an
> > Etag on a PROPPATCH response.  Otherwise, that's a good idea.
>
> So we may want to add this to RFC2518bis (if a PROPPATCH modifies the
etag,
> it SHOULD be returned in a PROPPATCH response).

Initially I'd say "We don't" because we have agreed previously that
changing properties
shouldn't change the etag.  I'd rather keep the message to the reader  as
simple as that.