Subject: Re: bind draft issues

From: Jason Crawford <[email-masked]>
Date: Mon, 3 Mar 2003 15:16:17 -0500

> URLs have properties too.  Think about how DAV:lockdiscovery
> works in the face of COPY/MOVE,
I'm not sure I understand what you're refering to, but it is true that
we protect the URL of a lock.   And it's true that the
influence of a lock causes there to be a DAV:lockdiscovery property
shown on the resource, but I'm not sure I'd call that property a "URL
property".  (It's more complex than that.)

>  or DAV:displayname for that matter.
DAV:displayname is a property of the resource in every way that
I can think of.

> Regarding this issue, I was not suggesting that the problem
> is that the binding protocol changed the behavior of properties,
> just that the behavior needs to be fully specified.  Do
> you feel that 2518 does fully specify the behavior of
> URL properties?

Hold that thought until we resolve what it is you mean by
URL properties...

------------------------------------------
Phone: 914-784-7569,   [email-masked]
I do not check [email-masked]

---

From: Brian Korver <[email-masked]>
Date: Tue, 4 Mar 2003 12:28:42 -0800

> property".  (It's more complex than that.)

Could you expand on "more complex than that"?

> DAV:displayname is a property of the resource in every way that

It is my understanding that there are implementations that
permit (or even mandate) that the DAV:displayname property
vary depending on URL.  For instance, imagine if you have two
different bindings to the same resource, say

    http://example.com/foo.html
    http://example.com/bar.html

and display names which are the respective names of the resource,
"foo.html" and "bar.html".  Are you saying that such implementations
would not be compliant with respect to 2518?

> Hold that thought until we resolve what it is you mean by

Perhaps "URL properties" isn't the right term, but what is?
In the face of bindings, "URL properties" are those properties
which are (potentially) effected by operations on bindings, where
"resource properties" are not effected by such operations.

-brian
[email-masked]

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 4 Mar 2003 22:17:18 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Brian Korver
> Sent: Tuesday, March 04, 2003 9:29 PM
> To: Jason Crawford
> Cc: WebDAV
> Subject: Re: bind draft issues
>
> ...

Yes. Clearly they aren't. RFC2518 never talked about "URL properties".
DAV:displayname is a property of the resource, and therefore it must be
independant of the URL through which the property is accessed.

BTW: I'm not aware of implementations that actually support multiple
bindings and show this behaviour.

> "resource properties" are not effected by such operations.

My understanding is that "URL properties" simply do not exist.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760