Subject: BIND response code 200

From: "Pill, Juergen" <[email-masked]>
Date: Thu, 22 May 2003 12:42:56 +0200

Hello,

The BIND method will return 201, if the bind was created and 200 is the
existing bind was overwritten.

In case of overwrite; wouldn't a response code of 204 better comply with
other commands in the WebDAV standard, e.g. PUT?

Best regards,

Juergen

---

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 22 May 2003 07:48:05 -0700

Good catch.  I agree, 200 is best used when there's a body and 204 for
no-body successes.  Who knows, there may be minor glitches when a proxy sees
a 200 and no body (or Content-Length or Content-Type headers).
 
Lisa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Pill, Juergen
Sent: Thursday, May 22, 2003 3:43 AM
To: [email-masked]
Subject: BIND response code 200

Hello,

Best regards,

Juergen