Subject: MSIE6SP1 and WebDAV

From: Michael Becker <[email-masked]>
Date: Fri, 09 May 2003 12:29:47 +0200

Hi,

does anyone know what's wrong in this answer:

**HTTP-recv(09.05.03/12:23:02.340293):
PROPFIND / HTTP/1.1
Content-Language: en-us
Accept-Language: de, en-us;q=0.5
Content-Type: text/xml
Translate: f
Depth: 0
Content-Length: 0
User-Agent: Microsoft Data Access Internet Publishing Provider DAV
Host: 192.168.0.2:8484
Connection: Keep-Alive
Authorization: Basic c3BpZGVyMzpzcGlkZXIz

**HTTP-send(09.05.03/12:23:02.400466):
HTTP/1.1 207 Multi-Status
Cache-Control: no-cache
Connection: Keep-Alive
Date: Fri, 09 May 2003 10:23:02 GMT
Server: Spider 4.1.3.2.1  (May  9 2003 12:22:28)
Content-Type: text/xml; charset="utf-8"
Content-Length: 430

<?xml version="1.0" encoding="utf-8" ?>
<multistatus xmlns="DAV:">
<response>
<href>/</href>
<propstat>
<status>HTTP/1.1 200 OK</status>
<prop>
<displayname>/</displayname>
<creationdate>2003-05-09T00:00:00</creationdate>
<getlastmodified>2003-05-09T00:00:00</getlastmodified>
<getcontentlanguage>en-us</getcontentlanguage>
<resourcetype><collection/></resourcetype>
</prop>
</propstat>
</response>
</multistatus>

After getting the answer MSIE6 tells me, that it can't open / as a 
WebFolder.

Regards: Michael

---

From: "Lisa Dusseault" <[email-masked]>
Date: Fri, 9 May 2003 08:53:59 -0700

Web Folders requires some non-standard decoration of the PROPFIND
response.  It needs to know what format the date/time properties are in
for some reason.  You can PROPFIND to a free account sharemation to see
how WFS made this work.

Also I suspect getlastmodified is in the wrong format in the first
place.

Lisa

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Michael Becker
> Sent: Friday, May 09, 2003 3:30 AM
> To: [email-masked]
> Subject: MSIE6SP1 and WebDAV
> 
> 
> 
> Hi,
>