Subject: Re: MSIE6SP1 and WebDAV

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 15 May 2003 09:30:47 -0700

Accidentally caught by the spam filter.

- Jim

-----Original Message-----
From: news [mailto:[email-masked]]On Behalf Of Martin Holz
Sent: Friday, May 09, 2003 4:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Moderator Action] Re: MSIE6SP1 and WebDAV

Michael Becker <[email-masked]> writes:

> Hi,
> 
> does anyone know what's wrong in this answer:
 
> HTTP/1.1 207 Multi-Status
> Cache-Control: no-cache
> Connection: Keep-Alive
> Date: Fri, 09 May 2003 10:23:02 GMT
> Server: Spider 4.1.3.2.1  (May  9 2003 12:22:28)
> Content-Type: text/xml; charset="utf-8"
> Content-Length: 430
> 
> <?xml version="1.0" encoding="utf-8" ?>
> <multistatus xmlns="DAV:">
> <response>
> <href>/</href>
> <propstat>
> <status>HTTP/1.1 200 OK</status>
^^^
> <prop>
> <displayname>/</displayname>
> <creationdate>2003-05-09T00:00:00</creationdate>
> <getlastmodified>2003-05-09T00:00:00</getlastmodified>
> <getcontentlanguage>en-us</getcontentlanguage>
> <resourcetype><collection/></resourcetype>
> </prop>
> </propstat>
> </response>
> </multistatus>
> 
> 
> After getting the answer MSIE6 tells me, that it can't open / as a
> WebFolder.
> 

Appendix 23.1 from http://www.ietf.org/rfc/rfc2518.txt
says :

<!ELEMENT propstat (prop, status, responsedescription?) >

The element status must occur after prop, not before. 

--
Martin Holz     <[email-masked]>

Softwareentwicklung / Vernetztes Studium - Chemie
FIZ CHEMIE Berlin
Franklinstrasse 11
D-10587 Berlin

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 15 May 2003 18:39:05 +0200

> The element status must occur after prop, not before. 

No. Element order is irrelevant in WebDAV.

The issue here are the broken timestamps.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: Michael Becker <[email-masked]>
Date: Thu, 15 May 2003 21:18:42 +0200

Hi all,

thanks for your help. The solution is a little bit more comlplex.
MSIE6 needs extensions to the WebDAV standard. The following works:

HTTP/1.1 207 Multi-Status
Cache-Control: no-cache
Connection: Keep-Alive
Date: Thu, 15 May 2003 15:23:28 GMT
Server: Spider 4.1.3.2.1  (May 15 2003 16:50:02)
Content-Type: text/xml; charset="utf-8"
Content-Length: 409

<?xml version="1.0" encoding="utf-8" ?>
<multistatus xmlns="DAV:" 
xmlns:b="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/">
<response>
<href>/</href>
<propstat>
<status>HTTP/1.1 200 OK</status>
<prop>
<displayname>/</displayname>
<getlastmodified b:dt="dateTime.tz">2003-05-09T08:00:00Z</getlastmodified>
<resourcetype><collection/></resourcetype>
</prop>
</propstat>
</response>
</multistatus>

So MSIE is not standard compliant and also no WebDAV client.
The same problem applies to all other MS products (Excel, Word, ...).

Michael

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 15 May 2003 21:35:13 +0200

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Michael Becker
> Sent: Thursday, May 15, 2003 9:19 PM
> To: [email-masked]
> Subject: Re: MSIE6SP1 and WebDAV
>
>
>
> Hi all,
>
> ...

Please note that it's not IE, it's a specific DLL (MSDAIPP.DLL) that is
shipping with various products in various versions (this explains why it
affects both IE and Office). This particular problem (among others) is
documented at:

<http://greenbytes.de/tech/webdav/webfolder-client-list.html#issue-date-form
at>

Regards, Julian