Subject: Notes from Vienna meeting

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 4 Sep 2003 15:43:10 -0700

It seems I entirely forgot to post the meeting notes from the WG meeting.  The meeting mostly consisted of me reporting on progress made on the mailing lists.  I put together the notes myself as well as giving the status so I'd appreciate review for errors.  

Lisa

---

WebDAV Working Group
Vienna IETF 
July 2003

AGENDA
–	Interop plans – 5 min
–	Various draft status
–	ACL progress
–	RFC2518bis issues
–	Possible SIP needs

VARIOUS DRAFT STATUS

Ordering
–	Minor nits but approved by IESG
–	Last check on specific changes
Binding
–	Still requires significant explanation if not changes
Search
–	Minor progress

ACL PROGRESS

Addressed IESG review issues
Issue: too many possible semantics
-	Resolution: chose one 
Issue: hard for clients to tell what ACL server will allow
–	Resolution: added acl-semantics info property
Issue: no clear privilege for DELETE method
–	Resolution: added ‘unbind’ privilege
Issue: allows insecure ‘Basic’ auth
–	Resolution: “Implementation of the ACL spec requires 
	that Basic authentication, if used, MUST only be 
	supported over secure transport such as TLS.”
Attempt to make mapping between methods and permissions more clear
The “who am I” request header, response header contains answer

RFC2518 BIS ISSUES

DTD usage
–	Do we include DTDs at all
–	Do we use content ANY or content a specific list of child elements
–	How do we show/enforce extensibility?
–	How do we show namespace usage (e.g. on attributes)?
–	ELEMENT foo | ns (bar, baz?, ANY)
207 response to DELETE failures
–	Again…
–	Keep or toss	
Stronger requirement for ETag support
–	Still not MUST

---

From: Geoffrey M Clemm <[email-masked]>
Date: Fri, 5 Sep 2003 10:18:59 -0400

There is only one open issue in the binding draft:
<http://www.webdav.org/bind/bind-issues-list.htm> 5.1_LOOP_STATUS.

If somebody believes that something in the draft still requires
significant explanation (or changes), they need to identify it
so we can add it to the bind-issues-list.  If not, the status 
for the binding protocol should be updated to state "only one
issue remaining to be resolved for last call".

Cheers,
Geoff

> VARIOUS DRAFT STATUS
...