Subject: XML elements in a copy method

From: "Stanley Guan" <[email-masked]>
Date: Tue, 21 Oct 2003 13:47:17 -0700

Hi,

Maybe my reading of RFC 2518 is not thorough enough.  It seems to me that:
   XML elements are allowed in a copy method to modify the copying behavior.

But, what kind of XML elements are allowed and how should they be
interpreted?

Thx,

-Stanley

---

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 21 Oct 2003 14:50:09 -0700

You are correct, but this functionality hasn't been widely implemented.  It
turns out the
server knows more about what properties can and should be kept live on a
COPY 
operation, so the clients never provided this information and servers didn't
need it
anyway.  In RFC2518bis this has been removed.
 
lisa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Stanley Guan
Sent: Tuesday, October 21, 2003 1:47 PM
To: [email-masked]
Subject: XML elements in a copy method

Hi,

 
Thx,
 
-Stanley

---

From: "Stanley Guan" <[email-masked]>
Date: Tue, 21 Oct 2003 15:39:42 -0700

MessageLisa,

Then, probably the following statement in RFC2518bis needs 
to be reworded:

8.9 COPY Method

COPY for HTTP/1.1 resources

After a successful COPY invocation, all properties on the
source resource MUST be duplicated on the destination resource,
subject to modifying headers and XML elements, following the
definition for copying properties.  

Thx,

-Stanley
  ----- Original Message ----- 
  From: Lisa Dusseault 
  To: 'Stanley Guan' ; [email-masked] 
  Sent: Tuesday, October 21, 2003 2:50 PM
  Subject: RE: XML elements in a copy method

  You are correct, but this functionality hasn't been widely implemented.  It turns out the
  server knows more about what properties can and should be kept live on a COPY 
  operation, so the clients never provided this information and servers didn't need it
  anyway.  In RFC2518bis this has been removed.

  lisa
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] On Behalf Of Stanley Guan
    Sent: Tuesday, October 21, 2003 1:47 PM
    To: [email-masked]
    Subject: XML elements in a copy method

    Hi,

    Thx,

    -Stanley