Subject: WebDAV resources must be in collections? (CONSISTENCY)

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 7 Oct 2003 17:46:27 -0700

This is the CONSISTENCY issue in http://www.webdav.org/wg/rfcdev/issues.htm.

RFC2518 says:

"  An HTTP URL namespace is said to be consistent if it meets the
   following conditions: for every URL in the HTTP hierarchy there
   exists a collection that contains that URL as an internal member.
   The root, or top-level collection of the namespace under
   consideration is exempt from the previous rule."

Roy Fielding - http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0155.html:

"There is no need for that requirement and it
is the root of many terminology issues.  Any individual resource is
capable of being or not being DAVable, as determined by either the
capabilities described by an OPTIONS response"

I've been thinking of a use case for WebDAV resources that may not 
be in WebDAV-capable collections.  The SIMPLE WG has discussed 
making Buddy lists be (in one model) a WebDAV resource.  This would 
mean that the buddy list could be locked, unlocked, could support
PROPFIND and PROPPATCH, could support the basic WebDAV properties 
to know when the content changed and what the ETag is.  It could 
have an owner and support the ACL method and the acl property.

Should we remove this consistency requirement from RFC2518bis?

Lisa

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 8 Oct 2003 09:51:11 +0200

Lisa,

what you are talking about is the consistency *definition*. Of course it's possible to have WebDAV-compliant resources in non-consistent namespaces.

What we'll have to look fot is where the term is *used*. If it isn't, the definition can go. However, I think we need it to define the behaviour of namespace operations such as MOVE?

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760 

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> Sent: Wednesday, October 08, 2003 2:46 AM
> To: 'Webdav WG'
> Subject: WebDAV resources must be in collections? (CONSISTENCY)
> 
> 
> 
> 
> This is the CONSISTENCY issue in 
> http://www.webdav.org/wg/rfcdev/issues.htm.
> 
> RFC2518 says:
> 
> Roy Fielding - 
> http://lists.w3.org/Archives/Public/w3c-dist-auth/1998OctDec/0155.html:
>

---

From: Stefan Eissing <[email-masked]>
Date: Wed, 8 Oct 2003 10:19:22 +0200

A quick scan of 2518 revealed that the "consistent namespace"  
definition is
used with COPY/MOVE/DELETE to define restrictions on the outcome of the
operation. E.g. that the copied/moved/deleted resource created a  
consistent
namespace, especially in case of collections.

I think that definition and the restrictions on COPY/MOVE/DELETE are  
necessary
and, in particular, do allow single WebDAV resources on a server  
without an
embedding, WebDAV-enabled collection.

Regards, Stefan

Am Mittwoch, 08.10.03, um 09:51 Uhr (Europe/Berlin) schrieb Julian  
Reschke:

>
> Lisa,
>
> what you are talking about is the consistency *definition*. Of course  
> it's possible to have WebDAV-compliant resources in non-consistent  
> namespaces.
>
> What we'll have to look fot is where the term is *used*. If it isn't,  
> the definition can go. However, I think we need it to define the  
> behaviour of namespace operations such as MOVE?
>
> Julian
>
> --

---

From: "Jim Whitehead" <[email-masked]>
Date: Wed, 8 Oct 2003 09:06:15 -0700

I'm OK with this. Implementors tend to do the "right" thing wrt consistency when it matters, and the current language has caused confusion far beyond its worth.

- Jim

> Sent: Tuesday, October 07, 2003 5:46 PM
> To: 'Webdav WG'

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 8 Oct 2003 18:14:15 +0200

It's causing confusion right now :-)

Looking at Roy's original complaint...:

"My comment was regarding the requirement that DAV capable resources be
within a DAV collection.  There is no need for that requirement and it
is the root of many terminology issues.  Any individual resource is
capable of being or not being DAVable, as determined by either the
capabilities described by an OPTIONS response or by the error response
received when attempting to do a WebDAV operation on a non-DAV resource.
"Save as..." dialogs are cool, but not necessary, for authoring."

So it's not about the term "consistent namespace", it's about "DAV-capable resource". I don't think that what Roy actually complained about is (section 5):

"All DAV compliant resources MUST support the HTTP URL namespace model specified herein."

This seems to be what needs to go, not the definition of consistency.

Julian

> [mailto:[email-masked]]On Behalf Of Jim Whitehead
> Sent: Wednesday, October 08, 2003 6:06 PM
> To: 'Webdav WG'
> Subject: RE: WebDAV resources must be in collections? (CONSISTENCY)
> 
> 
> 
> I'm OK with this. Implementors tend to do the "right" thing wrt 
> consistency when it matters, and the current language has caused 
> confusion far beyond its worth.
> 
> - Jim
>