Subject: non-collecton and multistatus response?

From: "Stanley Guan" <[email-masked]>
Date: Tue, 21 Oct 2003 12:35:03 -0700

From reading the RFC2518, it's not clear to me that
if I'm using a delete method to remove a non-collection
resource, is it possible that server still returns a multitasks
response?

Is there a method that if my resource is a non-collection type,
I'll be guaranteed that a multitasks response will never be 
returned?

Thx,

-Stanley

---

From: "Julian Reschke" <[email-masked]>
Date: Tue, 21 Oct 2003 22:00:52 +0200

Stanley,

I think it is *unlikely* that you'll get a 207 on a non-collection. However,
I wouldn't rely on that, and no, there's no way to enforce a specific server
behaviour.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Stanley Guan
Sent: Tuesday, October 21, 2003 9:35 PM
To: [email-masked]
Subject: non-collecton and multistatus response?

Thx,

-Stanley

---

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 21 Oct 2003 13:48:10 -0700

RFC2518 isn't clear on this, but implementations definitely do return
multistatus in response to operations on single items.  It's a single code
line for the server, rather than two.  So the cat's more or less out of the
bag on this one.
 
lisa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Stanley Guan
Sent: Tuesday, October 21, 2003 12:35 PM
To: [email-masked]
Subject: non-collecton and multistatus response?

Thx,
 
-Stanley