Subject: Windows XP Webdav redirector

From: Jan Wrang <[email-masked]>
Date: Fri, 03 Oct 2003 09:00:14 +0200

Hi,
I've been struggling for some days with the Windows XP webdav redirector.
I want to map a network drive to my webDAV server,
but keep getting "error 67 - The network name cannot be found" from win XP.
Access to the server through webfolders work on both Win XP and W2000!.

Below is the communication between Server and XP (collected through 
Ethereal):

Any input appreciated,

Best regards
Jan

PROPFIND /folder HTTP/1.1
Depth: 0 translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: dev1.cinatit.biz
Content-Length: 0 Connection: Keep-Alive
Authorization: Basic YW5ha2luOmFuYWtpbg== 

HTTP/1.1 301 Moved Permanently
Server: Resin/2.1.11
Cache-Control: private
Location: http://dev1.cinatit.biz/folder/shared/
Set-Cookie: mindcubeWebDAV=LkFkNkGkHkBkCnAhMhChPhMhIh; path=/folder
Set-Cookie: JSESSIONID=aZpBUuyWC4ld; path=/
Content-Length: 0 Date: Tue, 30 Sep 2003 07:53:07 GMT 

PROPFIND /folder/shared/ HTTP/1.1
Depth: 0 translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: dev1.cinatit.biz
Content-Length: 0
Connection: Keep-Alive
Authorization: Basic YW5ha2luOmFuYWtpbg== 

HTTP/1.1 207 Multi-Status
Server: Resin/2.1.11
Cache-Control: private
Set-Cookie: mindcubeWebDAV=LkFkNkGkHkBkCnAhMhChPhMhIh; path=/folder
Set-Cookie: JSESSIONID=a8WzepGZeh1_; path=/
Content-Type: text/xml; charset="utf-8"
Content-Length: 860 Date: Tue, 30 Sep 2003 07:53:07 GMT 
<?xml version="1.0" encoding="utf-8" ?>
<D:multistatus xmlns:D="DAV:" 
xmlns:b="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/" >
<D:response>
    <D:href>/folder/shared/</D:href>
    <D:propstat>
        <D:prop>
            <D:supportedlock>
                <D:lockentry>
                    <D:lockscope>
                        <D:exclusive/>
                    </D:lockscope>
                <D:locktype>
                    <D:write/>
                </D:locktype>
                </D:lockentry>
                <D:lockentry>
                    <D:lockscope>
                        <D:shared/>
                    </D:lockscope>
                    <D:locktype>
                        <D:write/>
                    </D:locktype>
                </D:lockentry>
            </D:supportedlock>
            <D:displayname><![CDATA[root]]></D:displayname>
            <D:getcontenttype/>
            <D:creationdate 
b:dt="dateTime.tz">1970-01-01Thu12:00:00Z</D:creationdate>
            <D:lockdiscovery/>
            <D:getetag>0_48563_0</D:getetag>
            <D:getlastmodified b:dt="dateTime.rfc1123">Thu, 1 Jan 1970 
12:00:00 GMT</D:getlastmodified>
            <D:resourcetype><D:collection/></D:resourcetype>
        </D:prop>
        <D:status>HTTP/1.1 200 OK</D:status>
    </D:propstat>
</D:response>
</D:multistatus>

error 67 - The network name cannot be found

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 3 Oct 2003 10:37:55 +0200

Hi,

I can't really tell why the client is failing (there are a lot of known
issues with it and Microsoft is obviously unwilling to do any bugfixing
before the next major Windows release).

> b:dt="dateTime.tz">1970-01-01Thu12:00:00Z</D:creationdate>

This timestamp doesn't use the ISO format (note the string "Thu"). This one
may be breaking the client.

>             <D:getetag>0_48563_0</D:getetag>

Value of ETag doesn't conform to HTTP header syntax (see RFC2616, section
14.19).

>         <D:status>HTTP/1.1 200 OK</D:status>

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jan Wrang
> Sent: Friday, October 03, 2003 9:00 AM
> To: [email-masked]
> Subject: Windows XP Webdav redirector
>
>
>
> Hi,

---

From: Jan Wrang <[email-masked]>
Date: Fri, 03 Oct 2003 11:20:51 +0200

Hi Julian,

Thanks for a very fast response.
Fixing the bug in the date actually did it :-))

Thanks a lot!

Best regards,

Jan