Subject: Re: Where an open source example of webdav to seamlessly access and version files?

From: [email-masked]
Date: Tue, 24 Feb 2004 20:49:07 +0100 (MET)

"Charlie Smith" <[email-masked]> schrieb:
> Is there available anywhere an open source example of using webdav to retrieve
> files through a browser and seemlessly work with them using a client application
> - word perfect or ms word.  Then, be able to save these files with same type of
> interface one would experience as if saving to local disk?
Interesting question. At the moment I can mount a WebDAV server as a filesystem,
can copy from to and create versions and baselines on the server.
(Using an Oberon client together with an Oberon server so it's probably not very
interesting for you)
The question is whether we really want to get and save seamlessly all the time.
Suppose you edit a big file, change just a couple of lines and save it again.
If you have a low bandwidth connection this will take a lot of time.
In this case the client should be intelligent enough to send a diff.
Is there a standard way a client and server could do that ?
Because that would be my next action point then :-)
Also if you want versioning you need at least an extended interface in your client.

Cheers, Edgar

---

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 24 Feb 2004 11:59:52 -0800

Adobe has a different approach in its client software, which is 
WebDAV-aware.  The "Save" and "Save as" operations prompt the user
to save locally.  It's the operations for sharing with a workgroup
that "publish" the document to a WebDAV repository.  This is key
for ease of working with large documents like Photoshop files :)

lisa

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, February 24, 2004 11:49 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Where an open source example of webdav to 
> seamlessly access and version files?
> 
> 
>