Subject: WebDAV WG meeting minutes

From: "Lisa Dusseault" <[email-masked]>
Date: Tue, 9 Mar 2004 02:19:36 -0800

Presentation: <http://www.sharemation.com/~milele/public/dav/presentations/webdav-wg-ietf59.ppt> 

Agenda bashing: No changes; Ted volunteered to scribe in chat room (also to be used for minutes)

WebDAV's been extant 7 years and rechartered once.  Lisa proposed that we should try to declare "partial success".  
We completed these goals: RFC2518, ACL, ordered collections (RFC3648).
Here's the milestones we haven't finished, and where they're at:

Property registry: no draft, no volunteers --> this obviously wasn't needed after all and should be scratched.

Binding: Major issues -- possible incompatible changes with WebDAV, causing existing clients to see completely unexpected behavior.  At least issues with spec ambiguity.

Redirect: No major issues -- but no recent activity.  OTOH, there may not be many implementors.  Perhaps we can last call and require a minimum # of reviews.

ACL goals document: we can submit the last draft (many years expired) as Informational if desired.

DRAFT standard status(2518bis) -- We've collectively put a lot of work into that draft, feeding the results of those interop events into the draft.  However, now it's stalled, as new ideas have been raised recently about the whole approach.  Not sure working group has the energy to finish (and to keep changes to a minimum to meet DRAFT standard requirements).

Responses to this summation showed disagreement on whether there are major issues with 'bindings'.  Julian Reschke says there are no issues.  Can clients create a lock on a binding, and have the expectation met that he underlying document cannot be changed by other clients?  Ted and Lisa believe the draft says that the underlying document may change (and that that would be a serious incompatible change).  Julian says that the underlying document cannot change.  

Other work is going on around WebDAV but as individual submissions: DASL, property data types, quota, http patch
DASL could go to proposed standard if it's in the form that's already been implemented by several separate groups.  Otherwise, it could go to experimental, etc.   

In general progress in this WG is hampered by limited participation, review, and consensus-building.  Chairs need to update the charter to reflect the things that actually will be done, and get the working group to agree whether it can resolve something that is a milestone.  Note that changing the charter requires new review by the IETF community.

Other suggestions (from Larry, Ted, Patrik in particular): suggest bugging people may be necessary--not waiting for people to respond, but going out and getting them involved.  Can do last call on some of our remaining docs, but require N independent reviews to be posted in order to successfully move on.  Without those N reviews -- e.g. 3 independent reviews -- Ted says it would no longer be considered a WG item (and it's up to the chairs to determine if the participation of the WG is sufficient to call consensus and come to completion).  The reviews would also indicate whether another cycle is needed on the document.

Complete Jabber room minutes are also available -- this is just a summation, as suggested in minute-writing guidelines.

Lisa

---

From: Geoffrey M Clemm <[email-masked]>
Date: Tue, 9 Mar 2004 08:24:40 -0500

Julian is correct.  Nothing in the binding draft allows a locked
resource to be modified by a client that does not hold the token
for that locked resource.  If anyone believes otherwise, 
I would appreciate it if they could raise the issue on the mailing
list by identifying the section of the draft that they believe 
makes this statement, so we can add whatever wording is necessary
to avoid anyone else misunderstanding the spec in this way.

Note: we carefully track all issues with the binding spec, but
(since none of us have reliable telepathic powers :-), we can only
track and respond to issues that have been explicitly raised on the
mailing list.

Cheers,
Geoff

Lisa wrote on 03/09/2004 05:19:36 AM:

> Binding: Major issues -- possible incompatible changes with WebDAV, 
> causing existing clients to see completely unexpected behavior.  At 
> least issues with spec ambiguity.
> 
> Responses to this summation showed disagreement on whether there are
> major issues with 'bindings'.  Julian Reschke says there are no 
> issues.  Can clients create a lock on a binding, and have the 
> expectation met that he underlying document cannot be changed by 
> other clients?  Ted and Lisa believe the draft says that the 
> underlying document may change (and that that would be a serious 
> incompatible change).  Julian says that the underlying document 
> cannot change.