Subject: Stepping down

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 18 Mar 2004 08:47:03 -0800

Over the past year it has become increasingly clear that I no longer have enough time to dedicate to the task of effectively leading the WebDAV Working Group. This is perhaps inevitable. When I started the WebDAV Working Group I was a PhD student, and could dedicate significant blocks of time to this project. Now, as an Assistant Professor with 8 PhD students of my own (as well as two small children at home), this is no longer the case. The final straw was me taking on the role of General Chair (organizer) of the ACM Hypertext 2004 conference, itself an enormously time consuming volunteer role.

WebDAV Working Group is very close to completing its original technical agenda, a tremendous accomplishment. Many standards development efforts never come close to this, or have the adoption and impact of WebDAV. Still, we do have some final work to complete. There is the bindings specification, and the redirect references protocol. Moving 2518 to Draft Standard is still as important as ever. DASL is already effectively at a Proposed Standard level of adoption, and needs to be finished to ensure greater adoption. WebDAV WG needs a steady hand to bring these to completion, and, alas, that's no longer me.

As a result, effective today, I am stepping down as Co-Chair of the WebDAV Working Group. Ted Hardie, our Applications Area Director, will be appointing Patrik Faltstrom (a former AD of the WebDAV WG) to take my place. Lisa Dusseault will be continuing her excellent work as Co-Chair. I very much encourage you to work with Patrik and Lisa (as will I) to complete the WebDAV agenda. 

I still intend to continue contributing to the WebDAV community. Several of my ongoing research projects have a WebDAV aspect to them, including the Catacomb server, and the Prestan performance analysis suite. I will continue to contribute to the webdav.org site, as well as help with additional explanation of the contributions and uses of the protocol. Finally, I also hope to work to interest people in building new protocols on top of WebDAV -- calendaring is one area that seems long overdue. I'm certainly not turning my back on the WebDAV community. Rather I'm acknowledging that I'm no longer the right person to lead protocol development efforts to completion.

- Jim Whitehead

---

From: Lisa Dusseault <[email-masked]>
Date: Thu, 18 Mar 2004 13:37:47 -0800

The WebDAV WG and general WebDAV community owes a huge thank-you to Jim 
and this seems like an appropriate time to do that publicly. Jim led 
the first WebDAV BOF in San Jose in 1996, and gave a presentation [0] 
summarizing the design and coordination work he'd already begun to 
lead.  Since then he's gone beyond being a simple WG chair, supporting 
and encouraging the DeltaV WG, hosting WebDAV Interop events and 
evangelizing in many ways.  He has made significant technical and 
authoring contributions to WebDAV, particularly to the most difficult 
specs like DeltaV and ACL.  If we're smart we'll keep Jim involved as 
much as possible even if not as WG chair.

Lisa

[0] http://www.ietf.org/proceedings/96dec/app/webdav-slides/tsld018.htm

On Mar 18, 2004, at 8:47 AM, Jim Whitehead wrote:

>
> Over the past year it has become increasingly clear that I no longer 
> have enough time to dedicate to the task of effectively leading the 
> WebDAV Working Group. This is perhaps inevitable. When I started the 
> WebDAV Working Group I was a PhD student, and could dedicate 
> significant blocks of time to this project. Now, as an Assistant 
> Professor with 8 PhD students of my own (as well as two small children 
> at home), this is no longer the case. The final straw was me taking on 
> the role of General Chair (organizer) of the ACM Hypertext 2004 
> conference, itself an enormously time consuming volunteer role.
>
> WebDAV Working Group is very close to completing its original 
> technical agenda, a tremendous accomplishment. Many standards 
> development efforts never come close to this, or have the adoption and 
> impact of WebDAV. Still, we do have some final work to complete. There 
> is the bindings specification, and the redirect references protocol. 
> Moving 2518 to Draft Standard is still as important as ever. DASL is 
> already effectively at a Proposed Standard level of adoption, and 
> needs to be finished to ensure greater adoption. WebDAV WG needs a 
> steady hand to bring these to completion, and, alas, that's no longer 
> me.
>
> As a result, effective today, I am stepping down as Co-Chair of the 
> WebDAV Working Group. Ted Hardie, our Applications Area Director, will 
> be appointing Patrik Faltstrom (a former AD of the WebDAV WG) to take 
> my place. Lisa Dusseault will be continuing her excellent work as 
> Co-Chair. I very much encourage you to work with Patrik and Lisa (as 
> will I) to complete the WebDAV agenda.
>
> I still intend to continue contributing to the WebDAV community. 
> Several of my ongoing research projects have a WebDAV aspect to them, 
> including the Catacomb server, and the Prestan performance analysis 
> suite. I will continue to contribute to the webdav.org site, as well 
> as help with additional explanation of the contributions and uses of 
> the protocol. Finally, I also hope to work to interest people in 
> building new protocols on top of WebDAV -- calendaring is one area 
> that seems long overdue. I'm certainly not turning my back on the 
> WebDAV community. Rather I'm acknowledging that I'm no longer the 
> right person to lead protocol development efforts to completion.
>
> - Jim Whitehead
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 18 Mar 2004 22:42:00 +0100

Lisa Dusseault wrote:

> and this seems like an appropriate time to do that publicly. Jim led the 
> first WebDAV BOF in San Jose in 1996, and gave a presentation [0] 

Yep.

Thanks Jim for all the work you've done (and you and your students will 
be doing in the future).

And welcome Patrik!

Regards, Julian

-- 
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760