Subject: Platform for WebDav Development

From: "Varun" <[email-masked]>
Date: Mon, 6 Sep 2004 13:20:25 +0530

Hi,
I need to develope one interface which picks data from a RDBMS and puts in exchange server 2000.
Restriction is that the interface exe should not do the processing on the exchange server, but it should reside and run from a different machine.
I need to know how can I use WebDav to achieve this and what are the possible development platforms for this?

Regards
-Varun

*********************************************************
Disclaimer:         

This message (including any attachments) contains
confidential information intended for a specific
individual and purpose, and is protected by law.
If you are not the intended recipient, you should
delete this message and are hereby notified that
any disclosure, copying, or distribution of this
message, or the taking of any action based on it,
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Gangadhar Pai" <[email-masked]>
Date: Mon, 6 Sep 2004 13:43:29 +0530

You will have to write a proxy server which will act as an conduit between the data source(RDBMS) and Content server(Exchange 2000)
 
This server should be an HTTP server with additional WebDAV support, for this you can consider IIS with ISAPI filters and Extension.
ODBC/OLE DB for RDBMS interface. Or parallely any Java Based HTTP server with JDBC support.
 
For typical CRUD operations following WebDAV methods should suffice:
1) Propfind (for read), Proppatch(create, update), Move or Delete(for delete) and Search(for querying), if you want this operation in a batch(Bulk) you can consider BPropfind, BProppatch  etc.

Regards
Gangadhar Pai 
|Project Manager| iGATE Global Solutions | email: [email-masked] < mailto:[email-masked]> | Website: < http://paionline.tripod.com <http://paionline.tripod.com/> > |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Varun
Sent: Monday, September 06, 2004 1:20 PM
To: [email-masked]
Subject: Platform for WebDav Development

Hi,
 
Regards
-Varun

	

Information transmitted by this EMAIL is proprietary to iGATE Group of Companies and is intended for use only by the individual or entity to whom it is addressed and may contain information that is privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient of this EMAIL immediately notify the sender at iGATE or [email-masked] and delete this EMAIL including any attachments.