Subject: Re: Platform for WebDav Development

From: "Varun" <[email-masked]>
Date: Mon, 6 Sep 2004 14:56:44 +0530

FYI
  ----- Original Message -----
  From: Varun
  To: Gangadhar Pai
  Sent: Monday, September 06, 2004 2:23 PM
  Subject: Re: Platform for WebDav Development

  Thanks a lot for educating me on that.

  I am new to WebDav methods, as i have worked only on client server applications using RDBMS databases and worked on VB/Vb.net and ASP.net only.

  I have few questions, if possible help me out.

  1) I need to know about the development languages which I can use for writing the code.

  2) Can I make the interface using standard exe in vb or vb.net?

  3) Can I use Ado and any any oledb provider for connectivity to exchange server? Has cdoex any role to play in WebDav?

  Thanks & Regards
  -Varun

    ----- Original Message -----
    From: Gangadhar Pai
    To: Varun ; [email-masked]
    Sent: Monday, September 06, 2004 1:43 PM
    Subject: RE: Platform for WebDav Development

    You will have to write a proxy server which will act as an conduit between the data source(RDBMS) and Content server(Exchange 2000)

    This server should be an HTTP server with additional WebDAV support, for this you can consider IIS with ISAPI filters and Extension.
    ODBC/OLE DB for RDBMS interface. Or parallely any Java Based HTTP server with JDBC support.

    For typical CRUD operations following WebDAV methods should suffice:
    1) Propfind (for read), Proppatch(create, update), Move or Delete(for delete) and Search(for querying), if you want this operation in a batch(Bulk) you can consider BPropfind, BProppatch  etc.

    Regards
    Gangadhar Pai
    |Project Manager| iGATE Global Solutions | email: [email-masked] <mailto:[email-masked]> | Website: <http://paionline.tripod.com> |

      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf Of Varun
      Sent: Monday, September 06, 2004 1:20 PM
      To: [email-masked]
      Subject: Platform for WebDav Development

      Hi,
      I need to develope one interface which picks data from a RDBMS and puts in exchange server 2000.
      Restriction is that the interface exe should not do the processing on the exchange server, but it should reside and run from a different machine.
      I need to know how can I use WebDav to achieve this and what are the possible development platforms for this?

      Regards
      -Varun

            *********************************************************
            Disclaimer:

            This message (including any attachments) contains
            confidential information intended for a specific
            individual and purpose, and is protected by law.
            If you are not the intended recipient, you should
            delete this message and are hereby notified that
            any disclosure, copying, or distribution of this
            message, or the taking of any action based on it,
            is strictly prohibited.

            *********************************************************
            Visit us at http://www.mahindrabt.com

----------------------------------------------------------------------------
    Information transmitted by this EMAIL is proprietary to iGATE Group of Companies and is intended for use only by the individual or entity to whom it is addressed and may contain information that is privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient of this EMAIL immediately notify the sender at iGATE or [email-masked] and delete this EMAIL including any attachments.

*********************************************************
Disclaimer:         

This message (including any attachments) contains
confidential information intended for a specific
individual and purpose, and is protected by law.
If you are not the intended recipient, you should
delete this message and are hereby notified that
any disclosure, copying, or distribution of this
message, or the taking of any action based on it,
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Farhad" <[email-masked]>
Date: Tue, 7 Sep 2004 09:03:39 +0330

I used Vb.net for handle requests, so I add a wild card filter, on windows
server 2003

And tried to handle request verbs,

In response to "Propfind", Regarding to "rfc2518"
http://www.webdav.org/specs/rfc2518.htm  or others, we've got that the
response object must return 

Some XML

But I do not know how can I make XML for my situation and how can I append
this XML to response object

Is there anybody to help me?

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Varun
Sent: Monday, September 06, 2004 12:57 PM
To: [email-masked]
Subject: Re: Platform for WebDav Development

FYI

----- Original Message ----- 

From: Varun <mailto:[email-masked]>  

To: Gangadhar <mailto:[email-masked]>  Pai 

I am new to WebDav methods, as i have worked only on client server
applications using RDBMS databases and worked on VB/Vb.net and ASP.net only.

1) I need to know about the development languages which I can use for
writing the code.

3) Can I use Ado and any any oledb provider for connectivity to exchange
server? Has cdoex any role to play in WebDav? 

Thanks & Regards

-Varun

----- Original Message ----- 

From: Gangadhar <mailto:[email-masked]>  Pai 

To: Varun <mailto:[email-masked]>  ; [email-masked] 

You will have to write a proxy server which will act as an conduit between
the data source(RDBMS) and Content server(Exchange 2000)

This server should be an HTTP server with additional WebDAV support, for
this you can consider IIS with ISAPI filters and Extension.

ODBC/OLE DB for RDBMS interface. Or parallely any Java Based HTTP server
with JDBC support.

1) Propfind (for read), Proppatch(create, update), Move or Delete(for
delete) and Search(for querying), if you want this operation in a
batch(Bulk) you can consider BPropfind, BProppatch  etc.

Regards

Gangadhar Pai 
|Project Manager| iGATE Global Solutions | email: [email-masked]
<mailto:[email-masked]> | Website: <http://paionline.tripod.com
<http://paionline.tripod.com/> > |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Varun
Sent: Monday, September 06, 2004 1:20 PM
To: [email-masked]
Subject: Platform for WebDav Development

Hi,

I need to develope one interface which picks data from a RDBMS and puts in
exchange server 2000. 

Restriction is that the interface exe should not do the processing on the
exchange server, but it should reside and run from a different machine.

I need to know how can I use WebDav to achieve this and what are the
possible development platforms for this?

Regards

-Varun

  _____  

Information transmitted by this EMAIL is proprietary to iGATE Group of
Companies and is intended for use only by the individual or entity to whom
it is addressed and may contain information that is privileged,
confidential, or exempt from disclosure under applicable law. If you are not
the intended recipient of this EMAIL immediately notify the sender at iGATE
or [email-masked] and delete this EMAIL including any attachments.

---

From: "Varun Pande" <[email-masked]>
Date: Fri, 10 Sep 2004 11:37:02 +0530

Hi,
I have been really struggling to find out how to carry out some basic tasks in Webdav development, having a rdbms background

Some besic queries if anyone can help me out with code samples.

1) How to connect to exchange server database?

2) How to add microsoft outlook tasks for particular user, so that if he opens his mailbox he can see the list of tasks? tasks are retrieved from an oracle table

I am also unable to find any documentation and code samples on microsoft outlook tasks as far as urn schemas and properties are concerned.

Waiting for some really helpful response from the group.

 Thanks & Regards
-Varun

---

From: Lisa Dusseault <[email-masked]>
Date: Fri, 10 Sep 2004 09:08:40 -0700

Hi Varun,

The mailing list you posted to discusses the WebDAV protocol standard, 
and issues related to IETF protocol specifications.  It does not 
discuss development of WebDAV tools.  It seems like you're looking for 
specific Microsoft developer assistance (because Exchange extended 
WebDAV in several non-standard ways, including the task schema) so I'd 
suggest you seek out a Microsoft-specific or Exchange-specific forum.

Lisa

On Sep 9, 2004, at 11:07 PM, Varun Pande wrote:

>
> Hi,
> I have been really struggling to find out how to carry out some basic 
> tasks in Webdav development, having a rdbms background
>
> 2) How to add microsoft outlook tasks for particular user, so that if 
> he opens his mailbox he can see the list of tasks? tasks are retrieved 
> from an oracle table
>
> I am also unable to find any documentation and code samples on 
> microsoft outlook tasks as far as urn schemas and properties are 
> concerned.
>