Subject: [Bug 70] New: REBIND arguments are like BIND

From: [email-masked]
Date: Sun, 5 Dec 2004 19:13:02 -0800

http://ietf.cse.ucsc.edu:8080/bugzilla/show_bug.cgi?id=70

           Summary: REBIND arguments are like BIND
           Product: WebDAV-BIND
           Version: -07
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: blocker
          Priority: P1
         Component: 06. REBIND Method
        AssignedTo: [email-masked]
        ReportedBy: [email-masked]
         QAContact: [email-masked]

The REBIND method was intended to have syntax that paralleled BIND.  This 
means that the request-URL is the collection into which the binding is being 
created, the segment in the body is the new binding name in the request-URL 
collection, and the href in the body is the "source", i.e. the resource that 
is being rebound. 

The recent edits in this section (intended to address Jim's observation that 
the meaning of arguments of the method were not underspecified) were incorrect 
and broke this.  In particular, the introductory sentences of REBIND should be 
modeled after BIND, and the precondition names (which were originally correct) 
should be restored.

------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

---

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 9 Dec 2004 16:03:02 -0800

Geoff Clemm writes:

> The REBIND method was intended to have syntax that paralleled 
> BIND.  This means that the request-URL is the collection into 
> which the binding is being created, the segment in the body 
> is the new binding name in the request-URL collection, and 
> the href in the body is the "source", i.e. the resource that 
> is being rebound. 
> 
> The recent edits in this section (intended to address Jim's 
> observation that the meaning of arguments of the method were 
> not underspecified) were incorrect and broke this.  In 
> particular, the introductory sentences of REBIND should be 
> modeled after BIND, and the precondition names (which were 
> originally correct) should be restored.

Do we care that the parameters are now switched as compared to those of
MOVE?

           Source            Destination

MOVE     Request-URI         Destination header

REBIND   href XML elem     Request-URI plus segment 
                             XML elem 

I think it doesn't matter, but thought I should raise it.

- Jim

---

From: Geoffrey M Clemm <[email-masked]>
Date: Thu, 9 Dec 2004 20:47:23 -0500

I think the consistency of REBIND with BIND is more important
than the consistency with MOVE.

Cheers,
Geoff

---

From: Julian Reschke <[email-masked]>
Date: Fri, 10 Dec 2004 09:43:41 +0100

> I think it doesn't matter, but thought I should raise it.

REBIND is different from MOVE anyway (by design). Making it consistent 
with BIND then makes a lot of sense.

Julian

-- 
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760