Subject: Re: Caching in WebDav

From: "Adam Mrozowski" <[email-masked]>
Date: Wed, 3 Aug 2005 20:48:10 +0200

Thanks for your quick answer:)
You are rigth. I'm using xythos but I think that the problem is still on
the protocol side.
Let's concider the HTTP protocol. In HTTP header you may set if the page is
to be cached or no.
I'm thinking about setting it on the protocol side like in http header. Is
it possible, because setting xythos not to cache is unfortunately not enough
for me (I don't want to configure all xythos clients not to cache)?
> ----- Original Message ----- 
> From: "Julian Reschke" <[email-masked]>
> To: "Adam Mrozowski" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, August 03, 2005 7:57 PM
> Subject: Re: Caching in WebDav
>
>
>>
>> Adam Mrozowski wrote:
>>> Hi,
>>>  I wonder if it's possible to omit cachnig in WebDAV. Now if the file is 
>>> once read from the server it's cached on the client hdd and next time 
>>> the client opens the file it's being read from the cache (not from the 
>>> server if there were no changes).
>>> Is there a way to force WebDAV not to cache files on local hdd?
>>
>> WebDAV is an extension of HTTP, so whatever RFC2616 says about caching 
>> applies to WebDAV as well.
>>
>> Your question seems to be about a particular client, right? If you tell 
>> us which, somebody may be able to come up with a more helpful answer...
>>
>> Best regards, Julian
>>
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 03 Aug 2005 20:56:29 +0200

> Let's concider the HTTP protocol. In HTTP header you may set if the page is

Same in WebDAV.

> for me (I don't want to configure all xythos clients not to cache)?

I guess you'll have to talk to the Xythos support. As far as I remember, 
Xythos offers different levels of "sharing levels", which will probably 
affect caching.

Best regards, Julian

---

From: "Adam Mrozowski" <[email-masked]>
Date: Wed, 3 Aug 2005 21:30:50 +0200

OK So do you know Julian how to set the We
----- Original Message ----- 
From: "Julian Reschke" <[email-masked]>
To: "Adam Mrozowski" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, August 03, 2005 8:56 PM
Subject: Re: Caching in WebDav

>> Let's concider the HTTP protocol. In HTTP header you may set if the page 
if it's the same can you tell me how to set it?
are there any standard markers that can be set outside xythos?

---

From: "Adam Mrozowski" <[email-masked]>
Date: Thu, 4 Aug 2005 12:15:14 +0200

So I've tried to set "Cache-Control: no-cache"
in the header using simple response.setHeader("Cache-Control","no-cache");

the header is correctly added but the file is still saved on the local hdd.

are there any other tags that must be set?