Subject: Re (2): last calling WebDAV mounting spec

From: [email-masked]
Date: Sat, 1 Oct 2005 13:32:09 +0200 (MEST)

Hi,
after havin a look at the spec here my naive thoughts.
If I'm overlooking something just flame me :-)
As I understand it the idea is to tell a webbrowser that an URL it got is
WebDAV or even DeltaV capable.
But this is just meta information. Do why not something simple like:

GET /documents/user42/inbox HTTP/1.1
Host: www.example.com

Response:
HTTP/1.1 200 OK
Content-Type: what/ever; dav/deltav
Content-Length: xxx

The normal document for the browser ....
....

I hope you get the idea to give a hint in the header.
If what I'm proposing above would confuse a plain vanilla browser perhaps
there is another way.
This would tell the browser that it makes sense to open this URL with a
WebDAV client.
Because I think that much of the information in the dm: is redundant.
 
Chees, Edgar
--- start of oberon mail ---
:O@h=:<P3m]eE^Y]\b=V`dUCM\^eU6e]di3Bc0`7<0<P?88X0OZH;[LO[KSY<MiD7[K0Z060eM0H
67P8=]\\QQe\d]\b5TX=\f=]^5TQ5T\m]_M]P<\d5Td5]U5Tc5^UM\P4]UE^U5T]=_Pd]Q=]f]\P
T^Xm]em\XU^ceU=<YV5T9mT]5T_e^UE^\m]_M]Ye]W5Tcm]]]\d5]Ye]W5TZ]^cU^Pd\\=\]]\P\
]U5Tj\UY\Q1M^P<YP\^^U\UE^cU^Qe]T5TYU^PT><]T]\Q5TYM^PT^_5Td]\\U]P<\Pl^UE\RE^_
m^c]\b5Td5]QU^P<\^5TEEZ<5TYU>?kKY;8CkLKhE;[H9J@]:8O[L1II]KIM;89JII;M3[E1iH3;
L3[HIKIMI35JMY;8Ycd>G@Vfi2BeF7ffbBg`2bdjFcnFiff`BgdnFgjB@Bdg2bkRfl2BgnFj2bin
ff0L^Y]]`U]U5T\=][]\j\Q=lX5UZPlUTm]S]^]]\^U^cmUeM^UE^dDV_<]^E\_5?19BY:EQj;SY
;SI3AjKW;Me98_kM_[;;;N3KKQ;Kjbanfff`6:eb>GhnFg>gbZc6RDZBEXPPDV`4VPlY;]Q3m]^U
^Ue]d]UD=_`]\j4Tg5]QU^_\\f]\bMWPT\Qe^_T\UU]dYMKh@O[KP<]\^m\d5]j4Th5_h]Q=TZX]
\Pd]_E^]9K19IOkH[32BcnFi2BjRfbD\bm]g1MY;MY;KX;MY;Ma6VD@Rfg2gb2blnfj2bcFFj22;
cdPdm]Pl\Ye^U5TQ5TX=]^U^P<]^5Td5=Rfb6FbFFijb6VDcl^XA@VdCfV`E^_5^_M^Ye]WIH5kK
]KI1iMOKMI;I1iHO[K=KMWKI1IH19LIKHC[K1YM3[KC;KIKH1YHU38L;[LAKHQkLK8MAKIUSYM>3
[KO;MAKIU;8_KHc[;K8EAKJWcknfj@jFFf8MASR18M66CS]=\[]\c5Tc]\^M^U5Tdm=O;L;[K19M
V6[ZDIbkVFjRF@6f6Neb:6L\\=]Ue]deU=DXUM\Q]^c]\P<YPT^X=]^M]PT^X=<ffj>Fd2bgJF@B
GdFVYe=@j@@VFg22T\]EWP<]c5Tb]\T]^^U\Qe]de51I37:J;KIW;;1IA9kI3[Lg^@CJAUj[7P8O
06PmM02@0b2180X2ZPoooDP14Pooo3eYQ]]UY0U[I7[;7;J3[K?KIMII9KJY[;cQ18E;;NYkA3;I
?KIYkLMYC;kM7jKM;MUkKIS020$

---

From: Julian Reschke <[email-masked]>
Date: Sat, 01 Oct 2005 14:07:43 +0200

> WebDAV or even DeltaV capable.

Not just that. For instance, you may also want to initiate an "mount" 
request for a different URL. For instance, many document management 
systems use separate URL namespaces for HTML-based navigation, and 
HTTP/WebDAV access. Thus one level of indirection is needed anyway.

> If what I'm proposing above would confuse a plain vanilla browser perhaps

Independant of the question whether it confuses browsers, how will it 
have any effect in existing browsers?

> Because I think that much of the information in the dm: is redundant.

Such as?

Best regards, Julian