Subject: [Bug 41] Paragraph numbering/nesting broken in Section 13

From: [email-masked]
Date: Mon, 21 Nov 2005 11:06:03 -0800

http://ietf.cse.ucsc.edu:8080/bugzilla/show_bug.cgi?id=41

------- Additional Comments From [email-masked]  2005-11-21 11:06 -------
There's nothing wrong with a flat list of XML element definition sections. It's
not a bug.  I propose that we close this bugzilla issue "won't fix".

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Nov 2005 21:38:59 +0100

> not a bug.  I propose that we close this bugzilla issue "won't fix".

Well, RFC2518 had an alphabetical list, with sub elements appearing 
subsections. I think this made a lot of sense, and AFAIK nobody asked 
for a change.

The new format uses a flatted list, but it wasn't sorted again, 
resulting in a TOC like:

13.   XML Element Definitions

     * 13.1   activelock XML Element
     * 13.2   depth XML Element
     * 13.3   locktoken XML Element
     * 13.4   lockroot XML Element
     * 13.5   timeout XML Element
     * 13.6   collection XML Element
     * 13.7   href XML Element
     * 13.8   lockentry XML Element
     * 13.9   lockinfo XML Element
     * 13.10   lockscope XML Element
     * 13.11   exclusive XML Element
     * 13.12   shared XML Element
     * 13.13   locktype XML Element
     * 13.14   write XML Element
     * 13.15   multistatus XML Element
     * 13.16   response XML Element
     * 13.17   propstat XML Element
     * 13.18   status XML Element
     * 13.19   responsedescription XML Element
     * 13.20   owner XML Element
     * 13.21   prop XML element
     * 13.22   propertyupdate XML element
     * 13.23   remove XML element
     * 13.24   set XML element
     * 13.25   propfind XML Element
     * 13.26   allprop XML Element
     * 13.27   propname XML Element
     * 13.28   dead-props XML Element
     * 13.29   error XML Element

which I think is less accessible than what we used to have in RFC2518:

12.   XML Element Definitions

     * 12.1   activelock XML Element
           o 12.1.1   depth XML Element
           o 12.1.2   locktoken XML Element
           o 12.1.3   timeout XML Element
     * 12.2   collection XML Element
     * 12.3   href XML Element
     * 12.4   link XML Element
           o 12.4.1   dst XML Element
           o 12.4.2   src XML Element
     * 12.5   lockentry XML Element
     * 12.6   lockinfo XML Element
     * 12.7   lockscope XML Element
           o 12.7.1   exclusive XML Element
           o 12.7.2   shared XML Element
     * 12.8   locktype XML Element
           o 12.8.1   write XML Element
     * 12.9   multistatus XML Element
           o 12.9.1   response XML Element
                 + 12.9.1.1   propstat XML Element
                 + 12.9.1.2   status XML Element
           o 12.9.2   responsedescription XML Element
     * 12.10   owner XML Element
     * 12.11   prop XML element
     * 12.12   propertybehavior XML element
           o 12.12.1   keepalive XML element
           o 12.12.2   omit XML element
     * 12.13   propertyupdate XML element
           o 12.13.1   remove XML element
           o 12.13.2   set XML element
     * 12.14   propfind XML Element
           o 12.14.1   allprop XML Element
           o 12.14.2   propname XML Element

Best regards, Julian

---

From: Geoffrey M Clemm <[email-masked]>
Date: Mon, 21 Nov 2005 15:47:09 -0500

I agree that the orginal 2518 formatting is superior.

Cheers,
Geoff