Subject: RE: XML InfoSet and property value preservation

From: "Lukas Mathis" <[email-masked]>
Date: Fri, 18 Nov 2005 08:49:13 +0100

> >   So unless the XML spec is going to change to require parsers to 
> > preserve prefix and we can require XML parsers to comply with the
> The XML spec requires that.

Are you sure? I didn't find any requirement like that.

I thought prefix names weren't important per se, it's their declaration that gives them meaning. You need to bind a prefix to a namespace name, and the parser needs to look that up. The server should be free to change the prefix as long as he keeps the binding consistent.

What if the client uses a prefix which the server already wants to use for another namespace? What if different clients change different properties, but use the same namespace prefixes with different bindings?

Now, if current clients expect the prefixes to be kept, servers should try to do that, but I don't think the spec should require it.

lucas

-- 
Lukas Mathis, Numcom Software AG
Hardturmstrasse 66, CH-8005 Zürich
Direct +41(0)43-204 06 08
mailto:[email-masked], http://www.numcom.com/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 18 Nov 2005 09:58:49 +0100

> Are you sure? I didn't find any requirement like that.

The XML spec doesn't say anything at all about prefixes. An attribute 
name with prefix + colon is just an ordinary attribute name from the XML 
spec's point of view.

> I thought prefix names weren't important per se, it's their declaration that gives them meaning. You need to bind a prefix to a namespace name, and the parser needs to look that up. The server shou…

That may have been the plan once, but when people started putting QNames 
(qualified names) into attribute values or text content, it wasn't true 
any longer.

> What if the client uses a prefix which the server already wants to use for another namespace? What if different clients change different properties, but use the same namespace prefixes with differe…

Nobody has asked for servers preserving prefixes on the WebDAV property 
elements itself. We're talking about child elements of properties.

> Now, if current clients expect the prefixes to be kept, servers should try to do that, but I don't think the spec should require it.

Best regards, Julian