Subject: Fixes for editorial issues

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Nov 2005 14:34:53 +0100

Hi,

the attachment fixes many editorial issues: 30, 41, 57, 63, 68, 88, 89, 
168, 174, 180, 182, 185, 187.

Hopefully this is useful in reducing the number of open issues, and 
concentrating on non-editorial ones.

Best regards, Julian
Index: draft-ietf-webdav-rfc2518bis-latest.xml
===================================================================
RCS file: /var/cvsroot/xml2rfc/draft-ietf-webdav-rfc2518bis-latest.xml,v
retrieving revision 1.8
diff -r1.8 draft-ietf-webdav-rfc2518bis-latest.xml
21a22,24
> <!-- BZ 168 -->
> <?rfc symrefs="yes"?>
> <?rfc sortrefs="yes"?>
23c26,28
< <rfc ipr="full3978" docName="draft-ietf-webdav-rfc2518bis-08">
---
> <!-- changes for BZ89 all over the place -->
> 
> <rfc ipr="full3978" docName="draft-ietf-webdav-rfc2518bis-latest">
99,100c104,105
<    companion document, <xref target="RFC2291">"Requirements for a Distributed Authoring and 
<    Versioning Protocol for the World Wide Web" (RFC2291)</xref>. 
---
>    companion document, "Requirements for a Distributed Authoring and 
>    Versioning Protocol for the World Wide Web" <xref target="RFC2291"/>. 
104,105c109,110
<    by <xref target="RFC2291">RFC2291</xref>. That work was done in a separate document, 
<    <xref target="RFC3253">"Versioning Extensions to WebDAV" (RFC3253)</xref>. 
---
>    by <xref target="RFC2291"/>. That work was done in a separate document, 
>    "Versioning Extensions to WebDAV" <xref target="RFC3253"/>. 
128c133
<    WebDAV uses <xref target="W3C.REC-xml-20001006">XML</xref> to marshal complicated 
---
>    WebDAV uses <xref target="XML"/> to marshal complicated 
149c154
<    <xref target="RFC2616">RFC2616</xref>, including the rules about 
---
>    <xref target="RFC2616"/>, including the rules about 
152c157
<    section 2.2 of <xref target="RFC2616">RFC2616</xref>, these rules apply to this document as 
---
>    section 2.2 of <xref target="RFC2616"/>, these rules apply to this document as 
158c163
<    this document are to be interpreted as described in <xref target="RFC2119">RFC2119</xref>. 
---
>    this document are to be interpreted as described in <xref target="RFC2119"/>. 
173c178
<    them) are defined in <xref target="RFC3986">RFC3986</xref>. 
---
>    them) are defined in <xref target="RFC3986"/>. 
236,237c241,242
<    properties include cases where a) the value of a property is read-
<    only, maintained by the server, and b) the value of the property is 
---
>    properties include cases where a) the value of a property is read-only,
>    maintained by the server, and b) the value of the property is 
263c268
<    information either in an <xref target="W3C.REC-xml-20001006">XML</xref> 
---
>    information either in an <xref target="XML"/> 
303,304c308,309
<    because of its support for multiple character sets.  XML's self-
<    describing nature allows any property's value to be extended by 
---
>    because of its support for multiple character sets.  XML's self-describing
>    nature allows any property's value to be extended by 
324a330
>   <!-- BZ 174 -->
329c335
<    further XML elements, namespace names that are in scope for that part of 
---
>    further XML elements, namespace declarations that are in scope for that part of 
364c370
<    The XML namespace mechanism, which is based on <xref target="RFC3986">URIs</xref>, is 
---
>    The XML namespace mechanism, which is based on URIs (<xref target="RFC3986"/>), is 
413c419
<   <section title="HTTP URL Namespace Model">
---
>   <section title="HTTP URL Namespace Model" anchor="http.url.namespace.model">
436,437c442,443
<    Although implicit in <xref target="RFC2616">RFC2616</xref> and 
<    <xref target="RFC3986">RFC3986</xref>, any resource, 
---
>    Although implicit in <xref target="RFC2616"/> and 
>    <xref target="RFC3986"/>, any resource, 
451,452c457,458
<    containing collection's URL plus an additional segment for non-
<    collection resources, or additional segment plus trailing slash "/" 
---
>    containing collection's URL plus an additional segment for non-collection
>    resources, or additional segment plus trailing slash "/" 
454c460
<    <xref target="RFC3986">RFC3986</xref>.  
---
>    <xref target="RFC3986"/>.  
569,570c575,576
<    band communication channel to coordinate their work (e.g., face-to-
<    face interaction, written notes, post-it notes on the screen, 
---
>    band communication channel to coordinate their work (e.g., face-to-face
>    interaction, written notes, post-it notes on the screen, 
643,644c649,650
<       and to use the URI form defined by <xref target="RFC4122">A Universally Unique 
<    Identifier (UUID) URN  Namespace</xref>.  However 
---
>       and to use the URI form defined by "A Universally Unique 
>    Identifier (UUID) URN  Namespace" (<xref target="RFC4122"/>).  However 
906,907c912,913
<    a Content-Type if any is known.  If the client supplies a Content-
<    Type value the server MUST set that value (this requirement actually 
---
>    a Content-Type if any is known.  If the client supplies a Content-Type
>    value the server MUST set that value (this requirement actually 
943,944c949,950
<       <t>MOVE a member into the collection, unless it overwrites a pre-
<       existing member </t>
---
>       <t>MOVE a member into the collection, unless it overwrites a pre-existing
>       member </t>
946,947c952,953
<       <t>COPY a member into a collection, unless it overwrites a pre-
<       existing member </t>
---
>       <t>COPY a member into a collection, unless it overwrites a pre-existing
>       member </t>
1111c1117
<    XML parsers that are compliant with <xref target="W3C.REC-xml-20001006">XML</xref> 
---
>    XML parsers that are compliant with <xref target="XML"/> 
1114,1115c1120,1121
<    formed and use namespaces correctly.  If a server receives non-
<    wellformed XML in a request it MUST reject the entire request with a 
---
>    formed and use namespaces correctly.  If a server receives non-wellformed
>    XML in a request it MUST reject the entire request with a 
1185c1191
<    (section 1.6 of <xref target="RFC3253">RFC3253</xref>). The mechanism is appropriate to use with 
---
>    (section 1.6 of <xref target="RFC3253"/>). The mechanism is appropriate to use with 
1277,1278c1283,1284
<    properties (see <xref target="RFC3253">RFC3253</xref> and 
<    <xref target="RFC3744">RFC3744</xref>) 
---
>    properties (see <xref target="RFC3253"/> and 
>    <xref target="RFC3744"/>) 
1582,1583c1588,1589
<    403 (Forbidden): The client has attempted to set a read-
<    only property, such as getetag.  If returning this error, the server
---
>    403 (Forbidden): The client has attempted to set a read-only
>    property, such as getetag.  If returning this error, the server
1707,1708c1713,1714
<    Responses from a MKCOL request MUST NOT be cached as MKCOL has non-
<    idempotent semantics. 
---
>    Responses from a MKCOL request MUST NOT be cached as MKCOL has non-idempotent
>    semantics. 
1840,1841c1846,1847
<    The server MAY return a 4xx status response, rather than a Multi-
<    Status, if the request failed. 
---
>    The server MAY return a 4xx status response, rather than a Multi-Status,
>    if the request failed. 
1844,1845c1850,1851
<    424 (Failed Dependency) errors SHOULD NOT be in the 207 (Multi-
<    Status) response for DELETE.  They can be safely left out because the client will know 
---
>    424 (Failed Dependency) errors SHOULD NOT be in the 207 (Multi-Status)
>    response for DELETE.  They can be safely left out because the client will know 
1848,1849c1854,1855
<    204 (No Content) errors SHOULD NOT be returned in the 207 (Multi-
<    Status).  The reason for this prohibition is that 204 (No Content) 
---
>    204 (No Content) errors SHOULD NOT be returned in the 207 (Multi-Status).  The
>    reason for this prohibition is that 204 (No Content) 
1914c1920
<    As defined in <xref target="RFC2616">RFC2616</xref>, the "PUT method requests that the enclosed 
---
>    As defined in <xref target="RFC2616"/>, the "PUT method requests that the enclosed 
2015a2022
>    <!-- BZ 57 -->
2018c2025
<    consistent namespace at the destination (see <xref target="delete-collections"/>for the 
---
>    consistent namespace at the destination (see <xref target="http.url.namespace.model"/> for the 
2032,2033c2039,2040
<    /a/c/. Similarly, after encountering an error copying a non-
<    collection resource as part of an infinite depth copy, the server 
---
>    /a/c/. Similarly, after encountering an error copying a non-collection
>    resource as part of an infinite depth copy, the server 
2087,2088c2094,2095
<    of the source and destination URLs, appear in the body of the multi-
<    status response. E.g. if a destination resource was locked and could 
---
>    of the source and destination URLs, appear in the body of the multi-status
>    response. E.g. if a destination resource was locked and could 
2298,2299c2305,2306
<    moving /a/c/. Similarly, after encountering an error moving a non-
<    collection resource as part of an infinite depth move, the server 
---
>    moving /a/c/. Similarly, after encountering an error moving a non-collection
>    resource as part of an infinite depth move, the server 
2344,2345c2351,2352
<    of the source and destination URLs, appear in the body of the multi-
<    status response. E.g. if a source resource was locked and could not 
---
>    of the source and destination URLs, appear in the body of the multi-status
>    response. E.g. if a source resource was locked and could not 
2483c2490
<       <t><list style="symbol">
---
>       <t><list style="symbols"><!-- BZ89 -->
2613c2620,2621
<       <t>h
---
>       <!-- BZ88 -->
>       <t>
2630a2639
>       <!-- BZ 30 -->
2674,2675c2683,2684
<           <D:href>urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4<
<           /D:href> 
---
>           <D:href
> >urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4</D:href> 
2948,2949c2957,2958
<    IETF RFC process are tokens, but other identifiers SHOULD be Coded-
<    URLs to encourage uniqueness. 
---
>    IETF RFC process are tokens, but other identifiers SHOULD be Coded-URLs
>    to encourage uniqueness. 
3059c3068
<    defined in <xref target="RFC3986">RFC3986</xref>.   
---
>    defined in <xref target="RFC3986"/>.   
3102c3111
<     header defined in section 14.24 of <xref target="RFC2616">RFC2616</xref>.  However the If 
---
>     header defined in section 14.24 of <xref target="RFC2616"/>.  However the If 
3125,3126c3134
<    Note that the absolute-URI production is defined in 
<       <xref target="RFC3986">RFC3986</xref>. 
---
>    Note that the absolute-URI production is defined in <xref target="RFC3986"/>. 
3294,3295c3302,3303
<    its cache.  When dealing with HTTP/1.0 proxies the "Pragma: no-
<    cache" request header MUST be used for the same reason. 
---
>    its cache.  When dealing with HTTP/1.0 proxies the "Pragma: no-cache"
>    request header MUST be used for the same reason. 
3406c3414
<    <xref target="RFC2616">RFC2616</xref>. 
---
>    <xref target="RFC2616"/>. 
3640,3641c3648,3649
<    wire. For example, it is illegal to use a space character or double-
<    quote in a <xref target="RFC3986">URI</xref>.  URIs appearing in PROPFIND or PROPPATCH 
---
>    wire. For example, it is illegal to use a space character or double-quote
>    in a URI.  URIs appearing in PROPFIND or PROPPATCH 
3664c3672
<    <xref target="W3C.REC-xml-20001006">XML</xref>. The 
---
>    <xref target="XML"/>. The 
3675c3683,3684
<   
---
>   <!-- BZ41 -->  
3688d3696
<   </section>
3735a3744
>   </section>
3776c3785
<       <t hangText="Value: ">URI (See section 3.2.1 of <xref target="RFC2616">RFC2616</xref>) </t>
---
>       <t hangText="Value: ">URI (See section 3.2.1 of <xref target="RFC2616"/>) </t>
3811a3821
>   <!-- BZ41 -->
3826d3835
<   </section>
3859a3869
>   </section>
3860a3871
>   <!-- BZ41 -->
3875d3885
<   </section>
3891a3902
>   </section>
3892a3904
>   <!-- BZ41 -->
3911d3922
<   </section>
3915c3926,3927
<       <t hangText="Name: ">locktype</t>
---
>       <!-- BZ63 -->
>       <t hangText="Name: ">response</t>
3936,3937d3947
<   </section>
<   
3961c3971,3972
<    <t hangText="Value: "> status-line (status-line defined in <xref target="RFC2616">RFC2616</xref>
---
>    <!-- BZ 180 -->
>    <t hangText="Value: "> status-line (status-line defined in Section 6.1 of <xref target="RFC2616"/>)
3970a3982,3983
>   </section>
3985a3999
>   </section>
4032a4047
>   <!-- BZ41 -->
4047d4061
<   </section>
4089a4104
>   </section>
4090a4106
>   <!-- BZ41 -->
4107d4122
<   </section>
4153a4169
>   </section>
4179c4195
<    declaration using the format defined in <xref target="W3C.REC-xml-20001006">XML</xref>. 
---
>    declaration using the format defined in <xref target="XML"/>. 
4205c4221
<    <t hangText="Value: ">  date-time (defined in <xref target="RFC3339">RFC3339</xref>, see the ABNF in section 
---
>    <t hangText="Value: ">  date-time (defined in <xref target="RFC3339"/>, see the ABNF in section 
4263c4279
<             <xref target="RFC2616">RFC2616</xref>) </t>
---
>             <xref target="RFC2616"/>) </t>
4287c4303
<    <t hangText="Value: ">content-length (see section 14.14 of <xref target="RFC2616">RFC2616</xref>) </t>
---
>    <t hangText="Value: ">content-length (see section 14.14 of <xref target="RFC2616"/>) </t>
4312c4328
<    <t hangText="Value: ">media-type (defined in section 3.7 of <xref target="RFC2616">RFC2616</xref>) </t>
---
>    <t hangText="Value: ">media-type (defined in section 3.7 of <xref target="RFC2616"/>) </t>
4336c4352
<    <t hangText="Value: ">entity-tag  (defined in section 3.11 of <xref target="RFC2616">RFC2616</xref>) </t>
---
>    <t hangText="Value: ">entity-tag  (defined in section 3.11 of <xref target="RFC2616"/>) </t>
4362c4378
<    <t hangText="Value: ">rfc1123-date  (defined in section 3.3.1 of <xref target="RFC2616">RFC2616</xref>) </t>
---
>    <t hangText="Value: ">rfc1123-date  (defined in section 3.3.1 of <xref target="RFC2616"/>) </t>
4380,4381c4396,4397
<             on any DAV compliant resource that returns the Last-
<             Modified header in response to a GET.  </t>
---
>             on any DAV compliant resource that returns the Last-Modified
>             header in response to a GET.  </t>
4419a4436
>       <!-- BZ 182 -->
4454,4455c4471,4472
<                 <D:href>urn:uuid:f81de2ad-7f3d-a1b2-4f3c
<                         -00a0c91a9d76</D:href> 
---
>                 <D:href
> >urn:uuid:f81de2ad-7f3d-a1b2-4f3c-00a0c91a9d76</D:href> 
4496,4497c4513,4514
<             recognized child elements it should be treated as a non-
<             collection WebDAV-compliant resource. </t>
---
>             recognized child elements it should be treated as a non-collection
>             WebDAV-compliant resource. </t>
4778c4795
<    compliant with <xref target="RFC2616">RFC2616</xref>. 
---
>    compliant with <xref target="RFC2616"/>. 
4801,4802c4818,4819
<    lockdiscovery property, the Time-Out response header and the Lock-
<    Token request header.  A class "2" compliant resource SHOULD also 
---
>    lockdiscovery property, the Time-Out response header and the Lock-Token
>    request header.  A class "2" compliant resource SHOULD also 
4843c4860
<    with the IETF Character Set Policy <xref target="RFC2616">RFC2277</xref>. In this specification, 
---
>    with the IETF Character Set Policy <xref target="RFC2277"/>. In this specification, 
4849c4866
<    encoded, at minimum, using the UTF-8 <xref target="RFC2279">RFC2279</xref> and UTF-16 encodings of 
---
>    encoded, at minimum, using the UTF-8 <xref target="RFC2279"/> and UTF-16 encodings of 
4852c4869
<    Content-Type header, as defined in <xref target="RFC2376">RFC2376</xref>, as well as the XML 
---
>    Content-Type header, as defined in <xref target="RFC2376"/>, as well as the XML 
4860c4877
<    language of its content and attributes. See <xref target="W3C.REC-xml-20001006">XML</xref> for 
---
>    language of its content and attributes. See <xref target="XML"/> for 
4867c4884
<    strongly encouraged to read "XML Media Types" <xref target="RFC2376">RFC2376</xref> for 
---
>    strongly encouraged to read "XML Media Types" <xref target="RFC2376"/> for 
4919,4920c4936,4937
<    <xref target="RFC2616">RFC2616</xref>) and XML (discussed in 
<    <xref target="RFC2376">RFC2376</xref>) also apply to WebDAV. In 
---
>    <xref target="RFC2616"/>) and XML (discussed in 
>    <xref target="RFC2376"/>) also apply to WebDAV. In 
4953c4970
<    <xref target="RFC2069">RFC2069</xref>. Since Digest authentication verifies that both parties to 
---
>    <xref target="RFC2069"/>. Since Digest authentication verifies that both parties to 
5037c5054
<    section 4.2.2 of <xref target="W3C.REC-xml-20001006">XML</xref>, which instruct an XML processor to 
---
>    section 4.2.2 of <xref target="XML"/>, which instruct an XML processor to 
5041,5045c5058,5061
<    used to include XML within the content of an XML document.  For non-
<    validating XML, such as the XML used in this specification, 
<    including an external XML entity is not required by 
<    <xref target="W3C.REC-xml-20001006">XML</xref>.   However, 
<    <xref target="W3C.REC-xml-20001006">XML</xref> does state that an XML processor may, at its 
---
>    used to include XML within the content of an XML document.  For non-validating
>    XML, such as the XML used in this specification, 
>    including an external XML entity is not required by XML.  However, 
>    XML does state that an XML processor may, at its 
5054c5070
<    XML processor to the security risks discussed in <xref target="RFC2376">RFC2376</xref>. 
---
>    XML processor to the security risks discussed in <xref target="RFC2376"/>. 
5074,5075c5090,5091
<    This specification requires the use of <xref target="RFC4122">A Universally 
<    Unique Identifier (UUID) URN Namespace</xref> for lock tokens, in order to guarantee 
---
>    This specification requires the use of "A Universally 
>    Unique Identifier (UUID) URN Namespace" (<xref target="RFC4122"/>) for lock tokens, in order to guarantee 
5129c5145
<     <list style="number">
---
>     <list style="numbers"><!-- BZ89 -->
5159,5160c5175,5176
<    Babich, Sanford Barr, Dylan Barrell, Bernard Chester, Tim Berners-
<    Lee, Dan Connolly, Jim Cunningham, Ron Daniel, Jr., Jim Davis, Keith 
---
>    Babich, Sanford Barr, Dylan Barrell, Bernard Chester, Tim Berners-Lee,
>    Dan Connolly, Jim Cunningham, Ron Daniel, Jr., Jim Davis, Keith 
5204a5221
>   <!-- BZ 185 -->
5206,5223d5222
<     <t>    
<      Editors of RFC2518 
<     </t>
<     
<     <t>
<      Y. Y. Goland 
<      Microsoft Corporation 
<      One Microsoft Way 
<      Redmond, WA 98052-6399 
<      Email: [email-masked] 
<     </t>
<     <t>
<      E. J. Whitehead, Jr. 
<      Dept. Of Information and Computer Science 
<      University of California, Irvine 
<      Irvine, CA 92697-3425 
<      Email: [email-masked] 
<     </t>
5225,5245c5224,5258
<      A. Faizi 
<      Netscape 
<      685 East Middlefield Road 
<      Mountain View, CA 94043 
<      Email: [email-masked] 
<     </t>
<     <t>
<      S. R. Carter 
<      Novell 
<      1555 N. Technology Way 
<      M/S ORM F111 
<      Orem, UT 84097-2399 
<      Email: [email-masked] 
<     </t>
<     <t>
<      D. Jensen 
<      Novell 
<      1555 N. Technology Way 
<      M/S ORM F111 
<      Orem, UT 84097-2399 
<      Email: [email-masked] 
---
>      Y. Y. Goland, 
>      Microsoft Corporation, 
>      One Microsoft Way, 
>      Redmond, WA 98052-6399. 
>      Email: [email-masked]. 
>     </t>
>     <t>
>      E. J. Whitehead, Jr., 
>      Dept. Of Information and Computer Science, 
>      University of California, Irvine,
>      Irvine, CA 92697-3425.
>      Email: [email-masked]. 
>     </t>
>     <t>
>      A. Faizi,
>      Netscape, 
>      685 East Middlefield Road, 
>      Mountain View, CA 94043.
>      Email: [email-masked]. 
>     </t>
>     <t>
>      S. R. Carter, 
>      Novell, 
>      1555 N. Technology Way, 
>      M/S ORM F111, 
>      Orem, UT 84097-2399. 
>      Email: [email-masked]. 
>     </t>
>     <t>
>      D. Jensen, 
>      Novell, 
>      1555 N. Technology Way, 
>      M/S ORM F111, 
>      Orem, UT 84097-2399. 
>      Email: [email-masked]. 
5267d5279
<     &w3cXML;
5268a5281,5319
> <!-- BZ68 -->
> <reference anchor="XML" target="http://www.w3.org/TR/2004/REC-xml-20040204">
>   <front>
>     <title>Extensible Markup Language (XML) 1.0 (Third Edition)</title>
>     <author initials="T." surname="Bray" fullname="Tim Bray">
>       <organization>Textuality and Netscape</organization>
>       <address>
>         <email>[email-masked]</email>
>       </address>
>     </author>
>     <author initials="J." surname="Paoli" fullname="Jean Paoli">
>       <organization>Microsoft</organization>
>       <address>
>         <email>[email-masked]</email>
>       </address>
>     </author>
>     <author initials="C.M." surname="Sperberg-McQueen" fullname="C. M. Sperberg-McQueen">
>       <organization>University of Illinois at Chicago and Text Encoding Initiative</organization>
>       <address>
>         <email>[email-masked]</email>
>       </address>
>     </author>
>     <author initials="E." surname="Maler" fullname="Eve Maler">
>       <organization>Sun Microsystems</organization>
>       <address>
>         <email>[email-masked]</email>
>       </address>
>     </author>
>     <author initials="F." surname="Yergeau" fullname="Francois Yergeau">
>       <organization/>
>       <address>
>         <email>[email-masked]</email>
>       </address>
>     </author>
>     <date day="4" month="February" year="2004"/>
>   </front>
>   <seriesInfo name="W3C" value="REC-xml-20040204"/>
> </reference>
>     
5470c5521
<   Extension = path  ; path is defined in section 3.3 of <xref target="RFC3986">RFC3986</xref> 
---
>   Extension = path  ; path is defined in section 3.3 of <xref target="RFC3986"/> 
5476,5477c5527,5528
< <section title="Changes">
<   <section title="Summary of changes from RFC2518">
---
> <!-- BZ 187 -->
> <section title="Summary of changes from RFC2518">
5527c5578
<     
---
5546,5547c5597,5599
<   
<     
---
> 
> <!-- BZ 187 -->
> <section title="Change Log (to be removed by RFC Editor before publication">
<?xml version="1.0"?>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
  <!ENTITY rfc2069 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2069.xml'>
  <!ENTITY rfc2119 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml'>
  <!ENTITY rfc2277 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2277.xml'>
  <!ENTITY rfc2279 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2279.xml'>
  <!ENTITY rfc2291 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2291.xml'>
  <!ENTITY rfc2376 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2376.xml'>    
  <!ENTITY rfc2518 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2518.xml'>
  <!ENTITY rfc2616 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2616.xml'>
  <!ENTITY rfc3253 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3253.xml'>
  <!ENTITY rfc3339 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3339.xml'>
  <!ENTITY rfc3744 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3744.xml'>
  <!ENTITY rfc3986 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3986.xml'>
  <!ENTITY rfc4122 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.4122.xml'>
  <!ENTITY w3cXMLNS PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml4/reference.W3C.REC-xml-names-19990114.xml'>
  <!ENTITY w3cXML PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml4/reference.W3C.REC-xml-20001006.xml'>
]>
<?rfc toc="yes"?>
<?rfc strict="yes"?>
<!-- BZ 168 -->
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>

<!-- changes for BZ89 all over the place -->

<rfc ipr="full3978" docName="draft-ietf-webdav-rfc2518bis-latest">

<front>

<title abbrev="RFC2518bis">
  HTTP Extensions for Distributed Authoring - WebDAV RFC2518 bis
</title>

<author initials="L.M." surname="Dusseault" fullname="Lisa Dusseault">
  <organization abbrev="OSAF">Open Source Application Foundation</organization>
  <address>
    <postal>
      <street>2064 Edgewood Dr.</street>
      <city>Palo Alto</city> <region>CA</region>
      <code>94303</code>
      <country>US</country>
    </postal>
    <email>[email-masked]</email>
  </address>
</author>

<date month="November" year="2005" />
<area>Applications</area>
<workgroup>WebDAV</workgroup>
<keyword>webdav</keyword>
<keyword>http</keyword>
<keyword>authoring</keyword>
<keyword>web</keyword>

<abstract>
  <t>WebDAV consists of a set of methods, headers, and content-types 
   ancillary to HTTP/1.1 for the management of resource properties, 
   creation and management of resource collections, namespace 
   manipulation, and resource locking (collision avoidance). 
  </t>
  <t>
   RFC2518 was published in February 1998, and this draft makes minor 
   revisions mostly due to interoperability experience. 
  </t>
</abstract>

</front>

<middle>

<section title="Introduction" anchor="intro" >

  <t>
   This document describes an extension to the HTTP/1.1 protocol that 
   allows clients to perform remote web content authoring operations.  
   This extension provides a coherent set of methods, headers, request 
   entity body formats, and response entity body formats that provide 
   operations for: 
  </t>
  <t>
   Properties: The ability to create, remove, and query information 
   about Web pages, such as their authors, creation dates, etc. Also, 
   the ability to link pages of any media type to related pages. 
  </t>
  <t>
   Collections: The ability to create sets of documents and to retrieve 
   a hierarchical membership listing (like a directory listing in a 
   file system). 
  </t>
  <t>
   Locking: The ability to keep more than one person from working on a 
   document at the same time. This prevents the "lost update problem", 
   in which modifications are lost as first one author then another 
   writes changes without merging the other author's changes. 
  </t>
  <t>
   Namespace Operations: The ability to instruct the server to copy and 
   move Web resources. 
  </t>
  <t>
   Requirements and rationale for these operations are described in a 
   companion document, "Requirements for a Distributed Authoring and 
   Versioning Protocol for the World Wide Web" <xref target="RFC2291"/>. 
  </t>
  <t>
   This standard does not specify the versioning operations suggested 
   by <xref target="RFC2291"/>. That work was done in a separate document, 
   "Versioning Extensions to WebDAV" <xref target="RFC3253"/>. 
  </t>
  <t>
   The sections below provide a detailed introduction to <xref target="properties">resource 
   properties</xref>, <xref target="collections">collections of resources</xref>, and 
   <xref target="locking">locking operations</xref>.  These sections introduce the 
   abstractions manipulated by the <xref target="methods">WebDAV-specific HTTP methods</xref> 
   and the <xref target="headers">new HTTP headers used with WebDAV methods</xref>. 
  </t>
  <t>
   While the status codes provided by HTTP/1.1 are sufficient to 
   describe most error conditions encountered by WebDAV methods, there 
   are some errors that do not fall neatly into the existing 
   categories.  This specification defines <xref target="webdav-status-codes">new status
   codes developed for WebDAV methods</xref> and describes 
   <xref target="http-status-codes">existing HTTP status codes</xref> as used in 
   WebDAV. Since some WebDAV methods may operate over many resources, the 
   <xref target="multi-status">Multi-Status response</xref> has been 
   introduced to return status information for multiple resources. Finally, this 
   version of WebDAV introduces XML elements in error response bodies 
   in <xref target="pre_post" />.
  </t>
  <t>
   WebDAV uses <xref target="XML"/> to marshal complicated 
    request and response 
   information, as well as to express metadata, so this specification contains
   <xref target="xml-elements">definitions of all XML elements used</xref>. 
   WebDAV includes a few special rules on <xref target="xml-processing">how to process 
   XML</xref> appearing in WebDAV so that it truly is extensible. 
  </t>
  <t>
   Finishing off the specification are sections on what it means for a resource to be 
   <xref target="compliance-classes">compliant with this specification</xref>, on 
   <xref target="i18n">internationalization support</xref>, and on 
   <xref target="security">security</xref>. 
  </t>
</section>
  
<section title="Notational Conventions">

  <t>
   Since this document describes a set of extensions to the HTTP/1.1 
   protocol, the augmented BNF used herein to describe protocol 
   elements is exactly the same as described in section 2.1 of 
   <xref target="RFC2616"/>, including the rules about 
    implied linear white-space.  
   Since this augmented BNF uses the basic production rules provided in 
   section 2.2 of <xref target="RFC2616"/>, these rules apply to this document as 
   well. 
  </t>
  <t>
   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", 
   "SHOULD", "SHOULD NOT", "RECOMMENDED",  "MAY", and "OPTIONAL" in 
   this document are to be interpreted as described in <xref target="RFC2119"/>. 
  </t>
  <t>
     Note that in natural language, a property like the 
   "creationdate" property in the "DAV:" namespace is sometimes 
   referred to as "DAV:creationdate" for brevity. 
  </t>

</section>

<section title="Terminology">

  <t>
   URI/URL - A Uniform Resource Identifier and Uniform Resource 
   Locator, respectively. These terms (and the distinction between 
   them) are defined in <xref target="RFC3986"/>. 
  </t>
  <t>
   Collection - A resource that contains a set of URLs, which identify 
   and locate member resources and which meet the <xref target="collections">collections
   requirements</xref>. 
  </t>
  <t>
   Member URL - A URL which is a member of the set of URLs contained by 
   a collection. 
  </t>
  <t>
   Internal Member URL - A Member URL that is immediately relative to 
   the URL of the collection (the definition of immediately relative is 
   given <xref target="collection-resources">later</xref>). 
  </t>
  <t>
   Property - A name/value pair that contains descriptive information 
   about a resource. 
  </t>
  <t>
   Live Property - A property whose semantics and syntax are enforced 
   by the server.  For example, the live "getcontentlength" property 
   has its value, the length of the entity returned by a GET request, 
   automatically calculated by the server. 
  </t>
  <t>
   Dead Property - A property whose semantics and syntax are not 
   enforced by the server.  The server only records the value of a dead 
   property; the client is responsible for maintaining the consistency 
   of the syntax and semantics of a dead property. 
  </t>
  
  <t>Principal - 
      A "principal" is a distinct human or computational actor that
      initiates access to network resources. 
  </t>

</section>

<section title="Data Model for Resource Properties" anchor="properties">
    
  <section title="The Resource Property Model">
    
   <t>
   Properties are pieces of data that describe the state of a resource.  
   Properties are data about data. 
  </t>
  <t>
   Properties are used in distributed authoring environments to provide 
   for efficient discovery and management of resources.  For example, a 
   'subject' property might allow for the indexing of all resources by 
   their subject, and an 'author' property might allow for the 
   discovery of what authors have written which documents. 
  </t>
  <t>
   The DAV property model consists of name/value pairs.  The name of a 
   property identifies the property's syntax and semantics, and 
   provides an address by which to refer to its syntax and semantics. 
  </t>
  <t>
   There are two categories of properties: "live" and "dead".  A live 
   property has its syntax and semantics enforced by the server. Live 
   properties include cases where a) the value of a property is read-only,
   maintained by the server, and b) the value of the property is 
   maintained by the client, but the server performs syntax checking on 
   submitted values. All instances of a given live property MUST comply 
   with the definition associated with that property name.  A dead 
   property has its syntax and semantics enforced by the client; the 
   server merely records the value of the property verbatim. 
  </t>

  </section>
  
  <section title="Properties and HTTP Headers">
    <t>
   Properties already exist, in a limited sense, in HTTP message 
   headers.  However, in distributed authoring environments a 
   relatively large number of properties are needed to describe the 
   state of a resource, and setting/returning them all through HTTP 
   headers is inefficient.  Thus a mechanism is needed which allows a 
   principal to identify a set of properties in which the principal is 
   interested and to set or retrieve just those properties. 
    </t>
  </section>
  
  <section title="XML Usage">
    <t>
   In HTTP/1.1, method parameter information was exclusively encoded in 
   HTTP headers. Unlike HTTP/1.1, WebDAV encodes method parameter 
   information either in an <xref target="XML"/> 
   request entity body, or in an HTTP header.  The use of XML to encode 
   method parameters was motivated by the ability to add extra XML 
   elements to existing structures, providing extensibility; and by 
   XML's ability to encode information in ISO 10646 character sets, 
   providing internationalization support.  
  </t>
  <t>
   In addition to encoding method parameters, XML is used in WebDAV to 
   encode the responses from methods, providing the extensibility and 
   internationalization advantages of XML for method output, as well as 
   input. 
  </t>
  <t>
   The <xref target="W3C.REC-xml-names-19990114">XML namespace extension</xref> 
   is also used in this specification in 
   order to allow for new XML elements to be added without fear of 
   colliding with other element names. Although WebDAV request and 
   response bodies can be extended by arbitrary XML elements, which can 
   be ignored by the message recipient, an XML element in the "DAV:" 
   namespace SHOULD NOT be used in the request or response body unless 
   that XML element is explicitly defined in an IETF RFC reviewed by a 
   WebDAV working group. 
  </t>
  <t>
   Note that "DAV:" uses a scheme name defined solely for
    the purpose of creating this namespace.  Defining new schemes for namespaces 
    is discouraged. "DAV:" was defined before 
   standard best practices emerged, and this namespace is  
   still used only because of significant existing deployments. 
    </t>
  </section>

  <section anchor="property_values" title="Property Values"> 
    <t>
   The value of a property is always a (well-formed) XML fragment. 
  </t>
  <t>
   XML has been chosen because it is a flexible, self-describing, 
   structured data format that supports rich schema definitions, and 
   because of its support for multiple character sets.  XML's self-describing
   nature allows any property's value to be extended by 
   adding new elements.  Older clients will not break when they 
   encounter extensions because they will still have the data specified 
   in the original schema and will ignore elements they do not 
   understand.  XML's support for multiple character sets allows any 
   human-readable property to be encoded and read in a character set 
   familiar to the user.  XML's support for multiple human languages, 
   using the "xml:lang" attribute, handles cases where the same 
   character set is employed by multiple human languages. Note that 
   xml:lang scope is recursive, so a xml:lang attribute on any element 
   containing a property name element applies to the property value 
   unless it has been overridden by a more locally scoped attribute. 
  </t>
  <t>
   A property is always represented in XML with an XML element 
   consisting of the property name. The simplest example is an empty 
   property, which is different from a property that does not exist. 
  </t>
  <t>
   &lt;R:title xmlns:R="http://www.example.com/ns/"&gt;&lt;/R:title&gt;
  </t>
  <!-- BZ 174 -->
  <t>
   The value of a property appears inside the property name element.  
   The value may be any kind of well-formed XML content, including both 
   text-only and mixed content.  When the property value contains 
   further XML elements, namespace declarations that are in scope for that part of 
   the XML document apply within the property value as well, and MUST 
   be preserved in server storage for retransmission later. Namespace 
   prefixes need not be preserved due to the rules of prefix 
   declaration in XML. 
  </t>
  <t>
   Attributes on the property name element may convey information about 
   the property, but are not considered part of the value. However, 
   when language information appears in the 'xml:lang' attribute on the 
   property name element, the language information MUST be preserved in 
   server storage for retransmission later.  Note that a property only has
    one value, in one language (or language MAY be left undefined), not
    multiple values in different languages or a single value in multiple languages.
  </t>
  <t>
   The XML attribute xml:space MUST NOT be used to change white space 
   handling.  White space in property values is significant.  
    </t>
  </section>
  
  <section title="Property Names">
    <t>    
   A property name is a universally unique identifier that is 
   associated with a schema that provides information about the syntax 
   and semantics of the property. 
  </t>
  <t>
   Because a property's name is universally unique, clients can depend 
   upon consistent behavior for a particular property across multiple 
   resources, on the same and across different servers, so long as that 
   property is "live" on the resources in question, and the 
   implementation of the live property is faithful to its definition. 
  </t>
  <t>
   The XML namespace mechanism, which is based on URIs (<xref target="RFC3986"/>), is 
   used to name properties because it prevents namespace collisions and 
   provides for varying degrees of administrative control. 
  </t>
  <t>
   The property namespace is flat; that is, no hierarchy of properties 
   is explicitly recognized.  Thus, if a property A and a property A/B 
   exist on a resource, there is no recognition of any relationship 
   between the two properties.  It is expected that a separate 
   specification will eventually be produced which will address issues 
   relating to hierarchical properties. 
  </t>
  <t>
   Finally, it is not possible to define the same property twice on a 
   single resource, as this would cause a collision in the resource's 
   property namespace. 
    </t>
  </section>
  
  <section title="Source Resources and Output Resources">
    <t>Some HTTP resources are dynamically generated by the server.  For these resources,
      there presumably exists source code somewhere governing how that resource
      is generated.  The relationship of source files to output HTTP resources
      may be one to one, one to many, many to one or many to many.  There is
      no mechanism in HTTP to determine whether a resource is even dynamic, let
       alone where its source files exist or how to author them.  
   Although this problem would usefully be solved, interoperable WebDAV 
   implementations have been widely deployed without actually solving 
   this problem, by dealing only with static resources. Thus, the 
      source vs. output problem is not solved in 
   this specification and has been deferred to a separate document. 
    </t>
  </section>
  
</section>

<section title="Collections of Web Resources" anchor="collections">
  <t>
   This section provides a description of a new type of Web resource, 
   the collection, and discusses its interactions with the HTTP URL 
   namespace. The purpose of a collection resource is to model 
   collection-like objects (e.g., file system directories) within a 
   server's namespace. 
  </t>
  <t>
   All DAV compliant resources MUST support the HTTP URL namespace 
   model specified herein. 
  </t>
  
  <section title="HTTP URL Namespace Model" anchor="http.url.namespace.model">
    <t>
   The HTTP URL namespace is a hierarchical namespace where the 
   hierarchy is delimited with the "/" character.    
    </t>
    <t>
   An HTTP URL namespace is said to be consistent if it meets the 
   following conditions: for every URL in the HTTP hierarchy there 
   exists a collection that contains that URL as an internal member. 
   The root, or top-level collection of the namespace under 
   consideration is exempt from the previous rule.   The top-level
      collection of the namespace under consideration is not necessarily
      the collection identified by the absolute path '/', it may be 
      identified by one or more path segments (e.g. /servlets/webdav/...)
    </t>
    <t>
   Neither HTTP/1.1 nor WebDAV require that the entire HTTP URL 
   namespace be consistent -- a WebDAV-compatible resource may
      not have a parent collection.  However, certain WebDAV methods are 
   prohibited from producing results that cause namespace 
   inconsistencies. 
    </t>
    <t>
   Although implicit in <xref target="RFC2616"/> and 
   <xref target="RFC3986"/>, any resource, 
   including collection resources, MAY be identified by more than one 
   URI. For example, a resource could be identified by multiple HTTP 
   URLs. 
    </t>
  </section>
  
  <section title="Collection Resources" anchor="collection-resources">
    <t>
   A collection is a resource whose state consists of at least a list 
   of internal member URLs and a set of properties, but which may have 
   additional state such as entity bodies returned by GET.  An internal 
   member URL MUST be immediately relative to a base URL of the 
   collection.  That is, the internal member URL is equal to a 
   containing collection's URL plus an additional segment for non-collection
   resources, or additional segment plus trailing slash "/" 
   for collection resources, where segment is defined in section 3.3 of 
   <xref target="RFC3986"/>.  
    </t>
    <t>
   Any given internal member URL MUST only belong to the collection 
   once, i.e., it is illegal to have multiple instances of the same URL 
   in a collection.  Properties defined on collections behave exactly 
   as do properties on non-collection resources.  
    </t>
    <t>
   For all WebDAV compliant resources A and B, identified by URLs U and 
   V, for which U is immediately relative to V, B MUST be a collection 
   that has U as an internal member URL. So, if the resource with URL 
   http://example.com/bar/blah is WebDAV compliant and if the resource 
   with URL http://example.com/bar/ is WebDAV compliant then the 
   resource with URL http://example.com/bar/ must be a collection and 
   must contain URL http://example.com/bar/blah as an internal member. 
    </t>
    <t>
   Collection resources MAY list the URLs of non-WebDAV compliant 
   children in the HTTP URL namespace hierarchy as internal members but 
   are not required to do so. For example, if the resource with URL 
   http://example.com/bar/blah is not WebDAV compliant and the URL 
   http://example.com/bar/ identifies a collection then URL 
   http://example.com/bar/blah may or may not be an internal member of 
   the collection with URL http://example.com/bar/. 
    </t>
    <t>
   If a WebDAV compliant resource has no WebDAV compliant children in 
   the HTTP URL namespace hierarchy then the WebDAV compliant resource 
   is not required to be a collection. 
    </t>
    <t>
   There is a standing convention that when a collection is referred to 
   by its name without a trailing slash, the server MAY handle the 
   request as if the trailing slash were present.  In this case it 
   SHOULD return a Content-Location header in the response, pointing to 
   the URL ending with the "/".  For example, if a client invokes a 
   method on http://example.com/blah (no trailing slash), the server 
   may respond as if the operation were invoked on 
   http://example.com/blah/ (trailing slash), and should return a 
   Content-Location header with the value http://example.com/blah/. 
   Wherever a server produces a URL referring to a collection, the 
   server MUST include the trailing slash. In general clients SHOULD 
   use the "/" form of collection names.   
    </t>
    <t>
   Clients MUST be able to support the case where WebDAV resources are 
   contained inside non-WebDAV resources.  For example, if a OPTIONS 
   response from "http://example.com/servlet/dav/collection" indicates 
   WebDAV support, the client cannot assume that 
   "http://example.com/servlet/dav/" or its parent necessarily are 
   WebDAV collections. 
    </t>
  </section>

</section>

<section title="Locking" anchor="locking">
  <t>
   The ability to lock a resource provides a mechanism for serializing 
   access to that resource.  Using a lock, an authoring client can 
   provide a reasonable guarantee that another principal will not 
   modify a resource while it is being edited.  In this way, a client 
   can prevent the "lost update" problem. 
  </t>
  <t>
   This specification allows locks to vary over two client-specified 
   parameters, the number of principals involved (exclusive vs. shared) 
   and the type of access to be granted. This document defines locking 
   for only one access type, write. However, the syntax is extensible, 
   and permits the eventual specification of locking for other access 
   types. 
  </t>
  
  <section title="Exclusive Vs. Shared Locks">
    <t>
   The most basic form of lock is an exclusive lock.  Only one 
   exclusive lock may exist on any resource, whether it is directly or 
   <xref target="depth-locks">indirectly locked</xref>.  Exclusive locks avoid having to merge 
   results, without requiring any coordination other than the methods 
   described in this specification. 
    </t>
    <t>
   However, there are times when the goal of a lock is not to exclude 
   others from exercising an access right but rather to provide a 
   mechanism for principals to indicate that they intend to exercise 
   their access rights.  Shared locks are provided for this case.  A 
   shared lock allows multiple principals to receive a lock.  Hence any 
   principal with appropriate access can use the lock. 
    </t>
    <t>
   With shared locks there are two trust sets that affect a resource.  
   The first trust set is created by access permissions.  Principals 
   who are trusted, for example, may have permission to write to the 
   resource.  Among those who have access permission to write to the 
   resource, the set of principals who have taken out a shared lock 
   also must trust each other, creating a (typically) smaller trust set 
   within the access permission write set. 
    </t>
    <t>
   Starting with every possible principal on the Internet, in most 
   situations the vast majority of these principals will not have write 
   access to a given resource.  Of the small number who do have write 
   access, some principals may decide to guarantee their edits are free 
   from overwrite conflicts by using exclusive write locks.  Others may 
   decide they trust their collaborators will not overwrite their work 
   (the potential set of collaborators being the set of principals who 
   have write permission) and use a shared lock, which informs their 
   collaborators that a principal may be working on the resource. 
    </t>
    <t>
   The WebDAV extensions to HTTP do not need to provide all of the 
   communications paths necessary for principals to coordinate their 
   activities.  When using shared locks, principals may use any out of 
   band communication channel to coordinate their work (e.g., face-to-face
   interaction, written notes, post-it notes on the screen, 
   telephone conversation, Email, etc.)  The intent of a shared lock is 
   to let collaborators know who else may be working on a resource. 
    </t>
    <t>
   Shared locks are included because experience from web distributed 
   authoring systems has indicated that exclusive locks are often too 
   rigid.  An exclusive lock is used to enforce a particular editing 
   process: take out an exclusive lock, read the resource, perform 
   edits, write the resource, release the lock.  This editing process 
   has the problem that locks are not always properly released, for 
   example when a program crashes, or when a lock owner leaves without 
   unlocking a resource.  While both timeouts and administrative action 
   can be used to remove an offending lock, neither mechanism may be 
   available when needed; the timeout may be long or the administrator 
   may not be available. 
    </t>
  </section>
  
  <section title="Required Support">
   <t>
   A WebDAV compliant resource is not required to support locking in 
   any form.  If the resource does support locking it may choose to 
   support any combination of exclusive and shared locks for any access 
   types. 
    </t>
    <t>
   The reason for this flexibility is that locking policy strikes to 
   the very heart of the resource management and versioning systems 
   employed by various storage repositories.  These repositories 
   require control over what sort of locking will be made available.  
   For example, some repositories only support shared write locks while 
   others only provide support for exclusive write locks while yet 
   others use no locking at all.  As each system is sufficiently 
   different to merit exclusion of certain locking features, this 
   specification leaves locking as the sole axis of negotiation within 
   WebDAV. 
   </t>
  </section>
  
  <section title="Lock Tokens">
    <t>
   A lock token is a type of state token, represented as a URI, which 
   identifies a particular lock.  Each lock has exactly one unique lock
      token generated by the server.  
    Clients MUST NOT attempt to interpret lock tokens in any way.</t>
    <t>
   Lock token URIs MUST be unique across all resources for all time. 
   This uniqueness constraint allows lock tokens to be submitted across 
   resources and servers without fear of confusion. 
    </t>
    <t> When a LOCK operation creates a new lock, the new lock token is 
      returned in the Lock-Token response header defined in 
      <xref target="lock-token-header"/>,
      and also in the body of the response.  
    </t>

    <t>
   Submitting a lock token does not confer full privilege to use
      the lock token or modify the locked resource. Anyone can 
   find out anyone else's lock token by performing lock discovery. 
   Write access and other privileges MUST be enforced through normal 
      privilege or authentication mechanisms, not based on the slight
      obscurity of lock token values. 
    </t>
    <t>
          Since lock tokens are unique, a client 
    MAY submit a lock token in an If header on a resource other 
   than the one that returned it. 
    </t>
     <t>
   This specification encourages servers to create UUIDs for lock tokens,
      and to use the URI form defined by "A Universally Unique 
   Identifier (UUID) URN  Namespace" (<xref target="RFC4122"/>).  However 
   servers are free to use another valid URI so long as it meets the 
   uniqueness requirements.  For example, a valid lock token might be constructed
      using the "opaquelocktoken" scheme defined in an appendix of this document.
    </t>
    <t>Example: "urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6"</t>
    
  </section>
  
  <section title="Lock Capability Discovery">
    <t>
   Since server lock support is optional, a client trying to lock a 
   resource on a server can either try the lock and hope for the best, 
   or perform some form of discovery to determine what lock 
   capabilities the server supports.  This is known as lock capability 
   discovery.  A client can determine what lock types the server 
   supports by retrieving the supportedlock property. 
    </t>
    <t>
   Any DAV compliant resource that supports the LOCK method MUST 
   support the supportedlock property. 
    </t>
  </section>
  
  <section title="Active Lock Discovery"> 
    <t>
   If another principal locks a resource that a principal wishes to 
   access, it is useful for the second principal to be able to find out 
   who the first principal is.  For this purpose the lockdiscovery 
   property is provided.  This property lists all outstanding locks, 
   describes their type, and where available, provides their lock 
   token. 
    </t>
    <t>
   Any DAV compliant resource that supports the LOCK method MUST 
   support the lockdiscovery property. 
    </t>
  </section>
  
    <section title="Locks and Multiple Bindings">
      <t>
   A resource may be made available through more than one URI. However 
   locks apply to resources, not URIs. Therefore a LOCK request on a 
   resource MUST NOT succeed if can not be honored by all the URIs 
   through which the resource is addressable. 
      </t>
    </section>
 
</section>

<section title="Write Lock">
  <t>
   This section describes the semantics specific to the write lock 
   type.  The write lock is a specific instance of a lock type, and is 
   the only lock type described in this specification. 
  </t>
  <t>
   An exclusive write lock will prevent parallel changes to a resource by
    any principal other than the write lock holder. In general 
   terms, changes affected by write locks include changes to: 
  </t>
  <t><list style="symbols">
    <t>the content of the resource </t>
    <t>any dead property of the resource </t>
    <t>any live property defined to be lockable (all properties defined 
   in this specification are lockable) </t>
    <t>the direct membership of the resource, if it is a collection </t>
    <t>the URL/location of a resource </t>
  </list>    </t>
  <t>
   The next few sections describe in more specific terms how write 
   locks interact with various operations. 
  </t>
  
  <section title="Lock Owner" anchor="lock-owner">
    <t>The creator of the lock is the lock owner.  The server MUST restrict the usage
      of the lock token to the lock owner (both for shared and exclusive locks -- for
      multi-user shared lock cases, each authenticated principal MUST obtain its own
    shared lock).  </t>
    <t>The server MAY allow privileged users other than the lock owner to destroy a lock
    (for example, the resource owner or an administrator) as a special case of lock
    usage.</t>
    <t>If an anonymous user requests a lock, the server MAY refuse the request.</t>
  </section>
  
  <section title="Methods Restricted by Write Locks">
    <t>
   A server MUST reject any write request that alters a write-locked resource unless
      a valid lock token is provided.  The
   write operations defined in HTTP and WebDAV are PUT, POST, PROPPATCH, LOCK, UNLOCK, 
   MOVE, COPY (for the destination resource), DELETE, and MKCOL.  All other HTTP/WebDAV methods, 
   GET in particular, function independently of the lock.  A shared write lock
      prevents the same operations, however it also allows access by any
      principal that has a shared write lock on the same resource.
    </t>
    <t>
   Note, however, that as new methods are created it will be necessary 
   to specify how they interact with a write lock. 
    </t>
  </section>
  
  <section title="Write Locks and Lock Tokens">

    <t>
   A successful request for an exclusive or shared write lock MUST 
   result in the generation of a unique lock token associated with the 
   requesting principal.  Thus if five principals have a shared write 
   lock on the same resource there will be five lock tokens, one for 
   each principal. 
    </t>
  </section>
  
  <section title="Write Locks and Properties">
    <t>
   While those without a write lock may not alter a property on a 
   resource it is still possible for the values of live properties to 
   change, even while locked, due to the requirements of their schemas.  
   Only dead properties and live properties defined to respect locks 
   are guaranteed not to change while write locked. 
    </t>
  </section>

  <section title="Avoiding Lost Updates">
    <t>
   Although the write locks provide some help in 
   preventing lost updates, they cannot guarantee that updates will 
   never be lost.  Consider the following scenario: 
    </t>
    <t>
   Two clients A and B are interested in editing the resource 
   'index.html'.  Client A is an HTTP client rather than a WebDAV 
   client, and so does not know how to perform locking. 
    </t>
    <t>
   Client A doesn't lock the document, but does a GET and begins 
   editing. 
    </t>
    <t>
   Client B does LOCK, performs a GET and begins editing. 
    </t>
    <t>
   Client B finishes editing, performs a PUT, then an UNLOCK. 
    </t>
    <t>
   Client A performs a PUT, overwriting and losing all of B's changes. 
    </t>
    <t>
   There are several reasons why the WebDAV protocol itself cannot 
   prevent this situation.  First, it cannot force all clients to use 
   locking because it must be compatible with HTTP clients that do not 
   comprehend locking.  Second, it cannot require servers to support 
   locking because of the variety of repository implementations, some 
   of which rely on reservations and merging rather than on locking.  
   Finally, being stateless, it cannot enforce a sequence of operations 
   like LOCK / GET / PUT / UNLOCK.  
    </t>
    <t>
   WebDAV servers that support locking can reduce the likelihood that 
   clients will accidentally overwrite each other's changes by 
   requiring clients to lock resources before modifying them.  Such 
   servers would effectively prevent HTTP 1.0 and HTTP 1.1 clients from 
   modifying resources. 
    </t>
    <t>
   WebDAV clients can be good citizens by using a lock / retrieve / 
   write /unlock sequence of operations (at least by default) whenever 
   they interact with a WebDAV server that supports locking. 
    </t>
    <t>
   HTTP 1.1 clients can be good citizens, avoiding overwriting other 
   clients' changes, by using entity tags in If-Match headers with any 
   requests that would modify resources.  
    </t>
    <t>
   Information managers may attempt to prevent overwrites by 
   implementing client-side procedures requiring locking before 
   modifying WebDAV resources. 
    </t>
    
  </section>  
  
  <section title="Write Locks and Unmapped URLs" anchor="lock-unmapped-urls">
    <t>
   It is possible to lock an unmapped URL in order to lock the name for 
   use.  This is a simple way to avoid the lost-update problem on the 
   creation of a new resource (another way is to use If-None-Match 
   header specified in HTTP 1.1).  It has the side benefit of locking 
   the new resource immediately for use of the creator.   
    </t>
    <t>
   The lost-update problem is not an issue for collections because 
   MKCOL can only be used to create a collection, not to overwrite an 
   existing collection.  When trying to lock a collection upon 
   creation, clients may attempt to increase the likelihood of this by 
      pipelining the MKCOL and LOCK requests together (but because this 
      doesn't convert two separate operations into one atomic operation 
      there's no guarantee this will work).   
    </t>
    <t>
   A lock request to an unmapped URL SHOULD result in the creation of an 
   locked resource with empty content.  A subsequent PUT request with the correct 
   lock token SHOULD normally succeed, and this new request provides 
   the content, content-type, content-language and other information as 
   appropriate.  
    </t>
    <t>
   In this situation, a WebDAV server that was implemented from RFC2518 
   MAY create "lock-null" resources which are special and unusual 
   resources.  Historically, a lock-null resource: 
    </t>
    <t><list style="symbols">
    
      <t>Responds with a 404 or 405 to any DAV method except for PUT, 
     MKCOL, OPTIONS, PROPFIND, LOCK, UNLOCK. </t>
      <t>Appears as a member of its parent collection. </t>
      <t>Disappears (URI becomes unmapped) if its lock goes away before it 
     is converted to a regular resource.  (This must also happen if it 
     is renamed or moved, or if any parent collection is renamed or 
     moved, because locks are tied to URLs). </t>
      <t>May be turned into a regular resource when a PUT request to the 
     URL is successful. Ceases to be a lock-null resource. </t>
      <t>May be turned into a collection when a MKCOL request to the URL 
     is successful.  Ceases to be a lock-null resource.</t>
      <t>Has defined values for lockdiscovery and supportedlock 
     properties.</t>
    </list></t>
    
    <t>
   However, interoperability and compliance problems have been found 
   with lock-null resources.  Therefore, they are deprecated.  WebDAV 
   servers SHOULD create regular locked empty resources, which are and 
   behave in every way as normal resources.  A locked empty resource: 
    </t>
    
    <t><list style="symbols">
      <t>Can be read, deleted, moved, copied, and in all ways behave as a 
     regular resource, not a lock-null resource. </t>
      <t>Appears as a member of its parent collection. </t>
      <t>SHOULD NOT disappear when its lock goes away (clients must 
     therefore be responsible for cleaning up their own mess, as with 
     any other operation) </t>
      <t>SHOULD default to having no content type. </t>
      <t>MAY NOT have values for properties like getcontentlanguage which 
     haven't been specified yet by the client. </t>
      <t>May have content added with a PUT request.  MUST be able to 
     change content type. </t>
      <t>MUST NOT be turned into a collection.  A MKCOL request must fail 
     as it would to any existing resource. </t>
      <t>MUST have defined values for lockdiscovery and supportedlock 
     properties.</t> 
      <t>The response MUST indicate that a resource was created, by use of 
     the "201 Created" response code (a LOCK request to an existing 
     resource instead will result in 200 OK).  The body must still 
     include the lockdiscovery property, as with a LOCK request to an 
     existing resource. </t>
    </list></t>
    <t>
   The client is expected to update the locked empty resource shortly 
   after locking it, using PUT and possibly PROPPATCH.  When the client 
   uses PUT to overwrite a locked empty resource the client MUST supply 
   a Content-Type if any is known.  If the client supplies a Content-Type
   value the server MUST set that value (this requirement actually 
   applies to any resource that is overwritten but is particularly 
   necessary for locked empty resources which are initially created 
   with no Content-Type.   
    </t>
    <t>
   Clients can easily interoperate both with servers that support the 
   deprecated lock-null resources and servers that support simpler 
   locked empty resources by only attempting PUT after a LOCK to an 
   unmapped URL, not MKCOL or GET. 
    </t>
  </section>
  
  <section title="Write Locks and Collections" anchor="depth-locks">
    <t>
   A write lock on a collection, whether created by a "Depth: 0" or 
   "Depth: infinity" lock request, prevents the addition or removal of 
   member URLs of the collection by non-lock owners.   
    </t>
    <t>
      A zero-depth lock on a collection affects changes to the direct 
      membership of that collection.  When a principal issues a write 
      request to create a new resource in a write locked collection, 
      or isses a DELETE, MOVE or other request that would remove 
      an existing internal member URL of a write locked collection or change
      the binding name, this 
      request MUST fail if the principal does not provide the correct lock 
      token for the locked collection. 
    </t>
    <t>
     This means that if a collection is locked (depth 0 or infinity), its 
   lock-token is required in all these cases: 
    </t>
    <t><list style="symbols">
      <t>DELETE a collection's direct internal member </t>
      <t> MOVE a member out of the collection </t>
      <t>MOVE a member into the collection, unless it overwrites a pre-existing
      member </t>
      <t>MOVE to rename it within a collection, </t>
      <t>COPY a member into a collection, unless it overwrites a pre-existing
      member </t>
      <t>PUT or MKCOL request which would create a new member.   </t>
    </list></t>
    <t>
   The collection's lock token is required in addition to the lock 
   token on the internal member itself, if it is locked separately. 
    </t>
    <t>
     In addition, a depth-infinity lock affects all write operations to 
     all descendents of the locked collection.  With a depth-infinity 
     lock, the root of the lock is directly locked, and all its 
     descendants are indirectly locked.   
    </t>
    <t><list style="symbols">
      <t> Any new resource added as a descendent of a depth-infinity locked 
       collection becomes indirectly locked.  </t>
      <t>Any indirectly locked resource moved out of the locked collection 
       into an unlocked collection is thereafter unlocked. </t>
      <t>Any indirectly locked resource moved out of a locked source 
       collection into a depth-infinity locked target collection remains 
       indirectly locked but is now within the scope of the lock on the 
       target collection (the target collection's lock token will 
       thereafter be required to make further changes). </t>
    </list></t>
    <t>
    
   If a depth-infinity write LOCK request is issued to a collection 
   containing member URLs identifying resources that are currently 
   locked in a manner which conflicts with the write lock, the request 
   MUST fail with a 423 (Locked) status code, and the response SHOULD
   contain the 'missing-lock-token' precondition.
    </t>
    <t>
   If a lock owner causes the URL of a resource to be added as an 
   internal member URL of a depth-infinity locked collection then the 
   new resource MUST be automatically added to the lock.  This is the 
   only mechanism that allows a resource to be added to a write lock.  
   Thus, for example, if the collection /a/b/ is write locked and the 
   resource /c is moved to /a/b/c then resource /a/b/c will be added to 
   the write lock. 
    </t>
  </section>
  
  <section title="Write Locks and the If Request Header" anchor="submit-lock-token">
    <t>    
   If a user agent is not required to have knowledge about a lock when 
   requesting an operation on a locked resource, the following scenario 
   might occur.  Program A, run by User A, takes out a write lock on a 
   resource.  Program B, also run by User A, has no knowledge of the 
   lock taken out by Program A, yet performs a PUT to the locked 
   resource.  In this scenario, the PUT succeeds because locks are 
   associated with a principal, not a program, and thus program B, 
   because it is acting with principal A's credential, is allowed to 
   perform the PUT.  However, had program B known about the lock, it 
   would not have overwritten the resource, preferring instead to 
   present a dialog box describing the conflict to the user.  Due to 
   this scenario, a mechanism is needed to prevent different programs 
   from accidentally ignoring locks taken out by other programs with 
   the same authorization. 
    </t>
    <t>
   In order to prevent these collisions a lock token MUST be submitted 
   by an authorized principal for all locked resources that a method 
   may change or the method MUST fail.  A lock token is submitted when 
   it appears in an If header.  For example, if a resource is to be 
   moved and both the source and destination are locked then two lock 
   tokens must be submitted in the if header, one for the source and 
   the other for the destination. 
    </t>

	<figure>
	  <preamble>Example - Write Lock</preamble>
	  <artwork><![CDATA[
   
   >>Request 
    
     COPY /~fielding/index.html HTTP/1.1 
     Host: www.ics.uci.edu 
     Destination: http://www.ics.uci.edu/users/f/fielding/index.html 
     If: <http://www.ics.uci.edu/users/f/fielding/index.html> 
         (<urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6>) 

   >>Response 
    
     HTTP/1.1 204 No Content 
      
      ]]></artwork>
    </figure>
  
    <t>
   In this example, even though both the source and destination are 
   locked, only one lock token must be submitted, for the lock on the 
   destination.  This is because the source resource is not modified by 
   a COPY, and hence unaffected by the write lock. In this example, 
   user agent authentication has previously occurred via a mechanism 
   outside the scope of the HTTP protocol, in the underlying transport 
   layer. 
    </t>
  </section>
  
  <section title="Write Locks and COPY/MOVE">
    <t>
   A COPY method invocation MUST NOT duplicate any write locks active 
   on the source.  However, as previously noted, if the COPY copies the 
   resource into a collection that is locked with "Depth: infinity", 
   then the resource will be added to the lock. 
    </t>
    <t>
   A successful MOVE request on a write locked resource MUST NOT move 
   the write lock with the resource. However, the resource is subject 
   to being added to an existing lock at the destination (see <xref target="depth-locks"/>). 
   For example, if the MOVE makes the resource a child 
   of a collection that is locked with "Depth: infinity", then the 
   resource will be added to that collection's lock. Additionally, if a 
   resource locked with "Depth: infinity" is moved to a destination 
   that is within the scope of the same lock (e.g., within the 
   namespace tree covered by the lock), the moved resource will again 
   be a added to the lock. In both these examples, as specified in 
   <xref target="submit-lock-token"/>, an If header must be submitted containing a lock token 
   for both the source and destination.  
    </t>
  </section>
  
  <section title="Refreshing Write Locks">
    <t>
   A client MUST NOT submit the same write lock request twice.  Note 
   that a client is always aware it is resubmitting the same lock 
   request because it must include the lock token in the If header in 
   order to make the request for a resource that is already locked. 
    </t>
    <t>
   However, a client may submit a LOCK method with an If header but 
   without a body.  This form of LOCK MUST only be used to "refresh" a 
   lock.  Meaning, at minimum, that any timers associated with the lock 
   MUST be re-set. 
    </t>
    <t>
   A server may return a Timeout header with a lock refresh that is 
   different than the Timeout header returned when the lock was 
   originally requested.  Additionally clients may submit Timeout 
   headers of arbitrary value with their lock refresh requests.  
   Servers, as always, may ignore Timeout headers submitted by the 
   client. Note that timeout is measured in seconds remaining until 
   expiration. 
    </t>
    <t>
   If an error is received in response to a refresh LOCK request the 
   client MUST NOT assume that the lock was refreshed. 
    </t>
  </section>
  
</section>

<section title="HTTP Methods for Distributed Authoring" anchor="methods">

  <section title="General request and response handling" anchor="response-handling">

    <section title="Use of XML">
      <t>
   Some of the following new HTTP methods use XML as a request and 
   response format.  All DAV compliant clients and resources MUST use 
   XML parsers that are compliant with <xref target="XML"/> 
   and <xref target="W3C.REC-xml-names-19990114">XML Namespaces</xref>.  All 
   XML used in either requests or responses MUST be, at minimum, well 
   formed and use namespaces correctly.  If a server receives non-wellformed
   XML in a request it MUST reject the entire request with a 
   400 (Bad Request).  If a client receives ill-formed XML in a 
   response then it MUST NOT assume anything about the outcome of the 
   executed method and SHOULD treat the server as malfunctioning. 
      </t>
    </section>
    
    <section title="Required Bodies in Requests">
      <t>
   Some of these new methods do not define bodies.  Servers MUST 
   examine all requests for a body, even when a body was not expected.  
   In cases where a request body is present but would be ignored by a 
   server, the server MUST reject the request with 415 (Unsupported 
   Media Type).  This informs the client (which may have been 
   attempting to use an extension) that the body could not be processed 
   as they intended. 
      </t>
    </section>  

    <section title="HTTP Headers for use in WebDAV">
      <t>
        HTTP defines many headers that can be used in WebDAV requests and
        responses.  Not all of these are appropriate in all situations and
        some interactions may be undefined. 

   Note that HTTP 1.1 requires the Date header in all responses if 
   possible. 
      </t>
      
    </section>
    
    <section title="ETag" anchor="etag">
      <t>    
   HTTP 1.1 recommends the use of the ETag header in responses to GET 
   and PUT requests. Correct use of ETags is even more important in a 
   distributed authoring environment, because ETags are necessary along 
   with locks to avoid the lost-update problem.  A client might fail to 
   renew a lock, for example when the lock times out and the client is 
   accidentally offline or in the middle of a long upload.  When a 
   client fails to renew the lock, it's quite possible the resource can 
   still be relocked and the user can go on editing, as long as no 
   changes were made in the meantime. ETags are required for the client 
   to be able to distinguish this case. Otherwise, the client is forced 
   to ask the user whether to overwrite the resource on the server 
   without even being able to tell the user whether it has changed. 
   Timestamps do not solve this problem nearly as well as ETags. 
      </t>
      <t>
   WebDAV servers SHOULD support strong ETags for all resources that 
   may be PUT.  If ETags are supported for a resource, the server MUST 
   return the ETag header in all PUT and GET responses to that 
   resource, as well as provide the same value for the 'getetag' 
   property.  
      </t>
      <t>
   Because clients may be forced to prompt users or throw away changed 
   content if the ETag changes, a WebDAV server SHOULD NOT change the 
   ETag (or getlastmodified value) for a resource that has an unchanged  
   body. The ETag represents the state of the body or contents of the 
   resource. There is no similar way to tell if properties have 
   changed. 
      </t>
    </section>
    
    <section title="Including error response bodies">
      <t>
   HTTP and WebDAV did not use the bodies of most error responses for 
   machine-parsable information until DeltaV introduced a mechanism to 
   include more specific information in the body of an error response 
   (section 1.6 of <xref target="RFC3253"/>). The mechanism is appropriate to use with 
   any error response that may take a body but does not already have a 
   body defined. The mechanism is particularly appropriate when a 
   status code can mean many things (for example, 400 Bad Request can 
   mean required headers are missing, headers are incorrectly 
   formatted, or much more).  
      </t>
      <t>
   This mechanism does not take the place of using a correct numeric 
   error code as defined here or in HTTP, because the client MUST 
   always be able to take a reasonable course of action based only on 
   the numeric error.  However, it does remove the need to define new 
   numeric error codes, avoiding the confusion of who is allowed to 
   define such new codes. The codes used in this mechanism are XML 
   elements in a namespace, so naturally any group defining a new error 
   code can use their own namespace. As always, the "DAV:" namespace is 
   reserved for use by IETF-chartered WebDAV working groups. 
      </t>
      <t>
   A server supporting "bis" SHOULD include a specific XML error code 
   in a "DAV:error" response body element, when a specific XML error 
   code is defined in this document. The DAV:error element may 
   contain multiple elements describing specific errors. For error 
   conditions not specified in this document, the server MAY simply 
   choose an appropriate numeric status and leave the response body 
   blank. 
      </t>
      <figure>
        <artwork><![CDATA[
     HTTP/1.1 403 Forbidden 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
    
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:error xmlns:D="DAV:"> 
       <D:forbid-external-entities/> 
     </D:error> 
        ]]></artwork>
      </figure>
      <t>
   In this specification, both the numeric and the XML error code are 
   defined for some failure situations, in which case the XML error 
   code must have the "DAV:" namespace, appear in the "error" root 
   element, and be returned in a body with the numeric error code 
   specified. 
      </t>
    </section>
  </section>
  
  <section title="PROPFIND" anchor="PROPFIND">
    <t>     
   The PROPFIND method retrieves properties defined on the resource 
   identified by the Request-URI, if the resource does not have any 
   internal members, or on the resource identified by the Request-URI 
   and potentially its member resources, if the resource is a 
   collection that has internal member URLs.  All DAV compliant 
   resources MUST support the PROPFIND method and the propfind XML 
   element (<xref target="propfind-element"/>) along with all XML elements defined for use 
   with that element. 
    </t>
    <t>
   A client may submit a Depth header with a value of "0", "1", or 
   "infinity" with a PROPFIND on a collection resource.  Servers MUST 
   support the "0", "1" and "infinity" behaviors on WebDAV-compliant 
   resources. By default, the PROPFIND method without a Depth header 
   MUST act as if a "Depth: infinity" header was included. 
    </t>
    <t>
   A client may submit a propfind XML element in the body of the 
   request method describing what information is being requested.  It 
   is possible to: 
    </t>
    <t><list style="symbols">
      <t>Request particular property values, by naming the properties 
     desired within the 'prop' element (the ordering of properties in 
     here MAY be ignored by server) </t>
      <t> Request all dead property values, by using 'dead-props' element.  
     This can be combined with retrieving specific live properties 
     named as above.  Servers advertising support for RFC2518bis MUST 
     support this feature. </t>
      <t>Request property values for those properties defined in this 
     specification plus dead properties, by using 'allprop' element </t>
      <t>Request a list of names of all the properties defined on the 
     resource, by using the 'propname' element.  </t>
    </list></t>
    <t>
   A client may choose not to submit a request body.  An empty PROPFIND 
   request body MUST be treated as if it were an 'allprop' request.   
    </t>
    <t>
   Note that 'allprop' does not return values for all live properties. 
   WebDAV servers increasingly have expensively-calculated or lengthy 
   properties (see <xref target="RFC3253"/> and 
   <xref target="RFC3744"/>) 
   and do not return all properties already.  Instead, WebDAV clients 
   can use propname requests to discover what live properties exist, 
   and request named properties when retrieving values.  A WebDAV 
   server MAY omit certain live properties from other specifications 
   when responding to an allprop request from an older client, and MAY 
   return only custom (dead) properties and those defined in this 
   specification. 
    </t>
    <t>
   All servers MUST support returning a response of content type 
   text/xml or application/xml that contains a multistatus XML element 
   that describes the results of the attempts to retrieve the various 
   properties.  
    </t>
    <t>
   If there is an error retrieving a property then a proper error 
   result MUST be included in the response.  A request to retrieve the 
   value of a property which does not exist is an error and MUST be 
   noted, if the response uses a multistatus XML element, with a 
   response XML element which contains a 404 (Not Found) status value. 
    </t>
    <t>
   Consequently, the multistatus XML element for a collection resource 
   with member URLs MUST include a response XML element for each member 
   URL of the collection, to whatever depth was requested. Each 
   response XML element MUST contain an href XML element that gives the 
   URL of the resource on which the properties in the prop XML element 
   are defined.  Results for a PROPFIND on a collection 
   resource with internal member URLs are returned as a flat list whose 
   order of entries is not significant. 
    </t>
    <t>
   Properties may be subject to access control. In the case of allprop 
   and propname, if a principal does not have the right to know whether 
   a particular property exists then the property MAY be silently 
   excluded from the response. 
    </t>
    <t>
   The results of this method SHOULD NOT be cached. 
    </t>

    <section title="PROPFIND status codes">
      <t>A server MAY fail an entire PROPFIND request with an appropriate status code and
        MAY redirect the entire request. In addition, the following error codes are
        specifically defined for PROPFIND requests:
      </t>
      
      <t>
   403 Forbidden  - A server MAY reject all 
   PROPFIND requests on collections with depth header of "Infinity", in 
   which case it SHOULD use this error with the element 'propfind-infinite-depth-forbidden' 
   inside the error body. 
      </t>

    </section>
    
    <section title="Status codes for use with 207 (Multi-Status)" anchor="PROPFIND-multistatus">
      <t>
   The following status codes
   are defined for use within the PROPFIND Multi-Status response:
      </t>

      <t><list>
    <t>200 OK - A property exists and/or its value is successfully returned.</t>
    
    <t>401 Unauthorized - The property cannot be viewed without appropriate authorization.</t>
    
    <t>403 Forbidden - The property cannot be viewed regardless of authentication.</t>
    
    <t>404 Not Found - The property does not exist.</t>

    </list></t>
    </section>
    
    <section title="Example - Retrieving Named Properties">
      <figure>
        <artwork><![CDATA[
 >>Request 
  
   PROPFIND  /file HTTP/1.1 
   Host: www.example.com 
   Content-type: text/xml; charset="utf-8" 
   Content-Length: xxxx 
    
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:propfind xmlns:D="DAV:"> 
    <D:prop xmlns:R="http://www.example.com/boxschema/"> 
      <R:bigbox/> 
      <R:author/> 
      <R:DingALing/> 
      <R:Random/> 
    </D:prop> 
   </D:propfind> 
  
 >>Response 
  
   HTTP/1.1 207 Multi-Status 
   Content-Type: text/xml; charset="utf-8" 
   Content-Length: xxxx 
    
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:multistatus xmlns:D="DAV:"> 
    <D:response xmlns:R="http://www.example.com/boxschema/"> 
      <D:href>http://www.example.com/file</D:href> 
      <D:propstat> 
        <D:prop> 
          <R:bigbox> 
            <R:BoxType>Box type A</R:BoxType> 
          </R:bigbox> 
          <R:author> 
            <R:Name>J.J. Johnson</R:Name> 
          </R:author> 
        </D:prop> 
        <D:status>HTTP/1.1 200 OK</D:status> 
      </D:propstat> 
      <D:propstat> 
        <D:prop><R:DingALing/><R:Random/></D:prop> 
        <D:status>HTTP/1.1 403 Forbidden</D:status> 
        <D:responsedescription> The user does not have access to the 
   DingALing property. 
        </D:responsedescription> 
      </D:propstat> 
    </D:response> 
    <D:responsedescription> There has been an access violation error.
    </D:responsedescription> 
   </D:multistatus> 
        ]]></artwork>
      </figure>
      <t>
   In this example, PROPFIND is executed on a non-collection resource 
   http://www.example.com/file.  The propfind XML element specifies the 
   name of four properties whose values are being requested. In this 
   case only two properties were returned, since the principal issuing 
   the request did not have sufficient access rights to see the third 
   and fourth properties. 
      </t>
    </section>
    
    <section title="Example - Retrieving Named and Dead Properties">
    
      <figure>
        <artwork><![CDATA[
   >>Request 
    
     PROPFIND /mycol/ HTTP/1.1 
     Host: www.example.com 
     Depth: 1 
     Content-type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:propfind xmlns:D="DAV:"> 
      <D:prop> 
        <D:creationdate/> 
        <D:getlastmodified/> 
      </D:prop> 
      <D:dead-props/> 
     </D:propfind> 
        ]]></artwork>
      </figure>
      <t>
   In this example, PROPFIND is executed on a collection resource 
   http://www.example.com/mycol/.  The client requests the values of 
   two specific live properties plus all dead properties (names and 
   values). The response is not shown. 
      </t>
    </section>
    
    <section title="Example - Using propname to Retrieve all Property Names">
    
      <figure>
        <artwork><![CDATA[
   >>Request 
     PROPFIND  /container/ HTTP/1.1 
     Host: www.example.com 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <propfind xmlns="DAV:"> 
      <propname/> 
     </propfind> 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <multistatus xmlns="DAV:"> 
      <response> 
        <href>http://www.example.com/container/</href> 
        <propstat> 
          <prop xmlns:R="http://www.example.com/boxschema/"> 
            <R:bigbox/> 
            <R:author/> 
            <creationdate/> 
            <displayname/> 
            <resourcetype/> 
            <supportedlock/> 
          </prop> 
          <status>HTTP/1.1 200 OK</status> 
        </propstat> 
      </response> 
      <response> 
        <href>http://www.example.com/container/front.html</href> 
        <propstat> 
          <prop xmlns:R="http://www.example.com/boxschema/"> 
            <R:bigbox/> 
            <creationdate/> 
            <displayname/> 
            <getcontentlength/> 
            <getcontenttype/> 
            <getetag/> 
            <getlastmodified/> 
            <resourcetype/> 
            <supportedlock/> 
          </prop> 
          <status>HTTP/1.1 200 OK</status> 
        </propstat> 
      </response> 
     </multistatus> 
        ]]></artwork>
      </figure>

      <t>
   In this example, PROPFIND is invoked on the collection resource 
   http://www.example.com/container/, with a propfind XML element 
   containing the propname XML element, meaning the name of all 
   properties should be returned.  Since no Depth header is present, it 
   assumes its default value of "infinity", meaning the name of the 
   properties on the collection and all its descendents should be 
   returned. 
      </t>
      <t>
   Consistent with the previous example, resource 
   http://www.example.com/container/ has six properties defined on it: 
   bigbox and author in the "http://www.example.com/boxschema/" 
   namespace, and creationdate, displayname, resourcetype, and 
   supportedlock in the "DAV:" namespace.   
      </t>
      <t>
   The resource http://www.example.com/container/index.html, a member 
   of the "container" collection, has nine properties defined on it, 
   bigbox in the "http://www.example.com/boxschema/" namespace and, 
   creationdate, displayname, getcontentlength, getcontenttype, 
   getetag, getlastmodified, resourcetype, and supportedlock in the 
   "DAV:" namespace. 
      </t>
      <t>
   This example also demonstrates the use of XML namespace scoping and 
   the default namespace.  Since the "xmlns" attribute does not contain 
   a prefix, the namespace applies by default to all enclosed elements.  
   Hence, all elements which do not explicitly state the namespace to 
   which they belong are members of the "DAV:" namespace. 
      </t>
    </section>

  </section>
  
  <section title="PROPPATCH">
    <t>
   The PROPPATCH method processes instructions specified in the request 
   body to set and/or remove properties defined on the resource 
   identified by the Request-URI. 
    </t>
    <t>
   All DAV compliant resources MUST support the PROPPATCH method and 
   MUST process instructions that are specified using the 
   propertyupdate, set, and remove XML elements.  Execution of the 
   directives in this method is, of course, subject to access control 
   constraints.  DAV compliant resources SHOULD support the setting of 
   arbitrary dead properties. 
    </t>
    <t>
   The request message body of a PROPPATCH method MUST contain the 
   propertyupdate XML element.  Instruction processing MUST occur in 
   document order (an exception to the normal rule that ordering is 
   irrelevant). Instructions MUST either all be executed or none 
   executed. Thus if any error occurs during processing all executed 
   instructions MUST be undone and a proper error result returned. 
   Instruction processing details can be found in the definition of the 
   set and remove instructions in sections 13.23 and section 13.24. 
    </t>
    
    <section title="Status Codes for use with 207 (Multi-Status)" anchor="PROPPATCH-status">
      <t>
   The following are examples of response codes one would expect to be 
   used in a 207 (Multi-Status) response for this method.  Note, 
   however, that unless explicitly prohibited any 2/3/4/5xx series 
   response code may be used in a 207 (Multi-Status) response. 
      </t>
      <t>
   200 (OK) - The command succeeded.  As there can be a mixture of sets 
   and removes in a body, a 201 (Created) seems inappropriate. 
      </t>
      <t>
   403 (Forbidden) - The client, for reasons the server chooses not to 
   specify, cannot alter one of the properties. 
      </t>
      <t>
   403 (Forbidden): The client has attempted to set a read-only
   property, such as getetag.  If returning this error, the server
   SHOULD use 'read-only-property' inside the response body.
      </t>
      <t>
   409 (Conflict) - The client has provided a value whose semantics are 
   not appropriate for the property.   
      </t>
      <t>
   423 (Locked) - The specified resource is locked and the client 
   either is not a lock owner or the lock type requires a lock token to 
   be submitted and the client did not submit it. This response SHOULD
   contain the 'missing-lock-token' precondition element.
      </t>
      <t>
   424 (Failed Dependency) - The property change could not be made because
   of another property change that failed.
      </t>
      <t>
   507 (Insufficient Storage) - The server did not have sufficient 
   space to record the property. 
      </t>
    </section>
    
    <section title="Example - PROPPATCH">
    
      <figure>
        <artwork><![CDATA[
   >>Request 
    
     PROPPATCH /bar.html HTTP/1.1 
     Host: www.example.com 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:propertyupdate xmlns:D="DAV:"   
     xmlns:Z="http://www.w3.com/standards/z39.50/"> 
      <D:set> 
        <D:prop> 
          <Z:authors> 
            <Z:Author>Jim Whitehead</Z:Author> 
            <Z:Author>Roy Fielding</Z:Author> 
          </Z:authors> 
        </D:prop> 
      </D:set> 
      <D:remove> 
        <D:prop><Z:Copyright-Owner/></D:prop> 
      </D:remove> 
     </D:propertyupdate> 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:multistatus xmlns:D="DAV:" 
     xmlns:Z="http://www.w3.com/standards/z39.50"> 
      <D:response> 
        <D:href>http://www.example.com/bar.html</D:href> 
        <D:propstat> 
          <D:prop><Z:Authors/></D:prop> 
          <D:status>HTTP/1.1 424 Failed Dependency</D:status> 
        </D:propstat> 
        <D:propstat> 
          <D:prop><Z:Copyright-Owner/></D:prop> 
          <D:status>HTTP/1.1 409 Conflict</D:status> 
        </D:propstat> 
        <D:responsedescription> Copyright Owner can not be deleted or 
     altered.</D:responsedescription> 
      </D:response> 
     </D:multistatus> 
        ]]></artwork>
      </figure>
      <t>
   In this example, the client requests the server to set the value of 
   the "Authors" property in the "http://www.w3.com/standards/z39.50/" 
   namespace, and to remove the property "Copyright-Owner" in the 
   "http://www.w3.com/standards/z39.50/" namespace.  Since the 
   Copyright-Owner property could not be removed, no property 
   modifications occur.  The 424 (Failed Dependency) status code for 
   the Authors property indicates this action would have succeeded if 
   it were not for the conflict with removing the Copyright-Owner 
   property. 
      </t>
    </section>
  </section>
  
  <section title="MKCOL Method">
    <t>
   The MKCOL method is used to create a new collection. All WebDAV 
   compliant resources MUST support the MKCOL method. 
    </t>
    <t>
   MKCOL creates a new collection resource at the location specified by 
   the Request-URI.  If the resource identified by the Request-URI is 
   non-null then the MKCOL MUST fail.  During MKCOL processing, a 
   server MUST make the Request-URI a member of its parent collection, 
   unless the Request-URI is "/".  If no such ancestor exists, the 
   method MUST fail.  When the MKCOL operation creates a new collection 
   resource, all ancestors MUST already exist, or the method MUST fail 
   with a 409 (Conflict) status code.  For example, if a request to 
   create collection /a/b/c/d/ is made, and /a/b/c/ does not exist, the 
   request must fail. 
    </t>
    <t>
   When MKCOL is invoked without a request body, the newly created 
   collection SHOULD have no members. 
    </t>
    <t>
   A MKCOL request message may contain a message body.  The precise behavior of 
   a MKCOL request when the body is present is undefined, but limited to creating 
   collections, members of a collection, bodies of members and 
   properties on the collections or members.  If the server receives a 
   MKCOL request entity type it does not support or understand it MUST 
   respond with a 415 (Unsupported Media Type) status code.  If the 
   server decides to reject the request based on the presence of an 
   entity or the type of an entity, it should use the 415 (Unsupported 
   Media Type) status code. 
    </t>

    <section title="MKCOL Status Codes">
      <t>
   Responses from a MKCOL request MUST NOT be cached as MKCOL has non-idempotent
   semantics. 
      </t>
      <t>
   201 (Created) - The collection was created. 
      </t>
      <t>
   403 (Forbidden) - This indicates at least one of two conditions: 1) 
   the server does not allow the creation of collections at the given 
   location in its namespace, or 2) the parent collection of the 
   Request-URI exists but cannot accept members. 
      </t>
      <t>
   405 (Method Not Allowed) - MKCOL can only be executed on an unmapped 
   URL. 
      </t>
      <t>
   409 (Conflict) - A collection cannot be made at the Request-URI 
   until one or more intermediate collections have been created.  The 
   server MUST NOT create those intermediate collections automatically. 
      </t>
      <t>
   415 (Unsupported Media Type) - The server does not support the 
   request type of the body. 
      </t>
      <t>
   507 (Insufficient Storage) - The resource does not have sufficient 
   space to record the state of the resource after the execution of 
   this method. 
      </t>
    </section>
    
    <section title="Example - MKCOL">
      <t>
   This example creates a collection called /webdisc/xfiles/ on the 
   server www.example.com. 
      </t>
      
      <figure>
        <artwork><![CDATA[
   >>Request 
    
     MKCOL /webdisc/xfiles/ HTTP/1.1 
     Host: www.example.com 
    
   >>Response 
    
     HTTP/1.1 201 Created 
      
        ]]></artwork>
      </figure>
    </section>
  </section>

  <section title="GET, HEAD for Collections">
    <t>
   The semantics of GET are unchanged when applied to a collection, 
   since GET is defined as, "retrieve whatever information (in the form 
   of an entity) is identified by the Request-URI" [RFC2616].  GET when 
   applied to a collection may return the contents of an "index.html" 
   resource, a human-readable view of the contents of the collection, 
   or something else altogether. Hence it is possible that the result 
   of a GET on a collection will bear no correlation to the membership 
   of the collection. 
    </t>
    <t>
   Similarly, since the definition of HEAD is a GET without a response 
   message body, the semantics of HEAD are unmodified when applied to 
   collection resources. 
    </t>
  </section>
  
  <section title="POST for Collections">
    <t>
   Since by definition the actual function performed by POST is 
   determined by the server and often depends on the particular 
   resource, the behavior of POST when applied to collections cannot be 
   meaningfully modified because it is largely undefined.  Thus the 
   semantics of POST are unmodified when applied to a collection. 
    </t>
  </section>
  
  <section title="DELETE"> 
    <t>
   Locks rooted on a resource MUST be destroyed in a successful DELETE of
   that resource.
    </t>
    <section title="DELETE for Non-Collection Resources">
      <t>
   When a client issues a DELETE request to a Request-URI mapping to a 
   non-collection resource, if the operation is successful the server 
   MUST remove that mapping.  Thus, after a successful DELETE operation 
   (and in the absence of other actions) a subsequent GET/HEAD/PROPFIND 
   request to the target Request-URI MUST return 404 (Not Found). 
      </t>
      
    </section>
    <section title="DELETE for Collections" anchor="delete-collections">
      <t>
   The DELETE method on a collection MUST act as if a "Depth: infinity" 
   header was used on it.  A client MUST NOT submit a Depth header with 
   a DELETE on a collection with any value but infinity. 
      </t>
      <t>
   DELETE instructs that the collection specified in the Request-URI 
   and all resources identified by its internal member URLs are to be 
   deleted. 
      </t>
      <t>
   If any resource identified by a member URL cannot be deleted then 
   all of the member's ancestors MUST NOT be deleted, so as to maintain 
   namespace consistency.        
      </t>
      <t>
   Any headers included with DELETE MUST be applied in processing every 
   resource to be deleted. 
      </t>
      <t>
   When the DELETE method has completed processing it MUST result in a 
   consistent namespace. 
      </t>
      <t>
   If an error occurs deleting an internal resource (a resource other 
   than the resource identified in the Request-URI) then the response 
   can be a 207 (Multi-Status). Multi-Status is used here to indicate 
   which internal resources could NOT be deleted, including an error 
   code which should help the client understand which resources caused 
   the failure.  For example, the Multi-Status body could include a 
   response with status 423 (Locked) if an internal resource was 
   locked.   
      </t>
      <t>
   The server MAY return a 4xx status response, rather than a Multi-Status,
   if the request failed. 
      </t>
      <t>
   424 (Failed Dependency) errors SHOULD NOT be in the 207 (Multi-Status)
   response for DELETE.  They can be safely left out because the client will know 
   that the ancestors of a resource could not be deleted when the 
   client receives an error for the ancestor's progeny.  Additionally 
   204 (No Content) errors SHOULD NOT be returned in the 207 (Multi-Status).  The
   reason for this prohibition is that 204 (No Content) 
   is the default success code. 
      </t>
    </section>
    
    <section title="Example - DELETE">
      <figure>
        <artwork><![CDATA[
    
   >>Request 
    
     DELETE  /container/ HTTP/1.1 
     Host: www.example.com 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <d:multistatus xmlns:d="DAV:"> 
      <d:response> 
        <d:href>http://www.example.com/container/resource3</d:href> 
        <d:status>HTTP/1.1 423 Locked</d:status> 
      </d:response> 
     </d:multistatus> 
        ]]></artwork>
      </figure>

      <t>
   In this example the attempt to delete 
   http://www.example.com/container/resource3 failed because it is 
   locked, and no lock token was submitted with the request. 
   Consequently, the attempt to delete 
   http://www.example.com/container/ also failed. Thus the client knows 
   that the attempt to delete http://www.example.com/container/ must 
   have also failed since the parent can not be deleted unless its 
   child has also been deleted.  Even though a Depth header has not 
   been included, a depth of infinity is assumed because the method is 
   on a collection. 
      </t>
    </section>
  </section>
  
  <section title="PUT">
  
    <section title="PUT for Non-Collection Resources">
      <t>
   A PUT performed on an existing resource replaces the GET response 
   entity of the resource.  Properties defined on the resource may be 
   recomputed during PUT processing but are not otherwise affected.  
   For example, if a server recognizes the content type of the request 
   body, it may be able to automatically extract information that could 
   be profitably exposed as properties. 
      </t>
      <t>
   A PUT that would result in the creation of a resource without an 
   appropriately scoped parent collection MUST fail with a 409 
   (Conflict). 
      </t>
    </section>
    
    <section title="PUT for Collections">
      <t>
   As defined in <xref target="RFC2616"/>, the "PUT method requests that the enclosed 
   entity be stored under the supplied Request-URI."  Since submission 
   of an entity representing a collection would implicitly encode 
   creation and deletion of resources, this specification intentionally 
   does not define a transmission format for creating a collection 
   using PUT.  Instead, the MKCOL method is defined to create 
   collections.  A PUT request to an existing collection MAY be treated as an
        error (405 Method Not Allowed).
     </t>
    </section>
    
  </section>
  
  <section title="COPY"> 
     <t>
   The COPY method creates a duplicate of the source resource
   identified by the Request-URI, in the destination resource 
   identified by the URI in the Destination header.  The Destination 
   header MUST be present.  The exact behavior of the COPY method 
   depends on the type of the source resource.  The state of the 
       resource to be copied is fixed at the point the server begins processing
       the COPY request.
    </t>
    <t>
   All WebDAV compliant resources MUST support the COPY method.  
   However, support for the COPY method does not guarantee the ability 
   to copy a resource. For example, separate programs may control 
   resources on the same server.  As a result, it may not be possible 
   to copy a resource to a location that appears to be on the same 
   server. 
    </t>
    <section title="COPY for Non-collection Resources">
      <t>
   When the source resource is not a collection the result of the COPY 
   method is the creation of a new resource at the destination whose 
   state and behavior match that of the source resource as closely as 
   possible.  Since the environment at the destination may be different 
   than at the source due to factors outside the scope of control of 
   the server, such as the absence of resources required for correct 
   operation, it may not be possible to completely duplicate the 
   behavior of the resource at the destination. Subsequent alterations 
   to the destination resource will not modify the source resource.  
   Subsequent alterations to the source resource will not modify the 
   destination resource. 
      </t>
    </section>
    
    <section title="COPY for Properties" anchor="copy-properties">
      <t>
   After a successful COPY invocation, all dead properties on the 
   source resource MUST be duplicated on the destination resource, 
   along with all properties as appropriate.  Live properties described 
   in this document SHOULD be duplicated as identically behaving live 
   properties at the destination resource, but not necessarily with the 
   same values.  If a property cannot be copied live, then its value 
   MUST be duplicated, octet-for-octet, in an identically named, dead 
   property on the destination resource. 
      </t>
      <t>
   A COPY operation creates a new resource, much like a PUT operation 
   does.  Live properties which are related to resource creation (such 
   as creationdate) should have their values set accordingly. 
      </t>
    </section>
    
    <section title="COPY for Collections" anchor="copy-collections">
      <t>
   The COPY method on a collection without a Depth header MUST act as 
   if a Depth header with value "infinity" was included.  A client may 
   submit a Depth header on a COPY on a collection with a value of "0" 
   or "infinity".  Servers MUST support the "0" and "infinity" Depth 
   header behaviors on WebDAV-compliant resources. 
      </t>
      <t>
   A COPY of depth infinity instructs that the collection resource 
   identified by the Request-URI is to be copied to the location 
   identified by the URI in the Destination header, and all its 
   internal member resources are to be copied to a location relative to 
   it, recursively through all levels of the collection hierarchy. 
   Servers should of course avoid infinite recursion, and can do so by
   copying the source resource as it existed at the point where processing
        started.
      </t>
      <t>
   A COPY of "Depth: 0" only instructs that the collection and its 
   properties but not resources identified by its internal member URLs, 
   are to be copied. 
      </t>
      <t>
   Any headers included with a COPY MUST be applied in processing every 
   resource to be copied with the exception of the Destination header. 
      </t>
      <t>
   The Destination header only specifies the destination URI for the 
   Request-URI. When applied to members of the collection identified by 
   the Request-URI the value of Destination is to be modified to 
   reflect the current location in the hierarchy.  So, if the Request-URI 
   is /a/ with Host header value http://example.com/ and the 
   Destination is http://example.com/b/ then when 
   http://example.com/a/c/d is processed it must use a Destination of 
   http://example.com/b/c/d. 
      </t>
   <!-- BZ 57 -->
      <t>
   When the COPY method has completed processing it MUST have created a 
   consistent namespace at the destination (see <xref target="http.url.namespace.model"/> for the 
   definition of namespace consistency).  However, if an error occurs 
   while copying an internal collection, the server MUST NOT copy any 
   resources identified by members of this collection (i.e., the server 
   must skip this subtree), as this would create an inconsistent 
   namespace. After detecting an error, the COPY operation SHOULD try 
   to finish as much of the original copy operation as possible (i.e., 
   the server should still attempt to copy other subtrees and their 
   members, that are not descendents of an error-causing collection).  
      </t>
      <t>
   So, for example, if an infinite depth copy operation is performed on 
   collection /a/, which contains collections /a/b/ and /a/c/, and an 
   error occurs copying /a/b/, an attempt should still be made to copy 
   /a/c/. Similarly, after encountering an error copying a non-collection
   resource as part of an infinite depth copy, the server 
   SHOULD try to finish as much of the original copy operation as 
   possible. 
      </t>
      <t>
   If an error in executing the COPY method occurs with a resource 
   other than the resource identified in the Request-URI then the 
   response MUST be a 207 (Multi-Status), and the URL of the resource 
   causing the failure MUST appear with the specific error.  
      </t>
      <t>
   The 424 (Failed Dependency) status code SHOULD NOT be returned in 
   the 207 (Multi-Status) response from a COPY method.  These responses 
   can be safely omitted because the client will know that the progeny 
   of a resource could not be copied when the client receives an error 
   for the parent.  Additionally 201 (Created)/204 (No Content) status 
   codes SHOULD NOT be returned as values in 207 (Multi-Status) 
   responses from COPY methods.  They, too, can be safely omitted 
   because they are the default success codes. 
      </t>
    </section>
    
    <section title="COPY and the Overwrite Header">
      <t>
   If a resource exists at the destination and the Overwrite header is 
   "T" then prior to performing the copy the server MUST perform a 
   DELETE with "Depth: infinity" on the destination resource.  If the 
   Overwrite header is set to "F" then the operation will fail. (Extensions
        to WebDAV might not follow this rule to the letter but must consider backwards 
        compatibility with clients that expect COPY to work this way.)
      </t>
      <t>Interoperability testing has shown that some clients expect a 
        collection COPY to actually do a merge if a destination collection exists.
        That behavior is appropriate for file system folders but not necessarily 
        for other data objects modelled as collections.  Thus, implementors are
        urged to comply with the standard language above, and leave clients to perform
        a manual merge if that's the expected behavior when copying a collection over
        another collection.
        </t>
    </section>
    
    <section title="Status Codes">
      <t>
   201 (Created) - The source resource was successfully copied.  The 
   copy operation resulted in the creation of a new resource. 
      </t>
      <t>
   204 (No Content) - The source resource was successfully copied to a 
   pre-existing destination resource. 
      </t>
      <t>
   207 (Multi-Status) - Multiple resources were to be affected by the 
   COPY, but errors on some of them prevented the operation from taking 
   place.  Specific error messages, together with the most appropriate 
   of the source and destination URLs, appear in the body of the multi-status
   response. E.g. if a destination resource was locked and could 
   not be overwritten, then the destination resource URL appears with 
   the 423 (Locked) status. 
      </t>
      <t>
   403 (Forbidden) - The operation is forbidden.  Possibly this is 
   because the source and destination resources are the same resource. 
      </t>
      <t>
   409 (Conflict) - A resource cannot be created at the destination 
   until one or more intermediate collections have been created.  The 
   server MUST NOT create those intermediate collections automatically. 
      </t>
      <t>
   412 (Precondition Failed) - A precondition failed, e.g. the 
   Overwrite header is "F" and the state of the destination resource is 
   non-null. 
      </t>
      <t>
   423 (Locked) - The destination resource, or resource within the destination
   collection, was locked. This response SHOULD
   contain the 'missing-lock-token' precondition element.
      </t>
      <t>
   502 (Bad Gateway) - This may occur when the destination is on 
   another server, repository or namespace.  Either the source 
   namespace does not support copying to the destination namespace, or 
   the destination namespace refuses to accept the resource. The client 
   may wish to try GET/PUT and PROPFIND/PROPPATCH instead. 
      </t>
      <t>
   507 (Insufficient Storage) - The destination resource does not have 
   sufficient space to record the state of the resource after the 
   execution of this method. 
      </t>
    </section>
    
    <section title="COPY Examples">
      <t>
   This example shows resource 
   http://www.ics.uci.edu/~fielding/index.html being copied to the 
   location http://www.ics.uci.edu/users/f/fielding/index.html.  The 
   204 (No Content) status code indicates the existing resource at the 
   destination was overwritten. 
      </t>
      <figure>
        <preamble>COPY with Overwrite</preamble>
        <artwork><![CDATA[
   >>Request 
    
     COPY /~fielding/index.html HTTP/1.1 
     Host: www.ics.uci.edu 
     Destination: http://www.ics.uci.edu/users/f/fielding/index.html 
    
   >>Response 
    
     HTTP/1.1 204 No Content 
        ]]></artwork>
      </figure>

      <t>
   The following example shows the same copy operation being performed, 
   but with the Overwrite header set to "F."  A response of 412 
   (Precondition Failed) is returned because the destination resource 
   has a non-null state. 
      </t>
      
      <figure>
        <preamble>COPY with No Overwrite</preamble>
        <artwork><![CDATA[
    
   >>Request 
    
     COPY /~fielding/index.html HTTP/1.1 
     Host: www.ics.uci.edu 
     Destination: http://www.ics.uci.edu/users/f/fielding/index.html 
     Overwrite: F 
     
   >>Response 
    
     HTTP/1.1 412 Precondition Failed 
        ]]></artwork>
      </figure>
     
      <figure>
        <preamble>Example - COPY of a Collection</preamble>
        <artwork><![CDATA[
   >>Request 
    
     COPY /container/ HTTP/1.1 
     Host: www.example.com 
     Destination: http://www.example.com/othercontainer/ 
     Depth: infinity 
      
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
      
     <d:multistatus xmlns:d="DAV:"> 
      <d:response> 
        <d:href>http://www.example.com/othercontainer/R2/</d:href> 
        <d:status>HTTP/1.1 423 Locked</d:status> 
      </d:response> 
     </d:multistatus> 
        ]]></artwork>
      </figure>
      
      <t>
   The Depth header is unnecessary as the default behavior of COPY on a 
   collection is to act as if a "Depth: infinity" header had been 
   submitted.  In this example most of the resources, along with the 
   collection, were copied successfully. However the collection R2 
   failed because the destination R2 is locked.  Because there was an 
   error copying R2, none of R2's members were copied.  However no 
   errors were listed for those members due to the error minimization 
   rules.
      </t>
    </section>
  </section>
    
  <section title="MOVE">
    <t>
   The MOVE operation on a non-collection resource is the logical 
   equivalent of a copy (COPY), followed by consistency maintenance 
   processing, followed by a delete of the source, where all three 
   actions are performed atomically.  The consistency maintenance step 
   allows the server to perform updates caused by the move, such as 
   updating all URLs other than the Request-URI which identify the 
   source resource, to point to the new destination resource.  
   Consequently, the Destination header MUST be present on all MOVE 
   methods and MUST follow all COPY requirements for the COPY part of 
   the MOVE method.  All WebDAV compliant resources MUST support the 
   MOVE method.  However, support for the MOVE method does not 
   guarantee the ability to move a resource to a particular 
   destination.  
    </t>
    <t>
   For example, separate programs may actually control different sets 
   of resources on the same server.  Therefore, it may not be possible 
   to move a resource within a namespace that appears to belong to the 
   same server. 
    </t>
    <t>
   If a resource exists at the destination, the destination resource 
   will be deleted as a side-effect of the MOVE operation, subject to 
   the restrictions of the Overwrite header. 
    </t>
    
    <section title="MOVE for Properties" anchor="move-properties">
      <t>
   Live properties described in this document MUST be moved along with 
   the resource, such that the resource has identically behaving live 
   properties at the destination resource, but not necessarily with the 
   same values.  If the live properties will not work the same way at 
   the destination, the server MUST fail the request (the client can 
   perform COPY then DELETE if it wants a MOVE to work that badly). 
   This can mean that the server reports the live property as "Not 
   Found" if that's the most appropriate behavior for that live 
   property at the destination, as long as the live property is still 
   supported with the same semantics. 
      </t>
      <t>
   MOVE is frequently used by clients to rename a file without changing 
   its parent collection, so it's not appropriate to reset live 
   properties which are set at resource creation. For example, the 
   creationdate property value SHOULD remain the same after a MOVE. 
      </t>
      <t>
   Dead properties must be moved along with the resource. 
      </t>
    </section>
    
    <section title="MOVE for Collections" anchor="move-collections">
      <t>
   A MOVE with "Depth: infinity" instructs that the collection 
   identified by the Request-URI be moved to the address specified in 
   the Destination header, and all resources identified by its internal 
   member URLs are to be moved to locations relative to it, recursively 
   through all levels of the collection hierarchy. 
      </t>
      <t>
   The MOVE method on a collection MUST act as if a "Depth: infinity" 
   header was used on it.  A client MUST NOT submit a Depth header on a 
   MOVE on a collection with any value but "infinity". 
      </t>
      <t>
   Any headers included with MOVE MUST be applied in processing every 
   resource to be moved with the exception of the Destination header. 
   The behavior of the Destination header is the same as given for COPY 
   on collections.  
      </t>
      <t>
   When the MOVE method has completed processing it MUST have created a 
   consistent namespace at both the source and destination (see section 
   5.1 for the definition of namespace consistency). However, if an 
   error occurs while moving an internal collection, the server MUST 
   NOT move any resources identified by members of the failed 
   collection (i.e., the server must skip the error-causing subtree), 
   as this would create an inconsistent namespace. In this case, after 
   detecting the error, the move operation SHOULD try to finish as much 
   of the original move as possible (i.e., the server should still 
   attempt to move other subtrees and the resources identified by their 
   members, that are not descendents of an error-causing collection).  
   So, for example, if an infinite depth move is performed on 
   collection /a/, which contains collections /a/b/ and /a/c/, and an 
   error occurs moving /a/b/, an attempt should still be made to try 
   moving /a/c/. Similarly, after encountering an error moving a non-collection
   resource as part of an infinite depth move, the server 
   SHOULD try to finish as much of the original move operation as 
   possible. 
      </t>
      <t>
   If an error occurs with a resource other than the resource 
   identified in the Request-URI then the response MUST be a 207 
   (Multi-Status), and the errored resource's URL MUST appear with the 
   specific error. 
      </t>
      <t>
   The 424 (Failed Dependency) status code SHOULD NOT be returned in 
   the 207 (Multi-Status) response from a MOVE method.  These errors 
   can be safely omitted because the client will know that the progeny 
   of a resource could not be moved when the client receives an error 
   for the parent.  Additionally 201 (Created)/204 (No Content) 
   responses SHOULD NOT be returned as values in 207 (Multi-Status) 
   responses from a MOVE.  These responses can be safely omitted 
   because they are the default success codes. 
      </t>
      
    </section>
    
    <section title="MOVE and the Overwrite Header">
      <t>
   If a resource exists at the destination and the Overwrite header is 
   "T" then prior to performing the move the server MUST perform a 
   DELETE with "Depth: infinity" on the destination resource.  If the 
   Overwrite header is set to "F" then the operation will fail. 
      </t>
    </section>
    
    <section title="Status Codes">
      <t>
   201 (Created) - The source resource was successfully moved, and a 
   new resource was created at the destination. 
      </t>
      <t>
   204 (No Content) - The source resource was successfully moved to a 
   pre-existing destination resource. 
      </t>
      <t>
   207 (Multi-Status) - Multiple resources were to be affected by the 
   MOVE, but errors on some of them prevented the operation from taking 
   place.  Specific error messages, together with the most appropriate 
   of the source and destination URLs, appear in the body of the multi-status
   response. E.g. if a source resource was locked and could not 
   be moved, then the source resource URL appears with the 423 (Locked) 
   status. 
      </t>
      <t>
   403 (Forbidden) - The source and destination resources are the same. 
      </t>
      <t>
   409 (Conflict) - A resource cannot be created at the destination 
   until one or more intermediate collections have been created.  The 
   server MUST NOT create those intermediate collections automatically. 
   Or, the server was unable to 
   preserve the behavior of the live properties and still move the 
   resource to the destination (see 'live-properties-not-preserved' postcondition).
      </t>
      <t>
   412 (Precondition Failed) - A condition failed, e.g. the Overwrite 
   header is "F" and the state of the destination resource is non-null. 
      </t>
      <t>
   423 (Locked) - The source or the destination resource, or some resource 
   within the source or destination collection, was locked. This response SHOULD
   contain the 'missing-lock-token' precondition element.
      </t>
      <t>
   502 (Bad Gateway) - This may occur when the destination is on 
   another server and the destination server refuses to accept the 
   resource.  This could also occur when the destination is on another 
   sub-section of the same server namespace.
      </t>
    </section>
    
    <section title="Examples">
      <t>
   This example shows resource 
   http://www.ics.uci.edu/~fielding/index.html being moved to the 
   location http://www.ics.uci.edu/users/f/fielding/index.html. The 
   contents of the destination resource would have been overwritten if 
   the destination resource had been non-null.  In this case, since 
   there was nothing at the destination resource, the response code is 
   201 (Created). 
     </t>
     
     <figure>
       <preamble>MOVE of a Non-Collection</preamble>
       <artwork><![CDATA[
   >>Request 
    
     MOVE /~fielding/index.html HTTP/1.1 
     Host: www.ics.uci.edu 
     Destination: http://www.ics.uci.edu/users/f/fielding/index.html 
    
   >>Response 
    
     HTTP/1.1 201 Created 
     Location: http://www.ics.uci.edu/users/f/fielding/index.html 
        ]]></artwork>
      </figure>
      
      <figure>
        <preamble>MOVE of a Collection</preamble>
        <artwork><![CDATA[
   >>Request 
    
     MOVE /container/ HTTP/1.1 
     Host: www.example.com 
     Destination: http://www.example.com/othercontainer/ 
     Overwrite: F 
     If: (<urn:uuid:fe184f2e-6eec-41d0-c765-01adc56e6bb4>) 
         (<urn:uuid:e454f3f3-acdc-452a-56c7-00a5c91e4b77>) 

   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <d:multistatus xmlns:d='DAV:'> 
      <d:response> 
        <d:href>http://www.example.com/othercontainer/C2/</d:href> 
        <d:status>HTTP/1.1 423 Locked</d:status> 
      </d:response> 
     </d:multistatus> 
        ]]></artwork>
        <postamble>      
   In this example the client has submitted a number of lock tokens 
   with the request.  A lock token will need to be submitted for every 
   resource, both source and destination, anywhere in the scope of the 
   method, that is locked.  In this case the proper lock token was not 
   submitted for the destination 
   http://www.example.com/othercontainer/C2/. This means that the 
   resource /container/C2/ could not be moved.  Because there was an 
   error moving /container/C2/, none of /container/C2's members were 
   moved.  However no errors were listed for those members due to the 
   error minimization rules.  User agent authentication has previously 
   occurred via a mechanism outside the scope of the HTTP protocol, in 
   an underlying transport layer. 
        </postamble>
      </figure>
    </section>
  </section>

  <section title="LOCK Method" anchor="LOCK">
    <t>
   The following sections describe the LOCK method, which is used to 
   take out a lock of any access type and to refresh an existing lock.  
   These sections on the LOCK method describe only those semantics that 
   are specific to the LOCK method and are independent of the access 
   type of the lock being requested. 
    </t>
    <t>
   Any resource which supports the LOCK method MUST, at minimum, 
   support the XML request and response formats defined herein. 
    </t>
    <t>
   A LOCK method invocation to an unlocked resource creates a lock on the resource 
   identified by the Request-URI, which 
   becomes the root of the lock.  Lock method requests to create a new 
   lock MUST have a XML request body which contains an owner XML 
   element and other information for this lock request. The server MUST preserve the 
   information provided by the client in the owner field when the lock 
   information is requested.  The LOCK request MAY have a Timeout 
   header. 
    </t>
    <t>
   Clients MUST assume that locks may arbitrarily disappear at any 
   time, regardless of the value given in the Timeout header.  The 
   Timeout header only indicates the behavior of the server if 
   extraordinary circumstances do not occur.  For example, a 
   sufficiently privileged user may remove a lock at any time or the 
   system may crash in such a way that it loses the record of the 
   lock's existence. 
    </t>
    <t>
   When a new lock is created, the LOCK response: </t>
      <t><list style="symbols"><!-- BZ89 -->
        <t>MUST contain a body with the value of the 
        lockdiscovery property in a prop XML element. </t>
        <t>MUST include the Lock-Token response header with the 
        token associated with the new lock.</t>
      </list></t>
    
    <section title="Refreshing Locks">
      <t>
   A lock is refreshed by sending a LOCK request without a request body to the URL
   of a resource within the scope of the lock. This request MUST specify which lock
   to refresh by using the 'Lock-Token' header with a single lock token (only one
   lock may be refreshed at a time). It MAY contain a Timeout header, which a
   server MAY accept to change the duration remaining on the lock to the new value.
   A server MUST ignore the Depth header on a LOCK refresh.
      </t>
      <t>
   If the resource has other (shared) locks, those locks are unaffected 
   by a lock refresh.  Additionally, those locks do not prevent the 
   named lock from being refreshed. 
      </t>
      <t>
   Note that in RFC2518, clients were indicated through the example in 
   the text to use the If header to specify what lock to refresh 
   (rather than the Lock-Token header). Servers are encouraged to 
   continue to support this as well as the Lock-Token header. 
      </t>
     <t> 
   Note that the 
   Lock-Token header is not be returned in the response for a 
   successful refresh LOCK request, but the LOCK response body MUST
       contain the new value for the lockdiscovery body. 
    </t>
    </section>

    <section title="Depth and Locking">
      <t>
   The Depth header may be used with the LOCK method.  Values other 
   than 0 or infinity MUST NOT be used with the Depth header on a LOCK 
   method.  All resources that support the LOCK method MUST support the 
   Depth header. 
      </t>
      <t>
   A Depth header of value 0 means to just lock the resource specified 
   by the Request-URI. 
      </t>
      <t>
   If the Depth header is set to infinity then the resource specified 
   in the Request-URI along with all its internal members, all the way 
   down the hierarchy, are to be locked.  A successful result MUST 
   return a single lock token which represents all the resources that 
   have been locked.  If an UNLOCK is successfully executed on this 
   token, all associated resources are unlocked.  If the lock cannot be 
   granted to all resources, a 207 (Multi-Status) status code MUST be 
   returned with a response entity body containing a multistatus XML 
   element describing which resource(s) prevented the lock from being 
   granted.  Hence, partial success is not an option.  Either the 
   entire hierarchy is locked or no resources are locked. 
      </t>
      <t>
   If no Depth header is submitted on a LOCK request then the request 
   MUST act as if a "Depth:infinity" had been submitted. 
      </t>
    </section>
    
    <section title="Locking Unmapped URLs">
      <t>
   A successful LOCK method MUST result in the creation of an empty 
   resource which is locked (and which is not a collection), when a 
   resource did not previously exist at that URL.   Later on, the lock 
   may go away but the empty resource remains.  Empty resources MUST 
   then appear in PROPFIND responses including that URL in the response 
   scope.  A server MUST respond successfully to a GET request to an 
   empty resource, either by using a 204 No Content response, or by 
   using 200 OK with a Content-Length header indicating zero length and 
   no Content-Type. 
     </t>
    </section>
    
    <section title="Lock Compatibility Table">
    
      <figure>
        <preamble>
    
   The table below describes the behavior that occurs when a lock 
   request is made on a resource. 
       </preamble>
       <artwork>
    
     Current State   Shared Lock Request   Exclusive Lock Request 
   ----------------------------------------------------------------
     None            True                  True 
     Shared Lock     True                  False 
     Exclusive Lock  False                 False* 
    
       </artwork>
       <postamble>
   Legend: True = lock may be granted.  False = lock MUST NOT be 
   granted. *=It is illegal for a principal to request the same lock 
   twice. 
       </postamble>
     </figure>
     
     <t>
    
   The current lock state of a resource is given in the leftmost 
   column, and lock requests are listed in the first row.  The 
   intersection of a row and column gives the result of a lock request.  
   For example, if a shared lock is held on a resource, and an 
   exclusive lock is requested, the table entry is "false", indicating 
   the lock must not be granted. 
      </t>
    </section>
    
    <section title="LOCK responses">
      <t>
   200 (OK) - The lock request succeeded and the value of the 
   lockdiscovery property is included in the body. 
      </t>
      <t>
   409 (Conflict) - A resource cannot be created at the destination 
   until one or more intermediate collections have been created.  The 
   server MUST NOT create those intermediate collections automatically. 
      </t>
      <t>
   423 (Locked) - The resource is locked already.  For consistency's sake, 
        this response SHOULD
   contain the 'missing-lock-token' precondition element.
      </t>
      <!-- BZ88 -->
      <t>
   400 (Bad Request), with 'request-uri-must-match-lock-token' precondition - 
   The LOCK request was made with a Lock-Token header, indicating that the 
   client wishes to refresh the given lock.  However, the Request-URI did not
   fall within the scope of the lock identified by the token.  The lock may have
   a scope that does not include the Request-URI, or the lock could have disappeared,
   or the token may be invalid.
      </t>
      <t>
      424 (Failed Dependency) - This may appear inside a 207 response to a LOCK
      request, to indicate that a resource could not be locked because of a failure
      on another resource.
      </t>
      
    </section>
    
    <section title="Example - Simple Lock Request">
      <figure>
      <!-- BZ 30 -->
        <artwork><![CDATA[
 >>Request 
  
   LOCK /workspace/webdav/proposal.doc HTTP/1.1 
   Host: example.com 
   Timeout: Infinite, Second-4100000000 
   Content-Type: text/xml; charset="utf-8" 
   Content-Length: xxxx 
   Authorization: Digest username="ejw", 
      realm="[email-masked]", nonce="...", 
      uri="/workspace/webdav/proposal.doc", 
      response="...", opaque="..." 
    
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:lockinfo xmlns:D='DAV:'> 
    <D:lockscope><D:exclusive/></D:lockscope> 
    <D:locktype><D:write/></D:locktype> 
    <D:owner> 
      <D:href>http://www.ics.uci.edu/~ejw/contact.html</D:href> 
    </D:owner> 
   </D:lockinfo> 
  
 >>Response 
  
   HTTP/1.1 200 OK 
   Lock-Token: <urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4> 
   Content-Type: text/xml; charset="utf-8" 
   Content-Length: xxxx 
    
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:prop xmlns:D="DAV:"> 
    <D:lockdiscovery> 
      <D:activelock> 
        <D:locktype><D:write/></D:locktype> 
        <D:lockscope><D:exclusive/></D:lockscope> 
        <D:depth>infinity</D:depth> 
        <D:owner> 
          <D:href> 
            http://www.ics.uci.edu/~ejw/contact.html 
          </D:href> 
        </D:owner> 
        <D:timeout>Second-604800</D:timeout> 
        <D:locktoken> 
          <D:href
>urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4</D:href> 
        </D:locktoken> 
        <D:lockroot> 
          <D:href
          >http://example.com/workspace/webdav/proposal.doc<
          /D:href> 
        </D:lockroot> 
      </D:activelock> 
    </D:lockdiscovery> 
   </D:prop> 
]]>
        </artwork>
      </figure>
          <t>
   This example shows the successful creation of an exclusive write 
   lock on resource http://example.com/workspace/webdav/proposal.doc.  
   The resource http://www.ics.uci.edu/~ejw/contact.html contains 
   contact information for the owner of the lock.  The server has an 
   activity-based timeout policy in place on this resource, which 
   causes the lock to automatically be removed after 1 week (604800 
   seconds).  Note that the nonce, response, and opaque fields have not 
   been calculated in the Authorization request header. 
          </t>
          <t>
   Note that the locktoken and lockroot href elements would not contain 
   any whitespace.  The line return appearing in this document is only 
   for formatting. 
          </t>
    </section>
    
    <section title="Example - Refreshing a Write Lock">
      <figure>
        <artwork><![CDATA[
 >>Request 
  
   LOCK /workspace/webdav/proposal.doc HTTP/1.1 
   Host: example.com 
   Timeout: Infinite, Second-4100000000 
   Lock-Token: <urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4> 
   Authorization: Digest username="ejw", 
      realm="[email-masked]", nonce="...", 
      uri="/workspace/webdav/proposal.doc", 
      response="...", opaque="..." 
  
 >>Response 
  
   HTTP/1.1 200 OK 
   Content-Type: text/xml; charset="utf-8" 
   Content-Length: xxxx 
    
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:prop xmlns:D="DAV:"> 
    <D:lockdiscovery> 
      <D:activelock> 
        <D:locktype><D:write/></D:locktype> 
        <D:lockscope><D:exclusive/></D:lockscope> 
        <D:depth>infinity</D:depth> 
        <D:owner> 
          <D:href> 
          http://www.ics.uci.edu/~ejw/contact.html 
          </D:href> 
        </D:owner> 
        <D:timeout>Second-604800</D:timeout> 
        <D:locktoken> 
          <D:href>urn:uuid:e71d4fae-5dec-22d6-fea5-00a0c91e6be4<
          /D:href> 
        </D:locktoken> 
        <D:lockroot> 
          <D:href
          >http://example.com/workspace/webdav/proposal.doc<
          /D:href> 
        </D:lockroot> 
      </D:activelock> 
    </D:lockdiscovery> 
   </D:prop> 
]]>
        </artwork>
        <postamble>
   This request would refresh the lock, attempting to reset the timeout 
   to the new value specified in the timeout header.  Notice that the 
   client asked for an infinite time out but the server choose to 
   ignore the request. In this example, the nonce, response, and opaque 
   fields have not been calculated in the Authorization request header. 
        </postamble>        
      </figure>
    </section>
    
    <section title="Example - Multi-Resource Lock Request">
      <figure>
        <artwork><![CDATA[
   >>Request 
    
     LOCK /webdav/ HTTP/1.1 
     Host: example.com 
     Timeout: Infinite, Second-4100000000 
     Depth: infinity 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
     Authorization: Digest username="ejw", 
        realm="[email-masked]", nonce="...", 
        uri="/workspace/webdav/proposal.doc", 
        response="...", opaque="..." 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:lockinfo xmlns:D="DAV:"> 
      <D:locktype><D:write/></D:locktype> 
      <D:lockscope><D:exclusive/></D:lockscope> 
      <D:owner> 
        <D:href>http://www.ics.uci.edu/~ejw/contact.html</D:href> 
      </D:owner> 
     </D:lockinfo> 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:multistatus xmlns:D="DAV:"> 
      <D:response> 
        <D:href>http://example.com/webdav/secret</D:href> 
        <D:status>HTTP/1.1 403 Forbidden</D:status> 
      </D:response> 
      <D:response> 
        <D:href>http://example.com/webdav/</D:href> 
        <D:propstat> 
          <D:prop><D:lockdiscovery/></D:prop> 
          <D:status>HTTP/1.1 424 Failed Dependency</D:status> 
        </D:propstat> 
      </D:response> 
     </D:multistatus> 
      
]]>
        </artwork>
      </figure>
      <t>
        This example shows a request for an exclusive write lock on a 
   collection and all its children.  In this request, the client has 
   specified that it desires an infinite length lock, if available, 
   otherwise a timeout of 4.1 billion seconds, if available. The 
   request entity body contains the contact information for the 
   principal taking out the lock, in this case a web page URL. 
      </t>
      <t>
   The error is a 403 (Forbidden) response on the resource 
   http://example.com/webdav/secret.  Because this resource could not 
   be locked, none of the resources were locked.  Note also that the 
   lockdiscovery property for the Request-URI has been included as 
   required.  In this example the lockdiscovery property is empty which 
   means that there are no outstanding locks on the resource. 
      </t>
      <t>
   In this example, the nonce, response, and opaque fields have not 
   been calculated in the Authorization request header. 
      </t>
    </section>
    
  </section>
  
  <section title="UNLOCK Method" anchor="UNLOCK">
    <t>
   The UNLOCK method removes the lock identified by the lock token in 
   the Lock-Token request header.  The Request-URI MUST identify a 
   resource within the scope of the lock.  The If header is not needed
   to provide the lock token although servers SHOULD still evaluate the
   If header and treat it as a conditional header.
    </t>
    <t>
   For a successful response to this 
   method, the server MUST remove the lock from the resource identified
   by the Request-URI and from all other resources included in the lock.    
    </t>
   
    <t>
   If all resources which have been locked under the submitted lock 
   token can not be unlocked then the UNLOCK request MUST fail. 
    </t>
    <t>
   A successful response to an UNLOCK method does not mean that the 
   resource is necessarily unlocked.  It means that the specific lock 
   corresponding to the specified token no longer exists. 
    </t>
    <t>
   Any DAV compliant resource which supports the LOCK method MUST 
   support the UNLOCK method. 
    </t>
    <section title="Status Codes">
      <t>
   204 (No Content) - Normal success response (rather than 200 OK, since 200 OK
        would imply a response body, and an UNLOCK success response does not 
        normally contain a body)
      </t>
      <t>
   400 (Bad Request) - No lock token was provided (see 'missing-lock-token' precondition), 
   or request was made to a Request-URI that was not within the scope of the lock 
   (see 'requesturi-must-match-lock-token' precondition). 
      </t>
      <t>
          403 (Forbidden) - The currently authenticated principal does not have permission
          to remove the lock (the server SHOULD use the 'need-privileges' precondition element).
      </t>
      <t>
   412 (Precondition Failed) - The resource was not locked. 
      </t>
    </section>
    
    <section title="Example">
      <figure>
        <artwork><![CDATA[
 >>Request 
  
   UNLOCK /workspace/webdav/info.doc HTTP/1.1 
   Host: example.com 
   Lock-Token: <urn:uuid:a515cfa4-5da4-22e1-f5b5-00a0451e6bf7> 
   Authorization: Digest username="ejw", 
      realm="[email-masked]", nonce="...", 
      uri="/workspace/webdav/proposal.doc", 
      response="...", opaque="..." 

 >>Response 
  
   HTTP/1.1 204 No Content 
   ]]></artwork>
      </figure>
      <t>
      
   In this example, the lock identified by the lock token 
   "urn:uuid:a515cfa4-5da4-22e1-f5b5-00a0451e6bf7" is 
   successfully removed from the resource 
   http://example.com/workspace/webdav/info.doc.  If this lock included 
   more than just one resource, the lock is removed from all resources 
   included in the lock.  The 204 (No Content) status code is used 
   instead of 200 (OK) because there is no response entity body. 
      </t>
      <t>
   In this example, the nonce, response, and opaque fields have not 
   been calculated in the Authorization request header. 
      </t>
    </section>
  </section>
  
</section>

<section title="HTTP Headers for Distributed Authoring" anchor="headers">

  <t>
   All DAV headers follow the same basic formatting rules as HTTP 
   headers. This includes rules like line continuation and how to 
   combine (or separate) multiple instances of the same header using 
   commas. 
  </t>
  
  <section title="DAV Header" anchor="DAV-header">
  
    <figure>
      <artwork>
  
   DAV             = "DAV" ":" #( compliance-code ) 
   compliance-code = ( "1" | "2" | "bis" | extend ) 
   extend          = Coded-URL | token 
      </artwork>
    </figure>
    <t>
   This general-header appearing in the response indicates that the resource 
   supports the DAV schema and protocol as specified. All DAV compliant 
   resources MUST return the DAV header on all OPTIONS responses. 
    </t>
    <t>
   The value is a comma-separated list of all compliance class 
   identifiers that the resource supports.  Class identifiers may be 
   Coded-URLs or tokens (as defined by [RFC2616]). Identifiers can 
   appear in any order.  Identifiers that are standardized through the 
   IETF RFC process are tokens, but other identifiers SHOULD be Coded-URLs
   to encourage uniqueness. 
    </t>
    <t>
   A resource must show class 1 compliance if it shows class 2 or "bis" 
   compliance. In general, support for one compliance class does not 
   entail support for any other.  Please refer to section 16 for more 
   details on compliance classes defined in this specification. 
    </t>
    <t>
   This header must also appear on responses to OPTIONS requests to the 
   special '*' Request-URI as defined in HTTP/1.1.  In this case it 
   means that the repository supports the named features in at least 
   some internal namespaces. 
    </t>
    <t>
   As an optional request header, this header allows the client to 
   advertise compliance with named features.  Clients need not 
   advertise 1, 2 or bis because a WebDAV server currently doesn't need 
   that information to decide how to respond to requests defined in 
   this specification or in HTTP/1.1.  However, future extensions may 
   define client compliance codes.  When used as a request header, the 
   DAV header MAY affect caching so this header SHOULD NOT be used on 
   all GET requests. 
    </t>
  </section>
  
  <section title="Depth Header">
    <figure>
      <artwork>
   Depth = "Depth" ":" ("0" | "1" | "infinity") 
      </artwork>
    </figure>
    
    <t>
   The Depth request header is used with methods executed on resources which 
   could potentially have internal members to indicate whether the 
   method is to be applied only to the resource ("Depth: 0"), to the 
   resource and its immediate children, ("Depth: 1"), or the resource 
   and all its progeny ("Depth: infinity"). 
    </t>
    <t>
   The Depth header is only supported if a method's definition 
   explicitly provides for such support. 
    </t>
    <t>
   The following rules are the default behavior for any method that 
   supports the Depth header. A method may override these defaults by 
   defining different behavior in its definition. 
    </t>
    <t>
   Methods which support the Depth header may choose not to support all 
   of the header's values and may define, on a case by case basis, the 
   behavior of the method if a Depth header is not present. For 
   example, the MOVE method only supports "Depth: infinity" and if a 
   Depth header is not present will act as if a "Depth: infinity" 
   header had been applied. 
    </t>
    <t>
   Clients MUST NOT rely upon methods executing on members of their 
   hierarchies in any particular order or on the execution being atomic 
   unless the particular method explicitly provides such guarantees. 
    </t>
    <t>
   Upon execution, a method with a Depth header will perform as much of 
   its assigned task as possible and then return a response specifying 
   what it was able to accomplish and what it failed to do. 
    </t>
    <t>
   So, for example, an attempt to COPY a hierarchy may result in some 
   of the members being copied and some not. 
    </t>
    <t>
   Any headers on a method that has a defined interaction with the 
   Depth header MUST be applied to all resources in the scope of the 
   method except where alternative behavior is explicitly defined. For 
   example, an If-Match header will have its value applied against 
   every resource in the method's scope and will cause the method to 
   fail if the header fails to match. 
    </t>
    <t>
   If a resource, source or destination, within the scope of the method 
   with a Depth header is locked in such a way as to prevent the 
   successful execution of the method, then the lock token for that 
   resource MUST be submitted with the request in the If request 
   header. 
    </t>
    <t>
   The Depth header only specifies the behavior of the method with 
   regards to internal children.  If a resource does not have internal 
   children then the Depth header MUST be ignored. 
    </t>
    <t>
   Please note, however, that it is always an error to submit a value 
   for the Depth header that is not allowed by the method's definition.  
   Thus submitting a "Depth: 1" on a COPY, even if the resource does 
   not have internal members, will result in a 400 (Bad Request). The 
   method should fail not because the resource doesn't have internal 
   members, but because of the illegal value in the header. 
    </t>
   </section>
    
   <section title="Destination Header" anchor="destination-header">
   
     <t>
   Destination = "Destination" ":" ( absolute-URI ) 
    </t>
    <t>
   The Destination request header specifies the URI which identifies a 
   destination resource for methods such as COPY and MOVE, which take 
   two URIs as parameters.  Note that the absolute-URI production is 
   defined in <xref target="RFC3986"/>.   
    </t>
    <t>
   If the Destination value is an absolute URI, it may name a different 
   server (or different port or scheme). If the source server cannot 
   attempt a copy to the remote server, it MUST fail the request with a 
   502 (Bad Gateway) response. Servers MAY attempt to copy the resource 
   to the remote server using PUT/PROPPATCH or another mechanism. 
    </t>
  </section>
  
  <section title="Force-Authentication Header" anchor="force-auth-header">
    <t>
   Force-Authentication = "Force-Authentication" ":" Method 
    </t>
    <t>
   The Force-Authentication request header is used with the OPTIONS method to 
   specify that the client wants to be challenged for authentication 
   credentials to the resource identified by the Request-URI.  If 
   present on a request to a WebDAV-compliant resource, the server MUST 
   respond with either 401 (Unauthorized) or 501 (Not Implemented) 
   status code. The Method value is used for the client to indicate 
   what method it intends to use first on the resource identified in 
   the Request-URI.  
    </t>
  </section>
  
  <section title="If Header" anchor="if-header">
    <figure>
      <artwork>
   If = "If" ":" ( 1*No-tag-list | 1*Tagged-list) 
   No-tag-list = List 
   Tagged-list = Resource 1*List 
   Resource = Coded-URL 
   List = #( "(" List | Clause ")" )
   Clause = ["Not"] State-token | State-token
   State-token = Coded-URL  | "[" entity-tag "]"
   Coded-URL = "&lt;" absolute-URI "&gt;" 
      </artwork>
    </figure>
    
    <t>
   The If request header is intended to have similar functionality to the If-Match
    header defined in section 14.24 of <xref target="RFC2616"/>.  However the If 
   header is intended for use with any URI which represents state 
   information, referred to as a state token, about a resource as well 
   as ETags.  A typical example of a state token is a lock token, and 
   lock tokens are the only state tokens defined in this specification. 
   The &lt;DAV:no-lock&gt; state token is an example of a state token that will never 
   match an actual valid lock token. The purpose of this is described 
   in <xref target="not-production"/>. 
    </t>
    <t>
   The If header's purpose is to describe a series of state lists.  If 
   the state of the resource to which the header is applied does not 
   match any of the specified state lists then the request MUST fail 
   with a 412 (Precondition Failed).  If one of the described state 
   lists matches the state of the resource then the request may 
   succeed. 
    </t>
    <t>
   The server must parse the If header when it appears on any request, 
   evaluate all the clauses, and if the conditional evaluates to false, 
   fail the request.  
    </t>
    <t>
   Note that the absolute-URI production is defined in <xref target="RFC3986"/>. 
    </t>
    <t>
   RFC2518 originally defined the If header without comma separators. 
   This oversight meant that the If header couldn't be divided up among 
   multiple lines according to the HTTP header manipulation rules. 
   Servers supporting "bis" MUST be able to accept commas in If header 
   values. If the header has commas between tokens or clauses, the 
   header can be evaluated simply by removing the commas and proceeding 
   with the evaluation rules. 
    </t>
    
    <section title="No-tag-list Production">
      <t>
   The No-tag-list production describes a series of state tokens and 
   ETags.  If multiple No-tag-list productions are used then one only 
   needs to match the state of the resource for the method to be 
   allowed to continue.  All untagged tokens apply to the resource 
   identified in the Request-URI. 
      </t>

      <figure>
        <preamble>Example - no-tag-list production</preamble>
        <artwork><![CDATA[
   If: (<urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2> 
          ["I am an ETag"]), (["I am another ETag"]) 
        ]]></artwork>
      </figure>
      <t>
   The previous header would require that the resource identified in 
   the Request-URI be locked with the specified lock token and in the 
   state identified by the "I am an ETag" ETag or in the state 
   identified by the second ETag "I am another ETag".  To put the 
   matter more plainly one can think of the previous If header as being 
   in the form (or (and &lt;urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2&gt; ["I am an 
   ETag"]) (and ["I am another ETag"])). 
      </t>
    </section>

    <section title="Tagged-list Production">
      <t>
   The tagged-list production may be used instead of the no-tag-list production,
        in order to scope each token to a specific resource.  That is, it 
   specifies that the lists following the resource specification only 
   apply to the specified resource.  The scope of the resource 
   production begins with the list production immediately following the 
   resource production and ends with the next resource production, if 
   any.  All clauses must be evaluated.  If 
   the state of the resource named in the tag does not 
   match any of the associated state lists then the request MUST fail 
   with a 412 (Precondition Failed).   The tagged-list production MUST NOT
        be used together with the no-tag-list production, either in the
        same If header or in a continuation.
      </t>
      <t>
   The same URI MUST NOT appear more than once in a resource production 
   in an If header. 
      </t>
      <figure>
        <preamble>Example - Tagged List If header</preamble>
        <artwork><![CDATA[
     COPY /resource1 HTTP/1.1 
     Host: www.example.com 
     Destination: http://www.example.com/resource2 
     If: <http://www.example.com/resource1> 
           (<urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2> 
           [W/"A weak ETag"]), (["strong ETag"]), 
         <http://www.bar.bar/random> 
          (["another strong ETag"]) 
    ]]></artwork>
      </figure>
      <t>
   In this example http://www.example.com/resource1 is being copied to 
   http://www.example.com/resource2.  When the method is first applied 
   to http://www.example.com/resource1, resource1 must be in the state 
   specified by "(&lt;urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2&gt; [W/"A weak ETag"]) 
   (["strong ETag"])", that is, it either must be locked with a lock 
   token of "urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2" and have a weak entity tag 
   W/"A weak ETag" or it must have a strong entity tag "strong ETag". 
      </t>
      <t>
   That is the only success condition since the resource 
   http://www.bar.bar/random never has the method applied to it (the 
   only other resource listed in the If header) and 
   http://www.example.com/resource2 is not listed in the If header. 
      </t>
    </section>
    
    <section title="Not Production" anchor="not-production">
      <t>
   Every state token or ETag is either current, and hence describes the 
   state of a resource, or is not current, and does not describe the 
   state of a resource. The boolean operation of matching a state token 
   or ETag to the current state of a resource thus resolves to a true 
   or false value.  The "Not" production is used to reverse that value.  
   The scope of the not production is the state-token or entity-tag 
   immediately following it. 
     </t>
      <figure>
        <artwork><![CDATA[
     If: (Not <urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2> 
          <urn:uuid:58f202ac-22cf-11d1-b12d-002035b29092>) 
        ]]></artwork>
      </figure>
      <t>
   When submitted with a request, this If header requires that all 
   operand resources must not be locked with 
        urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2 and must 
   be locked with urn:uuid:58f202ac-22cf-11d1-b12d-002035b29092. 
      </t>
      <t>
   The Not production is particularly useful with the "&lt;DAV:no-lock&gt;" 
   state token. The clause "Not &lt;DAV:no-lock&gt;" MUST evaluate to true. 
   Thus, any "OR" statement containing the clause "Not &lt;DAV:no-lock&gt;" 
   MUST also evaluate to true.  
      </t>
    </section>
    
    <section title="Matching Function">
      <t>
   When performing If header processing, the definition of a matching 
   state token or entity tag is as follows. 
      </t>
      <t>
          Identifying a resource:  The resource is identified by the URI
          along with the token, in tagged list production, or by the 
          Request-URI in untagged list production.
          </t>
      <t>
   Matching entity tag: Where the entity tag matches an entity tag 
   associated with the identified resource. 
      </t>
      <t>
   Matching state token: Where there is an exact match between the 
   state token in the If header and any state token on the identified resource. 
   A lock state token is considered to match if the resource is anywhere
   in the scope of the lock.
   
      </t>
            <figure>
        <preamble>Example - Matching lock tokens with collection locks</preamble>
        <artwork><![CDATA[
 DELETE /specs/rfc2518.txt HTTP/1.1 
 Host: www.example.com 
 If: <http://www.example.com/specs/> 
       (<urn:uuid:181d4fae-7d8c-11d0-a765-00a0c91e6bf2>) 
    ]]></artwork>
    <postamble>For this example, the lock token must be compared to the 
        identified resource, which is the 'specs' collection identified by
        the URL in the tagged list production.  If the 'specs' collection 
        is not locked or has a lock with a different token, the request MUST
        fail.  If the 'specs' collection is locked (depth infinity) with that 
        lock token, then this request could succeed, both because the If header
        evaluates to true, and because the lock token for the lock affecting the
        affected resource has been provided.  Alternatively, a 
        request where the 'rfc2518.txt' URL is associated with the lock token
        in the If header could also succeed.</postamble>
      </figure>

    </section>
    
    <section title="If Header and Non-DAV Aware Proxies">
      <t>
   Non-DAV aware proxies will not honor the If header, since they will 
   not understand the If header, and HTTP requires non-understood 
   headers to be ignored.  When communicating with HTTP/1.1 proxies, 
   the "Cache-Control: no-cache" request header MUST be used so as to 
   prevent the proxy from improperly trying to service the request from 
   its cache.  When dealing with HTTP/1.0 proxies the "Pragma: no-cache"
   request header MUST be used for the same reason. 
      </t>
    </section>
  </section>
  
  <section title="Lock-Token Header" anchor="lock-token-header">
    <t>
   Lock-Token = "Lock-Token" ":" Coded-URL 
    </t>
    <t>
   The Lock-Token request header is used with the UNLOCK method to 
   identify the lock to be removed.  The lock token in the Lock-Token 
   request header MUST identify a lock that contains the resource 
   identified by Request-URI as a member. 
    </t>
    <t>
   The Lock-Token response header is used with the LOCK method to 
   indicate the lock token created as a result of a successful LOCK 
   request to create a new lock. 
    </t>
  </section>
  
  <section title="Overwrite Header">
    <t>
   Overwrite = "Overwrite" ":" ("T" | "F") 
    </t>
    <t>
   The Overwrite request header specifies whether the server should overwrite 
   the state of a non-null destination resource during a COPY or MOVE.  
   A value of "F" states that the server must not perform the COPY or 
   MOVE operation if the state of the destination resource is non-null. 
   If the overwrite header is not included in a COPY or MOVE request 
   then the resource MUST treat the request as if it has an overwrite 
   header of value "T". While the Overwrite header appears to duplicate 
   the functionality of the If-Match: * header of HTTP/1.1, If-Match 
   applies only to the Request-URI, and not to the Destination of a 
   COPY or MOVE. 
    </t>
    <t>
   If a COPY or MOVE is not performed due to the value of the Overwrite 
   header, the method MUST fail with a 412 (Precondition Failed) status 
   code. 
    </t>
    <t>
   All DAV compliant resources MUST support the Overwrite header. 
    </t>
  </section>
  
  <section title="Timeout Request Header" anchor="timeout-header">
    <figure>
      <artwork>
   TimeOut = "Timeout" ":" 1#TimeType 
   TimeType = ("Second-" DAVTimeOutVal | "Infinite") 
   DAVTimeOutVal = 1*digit 
      </artwork>
    </figure>
    
    <t>
   Clients may include Timeout request headers in their LOCK requests.  
   However, the server is not required to honor or even consider these 
   requests.  Clients MUST NOT submit a Timeout request header with any 
   method other than a LOCK method. 
    </t>
    <t>
   Timeout response values MUST use a Second value or Infinite. 
    </t>
    <t>
   The "Second" TimeType specifies the number of seconds that will 
   elapse between granting of the lock at the server, and the automatic 
   removal of the lock.  The timeout value for TimeType "Second" MUST 
   NOT be greater than 2^32-1. 
    </t>
    <t>
   The timeout counter MUST be restarted if a refresh LOCK request is 
   successful.  The timeout counter SHOULD NOT be restarted at any 
   other time.   
    </t>
    <t>
   If the timeout expires then the lock may be lost.  Specifically, if 
   the server wishes to harvest the lock upon time-out, the server 
   SHOULD act as if an UNLOCK method was executed by the server on the 
   resource using the lock token of the timed-out lock, performed with 
   its override authority. Thus logs should be updated with the 
   disposition of the lock, notifications should be sent, etc., just as 
   they would be for an UNLOCK request. 
    </t>
    <t>
   Servers are advised to pay close attention to the values submitted 
   by clients, as they will be indicative of the type of activity the 
   client intends to perform.  For example, an applet running in a 
   browser may need to lock a resource, but because of the instability 
   of the environment within which the applet is running, the applet 
   may be turned off without warning.  As a result, the applet is 
   likely to ask for a relatively small timeout value so that if the 
   applet dies, the lock can be quickly harvested.  However, a document 
   management system is likely to ask for an extremely long timeout 
   because its user may be planning on going off-line. 
    </t>
    <t>
   A client MUST NOT assume that just because the time-out has expired 
   the lock has been lost. Likewise, a client MUST NOT assume that just 
   because the time-out has not expired, the lock still exists (and for 
   this reason, clients are strongly advised to use ETags as well). 
    </t>
  </section>
</section>

<section title="Status Code Extensions to HTTP/1.1" anchor="webdav-status-codes">

  <t>
   The following status codes are added to those defined in HTTP/1.1 
   <xref target="RFC2616"/>. 
  </t>
  
  <section title="102 Processing">
    <t>
   The 102 (Processing) status code is an interim response used to 
   inform the client that the server has accepted the complete request, 
   but has not yet completed it.  This status code SHOULD only be sent 
   when the server has a reasonable expectation that the request will 
   take significant time to complete. As guidance, if a method is 
   taking longer than 20 seconds (a reasonable, but arbitrary value) to 
   process the server SHOULD return a 102 (Processing) response. The 
   server MUST send a final response after the request has been 
   completed. 
    </t>
    <t>
   Methods can potentially take a long period of time to process, 
   especially methods that support the Depth header.  In such cases the 
   client may time-out the connection while waiting for a response.  To 
   prevent this the server may return a 102 (Processing) status code to 
   indicate to the client that the server is still processing the 
   method. 
    </t>
  </section>
  
  <section title="207 Multi-Status">
    <t>
   The 207 (Multi-Status) status code provides status for multiple 
   independent operations (see <xref target="multi-status"/>
   for more information). 
    </t>
  </section>
  
  <section title="422 Unprocessable Entity">
    <t>
   The 422 (Unprocessable Entity) status code means the server 
   understands the content type of the request entity (hence a 
   415(Unsupported Media Type) status code is inappropriate), and the 
   syntax of the request entity is correct (thus a 400 (Bad Request) 
   status code is inappropriate) but was unable to process the 
   contained instructions.  For example, this error condition may occur 
   if an XML request body contains well-formed (i.e., syntactically 
   correct), but semantically erroneous XML instructions. 
    </t>
  </section>
  
  <section title="423 Locked">
    <t>
   The 423 (Locked) status code means the source or destination 
   resource of a method is locked.  This response SHOULD
   contain the 'missing-lock-token' element and corresponding href in the error body.
    </t>
  </section>
  
  <section title="424 Failed Dependency">
    <t>
   The 424 (Failed Dependency) status code means that the method could 
   not be performed on the resource because the requested action 
   depended on another action and that action failed.  For example, if 
   a command in a PROPPATCH method fails then, at minimum, the rest of 
   the commands will also fail with 424 (Failed Dependency). 
    </t>
  </section>
  
  <section title="507 Insufficient Storage">
    <t>
   The 507 (Insufficient Storage) status code means the method could 
   not be performed on the resource because the server is unable to 
   store the representation needed to successfully complete the 
   request.  This condition is considered to be temporary.  If the 
   request which received this status code was the result of a user 
   action, the request MUST NOT be repeated until it is requested by a 
   separate user action. 
    </t>
  </section>
</section>

<section title="Use of HTTP Status Codes" anchor="http-status-codes">
  
  <t>
  These HTTP codes are not redefined, but this section serves as a reminder that 
  these HTTP codes may be used in responses to WebDAV methods and clients must be
  appropriately prepared to handle them. 
    </t>

  <section title="301 Moved Permanently">  
    <t>
   A server MAY use this status code in response to any request.
    </t>
  </section>
  
  <section title="302 Found">
    <t>
   A server MAY use this status code in response to any request.
    </t>
  </section>
  
  <section title="400 Bad Request">
    <t>
   A server MAY use this status code in response to any request.  Some possible 
      reasons: 
    </t>
    <t><list style="symbols">
      <t>the Host header is missing in any request </t>
      <t>The protocol version is HTTP/1.0 </t>
      <t>Any header is improperly formatted</t>
      <t>The request method line is improperly formatted</t>
    </list></t> 
    
  </section>

  <section title="403 Forbidden"> 
    <t>
   A server MAY use this status code in response to any request.  An appropriate use 
      example would be in response to a PUT request to a collection, if the server does
      not ever allow PUT to a collection. 
    </t>
  </section>
  
  <section title="409 Conflict"> 
    <t>
   A server MAY use this status code in response to any request.  In base WebDAV,
      the 409 Conflict is most typically returned when a method that 
   attempts to create a new resource must fail, because one of the 
   collections that resource depends on does not exist.  However, other 
   types of conflicts are defined in specifications extending RFC2518.  
   
      </t>
  </section>
  
  <section title="412 Precondition Failed">
    <t>
      Any request can contain a conditional header defined in HTTP
      (If-Match, If-Modified-Since, etc.) or the "If" conditional header
      defined in this specification.  If the request contains a conditional
      header, and if that condition fails to hold, then this error code MUST
      be returned unless some other error is returned.  On the other hand,
      if the client did not include a conditional header in the request,
      then the server MUST NOT use this error.
      
    </t>
    
  </section>
  
  <section title="414 Request-URI Too Long">
    <t>
   This status code is used in HTTP 1.1 only for Request-URIs, because 
   full URIs aren't used in other headers. WebDAV specifies full URLs 
   in other headers, therefore this error may be used if the URI is too 
   long in other locations as well. A server MAY use this status code in response
      to any request.  
    </t>
  </section>
  
  <section title="503 Service Unavailable">
    <t>This status code is particularly useful to respond to requests that the
    server considers a denial-of-service attack, such as excessively large
    PROPFIND depth infinity requests or requests in quick succession. A server
    MAY use this status code in response to any request, provided that the 
    request did not partially or completely succeed.  </t>
  </section>
</section>
  
<section title="Multi-Status Response" anchor="multi-status">
  <t>    
   A Multi-Status response contains one 'response' element for each 
   resource in the scope of the request (in no required order) or may
   be empty if no resources match the request. 
    The default 207 (Multi-Status) response body is a text/xml or 
   application/xml HTTP entity that contains a single XML element 
   called multistatus, which contains a set of XML elements called 
   response which contain 200, 300, 400, and 500 series status codes 
   generated during the method invocation.  100 series status codes 
   SHOULD NOT be recorded in a response XML element.  The 207 status 
   code itself MUST NOT be considered a success response, it is only 
   completely successful if all response elements inside contain 
   success status codes. 
  </t>
  <t>
   The body of a 207 Multi-Status response MUST contain a URL 
   associated with each specific status code, so that the client can 
   tell whether the error occurred with the source resource, 
   destination resource or some other resource in the scope of the 
   request. 
  </t>
  
  <section title="Response headers">
    <t>Use of the Location header with the Multi-Status response is intentionally 
    undefined.  Note that this specification does not define a way to redirect 
      requests for individual resources within the scope of a Multi-Status response.
      The server MAY always redirect the entire request by responding with a 300 
      level status response instead of a Multi-Status response.
    </t>
  </section>
  
  <section title="URL handling">
    
    <t>
     When a Multi-Status body is returned in response to a PROPFIND or 
     another request with a single scope, all URLs appearing in the body 
     must be equal to or inside the request-URI, thus the URLs MAY be 
     absolute or MAY be relative.   
    </t>

    <t><list style="symbols">
      <t>If the URLs are absolute, then the server MUST ensure that the 
     URLs have the same prefix (scheme, host, port, and path) as the URL 
     of the requested resource. 
      </t>
      <t>If the URLs are relative, they MUST be resolved against the 
     Request-URI.  
      </t>
    </list></t>
  
    <t>
     When a Multi-Status body is returned in response to MOVE or COPY, 
     relative URI resolution is ambiguous (the request had both a source 
     and a destination URL).  Thus, URLs appearing in the responses to 
     MOVE or COPY SHOULD be absolute and fully-qualified URLs.   
    </t>
    
    <t>Servers MUST NOT
      return "." or ".." within an absolute or relative URI returned within a
      Multi-Status response.
    </t>

    <t>URLs for collections appearing in the results SHOULD end in 
     a '/' character. 
    </t>

    <t>
   If a server allows resource names to include characters that aren't 
   legal in HTTP URL paths, these characters must be URI-escaped on the 
   wire. For example, it is illegal to use a space character or double-quote
   in a URI.  URIs appearing in PROPFIND or PROPPATCH 
   XML bodies (or other XML marshalling defined in this specification) 
   are still subject to all URI rules, including forbidden characters. 
    </t>
  </section>  
    
  <section title="Internal Status Codes">
  <t>
  <xref target="PROPPATCH-status"/>, <xref target="PROPFIND-multistatus"/>,
    <xref target="delete-collections"/>, <xref target="copy-collections"/> and
    <xref target="move-collections"/> define various 
    status codes used in Multi-Status responses. This specification does not 
    define the meaning of other status codes that could appear in these
    responses.
  </t>
  </section>
    
</section>

<section title="XML Element Definitions" anchor="xml-elements">
  <t>
   In this section, the final line of each section gives the 
   element type declaration using the format defined in 
   <xref target="XML"/>. The 
   "Value" field, where present, specifies further restrictions on the 
   allowable contents of the XML element using BNF (i.e., to further 
   restrict the values of a PCDATA element).  The "Extensibility" field 
   discusses how the element may be extended in the future (or in 
   existing extensions to WebDAV. 
  </t>
  <t>
   All of the elements defined here may be extended by the addition of 
   attributes and child elements not defined in this specification.  
  </t>

  <!-- BZ41 -->  
  <section title="activelock XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">activelock</t> 
   <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Describes a lock on a resource. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t>
   </list></t>
    <figure><artwork>
<![CDATA[<!ELEMENT activelock (lockscope, locktype, depth, owner?, timeout?, 
locktoken?, lockroot)>
     ]]></artwork></figure>
  
  <section title="depth XML Element ">
    <t><list style="hanging">
      <t hangText="Name: ">depth</t> 
   <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">The value of the Depth header. </t>
   <t hangText="Value: ">"0" | "1" | "infinity"   </t>
   <t hangText="Extensibility: ">MAY be extended with attributes which SHOULD be 
            ignored.</t>
    </list>
    </t>
    <figure><artwork><![CDATA[<!ELEMENT depth (#PCDATA) >]]>
    </artwork></figure>
    
  </section>
  
  <section title="locktoken XML Element ">
    <t><list style="hanging">
    <t hangText="Name: ">locktoken </t>
    <t hangText="Namespace: ">DAV:</t> 
    <t hangText="Purpose: ">The lock token associated with a lock. </t>
    <t hangText="Description: ">The href contains a single lock token URI which refers 
            to the lock. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t>
    </list>
    </t>
   <figure><artwork><![CDATA[<!ELEMENT locktoken (href) >]]></artwork></figure>
  </section>
  
  <section title="lockroot XML Element ">
    <t><list style="hanging">
   <t hangText="Name: ">lockroot </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Contains the root URL of the lock, which is the URL through
       which the resource was addressed in the LOCK request. </t>
   <t hangText="Description: ">The href contains a URL with the address of the root of 
            the lock. The server SHOULD include this in all 
            lockdiscovery property values and the response to LOCK 
            requests. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t>
    </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT lockroot (href) >  ]]></artwork></figure>
  </section>
  </section>
  
  <section title="timeout XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">timeout</t> 
      <t hangText="Namespace: ">DAV: </t>
      <t hangText="Purpose: ">The number of seconds remaining before a lock expires. </t>
      <t hangText="Value: ">TimeType (defined in <xref target="timeout-header"/>). </t>
      <t hangText="Extensibility: ">MAY be extended with attributes which SHOULD be 
            ignored. </t>
    </list></t>
    <figure><artwork><![CDATA[
   <!ELEMENT timeout (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="collection XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">collection </t>
      <t hangText="Namespace: ">DAV: </t>
      <t hangText="Purpose: ">Identifies the associated resource as a collection. The 
            resourcetype property of a collection resource MUST contain 
            this element.  It is normally empty but extensions may add 
            sub-elements. </t>
      <t hangText="Extensibility: ">MAY be extended with child elements or attributes 
      which SHOULD be ignored if not recognized. </t>
    </list></t>
    <figure><artwork><![CDATA[<!ELEMENT collection EMPTY > 
    ]]></artwork></figure>
  </section>
  
  <section title="href XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">href</t>
      <t hangText="Namespace: ">DAV: </t>
      <t hangText="Purpose: ">Identifies the content of the element as a URI.  In many
         situations, this URI MUST be a HTTP URI, and furthermore, it MUST identify a 
         WebDAV resource.  There is one exception to this general rule in the lockdiscovery
         property, where the lock token (which is a URI but may not be a HTTP URI) is 
         inside the href element.  Other specifications SHOULD be explicit if the 
         href element is to contain non-HTTP URIs.</t>
      <t hangText="Value: ">URI (See section 3.2.1 of <xref target="RFC2616"/>) </t>
      <t hangText="Extensibility: ">MAY be extended with attributes which SHOULD be 
            ignored. </t>
    </list></t>
    <figure><artwork>
   &lt;!ELEMENT href (#PCDATA)&gt;
    </artwork></figure>
  </section>
    
  <section title="lockentry XML Element ">
    <t><list style="hanging">
      <t hangText="Name: ">lockentry </t>
      <t hangText="Namespace: ">DAV:</t>
      <t hangText="Purpose: ">Defines the types of locks that can be used with the 
            resource. </t>
      <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t>
    </list></t>
    <figure><artwork><![CDATA[<!ELEMENT lockentry (lockscope, locktype) > 
    ]]></artwork></figure>
  </section>
  
  <section title="lockinfo XML Element">
   <t><list style="hanging">
     <t hangText="Name: ">lockinfo</t> 
     <t hangText="Namespace: ">DAV:</t> 
     <t hangText="Purpose: ">The lockinfo XML element is used with a LOCK method to 
            specify the type of lock the client wishes to have created. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t>
   </list>
   </t><figure><artwork>
<![CDATA[<!ELEMENT lockinfo (lockscope, locktype, owner?)  > 
    ]]></artwork></figure>
  </section>
  
  <!-- BZ41 -->
  <section title="lockscope XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">lockscope</t>
      <t hangText="Namespace: ">DAV:</t> 
      <t hangText="Purpose: ">Specifies whether a lock is an exclusive lock, or a shared 
            lock. </t>
      <t hangText="Extensibility: ">SHOULD NOT be extended with child elements. MAY be 
            extended with attributes which SHOULD be ignored. </t>
      </list>
    </t>
    <figure><artwork>
  <![CDATA[<!ELEMENT lockscope (exclusive | shared) > 
    ]]>
        </artwork></figure>
   
  <section title="exclusive XML Element">  
    <t><list style="hanging">
      <t hangText="Name: ">exclusive</t>
     <t hangText="Namespace: ">DAV:</t> 
     <t hangText="Purpose: ">Specifies an exclusive lock </t>
   <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized. </t>
            
    </list>
    </t>
    <figure><artwork>
<![CDATA[<!ELEMENT exclusive EMPTY > 
    ]]>
        </artwork></figure>
  </section>
  
  <section title="shared XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">shared</t>
     <t hangText="Namespace: ">DAV:</t> 
     <t hangText="Purpose: ">Specifies a shared lock</t> 
     <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized. </t>
    </list>
    </t>
    <figure><artwork>
<![CDATA[<!ELEMENT shared EMPTY > 
    ]]>
        </artwork></figure>
  </section>
  </section>
  
  <!-- BZ41 -->
  <section title="locktype XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">locktype</t>
      <t hangText="Namespace: ">DAV:</t> 
      <t hangText="Purpose: ">Specifies the access type of a lock.  At present, this 
            specification only defines one lock type, the write lock. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
    </list>
    </t>
    <figure><artwork>
<![CDATA[<!ELEMENT locktype (write) > 
    ]]>
        </artwork></figure>
  
  <section title="write XML Element">
    <t><list style="hanging">
      <t hangText="Name: ">write</t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Specifies a write lock. </t>
   <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized. </t>
    </list></t>
    <figure><artwork>
<![CDATA[<!ELEMENT write EMPTY > 
    ]]>
    </artwork></figure>
    
  </section>
  </section>
  
  <!-- BZ41 -->
  <section title="multistatus XML Element">
       <t><list style="hanging">
      <t hangText="Name: ">multistatus</t>
  <t hangText="Namespace: ">DAV:</t> 
  <t hangText="Purpose: ">Contains multiple response messages. </t>
   <t hangText="Description"> The responsedescription at the top level is used to 
            provide a general message describing the overarching nature 
            of the response.  If this value is available an application 
            may use it instead of presenting the individual response 
            descriptions contained within the responses. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
       </list></t>
    <figure><artwork>
<![CDATA[<!ELEMENT multistatus (response+, responsedescription?)  > 
    ]]>
    </artwork></figure>

  <section title="response XML Element">
     <t><list style="hanging">
      <!-- BZ63 -->
      <t hangText="Name: ">response</t>
    <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Holds a single response describing the effect of a method 
            on resource and/or its properties. </t>
   <t hangText="Description: ">A particular href MUST NOT appear more than 
            once as the child of a response XML element under a 
            multistatus XML element.  This requirement is necessary in 
            order to keep processing costs for a response to linear 
            time.  Essentially, this prevents having to search in order 
            to group together all the responses by href.  There are, 
            however, no requirements regarding ordering based on href 
            values. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
     </list>
     </t>
     <figure><artwork>
<![CDATA[<!ELEMENT response (href, ((href*, status)|(propstat+)), 
      responsedescription? , location?) > ]]>
    </artwork></figure>

  <section title="propstat XML Element">
    <t><list style="hanging">
    <t hangText="Name: ">propstat </t>
     <t hangText="Namespace: ">DAV:</t> 
     <t hangText="Purpose: ">Groups together a prop and status element that is 
            associated with a particular href element.  </t>
     <t hangText="Description:  ">The propstat XML element MUST contain one prop 
            XML element and one status XML element.  The contents of 
            the prop XML element MUST only list the names of properties 
            to which the result in the status element applies. </t>
     <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
    </list>
    </t>
   <figure><artwork><![CDATA[<!ELEMENT propstat (prop, status, responsedescription?) > 
    ]]></artwork></figure>
  </section>
  
  <section title="status XML Element">
    <t><list style="hanging">
   <t hangText="Name: ">status </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Holds a single HTTP status-line </t>
   <!-- BZ 180 -->
   <t hangText="Value: "> status-line (status-line defined in Section 6.1 of <xref target="RFC2616"/>)
   </t>
   <t hangText="Extensibility: ">MAY be extended with attributes which SHOULD be 
            ignored. </t>
    </list>
    </t>
   <figure><artwork><![CDATA[<!ELEMENT status (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  </section>
  
  <section title="responsedescription XML Element"> 
    <t><list style="hanging">
   <t hangText="Name: ">responsedescription </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Contains a message that can be displayed to the user 
            explaining the nature of the response. </t>
   <t hangText="Description: ">This XML element provides information suitable to be 
            presented to a user.</t> 
   <t hangText="Extensibility: ">MAY be extended with attributes which SHOULD be 
            ignored. </t>
   </list></t>         
    
   <figure><artwork><![CDATA[<!ELEMENT responsedescription (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  </section>
  
  <section title="owner XML Element">
   <t><list style="hanging"> 
   <t hangText="Name: ">owner </t> 
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Provides information about the principal taking out a lock. </t>
   <t hangText="Description">The owner XML element provides information sufficient 
            for either directly contacting a principal (such as a 
            telephone number or Email URI), or for discovering the 
            principal (such as the URL of a homepage) who owns a lock. 
            This information is provided by the client, and may only be 
            altered by the server if the owner value provided by the 
            client is empty. </t> 
   <t hangText="Extensibility">MAY be extended with child elements, mixed content, 
            text content or attributes.  Structured content, for 
            example one or more &lt;href&gt; child elements containing URLs, 
            is RECOMMENDED.</t>
       </list>     
   </t>
   
   <figure><artwork><![CDATA[<!ELEMENT owner ANY >]]></artwork></figure>

  </section>
  
  <section title="prop XML element"> 
    <t><list style="hanging">
   <t hangText="Name: ">prop</t> 
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Contains properties related to a resource. </t>
   <t hangText="Description">The prop XML element is a generic container for 
            properties defined on resources.  All elements inside a 
            prop XML element MUST define properties related to the 
            resource.  No other elements may be used inside of a prop 
            element. </t>
   <t hangText="Extensibility">MAY be extended with attributes which SHOULD be 
            ignored if not recognized.  Any child element of this 
            element must be considered to be a property name, however 
            these are not restricted to the property names defined in 
            this document or other standards. </t>
    </list>
    </t>
    
       <figure><artwork><![CDATA[<!ELEMENT prop ANY >]]></artwork></figure>
    
  </section>
  
  <!-- BZ41 -->
  <section title="propertyupdate XML element">
    <t><list style="hanging">
   <t hangText="Name: ">propertyupdate </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Contains a request to alter the properties on a resource. </t>
   <t hangText="Description: ">This XML element is a container for the 
            information required to modify the properties on the 
            resource.  This XML element is multi-valued. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
    </list>
    </t>
   <figure><artwork><![CDATA[<!ELEMENT propertyupdate (remove | set)+ > ]]></artwork></figure>

  <section title="remove XML element">
    <t><list style="hanging">
   <t hangText="Name: ">remove </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Lists the DAV properties to be removed from a resource.</t> 
   <t hangText="Description: ">Remove instructs that the properties specified 
            in prop should be removed.  Specifying the removal of a 
            property that does not exist is not an error.  All the XML 
            elements in a prop XML element inside of a remove XML 
            element MUST be empty, as only the names of properties to 
            be removed are required. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
    </list>
    </t>
   <figure><artwork><![CDATA[<!ELEMENT remove (prop) >]]></artwork></figure>

  </section>
  
  <section title="set XML element">
    <t><list style="hanging">
   <t hangText="Name: ">set </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Lists the DAV property values to be set for a resource. </t>
   <t hangText="Description: ">The set XML element MUST contain only a prop XML 
            element.  The elements contained by the prop XML element 
            inside the set XML element MUST specify the name and value 
            of properties that are set on the resource identified by 
            Request-URI.  If a property already exists then its value 
            is replaced. Language tagging information appearing in the 
            scope of the prop element (in the "xml:lang" attribute, if 
            present) MUST be persistently stored along with the 
            property, and MUST be subsequently retrievable using 
            PROPFIND. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
    </list>
    </t>
   <figure><artwork>&lt;!ELEMENT set (prop) &gt;</artwork></figure>

  </section>
  </section>

  <!-- BZ41 -->
  <section title="propfind XML Element" anchor="propfind-element">
   <t><list style="hanging">
     <t hangText="Name: ">propfind </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">Specifies the properties to be returned from a PROPFIND 
            method.  Four special elements are specified for use with 
            propfind: prop, dead-props, allprop and propname.  If prop 
            is used inside propfind it MUST NOT contain property 
            values. </t>
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized, as 
            long as it still contains one of the required elements. </t> 
   </list>
   </t>
   <figure><artwork><![CDATA[<!ELEMENT propfind (prop | dead-props | propname | allprop) > 
    ]]></artwork></figure>
  
  <section title="allprop XML Element">
  <t><list style="hanging">
      <t hangText="Name: ">allprop </t>
     <t hangText="Namespace: ">DAV:</t> 
   <t hangText="Purpose: ">The allprop XML element specifies that all names and values 
            of dead properties and the live properties defined by this 
            document existing on the resource are to be returned. </t>
   <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized.  </t>
  </list>
  </t>
   <figure><artwork><![CDATA[<!ELEMENT allprop EMPTY > 
    ]]></artwork></figure>
  </section>
  
  <section title="propname XML Element">
   <t><list style="hanging">
     <t hangText="Name: ">propname </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">The propname XML element specifies that only a list of 
            property names on the resource is to be returned. </t>
   <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized.  </t>
   </list>
   </t>
   <figure><artwork><![CDATA[<!ELEMENT propname EMPTY > ]]></artwork></figure>
  </section>
 
  <section title="dead-props XML Element ">
   <t><list style="hanging">
       <t hangText="Name: ">dead-props </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">The dead-props XML element specifies that all dead 
            properties, names and values, should be returned in the 
            response. </t>
   <t hangText="Extensibility: ">Normally empty, but MAY be extended with additional 
            child elements or attributes which SHOULD be ignored if not 
            recognized.  </t>
   </list>
   </t>
   <figure><artwork><![CDATA[<!ELEMENT dead-props EMPTY > 
    ]]></artwork></figure>
  </section>
  </section>

  <section title="error XML Element">
      <t><list style="hanging">
   <t hangText="Name: ">error</t>
   <t hangText="Namespace: ">DAV:</t>
   <t hangText="Purpose: ">Error responses, particularly 403 Forbidden and 409 Conflict,
     sometimes need more information to indicate what went wrong.  When an error
   response contains a body in WebDAV, the body is in XML with the root element
   'error'.  The 'error' tag SHOULD include a standard error tag defined in this
   specification or another specification.  The 'error' tag MAY include custom
   error tags (in custom namespaces) which a client can safely ignore.</t>
   <t hangText="Description: ">Contains any XML element </t>
   <t hangText="Extensibility: ">Fully extensible with additional child elements or 
            attributes which SHOULD be ignored if not recognized. </t> 
    </list></t>
   <figure><artwork><![CDATA[<!ELEMENT error ANY >  ]]></artwork></figure>
  </section>
  
</section>

<section title="DAV Properties">
  <t>
   For DAV properties, the name of the property is also the same as the 
   name of the XML element that contains its value. In the section 
   below, the final line of each section gives the element type 
   declaration using the format defined in <xref target="XML"/>. 
   The "Value" 
   field, where present, specifies further restrictions on the 
   allowable contents of the XML element using BNF (i.e., to further 
   restrict the values of a PCDATA element).  Note that a resource may 
   have only one value for a property of a given name, so the property 
   may only show up once in PROPFIND responses or PROPPATCH requests. 
  </t>
  <t>
   Some property values are calculated by the server and it is not 
   appropriate to allow client changes, thus they are protected. 
   Existing server implementations already have different sets of 
   RFC2518 properties protected, but clients can have some expectations 
   which properties are normally protected.  The value of a protected 
   property may not be changed even by a user with permission to edit 
   other properties.  The value of an unprotected property may be 
   changed by some users with appropriate permissions.  
  </t>
  
  <section title="creationdate Property">
    <t>
      <list style="hanging">
      
   <t hangText="Name: ">creationdate </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Records the time and date the resource was created. </t>
   <t hangText="Value: ">  date-time (defined in <xref target="RFC3339"/>, see the ABNF in section 
            5.6.) </t>
   <t hangText="Protected: ">MAY be protected.  Some servers allow creationdate to be 
            changed to reflect the time the document was created if 
            that is more meaningful to the user (rather than the time 
            it was uploaded).  Thus, clients SHOULD NOT use this 
            property in synchronization logic (use getetag instead). </t>
   <t hangText="COPY/MOVE behaviour: ">This property value SHOULD be kept during a 
            MOVE operation, but is normally re-initialized when a 
            resource is created with a COPY. It should not be set in a 
            COPY. </t>
   <t hangText="Description: ">The creationdate property should be defined on all DAV 
            compliant resources.  If present, it contains a timestamp 
            of the moment when the resource was created (i.e., the 
            moment it had non-null state).   </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
      </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT creationdate (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="displayname Property">
    <t>
      <list style="hanging">
      
   <t hangText="Name: ">displayname </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Provides a name for the resource that is suitable for 
            presentation to a user. </t>
   <t hangText="Value: ">Any text </t>
   <t hangText="Protected: ">Possibly </t>
   <t hangText="COPY/MOVE behaviour: ">This property value SHOULD be preserved in 
            local COPY and MOVE operations. It MAY be attempted to be 
            set in a COPY operation to a remote server. </t>
   <t hangText="Description: ">The displayname property should be defined on all DAV 
            compliant resources.  If present, the property contains a 
            description of the resource that is suitable for 
            presentation to a user.  </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
      </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT displayname (#PCDATA) > ]]></artwork></figure>
  </section>
  
  <section title="getcontentlanguage Property">
    <t>
      <list style="hanging">
      
   <t hangText="Name: ">getcontentlanguage </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Contains the Content-Language header returned by a GET 
            without accept headers </t>
   <t hangText="Value: ">language-tag (language-tag is defined in section 14.13 of 
            <xref target="RFC2616"/>) </t>
   <t hangText="Protected: "> SHOULD NOT be protected, so that clients can reset the 
            language. </t>
   <t hangText="COPY/MOVE behaviour: ">This property value SHOULD be preserved in 
            local COPY and MOVE operations. It SHOULD be attempted to 
            be set in a COPY operation to a remote server. </t>
   <t hangText="Description: ">The getcontentlanguage property MUST be defined on any 
            DAV compliant resource that returns the Content-Language 
            header on a GET.   </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
      </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT getcontentlanguage (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="getcontentlength Property">
      <t><list style="hanging">
   <t hangText="Name: ">getcontentlength </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Contains the Content-Length header returned by a GET 
            without accept headers. </t>
   <t hangText="Value: ">content-length (see section 14.14 of <xref target="RFC2616"/>) </t>
   <t hangText="Protected: ">SHOULD be protected so clients cannot set to misleading 
            values </t>
   <t hangText="Description: ">The getcontentlength property MUST be defined on any 
            DAV compliant resource that returns the Content-Length 
            header in response to a GET.  </t>
   <t hangText="COPY/MOVE behaviour: ">This property value is dependent on the size of 
            the destination resource, not the value of the property on 
            the source resource. </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
      </list>
    </t>

   <figure><artwork><![CDATA[<!ELEMENT getcontentlength (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="getcontenttype Property">
    <t><list style="hanging">
   <t hangText="Name: ">getcontenttype </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Contains the Content-Type header returned by a GET without 
            accept headers. </t>
   <t hangText="Value: ">media-type (defined in section 3.7 of <xref target="RFC2616"/>) </t>
   <t hangText="Protected: ">SHOULD NOT be protected, so clients may fix this value </t>
   <t hangText="COPY/MOVE behaviour: ">This property value SHOULD be preserved in 
            local COPY and MOVE operations. In a remote COPY operation 
            that is implemented through a PUT request, the PUT request 
            must have the appropriate Content-Type header. </t>
   <t hangText="Description: ">This getcontenttype property MUST be defined on 
            any DAV compliant resource that returns the Content-Type 
            header in response to a GET.  </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
    </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT getcontenttype (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="getetag Property">
    <t><list style="hanging">
   <t hangText="Name: ">getetag </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Contains the ETag header returned by a GET without accept 
            headers. </t>
   <t hangText="Value: ">entity-tag  (defined in section 3.11 of <xref target="RFC2616"/>) </t>
   <t hangText="Protected:">MUST be protected because this value is created and 
            controlled by the server. </t>
   <t hangText="COPY/MOVE behaviour: ">This property value is dependent on the final 
            state of the destination resource, not the value of the 
            property on the source resource. </t>
   <t hangText="Description: ">The getetag property MUST be defined on any DAV 
            compliant resource that returns the Etag header.  Refer to 
            RFC2616 for a complete definition of the semantics of an 
            ETag.  Note that changes in properties or lock state MUST 
            not cause a resource's ETag to change.  </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
    </list>
    </t>
    
   <figure><artwork><![CDATA[<!ELEMENT getetag (#PCDATA) > 
    ]]></artwork></figure>
  </section>
  
  <section title="getlastmodified Property">
    <t><list style="hanging">
   <t hangText="Name: ">getlastmodified </t>
   <t hangText="Namespace: "> DAV: </t>
   <t hangText="Purpose: ">Contains the Last-Modified header returned by a GET method 
            without accept headers. </t>
   <t hangText="Value: ">rfc1123-date  (defined in section 3.3.1 of <xref target="RFC2616"/>) </t>
   <t hangText="Protected: ">SHOULD be protected because some clients may rely on the 
            value for appropriate caching behavior, or on the value of 
            the Last-Modified header to which this property is linked. </t>
   <t hangText="COPY/MOVE behaviour: ">This property value is dependent on the last 
            modified date of the destination resource, not the value of 
            the property on the source resource.  Note that some server 
            implementations use the file system date modified value for 
            the 'getlastmodified' value, and this is preserved in a 
            MOVE even when the HTTP Last-Modified value SHOULD change. 
            Thus, clients cannot rely on this value for caching and 
            SHOULD use ETags. </t>
   <t hangText="Description: ">Note that the last-modified date on a resource SHOULD 
            only reflect changes in the body (the GET responses) of the 
            resource.  A change in a property only SHOULD NOT cause the 
            last-modified date to change, because clients MAY rely on 
            the last-modified date to know when to overwrite the 
            existing body. The getlastmodified property MUST be defined 
            on any DAV compliant resource that returns the Last-Modified
            header in response to a GET.  </t>
   <t hangText="Extensibility: ">MAY contain attributes which SHOULD be ignored if not 
            recognized. </t>
    </list>
    </t>

   <figure><artwork><![CDATA[<!ELEMENT getlastmodified (#PCDATA) > 
    ]]></artwork></figure>
    
  </section>
  
  <section title="lockdiscovery Property">
  <t><list style="hanging">
   <t hangText="Name: ">lockdiscovery</t> 
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Describes the active locks on a resource </t>
   <t hangText="Protected: ">MUST be protected.  Clients change the list of locks 
            through LOCK and UNLOCK, not through PROPPATCH. </t>
   <t hangText="COPY/MOVE behaviour: ">The value of this property depends on the lock 
            state of the destination, not on the locks of the source 
            resource.  Recall that locks are not moved in a MOVE 
            operation. </t>
   <t hangText="Description: ">The lockdiscovery property returns a listing of who has 
            a lock, what type of lock he has, the timeout type and the 
            time remaining on the timeout, and the associated lock 
            token.  If there are no locks, but the server supports 
            locks, the property will be present but contain zero 
            'activelock' elements.  If there is one or more lock, an 
            'activelock' element appears for each lock on the resource.</t>  
   <t hangText="Extensibility: ">MAY be extended with additional child elements or 
            attributes which SHOULD be ignored if not recognized.  </t>
  </list>
  </t>
  
   <figure><artwork><![CDATA[<!ELEMENT lockdiscovery (activelock)* > ]]></artwork></figure> 
  
    <section title="Example - Retrieving the lockdiscovery Property">
      <figure>
      <!-- BZ 182 -->
        <artwork><![CDATA[
    
   >>Request 
    
     PROPFIND /container/ HTTP/1.1 
     Host: www.example.com 
     Content-Length: xxxx 
     Content-Type: text/xml; charset="utf-8" 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:propfind xmlns:D='DAV:'> 
      <D:prop><D:lockdiscovery/></D:prop> 
     </D:propfind> 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:multistatus xmlns:D='DAV:'> 
      <D:response> 
        <D:href>http://www.example.com/container/</D:href> 
        <D:propstat> 
          <D:prop> 
            <D:lockdiscovery> 
             <D:activelock> 
              <D:locktype><D:write/></D:locktype> 
              <D:lockscope><D:exclusive/></D:lockscope> 
              <D:depth>0</D:depth> 
              <D:owner>Jane Smith</D:owner> 
              <D:timeout>Infinite</D:timeout> 
              <D:locktoken> 
                <D:href
>urn:uuid:f81de2ad-7f3d-a1b2-4f3c-00a0c91a9d76</D:href> 
              </D:locktoken> 
              <D:lockroot> 
                <D:href>http://www.example.com/container/</D:href> 
              </D:lockroot> 
              </D:activelock> 
            </D:lockdiscovery> 
          </D:prop> 
          <D:status>HTTP/1.1 200 OK</D:status> 
        </D:propstat> 
      </D:response> 
     </D:multistatus> 
      ]]></artwork>
        <postamble>
   This resource has a single exclusive write lock on it, with an 
   infinite timeout.
        </postamble>
      </figure>
      
    </section>
  </section>
  
  <section title="resourcetype Property">
    <t><list style="hanging">
   <t hangText="Name: ">resourcetype </t>
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">Specifies the nature of the resource. </t>
   <t hangText="Protected: ">SHOULD be protected. Resource type is generally decided 
            through the operation creating the resource (MKCOL vs PUT), 
            not by PROPPATCH. </t>
   <t hangText="COPY/MOVE behaviour: ">Generally a COPY/MOVE of a resource results in 
            the same type of resource at the destination. In a remote 
            COPY, the source server SHOULD NOT attempt to set this 
            property. </t>
   <t hangText="Description: ">The resourcetype property MUST be defined on all DAV 
            compliant resources.  The default value is empty. </t>
   <t hangText="Extensibility: ">MAY be extended with any child elements or attributes 
            which SHOULD be ignored if not recognized.  If the element 
            contains the 'collection' child element plus additional 
            unrecognized elements/attributes, it should generally be 
            treated as a collection.  If the element contains no 
            recognized child elements it should be treated as a non-collection
            WebDAV-compliant resource. </t>
    </list>
    </t>
   <figure>
     <preamble>Example: (fictional example to show extensibility) </preamble>
     <artwork><![CDATA[
    <x:resourcetype xmlns:x="DAV:"> 
        <x:collection/> 
        <f:search-results xmlns:f="http://www.example.com/ns"/> 
    </x:resourcetype> 
     ]]></artwork>
   </figure>
  </section>
  
  <section title="supportedlock Property">
    <t><list style="hanging">
   <t hangText="Name: ">supportedlock</t> 
   <t hangText="Namespace: ">DAV: </t>
   <t hangText="Purpose: ">To provide a listing of the lock capabilities supported by 
            the resource. </t>
   <t hangText="Protected: ">MUST be protected. Servers determine what lock mechanisms 
            are supported, not clients. </t>

   <t hangText="COPY/MOVE behaviour: ">This property value is dependent on the kind of 
            locks supported at the destination, not on the value of the 
            property at the source resource. Servers attempting to COPY 
            to a destination should not attempt to set this property at 
            the destination. </t>
   <t hangText="Description: ">The supportedlock property of a resource returns a 
            listing of the combinations of scope and access types which 
            may be specified in a lock request on the resource.  Note 
            that the actual contents are themselves controlled by 
            access controls so a server is not required to provide 
            information the client is not authorized to see. </t> 
   <t hangText="Extensibility: ">MAY be extended with any child elements or attributes 
            which SHOULD be ignored if not recognized.   </t>
    </list></t>
    
    <figure><artwork><![CDATA[<!ELEMENT supportedlock (lockentry)* > ]]></artwork></figure>
    
    <section title="Example - Retrieving the supportedlock Property">
    
      <figure>
        <artwork><![CDATA[
   >>Request 
    
     PROPFIND  /container/ HTTP/1.1 
     Host: www.example.com 
     Content-Length: xxxx 
     Content-Type: text/xml; charset="utf-8" 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:propfind xmlns:D="DAV:"> 
      <D:prop><D:supportedlock/></D:prop> 
     </D:propfind> 
    
   >>Response 
    
     HTTP/1.1 207 Multi-Status 
     Content-Type: text/xml; charset="utf-8" 
     Content-Length: xxxx 
      
     <?xml version="1.0" encoding="utf-8" ?> 
     <D:multistatus xmlns:D="DAV:"> 
      <D:response> 
        <D:href>http://www.example.com/container/</D:href> 
        <D:propstat> 
          <D:prop> 
            <D:supportedlock> 
              <D:lockentry> 
                <D:lockscope><D:exclusive/></D:lockscope> 
                <D:locktype><D:write/></D:locktype> 
              </D:lockentry> 
              <D:lockentry> 
                <D:lockscope><D:shared/></D:lockscope> 
                <D:locktype><D:write/></D:locktype> 
              </D:lockentry> 
            </D:supportedlock> 
          </D:prop> 
          <D:status>HTTP/1.1 200 OK</D:status> 
        </D:propstat> 
      </D:response> 
     </D:multistatus> 
        ]]></artwork>
      </figure>
    </section>
  </section>
  
    </section>
    
    <section title="Precondition/postcondition XML elements" anchor="pre_post">
        <t>
            The numerical status codes used in HTTP responses are not 
            sufficiently granular or informative for all purposes.  Some extensions
            to HTTP have used the error response body along with some status codes 
            in order to provide additiona machine-readable response detail.  The
            machine-readable codes are XML elements classified as preconditions (generally client
            error or failure to meet the conditions in order for the request to be
            considered) and postconditions (generally server error or failure to respond
            successfully to an otherwise valid request).  The precondition or postcondition
            XML element appears inside an 'error' element which is the root of the XML 
            body of the response.  The 'error' root element or the precondition or postcondition
            elements MAY contain additional XML elements or attributes not defined in this
            specification.
        </t>
        
        <t>
            XML elements in error response bodies were not used in RFC2518, but were 
            introduced in RFC2518bis.  Thus, use of these informative elements is
            RECOMMENDED.  Even if clients do not automatically recognize the error bodies
            they can be quite useful in interoperability testing and debugging.
        </t>

        <t><list style="hanging">
            <t hangText="Name:">external-entities-forbidden</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">403 Forbidden</t>
            <t hangText="Purpose:">(precondition) -- If the server rejects a client 
                request because the request body contains an external entity, the 
                server SHOULD use this error.
            </t>
            
        </list>
        </t>
    <figure><artwork><![CDATA[<!ELEMENT external-entities-forbidden EMPTY > ]]></artwork></figure>
        
        <t><list style="hanging">
            <t hangText="Name:">requesturi-must-match-lock-token</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">400 Bad Request</t>
            <t hangText="Purpose:">(precondition) -- 
   A request may include a Lock-Token header to identify a lock for the purposes of
   an operation such as refresh LOCK or UNLOCK.  However, if the Request-URI doe not
   fall within the scope of the lock identified by the token, the server SHOULD use 
   this error.  The lock may have
   a scope that does not include the Request-URI, or the lock could have disappeared,
   or the token may be invalid.</t>
        </list>
        </t>
            <figure><artwork><![CDATA[<!ELEMENT requesturi-must-match-lock-token EMPTY > ]]></artwork></figure>

        <t><list style="hanging">
            <t hangText="Name:">missing-lock-token</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">400 Bad Request</t>
            <t hangText="Purpose:">(precondition) -- If the server rejects a request
                because the request MUST have a lock token and is missing the lock
                token header or header value (e.g. on an UNLOCK request), 
                the server SHOULD use this error.  The 'missing-lock-token'
              element MUST contain at least one URL of a locked resource for which
              a lock token was expected.
            </t>
        </list>
        </t>
        <figure><artwork><![CDATA[<!ELEMENT missing-lock-token href* > ]]></artwork></figure>
        
        <t><list style="hanging">
            <t hangText="Name:">live-properties-not-preserved</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">409 Conflict</t>
            <t hangText="Purpose:">(postcondition) -- The server received an
                otherwise-valid MOVE or COPY request, but cannot maintain the live
                properties with the same behavior at the destination.  
                It may be that the server only supports some live properties
                in some parts of the repository, or simply has an internal error.
            </t>
        </list>
        </t>
        <figure><artwork><![CDATA[<!ELEMENT live-properties-not-preserved EMPTY > ]]></artwork></figure>
        
        <t><list style="hanging">
            <t hangText="Name:">read-only-property</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">403 Forbidden</t>
            <t hangText="Purpose:">(precondition) -- The client attempted to set
                a read-only property in a PROPPATCH (such as 'getetag').
            </t>
        </list>
        </t>
        
        <figure><artwork><![CDATA[<!ELEMENT read-only-property EMPTY > ]]></artwork></figure>
        
        <t><list style="hanging">
            <t hangText="Name:">propfind-infinite-depth-forbidden</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">403 Forbidden</t>
            <t hangText="Purpose:">(precondition) -- This server does not allow
                infinite-depth PROPFIND requests on collections.
            </t>
        </list>
        </t>
        
        <figure><artwork><![CDATA[<!ELEMENT propfind-infinite-depth-forbidden EMPTY > ]]></artwork></figure>
      
        <t><list style="hanging">
            <t hangText="Name:">need-privileges</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">403 Forbidden</t>
            <t hangText="Purpose:">(precondition) -- The currently authenticated
                user simply does not have the privileges required to do the
                requested operation (e.g. UNLOCK a lock created by someone else).
            </t>
        </list>
        </t>
        
        <figure><artwork><![CDATA[<!ELEMENT need-privileges EMPTY > ]]></artwork></figure>
        
        <t><list style="hanging">
            <t hangText="Name:">missing-lock-token</t>
            <t hangText="Namespace:">DAV:</t>
            <t hangText="Use with:">423 Locked</t>
            <t hangText="Purpose:">(precondition) -- The request could not succeed
                because a lock token should have been provided.  This element, if 
                present, MUST contain the URL of a locked resource that prevented
                the request.  In 
                cases of MOVE, COPY and DELETE where collection locks are involved,
                it can be difficult for the client to find out which locked resource 
                made the request fail -- but the server is only resonsible for returning
                one such locked resource.  The server MAY return every locked resource
                that prevented the request from succeeding if it knows them all.
            </t>
        </list>
        </t>
        
        <figure><artwork><![CDATA[<!ELEMENT missing-lock-token (href+) > ]]></artwork></figure>
        
    </section>

<section title="Instructions for Processing XML in DAV" anchor="xml-processing">
  <t>
   All DAV compliant resources MUST ignore any unknown XML element and 
   all its children encountered while processing a DAV method that uses 
   XML as its command language. 
  </t>
  <t>
   This restriction also applies to the processing, by clients, of DAV 
   property values where unknown XML elements SHOULD be ignored unless 
   the property's schema declares otherwise. 
  </t>
  <t>
   This restriction does not apply to setting dead DAV properties on 
   the server where the server MUST record unknown XML elements. 
  </t>
  <t>
   Additionally, this restriction does not apply to the use of XML 
   where XML happens to be the content type of the entity body, for 
   example, when used as the body of a PUT. 
  </t>
  <t>
   Since XML can be transported as text/xml or application/xml, a DAV 
   server MUST accept DAV method requests with XML parameters 
   transported as either text/xml or application/xml, and a DAV client 
   MUST accept XML responses using either text/xml or application/xml. 
  </t>
  <t>
   XML DTD fragments are included for all the XML elements defined in 
   this specification. However, legal XML may not be valid according to 
   any DTD due to namespace usage and extension rules, so the DTD is 
   only informational.  A recipient of a WebDAV message with an XML 
   body MUST NOT validate the XML document according to any hard-coded 
   or dynamically-declared DTD. 
  </t>
</section> 
    
<section title="DAV Compliance Classes" anchor="compliance-classes">
  <t>
   A DAV compliant resource can advertise several classes of 
   compliance.  A client can discover the compliance classes of a 
   resource by executing OPTIONS on the resource, and examining the 
   "DAV" header which is returned.  Note particularly that resources 
   are spoken of as being compliant, rather than servers. That is 
   because theoretically some resources on a server could support 
   different feature sets.  E.g. a server could have a sub-repository 
   where an advanced feature like server was supported, even if that 
   feature was not supported on all servers. 
  </t>
  <t>
   Since this document describes extensions to the HTTP/1.1 protocol, 
   minimally all DAV compliant resources, clients, and proxies MUST be 
   compliant with <xref target="RFC2616"/>. 
  </t>
  <t>
   A resource that is class 2 compliant must also be class 1 compliant, 
   and a resource that is compliant with "bis" must also be class 1 
   compliant.   
  </t>
 
  <section title="Class 1">
    <t>
   A class 1 compliant resource MUST meet all "MUST" requirements in 
   all sections of this document. 
    </t>
    <t>
   Class 1 compliant resources MUST return, at minimum, the value "1" 
   in the DAV header on all responses to the OPTIONS method. 
    </t>
  </section>
  
  <section title="Class 2"> 
    <t>
   A class 2 compliant resource MUST meet all class 1 requirements and 
   support the LOCK method, the supportedlock property, the 
   lockdiscovery property, the Time-Out response header and the Lock-Token
   request header.  A class "2" compliant resource SHOULD also 
   support the Time-Out request header and the owner XML element. 
    </t>
    <t>
   Class 2 compliant resources MUST return, at minimum, the values "1" 
   and "2" in the DAV header on all responses to the OPTIONS method. 
    </t>
  </section>
  
  <section title="Class 'bis'">
    <t>
   A resource can explicitly advertise its support for the revisions to 
   RFC2518 made in this document. In particular, this allows clients to 
   use the Force-Authentication header on requests.  Class 1 must be 
   supported as well. Class 2 MAY be supported.   
    </t>
    <t>
   A resource that supports bis MUST support: 
    </t>
    <t><list style="symbols">
      <t>the Force-Authentication header.  </t>
      <t>Any behavior that it supports, in the manner specified in this 
   document, rather than in the manner specified in RFC2518, for all 
   client requests.  A server MAY use an older behavior for specific 
   clients that are discovered to have interoperability problems with 
   the requirements of this specification, but MUST NOT use an older 
   behavior indiscriminately. </t>
    
    </list></t>
    <figure>
      <preamble>Example:</preamble>
      <artwork>
         DAV: 1, bis 
      </artwork>
    </figure>
  </section>
</section>
    
<section title="Internationalization Considerations" anchor="i18n">
  <t>
   In the realm of internationalization, this specification complies 
   with the IETF Character Set Policy <xref target="RFC2277"/>. In this specification, 
   human-readable fields can be found either in the value of a 
   property, or in an error message returned in a response entity body.  
   In both cases, the human-readable content is encoded using XML, 
   which has explicit provisions for character set tagging and 
   encoding, and requires that XML processors read XML elements 
   encoded, at minimum, using the UTF-8 <xref target="RFC2279"/> and UTF-16 encodings of 
   the ISO 10646 multilingual plane.  XML examples in this 
   specification demonstrate use of the charset parameter of the 
   Content-Type header, as defined in <xref target="RFC2376"/>, as well as the XML 
   declarations which provide charset identification information for 
   MIME and XML processors. 
  </t>
  <t>  
   XML also provides a language tagging capability for specifying the 
   language of the contents of a particular XML element.  The 
   "xml:lang" attribute appears on an XML element to identify the 
   language of its content and attributes. See <xref target="XML"/> for 
   definitions of values and scoping. 
  </t>
  <t>  
   WebDAV applications MUST support the character set tagging, 
   character set encoding, and the language tagging functionality of 
   the XML specification.  Implementors of WebDAV applications are 
   strongly encouraged to read "XML Media Types" <xref target="RFC2376"/> for 
   instruction on which MIME media type to use for XML transport, and 
   on use of the charset parameter of the Content-Type header. 
  </t>
  <t>  
   Names used within this specification fall into four categories: 
   names of protocol elements such as methods and headers, names of XML 
   elements, names of properties, and names of conditions.  Naming of 
   protocol elements follows the precedent of HTTP, using English names 
   encoded in USASCII for methods and headers.  Since these protocol 
   elements are not visible to users, and are simply long token 
   identifiers, they do not need to support multiple languages.  
   Similarly, the names of XML elements used in this specification are 
   not visible to the user and hence do not need to support multiple 
   languages. 
  </t>
  <t>  
   WebDAV property names are qualified XML names (pairs of XML 
   namespace name and local name).  Although some applications (e.g., a 
   generic property viewer) will display property names directly to 
   their users, it is expected that the typical application will use a 
   fixed set of properties, and will provide a mapping from the 
   property name and namespace to a human-readable field when 
   displaying the property name to a user.  It is only in the case 
   where the set of properties is not known ahead of time that an 
   application need display a property name to a user. We recommend 
   that applications provide human-readable property names wherever 
   feasible. 
  </t>
  <t>  
   For error reporting, we follow the convention of HTTP/1.1 status 
   codes, including with each status code a short, English description 
   of the code (e.g., 423 (Locked)).  While the possibility exists that 
   a poorly crafted user agent would display this message to a user, 
   internationalized applications will ignore this message, and display 
   an appropriate message in the user's language and character set. 
  </t>
  <t>  
    
   Since interoperation of clients and servers does not require locale 
   information, this specification does not specify any mechanism for 
   transmission of this information. 
  </t>
</section>

<section title="Security Considerations" anchor="security">
  <t>  
   This section is provided to detail issues concerning security 
   implications of which WebDAV applications need to be aware. 
  </t>
  <t>  
   All of the security considerations of HTTP/1.1 (discussed in 
   <xref target="RFC2616"/>) and XML (discussed in 
   <xref target="RFC2376"/>) also apply to WebDAV. In 
   addition, the security risks inherent in remote authoring require 
   stronger authentication technology, introduce several new privacy 
   concerns, and may increase the hazards from poor server design. 
   These issues are detailed below. 
  </t>
  <section title="Authentication of Clients">
    <t>  
   Due to their emphasis on authoring, WebDAV servers need to use 
   authentication technology to protect not just access to a network 
   resource, but the integrity of the resource as well.  Furthermore, 
   the introduction of locking functionality requires support for 
   authentication. 
    </t>
    <t>  
    
   A password sent in the clear over an insecure channel is an 
   inadequate means for protecting the accessibility and integrity of a 
   resource as the password may be intercepted.  Since Basic 
   authentication for HTTP/1.1 performs essentially clear text 
   transmission of a password, Basic authentication MUST NOT be used to 
   authenticate a WebDAV client to a server unless the connection is 
   secure. Furthermore, a WebDAV server MUST NOT send Basic 
   authentication credentials in a WWW-Authenticate header unless the 
   connection is secure.  Examples of secure connections include a 
   Transport Layer Security (TLS) connection employing a strong cipher 
   suite with mutual authentication of client and server, or a 
   connection over a network which is physically secure, for example, 
   an isolated network in a building with restricted access. 
       </t>
    <t>  

   WebDAV applications MUST support the Digest authentication scheme 
   <xref target="RFC2069"/>. Since Digest authentication verifies that both parties to 
   a communication know a shared secret, a password, without having to 
   send that secret in the clear, Digest authentication avoids the 
   security problems inherent in Basic authentication while providing a 
   level of authentication which is useful in a wide range of 
   scenarios. 
     </t>
  </section>
  
  <section title="Denial of Service">
    <t>
   Denial of service attacks are of special concern to WebDAV servers.  
   WebDAV plus HTTP enables denial of service attacks on every part of 
   a system's resources. 
      </t>
    <t>  

   The underlying storage can be attacked by PUTting extremely large 
   files. 
    </t>
    <t>  
    
   Asking for recursive operations on large collections can attack 
   processing time. 
    </t>
    <t>  
  
   Making multiple pipelined requests on multiple connections can 
   attack network connections. 
    </t>
    <t>  
  
   WebDAV servers need to be aware of the possibility of a denial of 
   service attack at all levels. 
    </t>
    
  </section>
  
  <section title="Security through Obscurity">
    <t>
   WebDAV provides, through the PROPFIND method, a mechanism for 
   listing the member resources of a collection.  This greatly 
   diminishes the effectiveness of security or privacy techniques that 
   rely only on the difficulty of discovering the names of network 
   resources.  Users of WebDAV servers are encouraged to use access 
   control techniques to prevent unwanted access to resources, rather 
   than depending on the relative obscurity of their resource names. 
  </t>
  </section>
  
  <section title="Privacy Issues Connected to Locks">
    <t>
   When submitting a lock request a user agent may also submit an owner 
   XML field giving contact information for the person taking out the 
   lock (for those cases where a person, rather than a robot, is taking 
   out the lock). This contact information is stored in a lockdiscovery 
   property on the resource, and can be used by other collaborators to 
   begin negotiation over access to the resource.  However, in many 
   cases this contact information can be very private, and should not 
   be widely disseminated.  Servers SHOULD limit read access to the 
   lockdiscovery property as appropriate.  Furthermore, user agents 
   SHOULD provide control over whether contact information is sent at 
   all, and if contact information is sent, control over exactly what 
   information is sent. 
   </t>
  </section>
  
  <section title="Privacy Issues Connected to Properties">
    <t>
   Since property values are typically used to hold information such as 
   the author of a document, there is the possibility that privacy 
   concerns could arise stemming from widespread access to a resource's 
   property data.  To reduce the risk of inadvertent release of private 
   information via properties, servers are encouraged to develop access 
   control mechanisms that separate read access to the resource body 
   and read access to the resource's properties.  This allows a user to 
   control the dissemination of their property data without overly 
   restricting access to the resource's contents. 
    </t>
  </section>
  
  <section title="Implications of XML External Entities">
    <t>
   XML supports a facility known as "external entities", defined in 
   section 4.2.2 of <xref target="XML"/>, which instruct an XML processor to 
   retrieve and include additional XML. An external XML entity can be 
   used to append or modify the document type declaration (DTD) 
   associated with an XML document.  An external XML entity can also be 
   used to include XML within the content of an XML document.  For non-validating
   XML, such as the XML used in this specification, 
   including an external XML entity is not required by XML.  However, 
   XML does state that an XML processor may, at its 
   discretion, include the external XML entity. 
    </t>
    <t>
   External XML entities have no inherent trustworthiness and are 
   subject to all the attacks that are endemic to any HTTP GET request.  
   Furthermore, it is possible for an external XML entity to modify the 
   DTD, and hence affect the final form of an XML document, in the 
   worst case significantly modifying its semantics, or exposing the 
   XML processor to the security risks discussed in <xref target="RFC2376"/>. 
   Therefore, implementers must be aware that external XML entities 
   should be treated as untrustworthy.  If a server implementor chooses 
   not to handle external XML entities, it SHOULD respond to requests 
   containing external entities with the precondition defined above
   (external-entities-forbidden). 
    </t>
    <t>
   There is also the scalability risk that would accompany a widely 
   deployed application which made use of external XML entities.  In 
   this situation, it is possible that there would be significant 
   numbers of requests for one external XML entity, potentially 
   overloading any server which fields requests for the resource 
   containing the external XML entity. 
    </t>
    
  </section>
  
  <section title="Risks Connected with Lock Tokens">
    <t>
   This specification requires the use of "A Universally 
   Unique Identifier (UUID) URN Namespace" (<xref target="RFC4122"/>) for lock tokens, in order to guarantee 
   their uniqueness across space and time.  The security considerations 
      for UUIDs do not apply because WebDAV does not assume that lock tokens
      are supposed to be hard to guess or require integrity.   In addition,
      UUIDs MAY contain a IEEE 802 node ID, usually the host address.  Since a 
      WebDAV server will 
   issue many locks over its lifetime, the use of node IDs might cause the 
      WebDAV server to reveal its IEEE 802 address. Several risks are related
      to this:
    </t>
    <t><list style="symbols">
      <t>It is possible to track the movement of hardware from subnet to 
   subnet.</t> 
    
      <t>It may be possible to identify the manufacturer of the hardware 
   running a WebDAV server. 
    </t>
      <t>It may be possible to determine the number of each type of 
   computer running WebDAV. </t>
     </list></t>
  </section>
  
  <section title="Hosting malicious scripts executed on client machines">
    <t>HTTP has the ability to host scripts which are executed on client machines.
      These scripts can be used to read another user's cookies and therefore may
      provide an attacker the ability to use another user's session, assume their
      identity temporarily and gain access to their resources.  Other attacks are
    also possible with client-executed scripts.</t>
    
    <t>WebDAV may worsen this situation only by making it easier for a Web server 
      to host content provided by many different authors (making it harder to trust
      the content providers) and to host content with restricted access alongside
    public pages (see particularly RFC3744).</t>
    
    <t>HTTP servers may mitigate some of these threats by filtering content in 
      areas where many authors contribute pages -- the server could, for example, 
    remove script from HTML pages.</t>
    
    <t>This vulnerability should provide yet another reason for server implementors
      and administrators not to replace authentication mechanisms with cookie-based
      session tokens if there's any sensitive information relying on the authenticated
    identity. </t>
    
    <t>HTTP and WebDAV client implementors might consider locking down the use of 
    scripts and cookies based on these considerations.</t>
  </section>

</section>

<section title = "IANA Considerations">
  <t>
    This specification defines two URI schemes:
    
    <list style="numbers"><!-- BZ89 -->
      <t>the "opaquelocktoken" scheme defined in <xref target="opaquelocktoken"/>, and
      </t>
      <t>the "DAV" URI scheme, which historically was used in RFC2518 to disambiguate 
      WebDAV property and XML element names and which continues to be used for that 
      purpose in this specification and others extending WebDAV. Creation of 
      identifiers in the "DAV:" namespace is controlled by the IETF.</t>
    </list>
  </t>
  
   <t>
   XML namespaces disambiguate WebDAV property names and XML elements.  Any WebDAV user 
     or application can define a new namespace in order to create custom properties
     or extend WebDAV XML syntax.  IANA does not need to manage such namespaces, property 
     names or element names.</t>
  
</section>

<section title="Acknowledgements">
  <t>
   A specification such as this thrives on piercing critical review and 
   withers from apathetic neglect.  The authors gratefully acknowledge 
   the contributions of the following people, whose insights were so 
   valuable at every stage of our work. 
  </t>
  <t>
   Contributors to RFC2518 
  </t>
  <t>
   Terry Allen, Harald Alvestrand, Jim Amsden, Becky Anderson, Alan 
   Babich, Sanford Barr, Dylan Barrell, Bernard Chester, Tim Berners-Lee,
   Dan Connolly, Jim Cunningham, Ron Daniel, Jr., Jim Davis, Keith 
   Dawson, Mark Day, Brian Deen, Martin Duerst, David Durand, Lee 
   Farrell, Chuck Fay, Wesley Felter, Roy Fielding, Mark Fisher, Alan 
   Freier, George Florentine, Jim Gettys, Phill Hallam-Baker, Dennis 
   Hamilton, Steve Henning, Mead Himelstein, Alex Hopmann, Andre van 
   der Hoek, Ben Laurie, Paul Leach, Ora Lassila, Karen MacArthur, 
   Steven Martin, Larry Masinter, Michael Mealling, Keith Moore, Thomas 
   Narten, Henrik Nielsen, Kenji Ota, Bob Parker, Glenn Peterson, Jon 
   Radoff, Saveen Reddy, Henry Sanders, Christopher Seiwald, Judith 
   Slein, Mike Spreitzer, Einar Stefferud, Greg Stein, Ralph Swick, 
   Kenji Takahashi, Richard N. Taylor, Robert Thau, John Turner, Sankar 
   Virdhagriswaran, Fabio Vitali, Gregory Woodhouse, and Lauren Wood. 
  </t>
  <t>
   Two from this list deserve special mention.  The contributions by 
   Larry Masinter have been invaluable, both in helping the formation 
   of the working group and in patiently coaching the authors along the 
   way.  In so many ways he has set high standards we have toiled to 
   meet. The contributions of Judith Slein in clarifying the 
   requirements, and in patiently reviewing draft after draft, both 
   improved this specification and expanded our minds on document 
   management. 
  </t>
  <t>
   We would also like to thank John Turner for developing the XML DTD. 
  </t>
  <t>
   The authors of RFC2518 were Yaron Goland, Jim Whitehead, A. Faizi, 
   Steve Carter and D. Jensen.  Although their names had to be removed 
   due to IETF author count restrictions they can take credit for the 
   majority of the design of WebDAV. 
  </t>
  <t>
   Additional Contributors to This Specification 
  </t>
  <t> 
   Valuable contributions to RFC2518 bis came from some already named. 
   New contributors must also be gratefully acknowledged. Julian 
   Reschke, Geoff Clemm, Joel Soderberg, and Dan Brotsky hashed out 
   specific text on the list or in meetings. Ilya Kirnos supplied text 
   for Force-Authentication header.  Joe Hildebrand contributed as 
   co-chair.  Barry Lind described an additional security consideration.
   Jason Crawford tracked issue status for this document for a period of
    years, followed by Elias Sinderson.
  </t>
  <!-- BZ 185 -->
  <section title="Previous Authors' Addresses">
    <t>
     Y. Y. Goland, 
     Microsoft Corporation, 
     One Microsoft Way, 
     Redmond, WA 98052-6399. 
     Email: [email-masked]. 
    </t>
    <t>
     E. J. Whitehead, Jr., 
     Dept. Of Information and Computer Science, 
     University of California, Irvine,
     Irvine, CA 92697-3425.
     Email: [email-masked]. 
    </t>
    <t>
     A. Faizi,
     Netscape, 
     685 East Middlefield Road, 
     Mountain View, CA 94043.
     Email: [email-masked]. 
    </t>
    <t>
     S. R. Carter, 
     Novell, 
     1555 N. Technology Way, 
     M/S ORM F111, 
     Orem, UT 84097-2399. 
     Email: [email-masked]. 
    </t>
    <t>
     D. Jensen, 
     Novell, 
     1555 N. Technology Way, 
     M/S ORM F111, 
     Orem, UT 84097-2399. 
     Email: [email-masked]. 
    </t>
  </section>

</section>

</middle>

<back>

<references title="Normative References">
    &rfc2069;
    &rfc2119;
    &rfc2277;
    &rfc2279;
    &rfc2518; 
    &rfc2616;
    &rfc3339;
    &rfc3986;  
    &rfc4122;
    &w3cXMLNS;

<!-- BZ68 -->
<reference anchor="XML" target="http://www.w3.org/TR/2004/REC-xml-20040204">
  <front>
    <title>Extensible Markup Language (XML) 1.0 (Third Edition)</title>
    <author initials="T." surname="Bray" fullname="Tim Bray">
      <organization>Textuality and Netscape</organization>
      <address>
        <email>[email-masked]</email>
      </address>
    </author>
    <author initials="J." surname="Paoli" fullname="Jean Paoli">
      <organization>Microsoft</organization>
      <address>
        <email>[email-masked]</email>
      </address>
    </author>
    <author initials="C.M." surname="Sperberg-McQueen" fullname="C. M. Sperberg-McQueen">
      <organization>University of Illinois at Chicago and Text Encoding Initiative</organization>
      <address>
        <email>[email-masked]</email>
      </address>
    </author>
    <author initials="E." surname="Maler" fullname="Eve Maler">
      <organization>Sun Microsystems</organization>
      <address>
        <email>[email-masked]</email>
      </address>
    </author>
    <author initials="F." surname="Yergeau" fullname="Francois Yergeau">
      <organization/>
      <address>
        <email>[email-masked]</email>
      </address>
    </author>
    <date day="4" month="February" year="2004"/>
  </front>
  <seriesInfo name="W3C" value="REC-xml-20040204"/>
</reference>
    
</references>
  
<references title="Informational References">

     &rfc2291;
     &rfc2376;
     &rfc3253;
     &rfc3744;

</references>

<section title="Notes on Processing XML Elements">
    
  <section title="Notes on Empty XML Elements">
      
    <t>
 XML supports two mechanisms for indicating that an XML element does 
 not have any content.  The first is to declare an XML element of the 
 form &lt;A&gt;&lt;/A&gt;.  The second is to declare an XML element of the form 
 &lt;A/&gt;.  The two XML elements are semantically identical. 
    </t>
  </section>
  <section title="Notes on Illegal XML Processing">
    <t>
 XML is a flexible data format that makes it easy to submit data that 
 appears legal but in fact is not.  The philosophy of "Be flexible in 
 what you accept and strict in what you send" still applies, but it 
 must not be applied inappropriately.  XML is extremely flexible in 
 dealing with issues of white space, element ordering, inserting new 
 elements, etc.  This flexibility does not require extension, 
 especially not in the area of the meaning of elements. 
    </t>
    <t>
 There is no kindness in accepting illegal combinations of XML 
 elements.  At best it will cause an unwanted result and at worst it 
 can cause real damage. 
    </t>
  </section>
  
  <section title="Example - XML Syntax Error">
    <t>
 The following request body for a PROPFIND method is illegal. 
    </t>
    <figure>
      <artwork><![CDATA[
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:propfind xmlns:D="DAV:"> 
    <D:allprop/> 
    <D:propname/> 
   </D:propfind> 
      ]]></artwork>
    </figure>
    <t>
 The definition of the propfind element only allows for the allprop 
 or the propname element, not both.  Thus the above is an error and 
 must be responded to with a 400 (Bad Request). 
    </t>
    <t>
 Imagine, however, that a server wanted to be "kind" and decided to 
 pick the allprop element as the true element and respond to it.  A 
 client running over a bandwidth limited line who intended to execute 
 a propname would be in for a big surprise if the server treated the 
 command as an allprop. 
    </t>
    <t>
 Additionally, if a server were lenient and decided to reply to this  
 request, the results would vary randomly from server to server, with 
 some servers executing the allprop directive, and others executing 
 the propname directive. This reduces interoperability rather than 
 increasing it. 
    </t>
  </section>
  
  <section title="Example - Unknown XML Element">
    <t>
 The previous example was illegal because it contained two elements 
 that were explicitly banned from appearing together in the propfind 
 element.  However, XML is an extensible language, so one can imagine 
 new elements being defined for use with propfind.  Below is the 
 request body of a PROPFIND and, like the previous example, must be 
 rejected with a 400 (Bad Request) by a server that does not 
 understand the expired-props element. 
    </t>
    <figure>
      <artwork><![CDATA[
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:propfind xmlns:D="DAV:" 
   xmlns:E="http://www.example.com/standards/props/"> 
    <E:expired-props/> 
   </D:propfind> 
      ]]></artwork>
    </figure>
    <t>
 To understand why a 400 (Bad Request) is returned let us look at the 
 request body as the server unfamiliar with expired-props sees it. 
    </t>
    <figure>
      <artwork><![CDATA[
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:propfind xmlns:D="DAV:"   
               xmlns:E="http://www.example.com/standards/props/"> 
   </D:propfind> 
      ]]></artwork>
    </figure>
    <t>    
 As the server does not understand the expired-props element, 
 according to the WebDAV-specific XML processing rules specified in 
 <xref target="xml-processing"/>, it must ignore it.  Thus the server sees an empty 
 propfind, which by the definition of the propfind element is 
 illegal. 
    </t>
    <t>
 Please note that had the extension been additive it would not 
 necessarily have resulted in a 400 (Bad Request).  For example, 
 imagine the following request body for a PROPFIND: 
    </t>
    <figure>
      <artwork><![CDATA[
  
   <?xml version="1.0" encoding="utf-8" ?> 
   <D:propfind xmlns:D="DAV:"  
               xmlns:E="http://www.example.com/standards/props/"> 
    <D:propname/> 
    <E:leave-out>*boss*</E:leave-out> 
   </D:propfind> 
      ]]></artwork>
    </figure>
    <t>    
 The previous example contains the fictitious element leave-out. Its 
 purpose is to prevent the return of any property whose name matches 
 the submitted pattern.  If the previous example were submitted to a 
 server unfamiliar with leave-out, the only result would be that the 
 leave-out element would be ignored and a propname would be executed. 
    </t>
  </section>
</section>

<section title="Notes on HTTP Client Compatibility">
  <t>
    The PUT and DELETE methods are defined in HTTP and thus may be used by HTTP
    clients, but the responses to PUT and DELETE have been extended in this 
    specification, so some special consideration on backward compatibility is 
    worthwhile.
  </t>
  <t>First, if a PUT or DELETE request includes a header defined in this 
    specification (Depth or If), the server can assume the request comes from
    a WebDAV-compatible client. The server may even be able to track a number
    of requests across a session and know that a client is a WebDAV client. 
    However, this kind of detection may not be necessary.
  </t>
  <t>Since any HTTP client ought to handle unrecognized 400-level and 500-level 
    status codes as errors, the following
  new status codes should not present any issues: 422, 423 and 507.  424 is also
  a new status code but it appears only in the body of a Multistatus response.
  So, for example, if a HTTP client attempted to PUT or DELETE a locked resource,
  the 423 Locked response ought to result in a generic error presented to the user.</t>
  
  <t>The 102 Processing response code is new, and indicates that the client may wish
    to extend its normal timeout period.  However, the choice to extend the timeout
    period is entirely optional, and thus a HTTP client receiving a 102 Processing
    status response may time out anyway, with no avoidable adverse effects.
  </t>
  <t>The 207 Multistatus response is interesting because a HTTP client issuing a 
    DELETE request to a collection might interpret a 207 response as a success, 
    even though it does not realize the resource is a collection and cannot understand
    that the DELETE operation might have been a complete or partial failure.  Thus,
    a server MAY choose to treat a DELETE of a collection as an atomic operation, 
    and use either 204 No Content in case of success, or some appropriate error 
    response (400 or 500 level) depending on what the error was.  This approach would
    maximize backward compatibility.  However, since interoperability tests and 
    working group discussions have not turned up any instances of HTTP clients 
    issuing a DELETE request against a WebDAV collection, this concern may be more
    theoretical than practical.  Thus, servers MAY instead choose to treat any such DELETE
    request as a WebDAV request, and send a 207 Multistatus containing more detail
    about what resources could not be deleted.
  </t>
</section>

<section title="The opaquelocktoken scheme and URIs" anchor="opaquelocktoken">
  <t>The 'opaquelocktoken' URI scheme was defined in RFC2518 (and registered
    by IANA) in order
    to create syntactically correct and easy-to-generate URIs out of UUIDs,
    intended to be used as lock tokens and to be unique across all 
   resources for all time.  This scheme has been obsoleted by 
    <xref target="RFC4122"/>, but is re-defined here for clarity.</t>
    
   <t>A server MAY generate one ore more UUIDs to use with the 'opaquelocktoken' 
     scheme as lock tokens.  A server MAY 
  reuse a UUID with extension characters added.  If the server does this then
     the algorithm generating the extensions MUST guarantee that the same 
  extension will never be used twice with the associated UUID. 
   </t>
   <t>
  OpaqueLockToken-URI = "opaquelocktoken:" UUID [Extension]  ; The 
  UUID production is the string representation of a UUID. Note 
     that white space (LWS) is not allowed between 
  elements of this production. 
   </t>
   <t>
  Extension = path  ; path is defined in section 3.3 of <xref target="RFC3986"/> 
   </t>
  
</section>

<!-- BZ 187 -->
<section title="Summary of changes from RFC2518">

    <t>This section describes changes that are likely to result in implementation 
    changes due to tightened requirements or changed behavior.  A more complete
    list of changes has been published in a separate document.</t>
    
    <section title="Changes Notable to Server Implementors">

      <t>Tightened requirements for storing <xref target="property_values">property 
      values</xref> when "xml:lang" appears and also when values are XML fragments
      (specifically on preserving prefixes, namespaces and whitespace.)</t>
      
      <t>Several tightened requirements for general <xref target="response-handling">response 
      handling</xref>, including response bodies for use with errors, use of Date header,
        ETag and Location header.</t>
        
      <t>Tightened requirements for URL construction in <xref target="PROPFIND">PROPFIND</xref>
      responses.  </t>
      
      <t>Tightened requirements for checking identity of <xref target="lock-owner">lock 
      owners</xref> during operations affected by locks.</t>
      
      <t>Tightened requirements for <xref target="copy-properties">copying properties</xref>
      and <xref target="move-properties">moving properties</xref>.</t>
      
      <t>Tightened requirements on preserving owner field in <xref target="LOCK">locks</xref>.
      Added "lockroot" element to lockdiscovery information.</t>
      
      <t>New value for <xref target="DAV-header">"DAV:" header</xref> to advertise 
      support for this specification.</t>
      
      <t>Tightened requirement for <xref target="destination-header">"Destination:" 
      header</xref> to work with path values</t>
      
      <t>New <xref target="force-auth-header">"Force-Authentication:"</xref> header added.</t>
      
      <t>Several changes for <xref target="if-header">"If:" header</xref>, including requirement to 
        accept commas and "DAV:no-lock" state token.</t>

      <t>Support for UTF-16 now required (<xref target="i18n">ref</xref>).</t>

      <t>Removed definition of "source" property and special handling for dynamic resources</t>
      
      <t>Replaced lock-null resources with simpler
        <xref target="lock-unmapped-urls">locked empty resources.</xref></t>
      
      <t>Encouraged servers to <xref target="etag">change ETags</xref> 
      only when body of resource changes.</t>

    </section>

    <section title="Changes Notable to Client Implementors">
      <t>Tightened requirements for supporting <xref target="collection-resources">WebDAV
      collections</xref> within resources that do not support WebDAV (e.g. servlet containers).</t>
      
      <t>Redefined 'allprop' PROPFIND requests so that the server does not have 
      to return all properties.</t>
      
      <t>Required to handle empty multistatus responses in <xref target="PROPFIND">PROPFIND 
      responses</xref></t>
      
      <t>No more "propertybehavior" specification allowed in MOVE and COPY requests</t>
      
      <t>Support for UTF-16 now required (<xref target="i18n">ref</xref>).</t>
      
      <t>Removed definition of "source" property and special handling for dynamic resources.</t>
      
    </section>
  </section>

<!-- BZ 187 -->
<section title="Change Log (to be removed by RFC Editor before publication">
   <section title="Changes from -05 to -06">
       <t>Specified that a successful LOCK request to an unmapped URL creates a 
           new, empty locked resource.
       </t>
       <t>Resolved UNLOCK_NEEDS_IF_HEADER by clarifying that only Lock-Token 
           header is needed on UNLOCK.</t>
       <t>Added <xref target="pre_post"/> on preconditions and postconditions
       and defined a number of preconditions and postconditions.  The 'missing-lock-token'
       precondition resolves the REPORT_OTHER_RESOURCE_LOCKED issue.</t>
       <t>Added example of matching lock token to URI in the case of a collection
           lock in the If header section.</t>
       <t>Removed ability for Destination header to take "abs_path" in order
            to keep consistent with other places where client provides URLs 
            (If header, href element in request body)</t>
       <t>Clarified the href element - that it generally contains HTTP URIs but not
           always.</t>
       <t>Attempted to fix the BNF describing the If header to allow commas</t>
       <t>Clarified presence of Depth header on LOCK refresh requests.</t>
   </section>
  
  <section title="Changes in -07">
    <t>Added text to "COPY and the Overwrite Header" section to resolve
      issue OVERWRITE_DELETE_ALL_TOO_STRONG.
    </t>
    <t>Added text to "HTTP URL Namespace Model" section to provide more clarification
      and examples on what consistency means and what is not required, to resolve
    issue CONSISTENCY.</t>
    <t>Resolve DEFINE_PRINCIPAL by importing definition of principal from RFC3744.</t>
    <t>Resolve INTEROP_DELETE_AND_MULTISTATUS by adding appendix 3 discussing
    backward-compatibility concerns.</t>
    <t>Resolve DATE_FORMAT_GETLASTMODIFIED by allowing only rfc1123-date, not HTTP-date
    for getlastmodified.</t>
    <t>Resolve COPY_INTO_YOURSELF_CLARIFY by adding sentence to first para. of COPY 
    section.</t>
    <t>Confirm that WHEN_TO_MULTISTATUS_FOR_DELETE_1 and WHEN_TO_MULTISTATUS_FOR_DELETE_2 
    are resolved and tweak language in DELETE section slightly to be clearly consistent.</t>
    <t>More text clarifications to deal with several of the issues in LOCK_ISSUES. 
      This may not completely resolve that set but we need feedback from the originator
    of the issues at this point.</t>
    <t>Resolved COPY_INTO_YOURSELF_CLARIFY with new sentence in Copy For Collections 
    section.</t>
    <t>Double checked that LEVEL_OR_CLASS is resolved by using class, not level.</t>
    <t>Further work to resolve IF_AND_AUTH and LOCK_SEMANTICS, clarifying text 
      on using locks and being authenticated.</t>
    <t>Added notes on use of 503 status response to resolve issue PROPFIND_INFINITY</t>
    <t>Removed section on other uses of Metadata (and associated references)</t>
    <t>Added reference to RFC4122 for lock tokens and removed section on generating
    UUIDs</t>
    <t>Explained that even with language variation, a property has only one value
    (section 4.5).</t>
    <t>Added section on lock owner (7.1) and what to do if lock requested by 
    unauthenticated user</t>
    <t>Removed section 4.2 -- justification on why to have metadata, not needed now</t>
    <t>Removed paragraph in section 5.2 about collections with resource type
      "DAV:collection" but which are non-WebDAV compliant -- not implemented.</t>

  </section>
  
  <section title="Changes in -08">
    <t>Added security considerations section on scripts and cookie sessions,
    suggested by Barry Lind</t>
    <t>Clarified which error codes are defined and undefined in MultiStatus</t>
    <t>Moved opaquelocktoken definition to an appendix and refer to RFC4122 for use of 
    'urn:uuid:' URI scheme; fix all lock token examples to use this.</t>
    <t>Multi-status responses contain URLs which MUST either be absolute (and begin 
    with the Request-URI or MUST be relative with new limitations. (bug 12)</t>
    <t>Moved status code sections before example sections within PROPFIND section
    for section ordering consistency.</t>
    <t>Clarified use of Location header with Multi-Status</t>
    <t>Bugzilla issue resolutions: bugs 9, 12, 14, 19, 20, 29, 30, 34, 36, 102 and 172.</t>
  </section>

</section>

</back>
</rfc>

---

From: Lisa Dusseault <[email-masked]>
Date: Mon, 21 Nov 2005 10:33:58 -0800

Thanks for the help, I've incorporated many of these changes, and the 
diff format was especially useful for the whitespace-after-hyphen 
problem as well as for the symbolic references.  Here's what I haven't 
entirely incorporated:

  - Bug 30, I didn't apply the XML line breaks exactly as you did but 
tried to retain the indentation as much as possible for readability.  
Still I think it achieves valid XML-ness now.

  - Bug 41, Nesting XML definition subsections, e.g. moving  "depth XML 
element" as a subsection of "activelock XML element" and similar 
sub-section moves:  This wasn't an error in RFC2518bis, it was an 
intentional editorial choice to flatten the subsection hierarchy.  It's 
just a list of definitions, and a flat list seems more readable.  Plus, 
with the nesting subsections, some section headers (like "propstat" 
definition section in your version) start to have four section numbers 
("Section 13.9.1.1.") and either get lost or confusing in the TOC.

  - Bug 168 I applied the symbolic references changes, but I may make 
further changes in the future.  Sometimes it's not very helpful to the 
reader just to have an RFC number and not a spec name or even acronym 
-- but we can have both.  And perhaps you can suggest how to fix this 
ugly one:

   The XML namespace extension [W3C.REC-xml-names-19990114] is also used
    in this specification in order to allow for new XML elements to be
    added without fear of colliding with other element names.

  - Bug 174 is not strictly editorial, it actually changes the meaning 
of a requirement.  Here's your suggested text:

    When the property value contains
    further XML elements, namespace declarations that are in scope for 
that part of
    the XML document apply within the property value as well, and MUST
    be preserved in server storage for retransmission later.

In the context of the whole sentence, your change would state that the 
namespace declarations... MUST be preserved in server storage.  
Previously the sentence only stated that the namespace must be 
preserved in server storage.  Perhaps we can find another phrasing 
entirely.

Lisa

On Nov 21, 2005, at 5:34 AM, Julian Reschke wrote:

> Hi,
>
> the attachment fixes many editorial issues: 30, 41, 57, 63, 68, 88, 
> 89, 168, 174, 180, 182, 185, 187.
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Nov 2005 19:57:36 +0100

> Still I think it achieves valid XML-ness now.

Well, it still doesn't parse because of

         <D:lockroot>
           <D:href
           /D:href>
         </D:lockroot>

Dunno why I didn't catch it, but it's a good indicator why the XML in 
the spec should be checked by an XML parser, not us.

> ("Section 13.9.1.1.") and either get lost or confusing in the TOC.

The elements were grouped in RFC2518, and I think that was fine. If 
there was consensus for this change, it would also need to be re-sorted. 
Anyway, I think this change should be reverted.

The TOC is not an issue here, the TOC depth can be configured (although 
I personally prefer to have all entries in the TOC, that's the place 
where I look first, after all).

> reader just to have an RFC number and not a spec name or even acronym -- 
> but we can have both. And perhaps you can suggest how to fix this ugly one:
> 

Just like for XML. In-line the reference and choose a good anchor name, 
preferably the same as in RFC2518.

> - Bug 174 is not strictly editorial, it actually changes the meaning of 
> a requirement. Here's your suggested text:
> 

I would have classified it as editorial. Could you please explain why 
you changed it in the first place? Anyway, I think that "namespace 
declarations" are to be preserved.

> namespace *declarations*... MUST be preserved in server storage. 
> Previously the sentence only stated that the namespace must be preserved 
> in server storage. Perhaps we can find another phrasing entirely.

Could you please explain what "preserving the namespace name" actually 
means?

Best regards, Julian

---

From: Lisa Dusseault <[email-masked]>
Date: Mon, 21 Nov 2005 11:26:27 -0800

On Nov 21, 2005, at 10:57 AM, Julian Reschke wrote:
> Just like for XML. In-line the reference and choose a good anchor 
> name, preferably the same as in RFC2518.

Ah, I see.  What a pain to have to have the whole reference inline -- I 
like having references in some external place, safe from my typos.  
Both ugly choices, sadly.

> declarations" are to be preserved.

If we state that namespace declarations must be preserved, doesn't that 
mean that the server must return the property value with the same 
namespace declarations it was originally sent with, on the same 
element, and even including the prefix?  Because the namespace 
declaration includes the prefix, as I understand.

>
>> In the context of the whole sentence, your change would state that 
>> the namespace *declarations*... MUST be preserved in server storage. 

Presumably if we require the server to store the namespace (the text no 
longer says to store the namespace name), then that means that the 
server can remember that the element "foo" was declared in namespace 
"bar" without having to remember what element namespace "bar" was 
declared on or what prefix was used in the declaration.  But like I 
said, perhaps we can come up with better wording overall, perhaps even 
simpler.

Here's a stab at it: "When a property value contains XML elements with 
qualified names, servers retransmitting the property value MUST include 
namespaces and equivalently scoped element names. "

I'm really struggling with a way to state this -- I'm not happy at all 
with "equivalently scoped element names" but I don't think we want to 
require that the server use the exact same qualified names (that would 
also imply preserving the prefix).

Here's another stab:  "When a property value contains XML elements with 
namespaces either declared or in scope, and that property value is 
retransmitted later by the server, the property value MUST continue to 
apply the same namespaces to all elements, even if the declarations 
have changed."

Soliciting other suggestions here,
Lisa

---

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Nov 2005 22:01:48 +0100

Lisa Dusseault wrote:
> like having references in some external place, safe from my typos.  Both 
> ugly choices, sadly.

Just copy the definition once, fixing it where needed (and the 
automatically generated once frequently need fixing). They are safe from 
typos as long as changes to the documents are controlled (for instance, 
by a working revision control system). That being said, here's the entry 
  for XMLNS I used on RFC2518.xml:

     <reference anchor="REC-XML-NAMES" 
target="http://www.w3.org/TR/1999/REC-xml-names-19990114">
       <front>
         <title>Namespaces in XML</title>
         <author initials="T." surname="Bray">
           <organization>Textuality</organization>
           <address>
             <email>[email-masked]</email>
           </address>
         </author>
         <author initials="D." surname="Hollander">
           <organization>Hewlett-Packard Company</organization>
           <address>
             <email>[email-masked]</email>
           </address>
         </author>
         <author initials="A." surname="Layman">
           <organization>Microsoft</organization>
           <address>
             <email>[email-masked]</email>
           </address>
         </author>
         <date month="January" year="1999" />
       </front>
       <seriesInfo name="W3C" value="REC-xml-names-19990114" />
     </reference>

> namespace declarations it was originally sent with, on the same element, 
> and even including the prefix?  Because the namespace declaration 
> includes the prefix, as I understand.

Well, I would have preferred that instead of silently changing the 
document, you would have explained why you think it needs to be changed 
so that the problem can be discussed.

I don't see how the current text "namespace names in scope" makes any 
sense. If you don't like "namespace declarations" (which may imply 
something about prefixes, granted), just stick with the text we had 
before. What was wrong with it?

 > ...

OK, case closed. The previous text is back in. No further discussion is 
needed.

> ...

Best regards, Julian