Subject: RE: XML InfoSet and property value preservation

From: "Lukas Mathis" <[email-masked]>
Date: Fri, 18 Nov 2005 11:01:21 +0100

> Maybe you could give a concrete example?

Client A stores XML code in property x:
	<p:Foo>some data</p:Foo>

Client B stores XML code in property y:
	<p:Bar>some other data</p:Bar>

Client A's namespace prefix p points to a different namespace than client B's namespace prefix p. Now, client A gets all properties (including x ans y) for this resource. The server needs to create on XML file containing both properties, but it can't preserve both prefixes, since they point to different namespaces.

It's entirely possible that I simply don't understand the sitation, of course.

lukas

-- 
Lukas Mathis, Numcom Software AG
Hardturmstrasse 66, CH-8005 Zürich
Direct +41(0)43-204 06 08
mailto:[email-masked], http://www.numcom.com/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 18 Nov 2005 11:19:53 +0100

> Client A's namespace prefix p points to a different namespace than client B's namespace prefix p. Now, client A gets all properties (including x ans y) for this resource. The server needs to create…

Sure it can. For instance. Let's assume "x" and "y" live in namespace 
"custom", and "p" has namespace "ns1" for x and "ns2" for y.

The response could be:

<prop xmlns="DAV:">
   <x xmlns="custom" xmlns:p="ns1"><p:Foo>some data</p:Foo></x>
   <y xmlns="custom" xmlns:p="ns2"><p:Bar>some other data</p:Bar></y>
</prop>

> It's entirely possible that I simply don't understand the sitation, of course.

Best regards, Julian