Subject: RE: XML InfoSet and property value preservation

From: "Lukas Mathis" <[email-masked]>
Date: Fri, 18 Nov 2005 11:33:31 +0100

Ah! Gah. I just realized that you could obviously define namespaces on the element level.

So I think there's no problem after all :-)

lukas

-- 
Lukas Mathis, Numcom Software AG
Hardturmstrasse 66, CH-8005 Zürich
Direct +41(0)43-204 06 08
mailto:[email-masked], http://www.numcom.com/

---

From: "Lukas Mathis" <[email-masked]>
Date: Fri, 18 Nov 2005 12:04:06 +0100

> Sure it can. For instance. Let's assume "x" and "y" live in 
> namespace "custom", and "p" has namespace "ns1" for x and "ns2" for y.
> 
> The response could be:
> 
> <prop xmlns="DAV:">
>    <x xmlns="custom" xmlns:p="ns1"><p:Foo>some data</p:Foo></x>
>    <y xmlns="custom" xmlns:p="ns2"><p:Bar>some other 
> data</p:Bar></y> </prop>

Yes, you're right, of course. Sorry for the confusion :-)

So the only issue that remains is that not all parsers can be used if the prefix names are to be kept.

lukas