Subject: HTTP Upload

From: Frank Lowney <[email-masked]>
Date: Thu, 24 Nov 2005 11:11:46 -0500

We think that we need to ask several vendors (RDBMS, web server, etc.) to provide us with ways and means to do HTTP uploads via HTTP 1.1 methods, namely WebDAV, via a web forms interface similar to what is available presently via HTTP 1.0.  The goals vary by project but include: multiple file uploads, more robust uploading, reduced timeout sensitivity, etc.

Is this a sensible request?  That is, would using HTTP 1.1 WebDAV features provide us with significant advantages over HTTP 1.0?

Does the WebDAV standard support uploads via web interfaces?  If so, are there examples that we could point to?

Thanks in advance for your answers.
-- 
==================================================================
Dr. Frank Lowney  Georgia College & State University
    Manager, Web Enabled Resources, a unit of the
    Division of Technology Solutions
    E-Mail: [email-masked]
    Professional Pages: http://www.gcsu.edu/oiit/eis/
    Personal Pages: http://www.faculty.de.gcsu.edu/~flowney
Voice: (478) 445-5260
NOTICE: Please be advised that I am hearing impaired and communicate most effectively via e-mail.  Follow-up summaries of telephone conversations by e-mail are most appreciated.
==================================================================
We don't make instruction effective, we make effective instruction more accessible.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 24 Nov 2005 17:28:45 +0100

> Thanks in advance for your answers.

Hi,

actually, WebDAV doesn't help you at all here. The only relevant methods 
here are POST and PUT, and these are defined in RFC2616 (HTTP), not 
RFC2518 (WebDAV).

Best regards, Julian