Subject: [Bug 190] New: HTTP examples using RFC2629 markup

From: [email-masked]
Date: Mon, 21 Nov 2005 07:19:04 -0800

http://ietf.cse.ucsc.edu:8080/bugzilla/show_bug.cgi?id=190

           Summary: HTTP examples using RFC2629 markup
           Product: WebDAV-RFC2518-bis
           Version: -08
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: enhancement
          Priority: P2
         Component: Other
        AssignedTo: [email-masked]
        ReportedBy: [email-masked]
         QAContact: [email-masked]

Currently the spec puts all (or most) HTTP request/response examples into a
single RCF2629 artwork element. This has several disadvantages:

- xm2rfc processors will not be aware that the whitespace between request and
response is a good place for a page break

- automatic XML checks in artwork fail (see
<http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#rfc.section.3.3>,
"parse-xml-in-artwork")

Also, putting the strings ">>> Request" and ">>> Response" into the figure
preambles will make it easier to read in non-plain-ASCII versions of the spec
(yes, this is cosmetic).

Should we have consensus for this change, I'm volunteering to make it.

------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

---

From: Geoffrey M Clemm <[email-masked]>
Date: Mon, 21 Nov 2005 10:50:29 -0500

That change sounds good to me.
+1

Cheers,
Geoff

> - automatic XML checks in artwork fail (see
<http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#rfc.section.3.3
> >,