Subject: RE: XML InfoSet and property value preservation

From: "Lukas Mathis" <[email-masked]>
Date: Fri, 18 Nov 2005 10:09:24 +0100

>> wants to use for another namespace? What if different clients 
>> change different properties, but use the same namespace 
>> prefixes with different bindings?
> Nobody has asked for servers preserving prefixes on the 
> WebDAV property elements itself. We're talking about child 
> elements of properties.

I realize that. But if clients store child elements into properties, different clients can potentially use the same namespace prefixes for different namespaces while doing so. If those two clients both change different properties, the server has to somehow work around that. When returning several properties at once, the server needs to reconcile this difference in order to create a coherent XML result.

Likewise, clients can't expect the prefixes to always mean what they meant when the clients stored the properties, because other clients could potentially use the same prefixes for different namespaces.

lukas

-- 
Lukas Mathis, Numcom Software AG
Hardturmstrasse 66, CH-8005 Zürich
Direct +41(0)43-204 06 08
mailto:[email-masked], http://www.numcom.com/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 18 Nov 2005 10:41:54 +0100

> I realize that. But if clients store child elements into properties, different clients can potentially use the same namespace prefixes for different namespaces while doing so. If those two clients…

I honestly understand your point (and I *have* written a server that 
preserves the prefixes). Maybe you could give a concrete example?

> Likewise, clients can't expect the prefixes to always mean what they meant when the clients stored the properties, because other clients could potentially use the same prefixes for different namesp…

Again, I don't understand. When Client A stores a property X, and client 
B overwrites that property with something else, then Client A may be 
confused. But this has nothing to do with whether prefixes are preserved 
or not.

Best regards, Julian