Subject: Re: New mini WebDAV server

From: "Johan" <[email-masked]>
Date: Sun, 7 May 2006 09:53:17 -0700

Thanks, Julian, but this applies to allowing XP with service pack 2 to do 
basic authentication.

> You may want to read... 
> <http://support.microsoft.com/default.aspx?scid=kb;en-us;841215>
>

Excerpt from the link you provided:
This behavior occurs if the following conditions are true:
* The server is configured to use Basic authentication.

The default "XP service pack 2" authentication is digest, which is supported 
by the server. Basic authentication is disabled for security reasons.

XP with service pack 2 correctly authenticates with digest authentication on 
one computer, but fails on another computer with apparently the same mini 
redirect version.

Here is the HTTP trace. One can clearly see from the trace that XP that this 
particular XP computer totally ignores the authentication.

192.168.1.111 OPTIONS "" Microsoft-WebDAV-MiniRedir/5.1.2600
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 200 OK
Date: Mon, 01 May 2006 18:22:01 GMT
Server: BarracudaServer.com (Windows)
Connection: Keep-Alive
Allow: OPTIONS, GET, HEAD, PROPFIND, PUT, COPY, DELETE, MOVE, MKCOL, 
PROPFIND, PROPPATCH, LOCK, UNLOCK
MS-Author-Via: DAV
Content-Length: 0

192.168.1.111 PROPFIND "dav" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 301 Moved Permanently
Date: Mon, 01 May 2006 18:22:01 GMT
Server: BarracudaServer.com (Windows)
Connection: Close
Location: http://192.168.1.100/dav/
Content-Length: 0

192.168.1.111 PROPFIND "dav/" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 401 Unauthorized
Date: Mon, 01 May 2006 18:22:01 GMT
Server: BarracudaServer.com (Windows)
Connection: Keep-Alive
WWW-Authenticate: Basic realm="BarracudaDrive"
Content-Length: 0
WWW-Authenticate: Digest realm="BarracudaDrive", domain="/", qop="auth", 
nonce="83d289abf0e8be189e7801f5d7ab4649"

192.168.1.111 PROPFIND "dav/" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 401 Unauthorized
Date: Mon, 01 May 2006 18:22:01 GMT
Server: BarracudaServer.com (Windows)
Connection: Keep-Alive
WWW-Authenticate: Basic realm="BarracudaDrive"
Content-Length: 0
WWW-Authenticate: Digest realm="BarracudaDrive", domain="/", qop="auth", 
nonce="83d289abf0e8be189e7801f5d7ab4649"

192.168.1.111 PROPFIND "dav" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 301 Moved Permanently
Date: Mon, 01 May 2006 18:22:06 GMT
Server: BarracudaServer.com (Windows)
Connection: Close
Location: http://192.168.1.100/dav/
Content-Length: 0

192.168.1.111 PROPFIND "dav/" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 401 Unauthorized
Date: Mon, 01 May 2006 18:22:06 GMT
Server: BarracudaServer.com (Windows)
Connection: Keep-Alive
WWW-Authenticate: Basic realm="BarracudaDrive"
Content-Length: 0
WWW-Authenticate: Digest realm="BarracudaDrive", domain="/", qop="auth", 
nonce="46492373fea83d1e0eb6d6429dceccfd"

192.168.1.111 PROPFIND "dav/" Microsoft-WebDAV-MiniRedir/5.1.2600
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: 192.168.1.100
Content-Length: 0
Connection: Keep-Alive

Response:
HTTP/1.1 401 Unauthorized
Date: Mon, 01 May 2006 18:22:06 GMT
Server: BarracudaServer.com (Windows)
Connection: Keep-Alive
WWW-Authenticate: Basic realm="BarracudaDrive"
Content-Length: 0
WWW-Authenticate: Digest realm="BarracudaDrive", domain="/", qop="auth", 
nonce="46492373fea83d1e0eb6d6429dceccfd"

---

From: "Alex Jalali" <[email-masked]>
Date: Sun, 7 May 2006 11:32:52 -0700

I've had similar problem when trying to have support for windows XP for my
i2drive webdav server. What you need in addition to digest authentication is
to allow the "OPTIONS" respond to be unauthenticated. If you ask for
authentication on OPTIONS method it will not respond. After you send the
OPTIONS response the next requests that it asks for is PROPFIND. You can
request for auth at that point. In that case windows will not ignore it.
Also windows send user info either as user@domain or user/domain so you have
to fix for that as well. Another thing to note is that it always requests
for the root path. So if the dav server is at http://domain/dav it will ask
for options on "/" 

-alex

 

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Johan
Sent: Sunday, May 07, 2006 9:53 AM
To: Julian Reschke
Cc: [email-masked]
Subject: Re: New mini WebDAV server

Response:
HTTP/1.1 200 OK

Response:

Response:

Response:

Response:

Response:

Response: