Subject: New mini WebDAV server

From: "Wilfred" <[email-masked]>
Date: Fri, 5 May 2006 08:48:17 -0700

We have just released a new WebDAV plugin for our server. The beta version can be downloaded from:
http://barracudaserver.com/examples/BarracudaDrive/WebDAV.html

We have so far tested the server with davfs2, Mac OS X, WebDrive, Web Folders, and MS MiniRedir.

The server accepts the MS domain name prefix and can authenticate using either Basic or Digest. It should therefore be easy to use with MiniRedir, which requires Digest authentication i.e. you do not have to mess with the registry. We have however seen that MiniRedir fails to authenticate on some computers, but works on others even though the MiniRedir version appears to be the same on the computers we tested it on. Let me know if anyone would like to see the MiniRedir HTTP trace when it fails to authenticate.

The purpose with the WebDAV plugin is to make it possible to mount embedded devices as a remote disk. The locking in DAV 2 is partly implemented in order to make it interoperate with "drive" clients requiring locking. A "drive" client such as davfs2 can then be mounted as a drive.

As far as we see, locking in not a feature embedded devices need. It adds unnecessary complexity to the server. It also requires runtime resources and is costly to process.

A WebDAV "drive" client should interoperate with a standard DAV 1 server.

Comments appreciated

Regards,
Wilfred

---

From: Julian Reschke <[email-masked]>
Date: Sun, 07 May 2006 15:52:37 +0200

Wilfred wrote:
> The server accepts the MS domain name prefix and can authenticate using 
> either Basic or Digest. It should therefore be easy to use with 
> MiniRedir, which requires Digest authentication i.e. you do not have to 
> mess with the registry. We have however seen that MiniRedir fails to 
> authenticate on some computers, but works on others even though the 
> MiniRedir version appears to be the same on the computers we tested it 
> on. Let me know if anyone would like to see the MiniRedir HTTP trace 
> when it fails to authenticate.

I think auth behavior for MiniRedir may depend on registry settings 
(those also control whether it allows Basic). I have no other pointers, 
so you may have to google for that info...

> The purpose with the WebDAV plugin is to make it possible to mount 
> embedded devices as a remote disk. The locking in DAV 2 is partly 
> implemented in order to make it interoperate with "drive" clients 
> requiring locking. A "drive" client such as davfs2 can then be mounted 
> as a drive.
>  
> As far as we see, locking in not a feature embedded devices need. It 
> adds unnecessary complexity to the server. It also requires runtime 
> resources and is costly to process.
>  

I agree here. It would be interesting to understand why client 
implementations actually request a lock (well, except if the application 
opening the file indeed asked for a file lock).

Best regards, Julian