Subject: overwrite and depth-0 locks

From: "Tim Olsen" <[email-masked]>
Date: Wed, 28 Mar 2007 16:17:04 -0400

Let's say you have resources /a/b and /c/d.  There is a depth-0 lock
on collection /c

Of the following cases, which ones require the locktoken for the lock on /c?

1.
COPY /a/b
Destination: /c/d
Overwrite: T

2.
MOVE /a/b
Destination: /c/d
Overwrite: T

3.
REBIND /c
Overwrite: T

<D:rebind xmlns:D="DAV:">
   <D:segment>d</D:segment>
   <D:href>/a/b</D:href>
</D:rebind>

4.
BIND /c
Overwrite: T

<D:bind xmlns:D="DAV:">
   <D:segment>d</D:segment>
   <D:href>/a/b</D:href>
</D:bind>

I believe #1 does not require the locktoken.  I'm not sure about the other ones.

Thanks for the help.

-Tim

---

From: Geoffrey M Clemm <[email-masked]>
Date: Wed, 28 Mar 2007 19:09:34 -0400

All use cases below other than #1 require the locktoken.

Cheers,
Geoff

---

From: Julian Reschke <[email-masked]>
Date: Thu, 29 Mar 2007 11:07:57 +0200

> All use cases below other than #1 require the locktoken.

Correct.

In all cases except #1, the state of the collection is changed, by 
replacing a binding (aka "path segment mapping" in RFC2518bis).

Tim: speaking of which, was there anything in 
draft-ietf-webdav-rfc2518bis-18 
(<http://greenbytes.de/tech/webdav/draft-ietf-webdav-rfc2518bis-18.html>) 
or draft-ietf-webdav-bind-18 
(<http://greenbytes.de/tech/webdav/draft-ietf-webdav-bind-18.html>) 
suggesting something else?

Best regards, Julian