Subject: Re: I-D ACTION:draft-reschke-webdav-search-12.txt

From: Julian Reschke <[email-masked]>
Date: Wed, 04 Apr 2007 22:44:40 +0200

Hi,

this is draft 12, as previously announced in 
<http://lists.w3.org/Archives/Public/w3c-dist-auth/2007JanMar/0114.html>. 
I have just requested publication as Experimental Standard 
(<http://tools.ietf.org/html/rfc2026#section-4.2.1>).

Best regards, Julian

[email-masked] schrieb:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: Web Distributed Authoring and Versioning (WebDAV) SEARCH
> 	Author(s)	: J. Reschke, et al.
> 	Filename	: draft-reschke-webdav-search-12.txt
> 	Pages		: 57
> 	Date		: 2007-4-4
> 	
> This document specifies a set of methods, headers, properties and
>    content-types composing WebDAV SEARCH, an application of the HTTP/1.1
>    protocol to efficiently search for DAV resources based upon a set of
>    client-supplied criteria.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-reschke-webdav-search-12.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-reschke-webdav-search-12.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-reschke-webdav-search-12.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Apr 2007 13:24:30 +0200

Julian Reschke schrieb:
> ...

Input for the IESG:

(a) Implementations:

- Apache Jackrabbit (just the SEARCH method and the DASL header, but not 
the DAV:basicsearch grammar)
- Apache Slide
- Apache/moddav+Catacomb
- Microsoft Exchange/Sharepoint (just the SEARCH method and the DASL 
header, but not the DAV:basicsearch grammar)
- SAP KM
- Xythos WFS

(there may be more; feedback appreciated)

(b) Known open issues:

Summarized in 
<http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-12.html#rfc.section.B>.

Best regards, Julian

---

From: Lisa Dusseault <[email-masked]>
Date: Sat, 14 Apr 2007 10:17:18 -0700

Are there any known client implementations?

thx,
Lisa

On Apr 13, 2007, at 4:24 AM, Julian Reschke wrote:

>
> Julian Reschke schrieb:
>> Hi,
>> this is draft 12, as previously announced in <http://lists.w3.org/ 
>> Archives/Public/w3c-dist-auth/2007JanMar/0114.html>. I have just  
>> requested publication as Experimental Standard (<http:// 
>> tools.ietf.org/html/rfc2026#section-4.2.1>).
>> ...
>
> Input for the IESG:
>
> (a) Implementations:
>
> - Apache Jackrabbit (just the SEARCH method and the DASL header,  
> but not the DAV:basicsearch grammar)
> - Apache Slide
> - Apache/moddav+Catacomb
> - Microsoft Exchange/Sharepoint (just the SEARCH method and the  
> DASL header, but not the DAV:basicsearch grammar)
> - SAP KM
> - Xythos WFS
>
> Summarized in <http://greenbytes.de/tech/webdav/draft-reschke- 
> webdav-search-12.html#rfc.section.B>.
>
> Best regards, Julian
>
>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 15 Apr 2007 09:44:29 +0200

> Are there any known client implementations?

SEARCH is used in several client libraries (Apache Slide, Apache 
Jackrabbit, SAP KM) quite frequently (just look at the mail archives 
from the Apache mailing lists). Also, the Microsoft Exchange and 
Sharepoint SEARCH implementations are known to be used by many custom 
clients (AFAIK, there are lots of things in Exchange and Sharepoint 
where you need SEARCH unless you want to use WS-*).

Best regards, Julian