Subject: Re: [ACL] ACL method and unsupported property principal

From: Julian Reschke <[email-masked]>
Date: Sat, 05 May 2007 13:08:52 +0200

Werner Donné wrote:
> Hi,
> 
> Can a server limit the set of properties that may be used to
> denote a principal in a principal element? If yes, what pre-condition

Yes, definitively. In particular, servers may not support the 
DAV:property element at all. It seems to me this needs clarification.

> violation should be reported when an unsupported property is included?

DAV:not-supported-privilege seems to come close:

"The ACEs submitted in the ACL request MUST be supported by the resource."

Do you think we need a more specific one?

Best regards, Julian

---

From: Werner Donné <[email-masked]>
Date: Sat, 05 May 2007 13:17:21 +0200

I thought the DAV:not-supported-privilege precondition was
about using an unsupported element inside a DAV:privilege
element and therefore I would expect a more specific
precondition.

Regards,

Werner.

Julian Reschke wrote:
> Werner DonnÃ© wrote:

-- 
Werner Donné  --  Re
Engelbeekstraat 8
B-3300 Tienen
tel: (+32) 486 425803	e-mail: [email-masked]

---

From: Julian Reschke <[email-masked]>
Date: Sat, 05 May 2007 13:30:56 +0200

> element and therefore I would expect a more specific

The precondition *name* sounds like that, but the description seems to 
make it way more flexible... It seems it changed between draft 07 and 
draft 08 from...:

    <DAV:supported-privilege/>: One or more of the privileges in the ACL
    request is not supported by the resource.

to:

    (DAV:not-supported-privilege): The ACEs submitted in the ACL
    request MUST be supported by the resource.

Not sure whether that was intentional.

Anyway: a new precondition would give us an opportunity to explain that 
a server is not required to support DAV:principal/DAV:property, so I am 
+1 for adding this.

Any objections?

Best regards, Julian