Subject: PROPFIND/REPORT on non existing resource/collection

From: Arnaud Quillaud <[email-masked]>
Date: Wed, 08 Aug 2007 18:06:49 +0200

Hello,

When issuing a PROPFIND or REPORT with a Request URI that does not exist, what should be returned:
- a 404 Not Found ?
- or a 207 multistatus containing a single response + href + status = 404 (e.g. <DAV:response><DAV:href>/toto/</DAV:href><DAV:status>404 Not Found</DAV:status></DAV:response>) ?

The only indication that I have found comes from the REPORT method definition where it is stated (http://tools.ietf.org/html/rfc3253#section-3.6): "If a Depth request header is included, the response MUST be a 207 Multi-Status.".

Thanks,

Arnaud Q

---

From: Julian Reschke <[email-masked]>
Date: Wed, 08 Aug 2007 22:11:27 +0200

> When issuing a PROPFIND or REPORT with a Request URI that does not exist, what should be returned:

Yes.

> - or a 207 multistatus containing a single response + href + status = 404 (e.g. <DAV:response><DAV:href>/toto/</DAV:href><DAV:status>404 Not Found</DAV:status></DAV:response>) ?

Should be equivalent.

> The only indication that I have found comes from the REPORT method definition where it is stated (http://tools.ietf.org/html/rfc3253#section-3.6): "If a Depth request header is included, the respon…

I guess we need to clarify that when we move REPORT into a separate spec.

Best regards, Julian