Subject: RE: INVOICE CONFIRMATION

From: [email-masked]
Date: Thu, 14 Sep 2017 21:24:46 -0400

Dear

My colleague is on leave, kindly confirm the attached sales invoice to
enable me proceed further

Best regards

Veronica Kai

---

From: [email-masked]
Date: Thu, 14 Sep 2017 21:24:46 -0400

Dear

Best regards

Veronica Kai