Subject: Re: [webfinger] Default language (Was: Last Call: <draft-ietf-appsawg-webfinger-10.txt> (WebFinger) to Proposed Standard

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 02 Apr 2013 10:59:53 +0900

Hello Paul, others,

ntohuntheonth

On 2013/03/21 11:55, Paul E. Jones wrote:
> Stephanie,
>
>>> The "titles" object comprises zero or more name/value pairs whose name
>>> is a language tag or the string "default". [...] If the language is
>>> unknown or unspecified, then the name is "default".
>>
>> Why inventing a special value when the language tag registry already has
>> a specific value, "und"? To quote RFC 5646:
>>
>>> The 'und' (Undetermined) primary language subtag identifies linguistic
>>> content whose language is not determined.  This subtag SHOULD NOT be
>>> used unless a language tag is required and language information is not
>>> available or cannot be determined.
>
> This is historical.  The JRD syntax was first defined in RFC 6415 and that
> document said to use "default" when the corresponding XML document did not
> specify the xml:lang attribute.

It would be very good if the people involved could come up with a way to 
get rid of this historic oversight, the earlier, the better. Maybe this 
should actually be an erratum to RFC 6415? It should have been caught 
before that RFC was published, but unfortunately, such oversights happen.

Regards,   Martin.

> We could change it, but it would break any existing implementations of RFC
> 6415.
>
>> Editorial comment: the reference is wrong:
>>
>>     [13]  Phillips, A., Davis, M., "Tags for Identifying Languages", RFC
>>           5646, January 2001.
>>
>> [It is 2009]
>
> That's an easy one.
>
> Thanks!
> Paul
>
>
> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger
>

---

From: 'Stephane Bortzmeyer' <[email-masked]>
Date: Tue, 2 Apr 2013 12:38:17 +0200

On Tue, Apr 02, 2013 at 10:59:53AM +0900,
 Martin J. Dürst <[email-masked]> wrote 
 a message of 57 lines which said:

> Maybe this should actually be an erratum to RFC 6415? 

I'm not sure. Errata are not supposed to be used when you disagree
with the working group, only when there is an involuntary slip. To
quote draft-rfc-editor-errata-process:

We note that allowing technical errata is a slippery slope: there may
be a temptation to use errata to "fix" protocol design errors, rather
than publishing new RFCs that update the erroneous documents.  In
general, an erratum is intended to report an error in a document,
rather than an error in the design of the protocol [...]

In this case, it seems the working group made a wrong choice, but
deliberately.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 02 Apr 2013 19:56:13 +0900

Hello Stephane,

On 2013/04/02 19:38, 'Stephane Bortzmeyer' wrote:
>   Martin J. Dürst<[email-masked]>  wrote
> I'm not sure.

I'm also not sure. That's why I wrote "Maybe".

> Errata are not supposed to be used when you disagree

I think it's going a bit too far to say that there was a deliberate choice.

I wasn't there, but it most probably just went like this: somebody got 
the idea that having a default would be a good idea, somebody proposed 
to use "default", and that was it. There was nobody who checked whether 
somebody else already had similar ideas (not only is there "und", but 
there's also "i-default"),...

So there probably wasn't much deliberation. Also, as a draft, RFC 6415 
was draft-hammer-hostmeta, so there wasn't a WG at all.

Regards,   Martin.

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 2 Apr 2013 13:20:24 -0400

Martin,

> was draft-hammer-hostmeta, so there wasn't a WG at all.

You're probably right.  I really do not care whether we use "und" or "default", but I do like consistency.

So, what can we do?  We have a few options:
1) Leave "default" in place for consistency with RFC 6415
2) Change "default" to "und" and introduce inconsistency
3) Change "default" to "und" in both specs
    a) WebFinger would be easy
    b) We could revise RFC 6415 or file an errata (perhaps it is a mistake)

I'll consult with Eran about this, but what does the WG prefer? 

Paul

---

From: Mike Jones <[email-masked]>
Date: Tue, 2 Apr 2013 17:39:00 +0000

I'd switch to using "und".  WebFinger has a normative dependency on RFC 5646 (Tags for Identifying Languages), which specifies the use of "und".  We have only an informative dependency upon RFC 6415 (Web Host Metadata) .  And I agree that the use of "default" in RFC 6415 is a spec defect that we should separately try to have corrected, either through the errata process or by publishing an updated spec.  We certainly shouldn't emulate the spec defect.

But correcting 6415 shouldn't hold up WebFinger, which should just use the convention in the spec that we normatively reference.

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul E. Jones
Sent: Tuesday, April 02, 2013 10:20 AM
To: '"Martin J. Dürst"'; 'Stephane Bortzmeyer'
Cc: [email-masked]; [email-masked]
Subject: Re: [webfinger] Default language (Was: Last Call: <draft-ietf-appsawg-webfinger-10.txt> (WebFinger) to Proposed Standard

Martin,

> to use "default", and that was it. There was nobody who checked 
> whether somebody else already had similar ideas (not only is there 
> "und", but there's also "i-default"),...
> 

Paul

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 2 Apr 2013 14:49:57 -0400

I agree with this course.

Gonzalo

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 03 Apr 2013 09:56:00 +0900

> But correcting 6415 shouldn't hold up WebFinger, which should just use the convention in the spec that we normatively reference.

This makes a lot of sense indeed.   Regards,   Martin.

> Subject: Re: [webfinger] Default language (Was: Last Call:<draft-ietf-appsawg-webfinger-10.txt>  (WebFinger) to Proposed Standard
>
> Martin,
>