Subject: [wpkops] FW: Adrian Farrel's Block on charter-ietf-wpkops-00-01: (with BLOCK)

From: Ronald Bonica <[email-masked]>
Date: Wed, 30 Jan 2013 20:06:14 +0000

Folks,

Adrian Farrel has posted a blocking objection to the proposed WPKOPS charter and offered alternative text (attached). IMHO, the text that Adrian proposes does not in any way change the WG's charter. 

Does anyone object to using Adrian's alternative text?

                                                 Ron

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, January 30, 2013 12:47 PM
> To: Ronald Bonica; 'The IESG'
> Subject: RE: Adrian Farrel's Block on charter-ietf-wpkops-00-01: (with
> BLOCK)
> 
> Alright Ron,
> 
> How does the attached look? I believe I have captured all of the WG
> actions, and all of the out of scope items.
> 
> But I have also tried to remove a lot of the explanation and history. I
> can believe this is interesting, but not that it belongs in the
> charter.
> 
> If it is no good, throw it out and I will probably Noobj the charter
> (given the "urgency" :-)
> 
> A
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Ronald Bonica
> > Sent: 30 January 2013 15:12
> > To: Adrian Farrel; The IESG
> > Subject: RE: Adrian Farrel's Block on charter-ietf-wpkops-00-01:
> (with
> > BLOCK)
> >
> > Adrian,
> >
> > The two paragraphs below, taken from the charter, tell you what the
> WG will do:
> >
> > "Starting from the premise that more consistency in Web security
> > behavior is desirable, a natural first step is to document current
> and
> > historic browser and server behavior, including: the trust model on
> > which they are based; the contents and processing of fields and
> > extensions; the processing of the various revocation schemes; and how
> > the TLS stack deals with PKI, including varying interpretations and
> > implementation errors, as well as state changes visible to the user.
> > Where appropriate, specific products and specific versions of those
> > products will be identified."
> >
> > "Future activities may attempt to prescribe how the Web PKI "should"
> > work, and the prescription may turn out to be a proper subset of the
> > PKIX PKI.  However, that task is explicitly not a goal of the
> proposed
> > working group.  Instead, the group's goal is merely to describe how
> > the Web PKI "actually" works in the set of browsers and servers that
> > are in common use today."
> >
> > I wouldn't fault the authors for providing "reams of background
> text".
> > When crafting this text, they were very aware of the fact that the
> > were writing to an audience that had no background in the area.
> >
> > If you want to take a crack at wordsmithing the charter, go for it.
> >
> >                                  Ron
> >
> >
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On
> Behalf
> > > Of Adrian Farrel
> > > Sent: Wednesday, January 30, 2013 9:37 AM
> > > To: The IESG
> > > Subject: Adrian Farrel's Block on charter-ietf-wpkops-00-01: (with
> > > BLOCK)
> > >
> > > Adrian Farrel has entered the following ballot position for
> > > charter-ietf-wpkops-00-01: Block
> > >
> > > When responding, please keep the subject line intact and reply to
> > > all email addresses included in the To and CC lines. (Feel free to
> > > cut this introductory paragraph, however.)
> > >
> > >
> > >
> > >
> > >
> > > -------------------------------------------------------------------
> -
> > > --
> > > BLOCK:
> > > -------------------------------------------------------------------
> -
> > > --
> > >
> > > Look, I am in favor of forming this working group, but this is a
> > > really awful draft charter! Far too much waffle, and far too little
> > > about what the WG will actually do.
> > >
> > > I could have a stab at rewriting, but I doubt I know wnough about
> > > the topic to make a good job.
> > >
> > > Can someone tell me that the reams of text are actually needed, or
> > > can someone please take an axe to it.
> > >
> > >
> > >
> > >

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 31 Jan 2013 09:07:39 +0200

Hi Ron, Hi Adrian, 

I am curious what the blocking objection is when the text that Adrian proposes does not in any way change the charter. 

Ciao
Hannes

On Jan 30, 2013, at 10:06 PM, Ronald Bonica wrote:

> <wpkops.txt>_______________________________________________
> wpkops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wpkops

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 31 Jan 2013 08:47:01 -0000

Hannes,

For whatever reason, the IESG has YES, BLOCK, and NO OBJECTION for charter
evaluation. BLOCK takes the same position as DISCUSS for an I-D.

In my case, I wanted to Discuss the charter text with the sponsoring AD (see my
note at the foot of this thread). The original draft charter very nearly didn't
actually mention the working group, but had lots of good words about Web PKI,
how it is used, and what the problems are. While it is helpful to have some
background and motivation, I believe it is move valuable to describe the work
that the working group will do.

In my re-draft I have tried to retain some of the background, but to reorganise
the text so that it more pithily describes the working group.

I present it as an offering at your altar, not as a mandatory change. I don't
want to get in the way of the formation of this WG, but I would like to use the
week remaining before the IESG telechat to try to get a better charter. If the
mailing list says "We spent a lot of effort crafting the current text. We like
it. It is good" then I am likely to back down.

Cheers,
Adrian

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: 31 January 2013 07:08
> To: Ronald Bonica
> Cc: Hannes Tschofenig; [email-masked]; [email-masked]
> Subject: Re: [wpkops] FW: Adrian Farrel's Block on charter-ietf-wpkops-00-01:
> (with BLOCK)
> 
> Hi Ron, Hi Adrian,
> 
> > Adrian Farrel has posted a blocking objection to the proposed WPKOPS charter
> and offered alternative text (attached). IMHO, the text that Adrian proposes
> does not in any way change the WG's charter.
> >

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 31 Jan 2013 15:14:00 +0000

Me too!

> Sent: Thursday, January 31, 2013 2:08 AM
> To: Ronald Bonica
> Subject: Re: [wpkops] FW: Adrian Farrel's Block on charter-ietf-wpkops-
> 00-01: (with BLOCK)
> 
> Hi Ron, Hi Adrian,
> 
> I am curious what the blocking objection is when the text that Adrian
> proposes does not in any way change the charter.
> 
> Ciao
> Hannes
> 
> > Adrian Farrel has posted a blocking objection to the proposed WPKOPS
> charter and offered alternative text (attached). IMHO, the text that
> Adrian proposes does not in any way change the WG's charter.
> >
> >> But I have also tried to remove a lot of the explanation and
> history.
> >> I can believe this is interesting, but not that it belongs in the
> >> charter.
> >>
> >>> extensions; the processing of the various revocation schemes; and
> >>> how the TLS stack deals with PKI, including varying interpretations
> >>> and implementation errors, as well as state changes visible to the
> user.

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 31 Jan 2013 07:38:20 -0800

> the text so that it more pithily describes the working group.

That is appropriate for a WG charter. It is especially appropriate here because the WG is not developing protocols.

> it. It is good" then I am likely to back down.

We did not spend much effort crafting the current text, as can be seen from the short length of the BoF archives.

I think Adrian's proposal is better than the original because it lets people not yet active in the WG know better what the WG is supposed to be doing.

--Paul Hoffman

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 31 Jan 2013 15:39:53 -0000

I think my answer to Ron is probably identical to my answer to Hannes, so I am
not going to retype it.
A

> From: Ronald Bonica [mailto:[email-masked]]
> Sent: 31 January 2013 15:14
> To: Hannes Tschofenig
> Cc: [email-masked]; [email-masked]
> Subject: RE: [wpkops] FW: Adrian Farrel's Block on charter-ietf-wpkops-00-01:
> (with BLOCK)
> 
> 
> Me too!
> 
>

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 31 Jan 2013 16:41:26 +0000

Yep. I responded to your message before reading your response to Hannes.

> Sent: Thursday, January 31, 2013 10:40 AM
> To: Ronald Bonica; 'Hannes Tschofenig'
> Cc: [email-masked]
> Subject: RE: [wpkops] FW: Adrian Farrel's Block on charter-ietf-wpkops-
> 00-01: (with BLOCK)
> 
> I think my answer to Ron is probably identical to my answer to Hannes,
> so I am not going to retype it.
> A
> 
> > > I am curious what the blocking objection is when the text that
> > > Adrian proposes does not in any way change the charter.
> > >
> > > Ciao
> > > Hannes
> > >
> > > >> How does the attached look? I believe I have captured all of the
> > > >> WG actions, and all of the out of scope items.
> > > >>
> > > >> If it is no good, throw it out and I will probably Noobj the
> > > >> charter (given the "urgency" :-)
> > > >>
> > > >> A
> > > >>
> > > >>> historic browser and server behavior, including: the trust
> model
> > > >>> on which they are based; the contents and processing of fields
> > > >>> and extensions; the processing of the various revocation
> > > >>> schemes; and how the TLS stack deals with PKI, including
> varying
> > > >>> interpretations and implementation errors, as well as state
> > > >>> changes visible to the
> > > user.
> > > >>> Where appropriate, specific products and specific versions of
> > > >>> those products will be identified."
> > > >>>
> > > >>> work, and the prescription may turn out to be a proper subset
> of
> > > the
> > > >>> working group.  Instead, the group's goal is merely to describe
> > > >>> how the Web PKI "actually" works in the set of browsers and
> > > >>> servers
> > > that
> > > >>> When crafting this text, they were very aware of the fact that
> > > >>> the were writing to an audience that had no background in the
> area.
> > > >>>
> > > >>>> When responding, please keep the subject line intact and reply
> > > >>>> to all email addresses included in the To and CC lines. (Feel
> > > >>>> free to cut this introductory paragraph, however.)
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>> --------------------------------------------------------------
> -
> > > >>>> ---
> > > -
> > > >> -
> > > >>>> --
> > > >>>> BLOCK:
> > > >>>> --------------------------------------------------------------
> -
> > > >>>> ---
> > > -
> > > >> -
> > > >>>> --
> > > >>>>
> > > >>>> Look, I am in favor of forming this working group, but this is
> > > >>>> a really awful draft charter! Far too much waffle, and far too
> > > little
> > > >>>> I could have a stab at rewriting, but I doubt I know wnough
> > > >>>> about the topic to make a good job.
> > > >>>>
> > > >>>> Can someone tell me that the reams of text are actually
> needed,
> > > >>>> or can someone please take an axe to it.
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>>
> > > >

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 31 Jan 2013 18:54:04 +0200

Hi Adrian, 

thanks for this clarification.

I agree it is useful to say what the working group is doing; I don't have a strong view about the level of detail regarding the background information. It is always difficult to find the right level. 

In any case, it is great to hear that you are not objecting against the work.

Ciao
Hannes

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 31 Jan 2013 16:52:12 +0000

Sounds reasonable. Unless there are any strong objections, we can adopt Adrian's text.

                                      Ron

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Hoffman
> Sent: Thursday, January 31, 2013 10:38 AM
> To: [email-masked]
> Cc: Ronald Bonica; 'Hannes Tschofenig'; [email-masked]
> Subject: Re: [wpkops] Adrian Farrel's Block on charter-ietf-wpkops-00-
> 01: (with BLOCK)
> 
> > In my re-draft I have tried to retain some of the background, but to
> > reorganise the text so that it more pithily describes the working
> group.
> 
> That is appropriate for a WG charter. It is especially appropriate here
> because the WG is not developing protocols.
> 
> > I present it as an offering at your altar, not as a mandatory change.
> > I don't want to get in the way of the formation of this WG, but I
> > would like to use the week remaining before the IESG telechat to try
> > to get a better charter. If the mailing list says "We spent a lot of
> > effort crafting the current text. We like it. It is good" then I am
> likely to back down.
> 
> We did not spend much effort crafting the current text, as can be seen
> from the short length of the BoF archives.
> 
> I think Adrian's proposal is better than the original because it lets
> people not yet active in the WG know better what the WG is supposed to
> be doing.
> 
> --Paul Hoffman
> _______________________________________________
> wpkops mailing list
> [email-masked]